Subject: RE: WG Last Call:draft-ietf-smime-cms-07.txt

From: "Flanigan, Bill" <[email-masked]>
Date: Tue, 3 Nov 1998 16:17:47 -0500

I have another "minor" request.  The last sentence of the second paragraph
in Section 5.6 seems to be particularly convoluted--like nested eggs.  How
would this process REALLY work in determining if the signature is valid?
Perhaps some wordsmithing as well as breaking the sentence up into two might
help.  Any thoughts anyone? 

Bill

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
William F. Flanigan, Jr., Ph.D.       Voice:           (703) 681-2318
Defense Information Systems Agency      Fax:           (703) 681-2814 
Information Assurance Office (JED)      DSN:                      761      
5600 Columbia Pike, Room 632     Voice Mail:           (703) 681-2318   
Falls Church, VA 22041-2717        Internet:  <[email-masked]>
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%% 

> -----Original Message-----
> From:	Paul Hoffman / IMC [SMTP:[email-masked]]
> Sent:	Tuesday, November 03, 1998 1:03 PM
> To:	[email-masked]
> Subject:	Re: WG Last Call:draft-ietf-smime-cms-07.txt
> 
> >One minor request, would it be possible to include a short example of
> data
> >wrapped up with each CMS content-type at the end of the draft (data,
> >encryptedData, etc)?  This would help solve some of the "we thought you
> were
> >supposed to interpret the text this way" problems which have come up, and
> >provide useful test vectors for implementors.
> 
> I would second this request, even if it delays the drafts a bit. From
> Jim's
> previous message, it is clear that the few people implementing right now
> are not 100% on track on this.
> 
> Russ, can you add these? Or, if anyone else can provide them quicker, that
> would be wonderful.
> 
> --Paul Hoffman, Director
> --Internet Mail Consortium

---

From: Russ Housley <[email-masked]>
Date: Mon, 09 Nov 1998 10:44:12 -0500

Bill:

Are we alking about the same sentence?  It looks okay to me.

For the signature to be valid, the message digest value calculated by
the recipient must be the same as the value of the messageDigest
attribute included in the signedAttributes of the signedData
signerInfo.

Russ

>William F. Flanigan, Jr., Ph.D.
Voice:           (703)
681-2318

>Defense Information Systems Agency
Fax:           (703)
681-2814

>Information Assurance Office (JED)
DSN:
761

>5600 Columbia Pike, Room 632     Voice
Mail:           (703)
681-2318

From:        Paul
Hoffman / IMC [SMTP:[email-masked]]

Sent:        Tuesday,
November 03, 1998 1:03 PM