Subject: What is the ToBeSignedData for signedData(pkcs#7) in SMIME system of Netscape Communicator 4.04?

From: [email-masked]
Date: Sun, 18 Apr 1999 12:04:10 +0800

Hi,
Recently, we implement SMIME system.
We use Netscape Communicator 4.04 to test our implemention.
Then we encounter the following problem.
We decrypt the SignedData(We get from smime mail of Netscape
Communicator 4.04).
We find the hash value is different from the hash value of the field
unauthenticatedAttributes(contained in SingnerInfo).
We are sure that our decrypted value is correct since it satisfy the
formate of PKCS#1.
We try hash every paragraph in SMIME mail.
One of our hash values is same as hash value in the field
unauthenticatedAttributes.
But no one is same as our decrypted value.

Our environment: Netscape Communicator 4.04, Trial Class 1 VeriSign
Digital ID.

Thanks for your help.

---

From: Russ Housley <[email-masked]>
Date: Mon, 19 Apr 1999 12:17:55 -0400

This is not the correct mail list for discussing this problem.  This
mail list is for the discussion of S/MIME v3 standards.  Please take
this discussion to the correct list.

Russ

At 12:04 PM 4/18/99 +0800, [email-masked] wrote:

Hi,

Communicator 4.04).

We find the hash value is different from the hash value of the
field

We are sure that our decrypted value is correct since it satisfy
the

formate of PKCS#1.

Our environment: Netscape Communicator 4.04,
Trial Class 1 VeriSign

Digital ID.

Thanks for your help.