Subject: RE: Compressed data type for S/MIME

From: Darren Harter <[email-masked]>
Date: Thu, 29 Jul 1999 09:40:32 +0100

All,

I've been watching this thread with interest and I'd like to raise a few observations/questions/issues.  I'd like to make the point first though that what follows is not intended to contradict or counter any of the messages that proceed this one - I'd just like to widen the debate a little and firm up my understanding of the relative merits of performing compression or not.

1. Are we really concerned with saving network bandwidth these days?  If we are then clearly compression is essential.  If we're not, why are we discussing it at all?

2. If we need compression, how does the algorithm complexity of zlib compression algorithm compare with 3DES encryption?  What's its average compression rate?

e.g. How does the time to process the data compare in the following:

	a. Encrypt 10Mb of plaintext with 3DES
	b. Compress 10Mb to (say) 5Mb using zlib and then encrypt using 3DES.

3. If b. takes longer than a. and we're not that concerned with network bandwidth why bother compressing?  

I think my bottom line questions here are: how important is processing speed compared to network bandwidth? and how much time does this aspect of the processing take compared with all those cert/crl processes going on in S/MIME and/or CMS?

Regards,

Darren

------------------------------------------------------------------------
Darren Harter B.Sc (Hons) CEng MBCS
Application Development Group, UK
Entegrity Solutions Corp.
Tel: +44 1452 371383
Fax: +44 1452 371384
Cell: +44 7801 812850
Email: mailto:[email-masked]
http://www.entegrity.com
http://www.entegrity.co.uk

---

From: Paul Hoffman / IMC <[email-masked]>
Date: Thu, 29 Jul 1999 09:41:30 -0700

At 09:40 AM 7/29/1999 +0100, Darren Harter wrote:
>1. Are we really concerned with saving network bandwidth these days?  If 
>we are then clearly compression is essential.  If we're not, why are we 
>discussing it at all?

There is another aspect that is more relevant to non-S/MIME uses of CMS: 
speed of encrypting. Studies done by the IPsec folks found that the 
combination of compressing and encrypting with TripleDES is faster than 
encrypting uncompressed data. The fact that the resulting payload is 
smaller is obviously an additional advantage.

--Paul Hoffman, Director
--Internet Mail Consortium