Subject: RE: The subject line leakage problem

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Mon, 17 Dec 2001 13:37:19 -0800

Aggk!

Yes of course I meant S/MIME. Result of having just spent time explaining
why Pretty Good Privacy is not a first choice for solving problems of
document authenticity (think PGP code signing).

Yes, the only problem we are dealling with here is confidentiality.

On the 'replace other headers', the problem there is that we end up back in
the rat-hole. People will propose all sorts of random headers ad infinitum.
And others will counter that there are integrity problems and then we have
the interop issue, etc.

I don't think that the problem is big enough to require a whole new S/MIME
spec to solve, just a minor tweak to implementations.

	Phill

Phillip Hallam-Baker FBCS C.Eng.
Principal Scientist
VeriSign Inc.
[email-masked]
781 245 6996 x227

> -----Original Message-----
> From: Paul Hoffman / IMC [mailto:[email-masked]]
> Sent: Monday, December 17, 2001 4:08 PM
> To: Hallam-Baker, Phillip
> Cc: [email-masked]
> Subject: Re: The subject line leakage problem
> 
> 
> At 10:34 AM -0800 12/17/01, Hallam-Baker, Phillip wrote:
> >	One of the ongoing problems with people using PGP
> 
> Or S/MIME, which is the topic of this mailing list :-)
> 
> >  is that people put
> >confidential information in the mail subject lines, eg:
> >
> >Subject: Proposed purchase of Excite@Home
> >Subject: Your STD test results
> >Subject: Planned head count reduction
> >
> >	etc.
> >
> >So over the years there have been plenty of fixes involving 
> CMS encrypted
> >attributes etc. which gets into the rat hole of what other 
> headers to add
> >in.
> 
> Just to be clear: you are talking about leaking headers in 
> *encrypted* messages, not signed messages, I assume.
> 
> >So instead of that how about the following fix:
> >
> >1) A Best Current Practice Draft that says
> >2) Clients SHOULD offer users the option of replacing the 
> subject line on
> >confidential messages and carrying the subject as the first 
> line in the body
> >of the message.
> 
> A few thoughts:
> 
> 1) That only covers the subject; you might want to cover other 
> headers that have valuable information.
> 
> 2) That prevents the headers from being automatically processed.
> 
> Instead, how about encouraging the use of multipart/mixed which 
> starts with text/rfc822-headers. Any headers in that first part are 
> to replace the same headers on display only.
> 
> --Paul Hoffman, Director
> --Internet Mail Consortium
>

---

From: Paul Hoffman / IMC <[email-masked]>
Date: Mon, 17 Dec 2001 13:42:46 -0800

>the rat-hole. People will propose all sorts of random headers ad infinitum.

That doesn't matter because RFC 2822 allows you to add as many 
ill-conceived headers as you want to a message.

>And others will counter that there are integrity problems and then we have

There is no interop issue. What I proposed was that headers found in 
the body part be *displayed* in the message, not substituted into the 
message for storage. It's a user presentation hack, not a message 
format hack.

>spec to solve, just a minor tweak to implementations.

Fully agree.

--Paul Hoffman, Director

---

From: Simon Josefsson <[email-masked]>
Date: Tue, 18 Dec 2001 00:40:28 +0100

> spec to solve, just a minor tweak to implementations.

I agree that this is a problem for email clients, but I also believe
that this could be solved by implementation recomendations.  Always
wrapping the intended mail as a message/rfc822 part inside the
encrypted part could be a solution.  The problem with this seem to be
that most clients doesn't handle message/rfc822 in any intelligent
way.

While we are on the topic of MIME and encryption -- does anyone know
the history behind S/MIME not using multipart/encrypted of RFC 1847
for encrypted data?  This decision causes some pain when implementing
a client that supports both PGP and CMS; S/MIME encryption becomes a
special case.  Multipart/encrypted doesn't seem to have been discussed
here, judging by the mail archives at least.

---

From: "Jim Schaad" <[email-masked]>
Date: Mon, 17 Dec 2001 21:40:41 -0800

> --Internet Mail Consortium

First, this is an issue for signed as well as encrypted messages.  You
want to protect the subject for signed messages as well as hide the
subject for encrypted messages.

Second, the solution of putting items here solves the problem for
MIME/Internet mail.  But I think that we need to ask the X.400
communities if they want the problem solved for them as well.

Third, I worry about what happens for forms type messages.  Using the
multipart may take care of this however.  We initially had a "bug" in
Microsoft Outlook Express where we place the 822 headers in the body of
the message, and then populated the display headers from this
information.  I agree that this is a bad solution and should not be
persued.

Jim