Subject: few more basic questions

From: "Pradeep, PK" <[email-masked]>
Date: Tue, 16 Apr 2002 09:43:52 +0530

Hello Russ/Group,
thanks for your reply.

Are there free APIs available in Java or Vb or both to 
1) build S/MIME message
2) build PKCS#7 object to SignedData and Enveloped Data.

If free APIs are not available then:

Is it possible to build one's own component to build S/MIME message and
PKCS#7 objects? As I understand basically speaking S/MIME message and
PKCS#7 objects are nothing but a particular structure of text strings.
if the binary portion is base64 encoded then it is nothing but text
message. Kindly throw some light on this.

Warm Regards,

Pradeep

-----Original Message-----
From: Housley, Russ [mailto:[email-masked]]
Sent: Monday, April 15, 2002 11:12 PM
To: Pradeep, PK
Cc: [email-masked]
Subject: Re: a basic question

Pradeep:

In response to your beginner questions:

>1. S/MIME message is a ascii (text) message or a binary message?

The protected content is MIME encoded, so it can be anything.

>2. suppose i have a .gif file which i am sending as attachment of
>multipart/related MIME message. the attachment file is base64
>transfer-encoded...the resulting MIME message is a binary message or a
text
>message. can the MIME message be srored as string.

The result of the base64 encoding is a character string.

>3. I have a multipart/signed message which i have signed using my
private
>key...the message is a binary message or text message?

This depends on the encoding that is employed.  If base64 is used, then
(as 
before) the output is a character string.  If a binary encoding is used,

then, as expected, a binary message is the result.

Russ

---

From: "Jim Schaad" <[email-masked]>
Date: Tue, 16 Apr 2002 06:52:43 -0700

Look on the Microsoft web site for the CAPICOM code to do CMS and
certificate processing from VB and script.

jim

> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Pradeep, PK
> Sent: Monday, April 15, 2002 9:14 PM
> To: [email-masked]
> Cc: Housley, Russ
> Subject: few more basic questions
> 
> 
> 
> Hello Russ/Group,
> thanks for your reply.
>

---

From: "Blake Ramsdell" <[email-masked]>
Date: Wed, 24 Apr 2002 17:58:59 -0700

----- Original Message -----
From: "Pradeep, PK" <[email-masked]>
To: <[email-masked]>
Cc: "Housley, Russ" <[email-masked]>
Sent: Monday, April 15, 2002 9:13 PM
Subject: few more basic questions

> 2) build PKCS#7 object to SignedData and Enveloped Data.

Try the Javamail third-party page for Java implementations.  This lists at
least three implementations that might still be around.

http://java.sun.com/products/javamail/Third_Party.html

Blake