Subject: RE: I-D ACTION:draft-ietf-smime-rfc2632bis-00.txt

From: "Jim Schaad" <[email-masked]>
Date: Thu, 4 Apr 2002 19:34:35 -0800

Gentlemen,

I have been thinking about what the problem with this response it, I
cannot explain it very well to my standard IT manager.

One one hand we are saying - MD2 is so bad that you should never use it
for generating signatures on S/MIME messages or certificates to be used
with validating S/MIME purposed certificates. (MUST NOT) 

On the other hand we are saying - If you find a certificate with MD2 in
it, you really need to validate it.  We lied, there are not really any
problems with it.

The difference in approaches between Blake and me boil down to the fact
that I am writing a security document on what you really ought to do,
and Blake is creating an interopablity document describing how the real
world operates and what you need to do to survive there.  Given that
this is an IETF document, I believe that correctness is the primary
importance and compatability with the real world a secondary
consideration.  I would rather say nothing about MD2 except it exists
and there are potential problems (that we believe could lead to
incorrect validation) however I can accept MAY rather than SHOULD for
this along with the scary warning text in the security considerations.

jim

> -----Original Message-----
> From: Housley, Russ [mailto:[email-masked]] 
> Sent: Saturday, March 30, 2002 10:59 AM
> To: Blake Ramsdell
> Cc: [email-masked]; [email-masked]
> Subject: Re: I-D ACTION:draft-ietf-smime-rfc2632bis-00.txt
> 
> 
> Blake:
> 
> I am fine with this approach.
> 
> Russ
> 
> 
> At 03:55 PM 3/29/2002 -0800, Blake Ramsdell wrote:
> >----- Original Message -----
> >From: "Housley, Russ" <[email-masked]>
> >To: <[email-masked]>
> >Cc: "'Blake Ramsdell'" <[email-masked]>; 
> <[email-masked]>
> >Sent: Friday, March 29, 2002 1:57 PM
> >Subject: RE: I-D ACTION:draft-ietf-smime-rfc2632bis-00.txt
> >
> >
> > > I think that we should include is as a MAY for 
> validation.  I do not think
> > > that anyone should generate new certificates that use MD2.
> >
> >My opinion is we should say SHOULD verify, and MUST NOT 
> generate, perhaps
> >mentioning the known issues with MD2 in the security considerations.
> >
> >Blake
>

---

From: "Housley, Russ" <[email-masked]>
Date: Fri, 05 Apr 2002 11:03:43 -0500

Jim:

I have no problem with:
         MUST SHA-1
         SHOULD MD5
         MAY MD2

Russ