Subject: Re: Compression within RFC2633bis?

From: "Housley, Russ" <[email-masked]>
Date: Thu, 18 Apr 2002 16:37:27 -0400

Francois:

Yes.  I think that RFC2633bis out to say that compression MAY be applied 
before encryption or signing.  It should probably indicate that compression 
should only be applied once for a particular message.

Russ

At 04:15 PM 4/18/2002 -0400, [email-masked] wrote:
>Hi Blake and Russ,
>
>Since the IESG has approved the Internet-Draft "Compressed Data Content Type
>for S/MIME" <draft-ietf-smime-compression-07.txt> as a Proposed Standard,
>shouldn't it be referred as a MAY under the "S/MIME Version 3.1 Message
>Specification" <draft-ietf-smime-rfc2633bis-00.txt>?
>
>Please feel free to distribute your response to the S/MIME mailing list
>since I am not currently a member, but only occasionally monitor its
>content.
>
>Regards,
>
>Francois
>---------------------------------
>Francois Rousseau
>IT Standards, Senior Advisor - CSE
>Conseiller Superieur, Normes TI - CST
>[email-masked]
>(613) 991-8364
>Edward Drake Building
>1500 Bronson, Ottawa, Ontario, K1G 3Z4

---

From: "Blake Ramsdell" <[email-masked]>
Date: Thu, 18 Apr 2002 14:18:26 -0700

----- Original Message -----
From: "Housley, Russ" <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>;
<[email-masked]>
Sent: Thursday, April 18, 2002 1:37 PM
Subject: Re: Compression within RFC2633bis?

> should only be applied once for a particular message.

I think that an S/MIME capability should be used to negotiate this
beforehand, if we're going to head down this path.

Blake

---

From: "Housley, Russ" <[email-masked]>
Date: Fri, 19 Apr 2002 08:53:12 -0400

Blake:

Good point.

Russ

---

From: "Bonatti, Chris" <[email-masked]>
Date: Fri, 26 Apr 2002 09:04:57 -0400

> beforehand, if we're going to head down this path.

My apologies for having nodded off on this thread, but why does this need to be negotiated?  All the prior discussions of this revolved around what the signer preferred.  So why can't it just be sender's choice?  The encodings are unambiguous on reception.

I'll apologize in advance in case I've just got my 'stupid hat' on.

Chris

---

From: "Blake Ramsdell" <[email-masked]>
Date: Fri, 26 Apr 2002 09:55:08 -0700

----- Original Message -----
From: "Bonatti, Chris" <[email-masked]>
To: "Blake Ramsdell" <[email-masked]>; "Housley, Russ"
<[email-masked]>; <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>
Sent: Friday, April 26, 2002 6:04 AM
Subject: RE: Compression within RFC2633bis?

> My apologies for having nodded off on this thread, but why does this need
to be negotiated?  All the prior discussions of this revolved around what
the signer preferred.  So why can't it just be sender's choice?  The
encodings are unambiguous on reception.

I agree that it can be sender's choice.  I'd just make that choice based on
knowing that the recipient can receive it.

Blake