Subject: Re: few more basic questions

From: "Housley, Russ" <[email-masked]>
Date: Tue, 16 Apr 2002 09:45:50 -0400

Pradeep:

There are several freeware toolkits that contain the necessary building 
blocks.  OpenSSL is one.

Some platforms have support for many of the functions as well.

Russ

At 09:43 AM 4/16/2002 +0530, Pradeep, PK wrote:
>Hello Russ/Group,
>thanks for your reply.
>
>Are there free APIs available in Java or Vb or both to
>1) build S/MIME message
>2) build PKCS#7 object to SignedData and Enveloped Data.
>
>If free APIs are not available then:
>
>Is it possible to build one's own component to build S/MIME message and
>PKCS#7 objects? As I understand basically speaking S/MIME message and
>PKCS#7 objects are nothing but a particular structure of text strings.
>if the binary portion is base64 encoded then it is nothing but text
>message. Kindly throw some light on this.
>
>Warm Regards,
>
>Pradeep
>
>-----Original Message-----
>From: Housley, Russ [mailto:[email-masked]]
>Sent: Monday, April 15, 2002 11:12 PM
>To: Pradeep, PK
>Cc: [email-masked]
>Subject: Re: a basic question
>
>
>Pradeep:
>
>In response to your beginner questions:
>
> >1. S/MIME message is a ascii (text) message or a binary message?
>
>The protected content is MIME encoded, so it can be anything.
>
> >2. suppose i have a .gif file which i am sending as attachment of
> >multipart/related MIME message. the attachment file is base64
> >transfer-encoded...the resulting MIME message is a binary message or a
>text
> >message. can the MIME message be srored as string.
>
>The result of the base64 encoding is a character string.
>
> >3. I have a multipart/signed message which i have signed using my
>private
> >key...the message is a binary message or text message?
>
>This depends on the encoding that is employed.  If base64 is used, then
>(as
>before) the output is a character string.  If a binary encoding is used,
>
>then, as expected, a binary message is the result.
>
>Russ

---

From: [email-masked] (Peter Gutmann)
Date: Wed, 17 Apr 2002 16:30:55 +1200 (NZST)

>2) build PKCS#7 object to SignedData and Enveloped Data.

Finding something open-source which has Java and VB support (rather than C/C++)
is going to be tricky, because commercial VB and open-source crypto don't
really match up very well.  At the risk of posting advertising :-),
http://www.cs.auckland.ac.nz/~pgut001/cryptlib/ is available with both a VB
interface to the Windows DLL and as an ActiveX control.  There's also
Microsoft's clcom(?) control, which you can get from their web site somewhere.

(Disclaimer: I don't use VB or Java, so I don't have any direct experience with
             any of these).

Peter.