Subject: Small comments on pss-01

From: "Blake Ramsdell" <[email-masked]>
Date: Thu, 1 May 2003 12:57:15 -0700

In pss-01, I believe that draft-jonsson-pkcs1-v2dot1-00.txt has been
released as RFC3447, so the reference "P1v2.1" probably needs updating.

Also, the SHA2 normative reference is not used -- it may need to be
moved to Informational References or removed completely.

I remember some discussion about this at one point, but are we using
X.208 and X.209 for references to ASN.1 / BER / DER instead of X.680 and
X.690?  If not, then these may need updating.

Blake
--
Blake Ramsdell | Brute Squad Labs | http://www.brutesquadlabs.com

---

From: "Jim Schaad" <[email-masked]>
Date: Thu, 1 May 2003 14:30:38 -0700

Blake,

We are still using the X.208/X.209 references for ASN.1/BER since we
have never gone beyond using 1988 syntax.  (Note that the DER reference
is either X509-88 or X.660.)

jim

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Blake Ramsdell
> Sent: Thursday, May 01, 2003 12:57 PM
> To: 'Jim Schaad'; [email-masked]
> Subject: Small comments on pss-01
> 
> 
> 
> In pss-01, I believe that draft-jonsson-pkcs1-v2dot1-00.txt 
> has been released as RFC3447, so the reference "P1v2.1" 
> probably needs updating.
> 
> Also, the SHA2 normative reference is not used -- it may need 
> to be moved to Informational References or removed completely.
> 
> I remember some discussion about this at one point, but are 
> we using X.208 and X.209 for references to ASN.1 / BER / DER 
> instead of X.680 and X.690?  If not, then these may need updating.
> 
> Blake
> --

---

From: "Blake Ramsdell" <[email-masked]>
Date: Thu, 1 May 2003 17:04:58 -0700

(List removed)

> From: Jim Schaad [mailto:[email-masked]] 
> Sent: Thursday, May 01, 2003 2:31 PM
> To: 'Blake Ramsdell'; [email-masked]
> Subject: RE: Small comments on pss-01
> 

Just so we're on the same page, the title of X.660 is "Procedures for
the operation of OSI Registration Authorities: General procedures", and
the title of X.690 is "ASN.1 encoding rules: Specification of Basic
Encoding Rules (BER), Canonical Encoding Rules (CER) and Distinguished
Encoding Rules (DER)".  I've been using X.690 for all of my DER
research, but I could be nutty.

Blake