Subject: RE: Anti-spam news article / S/MIME Gateways

From: "Craig McGregor" <[email-masked]>
Date: Tue, 22 Jun 2004 15:12:14 +1200

>Tumbleweed Chief Executive Jeff Smith says there's a lot of
misunderstanding about 
>S/MIME, because it was created as a desktop encryption technology. He
argues it's
> also simple and cost-effective to use as a gateway authentication
technology, and
> that its quality advantages make it the best choice. Tumbleweed would
like to work
> with Yahoo to merge their technologies.

S/MIME gateway software in the context of a 'closed-community' is a
proven method of authenticating the sending domains of e-mail messages
and has been effective at blocking increased volumes of spoofed e-mail
messages (providing they were sent from a participating domain). And of
cause using S/MIME encryption protects one from in-transit eavesdropping
too! 

Applying what is quite managable in a 'closed-community' for an
Internet-wide deployment would be somewhat more challenging though.
Particularly around certificate deployment, trust-chains and
auto-discovery (assume DNS for internet-wide; a 'closed-community' could
use LDAP). I think that is why domain keys proposes to trust DNS data as
being authorative without any further validation.

Craig.

---

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Tue, 22 Jun 2004 11:13:41 -0700

> cause using S/MIME encryption protects one from in-transit 

Quite, and don't forget that TLS can add value.

> being authorative without any further validation.

Storing keys in the DNS has its place, any technique to obtain
a rough authentication of a domain key is worthwhile. I do not
think the technique works when you get down to the user level.

I entirely disagree on the LDAP issue. I think that LDAP has
had its chance as an Internet protocol and the use that it has
found will never pass beyond the firewall (which contrary to
some thought will not go away).

LDAP is a BAD certificate discovery protocol. It provides none
of the support that is really needed, except in the simplest
trust models where support is unnecessary. XKMS does the job much
better. SCVP might prove to be of use, but the time for deploying
new ASN.1 based protocols has gone. We have seen the future and
it has angle brackets arround it.

---

From: "Trevor Freeman" <[email-masked]>
Date: Fri, 25 Jun 2004 07:45:09 -0700

Hi Phil,
I agree that the end-to-end model is part of the problem. There is
obvious some ground to cover, but I am much more comfortable just fixing
what is broken and reusing what is not. There is no value in reinventing
another wheel - life is to short.
Trevor

* -----Original Message-----
* From: Hallam-Baker, Phillip [mailto:[email-masked]]
* Sent: Thursday, June 24, 2004 9:44 PM
* To: Trevor Freeman; Ben Littauer; [email-masked]
* Subject: RE: Anti-spam news article / S/MIME Gateways
* 
* Trevor,
* 
* 	The CMS format is fine, 95% of the spec is fine.
* 
* 	The problem is that there is a 5% gap between what S/MIME
delivers
* and what is needed.
* 
* 	I think we can close the gap, the key is to throw away the bone
* headed insistence that some people had concerning the end to end model
or
* nothing. We tried that for ten years, we ended up with nothing. IPSEC
* makes
* a lousy VPN protocol for the exact same reason, give me something that
* really works through a NAT box without complaint any day.
* 
* 	What is needed is more than just better discovery protocols, or
* logos in the certs. We need better client interfaces, we also need an
in
* band signalling mechanism so you know that when S/MIME enhancements
are
* being added that the channel can support them, including stripping
them
* out
* if some appliance or client turns out not to support them.
* 
* 	[Draft to follow]
* 
* 		Phill
* 
* > -----Original Message-----
* > From: [email-masked]
* > [mailto:[email-masked]]On Behalf Of Trevor Freeman
* > Sent: Thursday, June 24, 2004 1:42 PM
* > To: Ben Littauer; [email-masked]
* > Subject: RE: Anti-spam news article / S/MIME Gateways
* >
* >
* >
* > Hi Ben
* > I agree there are issues with the trust mechanisms etc. Domain
signing
* > is a good idea. What has that to do with the format and
* > encoding of how
* > you sign a message? What part of CMS is so horribly broken
* > that we need
* > another signature format?
* > Trevor
* >
* > * -----Original Message-----
* > * From: [email-masked]
* > [mailto:[email-masked]]
* > * On Behalf Of Ben Littauer
* > * Sent: Wednesday, June 23, 2004 6:34 AM
* > * To: [email-masked]
* > * Subject: Re: Anti-spam news article / S/MIME Gateways
* > *
* > *
* > * There's scalability and there's scalability.
* > *
* > * The problem with desktop to desktop PKI is both the
* > directory problem
* > * (i.e.
* > * key discovery and distribution) and the administration problem
* > (issuance,
* > * renewal, and revocation of certificates).  Domain-level PKI
reduces
* > the
* > * scale of both problems by several orders of magnitude.  Solving
the
* > domain
* > * level problems first will perhaps give some clue to the mechanisms
* > * required
* > * for the desktop implementation, should it ever become required.
* > *
* > * -ben-
* > *
* > * > From: "Trevor Freeman" <[email-masked]>
* > * > Date: Tue, 22 Jun 2004 11:15:39 -0700
* > * > To: "Craig McGregor" <[email-masked]>, "Russ
* > Housley"
* > * > <[email-masked]>, <[email-masked]>
* > * > Subject: RE: Anti-spam news article / S/MIME Gateways
* > * >
* > * >
* > * > Hi Craig,
* > * > While I understand you comments about closed groups. The real
* > problem
* > * > with scaling beyond closed groups is, as you point out, trust
* > * > mechanisms. What I fail to see is why we need a different
* > signature
* > * > format to deploy a more scalable trust mechanism.
* > * > Trevor
* > * >
* > * > * -----Original Message-----
* > * > * From: [email-masked]
* > * > [mailto:[email-masked]]
* > * > * On Behalf Of Craig McGregor
* > * > * Sent: Monday, June 21, 2004 8:12 PM
* > * > * To: Russ Housley; [email-masked]
* > * > * Subject: RE: Anti-spam news article / S/MIME Gateways
* > * > *
* > * > *
* > * > *
* > * > * >Tumbleweed Chief Executive Jeff Smith says there's a lot of
* > * > * misunderstanding about
* > * > * >S/MIME, because it was created as a desktop encryption
* > technology. He
* > * > * argues it's
* > * > * > also simple and cost-effective to use as a gateway
* > authentication
* > * > * technology, and
* > * > * > that its quality advantages make it the best choice.
* > Tumbleweed
* > * > would
* > * > * like to work
* > * > * > with Yahoo to merge their technologies.
* > * > *
* > * > * S/MIME gateway software in the context of a
* > 'closed-community' is
* > a
* > * > * proven method of authenticating the sending domains of e-mail
* > messages
* > * > * and has been effective at blocking increased volumes of
spoofed
* > e-mail
* > * > * messages (providing they were sent from a participating
domain).
* > And
* > * > of
* > * > * cause using S/MIME encryption protects one from in-transit
* > * > eavesdropping
* > * > * too!
* > * > *
* > * > * Applying what is quite managable in a 'closed-community' for
an
* > * > * Internet-wide deployment would be somewhat more challenging
* > though.
* > * > * Particularly around certificate deployment, trust-chains and
* > * > * auto-discovery (assume DNS for internet-wide; a
* > 'closed-community'
* > * > could
* > * > * use LDAP). I think that is why domain keys proposes to trust
DNS
* > data
* > * > as
* > * > * being authorative without any further validation.
* > * > *
* > * > * Craig.
* > * > *
* > * > *
* > * > *
* > * > *
* > * > *
* > * > *
* > * > *
* > * > *
* > * > *
* > * > *
* > * > *
* > * > *
* > * >
* >
* >

---

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Fri, 25 Jun 2004 09:07:34 -0700

Absolutely, there is no point in reopening the message format issue. All
that does is move us back to the start.

The missing 5% is the stuff that is the diference between security for geeks
and security for real people.

 -----Original Message-----
From: 	Trevor Freeman [mailto:[email-masked]]
Sent:	Fri Jun 25 07:45:20 2004
To:	Hallam-Baker, Phillip; Ben Littauer; [email-masked]
Subject:	RE: Anti-spam news article / S/MIME Gateways

Hi Phil,

---

From: "Hallam-Baker, Phillip" <[email-masked]>
Date: Fri, 25 Jun 2004 09:43:41 -0700

The debate I hope to carry here is that domain keys should be a subset of
smime and not try to design yet another message format.

That way we can get end to end in the end or at least when relevant. 

I would guess that you guys also have cases where end to end is not the best
approach. 

Time to ditch the dogma. The real prolem with ideology is that it is usually
part way right, problem is that it isn't completely right.

 -----Original Message-----
From: 	David P. Kemp [mailto:[email-masked]]
Sent:	Fri Jun 25 08:03:32 2004
To:	Hallam-Baker, Phillip
Cc:	[email-masked]
Subject:	Re: Anti-spam news article / S/MIME Gateways

Phill,

I'll look forward to the draft, to better understand what is needed
beyond user agent enhancements and "better discovery protocols".

    Client A  ---------> GW A -----------> GW B --------> Client B
                              \--------> GW C ---------> Client C

1. Assume no clients support S/MIME, A sends a message to B and C;
GW A needs to discover the gateways serving B and C and encrypt
to the appropriate GWs.

2. Assume only Client B supports S/MIME, GW A needs to discover
GW C and the fact that User B has a cert.

3. Assume only Clients A and B support S/MIME, Client A needs to
discover User B's cert and discover GW C's cert as a proxy for
email address of user C.

An in-band signalling mechanism can only work between signalling-
enabled nodes, which I assume means S/MIME-enabled nodes.  What
kind of signalling is needed other than agreed mechanisms
for handling mixtures of "[email-masked]" gateway certs, [email-masked]
user certs, and Bob (no email address, multi-mail-server) user
certs.  In other words, I don't see what in-band signalling
(contained in messages vs. certificates) you have in mind.

Of course we bone-heads want to ensure that when end-to-end
is available, a MITM can't exploit gateway features to bypass
it.  But that just means that end-to-end must have priority,
not that it's end-to-end or nothing.

Dave

Hallam-Baker, Phillip wrote:
> Trevor,
> 
> 	The CMS format is fine, 95% of the spec is fine.
> 
> 	The problem is that there is a 5% gap between what S/MIME delivers
> and what is needed.
> 
> 	I think we can close the gap, the key is to throw away the bone
> headed insistence that some people had concerning the end to end model or
> nothing. We tried that for ten years, we ended up with nothing. IPSEC
makes
> a lousy VPN protocol for the exact same reason, give me something that
> really works through a NAT box without complaint any day.
> 
> 	What is needed is more than just better discovery protocols, or
> logos in the certs. We need better client interfaces, we also need an in
> band signalling mechanism so you know that when S/MIME enhancements are
> being added that the channel can support them, including stripping them
out
> if some appliance or client turns out not to support them.
> 
> 	[Draft to follow]
> 
> 		Phill

---

From: "Craig McGregor" <[email-masked]>
Date: Mon, 28 Jun 2004 08:48:36 +1200

Trevor,

I do not believe there is a need for a new signature format - existing
S/MIME formats could be used. Perhaps an e-mail gateway / MTA  just
needs to know that the other side supports domain-to-domain signing
and/or encryption.

Perhaps something similar to RFC3183? Or, http://e.govt.nz/see/mail? Or,
http://www.mahealthdata.org/initiatives/e-mail/phases.html?
But spec'd for use in an open-community rather than a closed-community?

Regards,
Craig

> From: [email-masked]
> [mailto:[email-masked]] On Behalf Of Trevor Freeman
> Sent: Friday, 25 June 2004 5:42 a.m.
> To: Ben Littauer; [email-masked]
> Hi Ben
> I agree there are issues with the trust mechanisms etc.
> Domain signing is a good idea. What has that to do with the 
> format and encoding of how you sign a message? What part of 
> CMS is so horribly broken that we need another signature 
> format? Trevor
> 
> * From: [email-masked]
> [mailto:[email-masked]]
> * On Behalf Of Ben Littauer
> * Sent: Wednesday, June 23, 2004 6:34 AM
> * To: [email-masked]
> * Subject: Re: Anti-spam news article / S/MIME Gateways
> * 
> * 
> * There's scalability and there's scalability.
> * 
> * The problem with desktop to desktop PKI is both the 
> directory problem
> * (i.e.
> * key discovery and distribution) and the administration 
> problem (issuance,
> * renewal, and revocation of certificates).  Domain-level PKI 
> reduces the
> * scale of both problems by several orders of magnitude.  
> Solving the domain
> * level problems first will perhaps give some clue to the mechanisms
> * required
> * for the desktop implementation, should it ever become required.
> * 
> * -ben-
> * 
> * > From: "Trevor Freeman" <[email-masked]>
> * > Date: Tue, 22 Jun 2004 11:15:39 -0700
> * > To: "Craig McGregor" <[email-masked]>, 
> "Russ Housley"
> * > <[email-masked]>, <[email-masked]>
> * > Hi Craig,
> * > While I understand you comments about closed groups. The 
> real problem
> * > with scaling beyond closed groups is, as you point out, trust
> * > mechanisms. What I fail to see is why we need a different 
> signature
> * > format to deploy a more scalable trust mechanism.
> * > Trevor
> * >
> * > * On Behalf Of Craig McGregor
> * > * Sent: Monday, June 21, 2004 8:12 PM
> * > * To: Russ Housley; [email-masked]
> * > * Subject: RE: Anti-spam news article / S/MIME Gateways
> * > *
> * > *
> * > *
> * > * >Tumbleweed Chief Executive Jeff Smith says there's a lot of
> * > * misunderstanding about
> * > * >S/MIME, because it was created as a desktop encryption 
> technology. He
> * > * argues it's
> * > * > also simple and cost-effective to use as a gateway 
> authentication
> * > * technology, and
> * > * > that its quality advantages make it the best choice. 
> Tumbleweed
> * > would
> * > * like to work
> * > * > with Yahoo to merge their technologies.
> * > *
> * > * S/MIME gateway software in the context of a 
> 'closed-community' is a
> * > * proven method of authenticating the sending domains of 
> e-mail messages
> * > * and has been effective at blocking increased volumes of 
> spoofed e-mail
> * > * messages (providing they were sent from a participating 
> domain). And
> * > of
> * > * cause using S/MIME encryption protects one from in-transit
> * > eavesdropping
> * > * too!
> * > *
> * > * Applying what is quite managable in a 'closed-community' for an
> * > * Internet-wide deployment would be somewhat more 
> challenging though.
> * > * Particularly around certificate deployment, trust-chains and
> * > * auto-discovery (assume DNS for internet-wide; a 
> 'closed-community'
> * > could
> * > * use LDAP). I think that is why domain keys proposes to 
> trust DNS data
> * > as
> * > * being authorative without any further validation.
> * > *
> * > * Craig.
> * > *
> * > *
> * > *
> * > *
> * > *
> * > *
> * > *
> * > *
> * > *
> * > *
> * > *
> * > *
> * >
> 
> 
>