Subject: To Meet or Not

From: "Sean P. Turner" <[email-masked]>
Date: Thu, 14 Oct 2004 09:25:02 -0400

All,

At the last meeting in San Diego we determined that the list should
decide whether we hold future meetings.  Here's the list of open issues
for this meeting:

- Symkeydist - it's still going to be pinned by CMC

- PSS - it's still going to be pinned by PSS in PKIX

- KEM - it's still going to be pinned/waiting on ANSI

- Static S/MIME Capabilities (i.e., cert extension) - new draft?

- ESS Update - any news?

- GOST - any news?

So a couple of questions:

- Are there any other issues that ought to be addressed?

- Do we believe there is enough to warrant a meeting?

I'll be soliciting input on whether we should have a meeting until 20
October 2004.  Silence means no meeting.

spt

---

From: "Dieter Bratko" <[email-masked]>
Date: Thu, 14 Oct 2004 17:14:56 +0200

Hello,

there seems to be a typo in the HMACwith3DESwrap test vector (chapter 3.4)
of RFC 3537. The PAD value is given as 38be62; but should be be62fe (see
LKEYPADICV)?

Regards,
Dieter Bratko

---------
Dieter Bratko, mailto:[email-masked]
SIC - Stiftung Secure Information and Communication Technologies
IAIK, Inffeldgasse 16a, 8010 Graz, Austria, http://jce.iaik.tugraz.at/

---

From: Russ Housley <[email-masked]>
Date: Thu, 14 Oct 2004 16:18:09 -0400

I just reran my test code from the development of this RFC, and you are 
correct.

I do not remember if we used my code or Jim's code to generate the test 
vector data for the RFC, but the PAD value is incorrect in the RFC.

 >hmac_3des_key_wrap
3DES KEK     :
   KEK Key 1  :  5840df6e 29b02af1
   KEK Key 2  :  ab493b70 5bf16ea1
   KEK Key 3  :  ae8338f4 dcc176a8

Length (L)   :  14

KEY          :  c37b7e64 92584340
              :  bed12207 80894115
              :  5068f738

PAD          :  be62fe

ICV          :  1f363a31 cdaa9037

LKEYPADICV   :  14c37b7e 64925843
              :  40bed122 07808941
              :  155068f7 38be62fe
              :  1f363a31 cdaa9037

IV           :  050d8c79 e0d56b75

TEMP1        :  157a8210 f432836b
              :  a618b096 475c864b
              :  6612969c dfa445b1
              :  5646bd00 500b2cc1

TEMP2        :  050d8c79 e0d56b75
              :  157a8210 f432836b
              :  a618b096 475c864b
              :  6612969c dfa445b1
              :  5646bd00 500b2cc1

TEMP3        :  c12c0b50 00bd4656
              :  b145a4df 9c961266
              :  4b865c47 96b018a6
              :  6b8332f4 10827a15
              :  756bd5e0 798c0d05

Wrapped Key  :  0f1d715d 75a0aaf6
              :  6f02e371 c08b79e2
              :  a1253dc4 3040136b
              :  dc161118 601f2863
              :  e2929b3b dd17697c