Subject: RE: To Meet or Not

From: "Jim Schaad" <[email-masked]>
Date: Mon, 8 Nov 2004 11:20:18 -0500

I concur that there is an error in the document.  My guess is that it was a
cut and paste error as my code produces the correct values, but I tended to
cut the entire blob in and then broke it apart.  Russ and I will get an
errata posted on this issue.

jim

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Russ Housley
> Sent: Thursday, October 14, 2004 4:18 PM
> To: Dieter Bratko; SMIME
> Subject: Re: To Meet or Not
> 
> 
> I just reran my test code from the development of this RFC, 
> and you are correct.
> 
> I do not remember if we used my code or Jim's code to 
> generate the test vector data for the RFC, but the PAD value 
> is incorrect in the RFC.
> 
>  >hmac_3des_key_wrap
> 3DES KEK     :
>    KEK Key 1  :  5840df6e 29b02af1
>    KEK Key 2  :  ab493b70 5bf16ea1
>    KEK Key 3  :  ae8338f4 dcc176a8
> 
> Length (L)   :  14
> 
> KEY          :  c37b7e64 92584340
>               :  bed12207 80894115
>               :  5068f738
> 
> PAD          :  be62fe
> 
> ICV          :  1f363a31 cdaa9037
> 
> LKEYPADICV   :  14c37b7e 64925843
>               :  40bed122 07808941
>               :  155068f7 38be62fe
>               :  1f363a31 cdaa9037
> 
> IV           :  050d8c79 e0d56b75
> 
> TEMP1        :  157a8210 f432836b
>               :  a618b096 475c864b
>               :  6612969c dfa445b1
>               :  5646bd00 500b2cc1
> 
> TEMP2        :  050d8c79 e0d56b75
>               :  157a8210 f432836b
>               :  a618b096 475c864b
>               :  6612969c dfa445b1
>               :  5646bd00 500b2cc1
> 
> TEMP3        :  c12c0b50 00bd4656
>               :  b145a4df 9c961266
>               :  4b865c47 96b018a6
>               :  6b8332f4 10827a15
>               :  756bd5e0 798c0d05
> 
> Wrapped Key  :  0f1d715d 75a0aaf6
>               :  6f02e371 c08b79e2
>               :  a1253dc4 3040136b
>               :  dc161118 601f2863
>               :  e2929b3b dd17697c
> 
> 
> At 11:14 AM 10/14/2004, Dieter Bratko wrote:
> 
> >Hello,
> >
> >there seems to be a typo in the HMACwith3DESwrap test vector 
> (chapter 
> >3.4) of RFC 3537. The PAD value is given as 38be62; but should be 
> >be62fe (see LKEYPADICV)?
> >
> >Regards,
> >Dieter Bratko
> >
> >---------
> >Dieter Bratko, mailto:[email-masked] SIC - Stiftung Secure 
> >Information and Communication Technologies IAIK, 
> Inffeldgasse 16a, 8010 
> >Graz, Austria, http://jce.iaik.tugraz.at/
> 
> 
>

---

From: Russ Housley <[email-masked]>
Date: Mon, 08 Nov 2004 13:38:47 -0500

>Date: Thu, 14 Oct 2004 16:24:43 -0400
>To: [email-masked]
>From: Russ Housley <[email-masked]>
>Subject: RFC 3537 Errata
>
>Dear RFC Editor:
>
>There is a typographical error in section 3.4 of RFC 3537.
>Since this error occurs in an algorithm test vector, it is
>important to publish the corrected data.
>
>OLD:
>
>    PAD          :  38be62
>
>NEW:
>
>    PAD          :  be62fe
>
>Thanks,
>   Russ