Subject: on the use of IBC with CMS

From: Michael Cheng <[email-masked]>
Date: Mon, 11 Jun 2007 13:31:44 +0100

Hi List,

We have just submitted a draft on the use of 

Identity-Based Cryptography in CMS to this working group.

We are aware that there are several group working drafts 

which are dealing with Identity-Based Encryption in CMS. 

However, we think it is important to look at the use of 

IBC in CMS as a whole, including both IBE and Identity-Based 

Signature.

As the Signed-Data content type does not support new extensions 

as the Enveloped-Data content type, the encoding method used in 

the existing drafts, which merely focus on IBE, cannot be adopted

for IBS.

In our draft, we take a unified approach to deal with encoding 

both IBS and IBE in CMS.

Of course, there could be other encoding schemes within the current 

CMS framework. We hope this submission could initiate serious 

discussion on the use of IBC in CMS.

Kind regards,

Michael Cheng
 
Middlesex University
The Burroughs Hendon, 
London NW4 4BT, UK       
Phone: +44 20 84114932 
Email: [email-masked]

---

From: Russ Housley <[email-masked]>
Date: Mon, 11 Jun 2007 09:54:28 -0400

What is the name of the draft?

At 08:31 AM 6/11/2007, Michael Cheng wrote:

Hi List,

Signature.

for IBS.

both IBS and IBE in CMS.

Kind regards,

Michael
Cheng

Middlesex
University

The Burroughs Hendon,

London NW4 4BT,
UK

Phone: +44 20 84114932