Subject: Verifying SMIME CAPS

From: Sean Turner <[email-masked]>
Date: Mon, 18 May 2009 13:42:05 -0400

So far I've been able to verify the following SMIME Caps from at least 
two implementations:
  SHA-1 (absent parameters)
  MD5   (absent parameters)
  DES-EDE3-CBC (absent parameters)
  DES-CBC (absent parameters)
  RC2-128 (parameters INT=128)
  RC2-64 (parameters INT=64)
  RC2-40 (parameters INT=40)

Still trying to locate two examples for:
  SHA-224, SHA-256, SHA-384, SHA-512
  Any: ECDH, ECMQV, DH, GOST, AES-CCM-*, AES-GCM-*, HMAC-*,
       RSA with *, DSA with *, and probably some others

Looking for one more implementation that:
  SEED
  Camilla
  AES-128, 192, 256 CBC
  IDEA
  CAST

spt

---

From: Dr Stephen Henson <[email-masked]>
Date: Mon, 18 May 2009 19:09:09 +0100

> Looking for one more implementation that:

OpenSSLs CMS implementation includes the three AES cases above and it can also
include GOST OIDs if the GOST ENGINE is loaded.

It is easy enough to add SHA-2* OIDS too.

Steve.
-- 
Dr Stephen N. Henson.
Core developer of the   OpenSSL project: http://www.openssl.org/
Freelance consultant see: http://www.drh-consultancy.co.uk/
Email: [email-masked], PGP key: via homepage.