Subject: snmpconf update to the Diffserv Policy MIB

From: David Partain <[email-masked]>
Date: Mon, 26 Feb 2001 14:08:57 +0100

Greetings,

At http://www.cs.utk.edu/~partain/draft-ietf-snmpconf-diffpolicy-PRE04.txt
you will find a PRELIMINARY version of the draft that Harrie
and I will be submitting prior to the deadline on Friday.
The only section that is new is 7.1, which is an example.  So,
if you care, that's where you should look.  Given the hairy
nature of the diffserv MIB, the example may not be perfect,
so comments are more than welcome.

Ignore for the moment the fact that the dates and such are
incorrect.  That will be corrected prior to submission.

With kind regards,

David Partain

---

From: "Jonas Olsson M (ERA)" <[email-masked]>
Date: Wed, 28 Feb 2001 08:29:02 +0100

Hi David,

Some remarks on the DiffServ Policy MIB.

(p. 11) In your policy: setvar("diffServDataPathStart" + $1 + "2", ... 
Should it not read: setvar("diffServDataPathStart." + $1 + ".2", ... ?

(p. 12, In diffPolicyDPCTable): 
Reads: diffServPolicyDPCConfiguration = diffServClfrElementId.1
Comment: diffServClfrElementId is not accessible!

(In diffPolicyDPCTable): diffPolicyDPCConfiguration points to an instance of diffServClfrElementEntry, but according to the specification on p. 17 it should point to an instance of one of:
	diffServClfrEntry
	diffServMeterEntry
	diffServActionEntry
	diffServAlgDropEntry
	diffServQEntry

(Sec. 7.1) You use the term "policy rule" for the IF-THEN command, while (as far as I know) SNMPConf uses the term "policy" (except in definition of pmRoleSEString in the Policy MIB).  

Best regards,

Jonas Olsson

-----Original Message-----
From: David Partain [mailto:[email-masked]]
Sent: den 26 februari 2001 14:09
To: [email-masked]
Subject: snmpconf update to the Diffserv Policy MIB

Greetings,

With kind regards,

David Partain