Subject: snmpconf PM MIB issue #7 - pmPolicyAdminStatus name

From: Steve Waldbusser <[email-masked]>
Date: Mon, 04 Jun 2001 10:22:04 -0700

Issue #7 suggests that the pmPolicyAdminStatus might be confused with
ifAdminStatus and that instead we should change it to
pmPolicyEnabledStatus.

I think that AdminStatus has become an idiom in
SNMP MIBs for the read-write administratively desired state of
something. I found wide use of this idiom:

rfc1473 pppIpConfigAdminStatus
rfc1474 pppBridgeConfigAdminStatus
rfc1604 frPVCConnectAdminStatus
rfc1657 bgpPeerAdminStatus
rfc1658 charPortAdminStatus
rfc1695 atmVplAdminStatus
        atmVclAdminStatus
        atmVpCrossConnectAdminStatus
        atmVcCrossConnectAdminStatus
rfc1747 sdlcLSAdminState
rfc2051 appcCntrlAdminStat
        appcTpAdminStatus
rfc2108 rptrPortAdminStatus
etc...

(www.mibcentral.com has a search facility that's helpful for this
search)

I think we should stick with the current name.

Steve

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Tue, 5 Jun 2001 10:24:06 +0200

>>>>> Steve Waldbusser writes:

Steve> Issue #7 suggests that the pmPolicyAdminStatus might be
Steve> confused with ifAdminStatus and that instead we should change
Steve> it to pmPolicyEnabledStatus.

Steve> I think that AdminStatus has become an idiom in SNMP MIBs for
Steve> the read-write administratively desired state of something. I
Steve> found wide use of this idiom:

[...]

Steve> I think we should stick with the current name.

I agree.

/js

---

From: David Harrington <[email-masked]>
Date: Tue, 05 Jun 2001 11:42:05 -0400

I think I raised the issue, and I do not consider this high priority. 
As far as I am concerned your proposal to leave it as is is acceptable.

dbh

-- 
---
David Harrington            Network Management Standards Architect
[email-masked]           Office of the CTO
+1 603 337 2614 - voice     Enterasys Networks
+1 603 332 1524 - fax       Rochester NH, USA

---

From: David Partain <[email-masked]>
Date: Mon, 11 Jun 2001 11:37:45 +0200

Hi,

> As far as I am concerned your proposal to leave it as is is acceptable.

Closed.

Cheers,

dlp