Subject: RE: I-D ACTION:draft-hardaker-snmp-session-sm-00.txt

From: "Golovinsky, Eugene" <[email-masked]>
Date: Thu, 9 Oct 2003 10:15:40 -0500

Wes.

For your TODO list. I think we also need to have a section that allows
management of sessions.
In other words an "administrator" should be able to get a list of active
sessions with associated statistics, to be 
able to remove/disable/suspend sessions and to revoke session keys if
necessary.
Simply relaying on aging of the session or the key may not be enough.

Cheers.
--Gene

Gene Golovinsky
BMC Software, Inc
Cross Business Unit Development

[email-masked]
Office:	713-918-1816
Mobile:	832-876-2726

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Monday, October 06, 2003 12:14 PM
Cc: [email-masked]
Subject: I-D ACTION:draft-hardaker-snmp-session-sm-00.txt

A New Internet-Draft is available from the on-line Internet-Drafts
directories.

	Title		: A Security Based Session Model (SBSM) for the
Simple
			  Network Management Protocol (SNMP).
	Author(s)	: W. Hardaker
	Filename	: draft-hardaker-snmp-session-sm-00.txt
	Pages		: 39
	Date		: 2003-10-6
	
This document describes a Session Based Security Model (SBSM) for use within
the Simple Network Management Protocol (SNMP).  The security model is
designed to establish a 'session' between two interacting hosts, over which
SNMP operations can be sent.  It provides a number of security properties
not previously available in defined SNMP security models, such as public key
based authentication, limited life-time keying, and the ability to make use
of previously implemented and deployed security infrastructures for purposes
of identification and authentication.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-hardaker-snmp-session-sm-00.txt

To remove yourself from the IETF Announcement list, send a message to 
ietf-announce-request with the word unsubscribe in the body of the message.

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in, type
"cd internet-drafts" and then
	"get draft-hardaker-snmp-session-sm-00.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-hardaker-snmp-session-sm-00.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: Wes Hardaker <[email-masked]>
Date: Thu, 09 Oct 2003 10:29:38 -0700

>>>>> On Thu, 9 Oct 2003 10:15:40 -0500 , "Golovinsky, Eugene" <[email-masked]> said:

Eugene> For your TODO list. I think we also need to have a section that allows
Eugene> management of sessions.

Yep.  It's actually planned for the MIB, and David Perkins has
promised to write a MIB to do a good number of the tasks you've talked
about.

Eugene> Simply relaying on aging of the session or the key may not be enough.

Agreed.

Thanks for the comments!  (and the feedback to let us know that you
think a management element is needed as well)
-- 
Wes Hardaker
Sparta