Subject: RE: [Softwires] Charter review and WG creation

From: "Durand, Alain" <[email-masked]>
Date: Wed, 7 Sep 2005 15:31:00 -0400

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Pekka Savola
> Sent: Wednesday, September 07, 2005 2:58 PM
> To: Mark Townsley
> Cc: [email-masked]
> Subject: Re: [Softwires] Charter review and WG creation
> 
> 
> Alain said:
> >We are trying to model our kick-off metting on the procedure 
> that was 
> >followed during the creation of v6ops, i.e. announcing the meeting a 
> >month in advance, anticipating the formal creation of the wg.
> 
> Remember that the case was a bit different -- the interim 
> meeting was first announced for *ngtrans*, an existing WG, 
> according to the appropriate procedures.  Right now, we still 
> don't have a WG, so we probably can't have *WG* interim meetings..

Here is the announcement that was sent for the v6ops interim kick-off
meeting.
No mention of Ngtrans.

   - Alain.

From:  Margaret Wasserman <[email-masked]>
To: IETF-Announce:;
dcc: all-ietf
Subject: IPv6 Operations (v6ops) Interim Meeting
--------
Hi All,

As we saw in Yokohama, the global deployment of IPv6 is underway,
creating an IPv4/IPv6 Internet consisting of IPv4-only, IPv6-only and
IPv4/IPv6 networks and nodes.  This deployment must be properly
handled to avoid the division of the Internet into separate IPv4 and
IPv6 networks while ensuring global addressing and connectivity for
all IPv4 and IPv6 nodes.

To meet this need, we have proposed the formation of IPv6 Operations
Working Group (v6ops) within the OPS area.  If approved by the IESG,
this new WG will develop guidelines for the operation of a shared
IPv4/IPv6 Internet and provide guidance for network operators on how
to deploy IPv6 into existing IPv4-only networks, as well as into new
network installations.

In anticipation of IESG approval for the formation of this new WG, we
have scheduled an interim meeting of the v6ops WG for September 18th &
19th, 2002 in Sunnyvale, CA.  A proposed agenda for the interim
meeting is included below.

Further information about this meeting, including travel details and a 
sign-up form can be found at:

http://home.attbi.com/~margaretw/v6ops-Interim-Sep02.html

Attendance at the meeting will be limited to 85 people, due to the size
of the available facility.  If you plan to attend, please register ASAP,
as space is filling up fast.

itojun and Margaret
[The proposed v6ops WG chairs]

IPv6 Operations (v6ops) Interim Meeting
Wednesday & Thursday, September 18th & 19th, 2002
=================================================

CHAIRS		Jun-Ichiro itojun Hagino <[email-masked]>
		Margaret Wasserman <[email-masked]>

LOCATION	Wind River
		201 Moffett Park Drive
		Sunnyvale, CA

SCHEDULE	0830-1730, Wednesday & Thursday

SIGN-UP/INFO
http://home.attbi.com/~margaretw/v6ops-Interim-Sep02.html

PROPOSED AGENDA

Wednesday, September 18th
=========================

0830-0900	Continental Breakfast

0900-1200

Introduction and Agenda Bashing (10 min)

Review v6ops Charter (as approved by IESG) (2 hrs)
	- Overall mission of the WG
	- Review Task List
	- Reach consensus on goals and priorities 

Discuss Candidate Work Items:

- Survey of IPv4 Addresses in IETF Standards -- Phil Nesser (15 min)
 
http://www.ietf.org/internet-drafts/draft-ietf-ngtrans-ipv4survey-02.txt
	- Current status and open issues
	- Accept as a WG work item?

- Transition Mechanisms Update -- Erik Nordmark (15 min)
   http://www.ietf.org/internet-drafts/draft-ietf-ngtrans-mech-v2-00.txt
	- Current status and open issues
	- Accept as a WG work item?

1200-0130	Lunch

0130-0530

Security Implications of Mixed IPv4/IPv6 Networks (1-1/2 hours)

Discussion/Status of Deployment Scenario/Solutions Work
	- Introduction and Re-Focus (15 min)
	- Cellular Networks (30 min)
	- ISP Networks (30 min)
	- Unmanaged Network (30 minutes)
	- Enterprise Networks (30 min)

Thursday, September 19th
========================

0830-0900	Continental Breakfast

0900-1200	[Deployment Solution Break-outs]

Goals of Breakout Sessions and Formation of Breakout Groups (15 min)

Deployment Solution Breakouts (2-1/2 hours)
	- Cellular Networks
	- ISP Networks
	- Unmanaged Networks
	- Enterprise Networks

1200-0130	Lunch

0130-0530	

Breakout Reports and Next Steps
	- Cellular Networks (20 min)
	- ISP Networks (20 min)
	- Unmanaged Networks (20 min)
	- Enterprise Networks (20 min)

New Work Related to v6ops Charter (2 hours)

Wrap-up and Review of Action Items (30 min)

_______________________________________________
Softwires mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/softwires

---

From: "Durand, Alain" <[email-masked]>
Date: Wed, 7 Sep 2005 15:53:28 -0400

> > 2. Is the posted charter ready as is?
> 
> Not quite -- and quite frankly, I think it is way too 
> optimistic to assume everything would go through without 
> questions asked.
> 
> That doesn't need to preclude having a meeting though.  We 
> just can call it an informal, pre-WG interim meeting, a third 
> BOF or whatever :-).
> 
> In any event, the WG isn't going to be chartered by the 
> face-to-face meeting, that's for sure.  If the WG would be 
> chartered before the IETF scheduling cut-off dates (or heck, 
> the next IETF :), I'd call even that a tremendous success!

So, could we get to the point and comment on the said charter?

   - Alain.

---

From: "Durand, Alain" <[email-masked]>
Date: Wed, 7 Sep 2005 18:17:35 -0400

Pekka,

This is the reason why I think the charter should stay away from saying anything about limiting softwires to customer-to-isp scenario or on the opposite, actually describing the intra-isp case.

   - Alain.

-----Original Message-----
From: Pekka Savola <[email-masked]>
To: Durand, Alain <[email-masked]>
CC: [email-masked] <[email-masked]>; [email-masked] <[email-masked]>; [email-masked] <[email-masked]>
Sent: Wed Sep 07 18:02:59 2005
Subject: Re: [Softwires] Charter review and WG creation

On Wed, 7 Sep 2005, Durand, Alain wrote:
> Should we explicitely rulled out the intra-isp tunnelibg case now?
>
> A) in Paris, sprint and the chineese ISP were asking for it

It would be useful to have them speak up on the list on why they think 
the solution is needed; in the earlier mail, I wrote my reasons why I 
think it isn't.

Don't get me wrong: softwires protocol _could_ be used used in 
intra-ISP cases as well, but:
  a) The benefits offered by the softwires protocol compared to the
     manual config don't seem significant, and there are significant
     problem.
  b) There is no need to wait for the softwires protocol
     (specification, implementation, deployment, ...), as everything
     can be done easily manually today, from day one.

As such, even b) alone would give the wrong signal that intra-ISP 
cases need to wait for the protocol, which would unduly delay 
deployment.

Thus designing and/or marketing the protocol for intra-ISP case seems 
counterproducive *unless* we get to hear more about the operators' 
requirements why they think it's necessary.

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings
_______________________________________________
Softwires mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/softwires