Subject: RE: [Softwires] Charter review and WG creation

From: "Durand, Alain" <[email-masked]>
Date: Wed, 7 Sep 2005 12:53:42 -0400

We should target the interim meeting early october.

   - Alain. 

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of JORDI PALET MARTINEZ
> Sent: Wednesday, September 07, 2005 12:30 PM
> To: [email-masked]
> Subject: Re: [Softwires] Charter review and WG creation
> 
> Ok. Then, when is the date (if fixed) or target one to get 
> the WG chartered, so everybody that has something in the way 
> make sure to send to the RFC editor before ?.
> 
> Regards,
> Jordi
> 
> 
> 
> 
> > De: Mark Townsley <[email-masked]> Responder a: 
> > <[email-masked]>
> > Fecha: Wed, 07 Sep 2005 14:34:01 +0200
> > Para: <[email-masked]>
> > CC: "[email-masked]" <[email-masked]>
> > Asunto: Re: [Softwires] Charter review and WG creation
> > 
> > JORDI PALET MARTINEZ wrote:
> > 
> >> Hi Mark,
> >> 
> >> Somehow you replied my question regarding the IETF process. I just 
> >> readed
> >> 3932 now so I'm up-to-date on that ;-), but still not 
> clear to me if 
> >> you're referring to RFCs or IDs ?
> >>  
> >> 
> > 
> >> The question is still, regardless of the process, if this 
> is fair w/o 
> >> making sure that we have a clear deadline for those 
> documents. Some 
> >> being cooked my be inadvertently be left out if a concrete date (a 
> >> fair one) is not fixed up-front.
> >> 
> >>  
> >> 
> > Again, in principal any idea may be brought to the WG to be 
> considered 
> > at any time and in any form. But, once the WG exists, I 
> would like all 
> > energies focused on creating a standard solution (which may include 
> > making decisions which will not be revisited). After the 
> standard is 
> > published, other methods may be sent to the RFC Editor, 
> shepherded by 
> > and AD, etc. I'm not really creating any special policy here, just 
> > identifying that RFC 3932 exists and not to be surprised if 
> it is used.
> > 
> > I was told that in the past IESG members have said that, 
> since there 
> > was no WG chartered for creating this protocol, to send any 
> > submissions directly to the RFC Editor for publication or 
> to find an 
> > AD to shepherd the work. I don't necessarily want to rehash all the 
> > associated history, so I am simply pointing out now that 
> this is all 
> > well and good up until the point the IETF community decides to take 
> > this work on as a standards-track effort by chartering a WG. It 
> > logically follows, then, that if you have a protocol that 
> you believe 
> > should have an RFC published for *regardless* of the 
> outcome of the WG 
> > (for example, in your opinion it is well-documented, 
> implemented and 
> > deployed), you might be well served to get these to the RFC 
> Editor as 
> > individual submissions before the WG exists. Whether you do this or 
> > not has no bearing on whether the solution will be 
> considered in the 
> > WG or not, what is more important to the WG is whether the solution 
> > actually is well-documented, implemented and deployed when 
> judged by consensus.
> > 
> > 
> >> What about the expired I-Ds ? If they are candidate, need to be 
> >> resubmitted, even w/o modifications or they will still be 
> considered ?
> >>  
> >> 
> > Expired IDs are never a good thing to bring to a WG. Please 
> update any 
> > IDs you would like to discuss in the WG with the latest 
> boiler-plates, 
> > etc. I don't think I am saying anything new here.
> > 
> > All good ideas will be considered. As I believe it states in the 
> > proposed charter, existing mechanisms will be given more 
> weight than 
> > those that do not exist. Thus, if an idea is brought 
> forward that is 
> > brand new, with no implementations or deployments, it carries a 
> > substantially greater burden of proof than one that does 
> have multiple 
> > implementations and/or deployments. In other words, the WG prefers 
> > running code.
> > 
> > - Mark
> > 
> >> Regards,
> >> Jordi
> >> 
> >> 
> >> 
> >> 
> >>  
> >> 
> >>> De: Mark Townsley <[email-masked]> Responder a: 
> >>> <[email-masked]>
> >>> Fecha: Wed, 07 Sep 2005 12:19:11 +0200
> >>> Para: "[email-masked]" <[email-masked]>
> >>> Asunto: [Softwires] Charter review and WG creation
> >>> 
> >>> 
> >>> Everyone,
> >>> 
> >>> Again, apologies for the administrative bumbling getting 
> this list 
> >>> together, proposed charter ready, etc. I learned some 
> lessons here, 
> >>> sorry you had to be the group to endure that.
> >>> 
> >>> Please review the charter on the link that Dave posted 
> and provide 
> >>> feedback here. Naturally, I'd like to finalize this and 
> move towards 
> >>> a WG before the proposed interim meeting date. Please review the 
> >>> presentations from the BoF as well, and if you have any questions 
> >>> now is the time to post them (though be sure to look at 
> the Chairs' 
> >>> "obvious questions" slide before). Let's hold back on discussing 
> >>> solutions just yet, and stay focused on the proposed 
> charter. If you 
> >>> think it is good in its present form, please make that 
> known as well.
> >>> 
> >>> I understand there was some confusion at the BoF in Paris 
> about what 
> >>> "candidate proposals" will be considered for this WG. 
> Please let me 
> >>> clarify that, in general, good ideas are always welcome, 
> and any can 
> >>> be brought to the WG in whatever form at any time (ID, 
> email, etc). 
> >>> That said, this WG will be on a very tight schedule for 
> some of its 
> >>> first deliverables, and there will be some important 
> choices for the 
> >>> WG to make and not be revisited ad-infinitum. Also, please note 
> >>> that, once the WG is formed, the IESG may request that the RFC 
> >>> Editor withhold publication of any overlapping or 
> conflicting until 
> >>> the WG concludes its work (as described in RFC 3932).
> >>> 
> >>> Many thanks,
> >>> 
> >>> - Mark
> >>> 
> >>> _______________________________________________
> >>> Softwires mailing list
> >>> [email-masked]
> >>> https://www1.ietf.org/mailman/listinfo/softwires
> >>>    
> >>> 
> >> 
> >> 
> >> 
> >> 
> >> ************************************
> >> The IPv6 Portal: http://www.ipv6tf.org
> >> 
> >> Barcelona 2005 Global IPv6 Summit
> >> Information available at:
> >> http://www.ipv6-es.com
> >> 
> >> This electronic message contains information which may be 
> privileged 
> >> or confidential. The information is intended to be for the 
> use of the
> >> individual(s) named above. If you are not the intended 
> recipient be 
> >> aware that any disclosure, copying, distribution or use of the 
> >> contents of this information, including attached files, is 
> prohibited.
> >> 
> >> 
> >> 
> >> 
> >> _______________________________________________
> >> Softwires mailing list
> >> [email-masked]
> >> https://www1.ietf.org/mailman/listinfo/softwires
> >> 
> >>  
> >> 
> 
> 
> 
> 
> ************************************
> The IPv6 Portal: http://www.ipv6tf.org
> 
> Barcelona 2005 Global IPv6 Summit
> Information available at:
> http://www.ipv6-es.com
> 
> This electronic message contains information which may be 
> privileged or confidential. The information is intended to be 
> for the use of the individual(s) named above. If you are not 
> the intended recipient be aware that any disclosure, copying, 
> distribution or use of the contents of this information, 
> including attached files, is prohibited.
> 
> 
> 
> 
> _______________________________________________
> Softwires mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/softwires
> 

_______________________________________________
Softwires mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/softwires

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Thu, 08 Sep 2005 00:12:29 +0700

Hi Alain,

Agree, but the question was when is the target date for the WG creation,
otherwise is not clear when the documents that aren't submitted at that time
will lose weight ;-)

Regards,
Jordi

> De: "Durand, Alain" <[email-masked]>
> Responder a: <[email-masked]>
> Fecha: Wed, 7 Sep 2005 12:53:42 -0400
> Para: <[email-masked]>, <[email-masked]>
> Asunto: RE: [Softwires] Charter review and WG creation
> 

This electronic message contains information which may be privileged or confidential. The information is intended to be for the use of the individual(s) named above. If you are not the intended recipient be aware that any disclosure, copying, distribution or use of the contents of this information, including attached files, is prohibited.

---

From: Mark Townsley <[email-masked]>
Date: Wed, 07 Sep 2005 19:40:25 +0200

>otherwise is not clear when the documents that aren't submitted at that time
I'd like it to happen soon, that depends first on whether we are all 
happy with the charter in its current form or not.

- Mark

---

From: Mark Townsley <[email-masked]>
Date: Wed, 07 Sep 2005 20:09:09 +0200

After reviewing the rules here, we are really cutting things close for 
this interim.

 From http://www.ietf.org/IESG/STATEMENTS/Interim-meetings.txt (Thanks 
Pekka)

- They cannot be held within 30 days prior to an IETF meeting
- They must be announced at least 30 days in advance
- The proposed agenda must be published at least 15 days before meeting 

So, to be strict, we needed to send an announcement to [email-masked] before, 
well, yesterday, and we cannot hold the meeting after Oct 6. Since the time between 
meetings is less than usual (3 instead of 4 months), I think we can relax that a week. So,
latest possible date Oct 13, preferably earlier. 

The announcement for the meeting needs to be sent ASAP, if we hold the meeting on 
Oct 10, the announcement must be sent before Sept 10. 

As for WG creation, if I can have consensus that the charter is ready by *tomorrow* 
(Thurs, Sept 8) and the process goes perfectly, the WG could exist by Sept 29. 

That all said, I'd like to get a poll from the group:

1. Should we have an interim meeting on or around Oct 10?

2. Is the posted charter ready as is?

Thanks,

- Mark

---

From: Pekka Savola <[email-masked]>
Date: Wed, 7 Sep 2005 21:58:03 +0300 (EEST)

Alain said:
>We are trying to model our kick-off metting on the procedure that was
>followed during the creation of v6ops, i.e. announcing the meeting a
>month in advance, anticipating the formal creation of the wg.

Remember that the case was a bit different -- the interim meeting was 
first announced for *ngtrans*, an existing WG, according to the 
appropriate procedures.  Right now, we still don't have a WG, so we 
probably can't have *WG* interim meetings..

On Wed, 7 Sep 2005, Mark Townsley wrote:
> The announcement for the meeting needs to be sent ASAP, if we hold the 
> meeting on Oct 10, the announcement must be sent before Sept 10. 
> As for WG creation, if I can have consensus that the charter is ready by 
> *tomorrow* (Thurs, Sept 8) and the process goes perfectly, the WG could exist 
> by Sept 29. 
>

It might not hurt, if there is sufficient energy/time to prepare it 
well and people can attend it.

(I don't have funding to attend, but if there is a remote 
participation facility, I could possibly "attend" that way).

> 2. Is the posted charter ready as is?

Not quite -- and quite frankly, I think it is way too optimistic to 
assume everything would go through without questions asked.

That doesn't need to preclude having a meeting though.  We just can 
call it an informal, pre-WG interim meeting, a third BOF or whatever 
:-).

In any event, the WG isn't going to be chartered by the face-to-face 
meeting, that's for sure.  If the WG would be chartered before the 
IETF scheduling cut-off dates (or heck, the next IETF :), I'd call 
even that a tremendous success!

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings

---

From: JORDI PALET MARTINEZ <[email-masked]>
Date: Thu, 08 Sep 2005 09:07:55 +0700

Agree, if we need the meeting and want to make it an informal one should be
fine.

I think is more relevant to have a good consensus in the charter instead of
hurrying up to fix it just to make the meeting a formal one.

Regards,
Jordi

> De: Pekka Savola <[email-masked]>
> Responder a: <[email-masked]>
> Fecha: Wed, 7 Sep 2005 21:58:03 +0300 (EEST)
> Para: Mark Townsley <[email-masked]>
> CC: <[email-masked]>, "[email-masked]" <[email-masked]>