Subject: [Softwires] DS-lite update

From: Alain Durand <[email-masked]>
Date: Thu, 3 Mar 2011 07:50:07 -0800

Dear ADs,

New rev of the them main DS-lite doc (draft-ietf-softwire-dual-stack-lite-07) and the DHCP tunnel option (draft-ietf-softwire-ds-lite-tunnel-option-09)
have been published. I believe they address all remaining comments. This should enable to restart the IESG process.

  - Alain.

---

From: <[email-masked]>
Date: Thu, 17 Mar 2011 09:55:56 +0100

Dear all,

I have just read the new DS-Lite version and I have the following comments for Section 8:

(1)

"
8.2. NAT conformance

   A dual-stack lite AFTR SHOULD implement behavior conforming to the
   best current practice, currently documented in [RFC4787] and
   [RFC5382].  Other discusions about carrier-grade NATs can be found in
   [I-D.nishitani-cgn]."

* This text should be updated to something like: "a DS-Lite AFTR MUST follow the requirements specified in [I-D.ietf-behave-lsn-requirements]".
* In addition, [I-D.ietf-behave-lsn-requirements] is to be listed as a normative reference.

(2)

Section "8.3. Application Level Gateways (ALG)" is to be removed since this can be covered in [I-D.ietf-behave-lsn-requirements].

Cheers,
Med 

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de Alain Durand
Envoyé : jeudi 3 mars 2011 16:50
À : Jari Arkko; Ralph Droms
Cc : [email-masked] list; Yong Cui
Objet : [Softwires] DS-lite update

Dear ADs,

  - Alain.

_______________________________________________
Softwires mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/softwires

---

From: Francis Dupont <[email-masked]>
Date: Thu, 17 Mar 2011 16:47:11 +0100

In your previous mail you wrote:

   * This text should be updated to something like: "a DS-Lite AFTR MUST follo=
   w the requirements specified in [I-D.ietf-behave-lsn-requirements]".
   * In addition, [I-D.ietf-behave-lsn-requirements] is to be listed as a norm=
   ative reference.
   
=> I have a mixed opinion about this: RFC 4787 and 5382 are clearly
disconnected from the reality to stay polite. CGN (aka LSN)
requirements should be better but it is a work in progress.
I can't see a solution, in particular if we want this document to
be published as a RFC soon...

Thanks

[email-masked]

---

From: Alain Durand <[email-masked]>
Date: Thu, 17 Mar 2011 18:04:37 -0700

Comments like this one should really have been sent  during the wg last call, long ago...

That said, I tend to agree with Francis that MUST is too strong.

As about ALG, I do not see what is wrong there.

  - Alain.