Subject: Re: [Softwires] WG Review: Recharter of Softwires (softwire)

From: Tomoki Murai <[email-masked]>
Date: Thu, 24 Mar 2011 11:34:10 +0900 (JST)

+1
I support 4rd as a WG item.

Tomoki
> Hello all,
> 
> 
> Le 21 mars 2011 à 22:29, IESG Secretary a écrit :
> 
>> A modified charter has been submitted for the Softwires (softwire)
>> working group in the Internet Area of the IETF.  The IESG has not made any
>> determination as yet.  The modified charter is provided below for
>> informational purposes only.  
> 
>> Please send your comments to the IESG
>> mailing list ([email-masked]) by Tuesday, March 29, 2011.
> 
> The main comment of this mail is a suggestion to add 4rd to the charter, in view of the following:  
> - It is a tunnel solution for IPv4 across IPv6 networks
> - Implementations have already been made
> - Some ISP's have expressed their preference for this stateless solution over a stateful solution (DS-lite)
> - A proposed specification is available for WG comments 
> 
> It is distinct from other solutions in that:
> - Unlike 6rd it is for IPv4 over IPv6
> - Unlike DS-lite, it optimizes routing between CE's with point to multipoint tunnels and needs no CGN. 
> - Unlike Mesh solutions, it doesn't need a (stateful) BGP between AFBR's (it's route selections are stateless).
> 
> Proposed additions to the charter text are in line.
> 
> 
> Regards,
> RD
> 
> 
>> 
>> Softwires (softwire)
>> ---------------------------------------------------
>> Current Status: Active Working Group
>> 
>> Chairs:
>>   Alain Durand <[email-masked]>
>>   Yong Cui <[email-masked]>
>> 
>> Internet Area Directors:
>>   Ralph Droms <[email-masked]>
>>   Jari Arkko <[email-masked]>
>> 
>> Internet Area Advisor:
>>   Ralph Droms <[email-masked]>
>> 
>> Mailing Lists:
>>   General Discussion: [email-masked]
>>   To Subscribe:       [email-masked]
>>   Archive:           
>> http://www.ietf.org/mail-archive/web/softwires/current/maillist.html
>> 
>> Description of Working Group:
>> 
>> The Softwires Working Group is specifying the standardization of
>> discovery, control and encapsulation methods for connecting IPv4
>> networks across IPv6 networks and IPv6 networks across IPv4 networks
>> in a way that will encourage multiple, inter-operable
>> implementations.
>> 
>> For various reasons, native IPv4 and/or IPv6 transport may not be
>> available in all cases, and there is a need to tunnel IPv4 in IPv6
>> or IPv6 in IPv4 to cross a part of the network which is not IPv4 or
>> IPv6 capable. The Softwire Problem Statement, RFC 4925, identifies
>> two distinct topological scenarios that the WG will provide
>> solutions for: "Hubs and Spokes" and "Mesh." In the former case,
>> hosts or "stub" networks are attached via individual,
>> point-to-point, IPv4 over IPv6 or IPv6 over IPv4 softwires to a
>> centralized Softwire Concentrator. In the latter case (Mesh),
>> network islands of one Address Family (IPv4 or IPv6) are connected
>> over a network of another Address Family via point to multi-point
>> softwires among Address family Border Routers (AFBRs).
>> 
>> The WG will reuse existing technologies as much as possible and only
>> when necessary, create additional protocol building blocks.
>> 
>> For generality, all base Softwires encapsulation mechanisms should
>> support all combinations of IP versions over one other (IPv4 over
>> IPv6, IPv6 over IPv4, IPv4 over IPv4, IPv6 over IPv6). IPv4 to IPv6
>> translation mechanisms (NAT-PT), new addressing schemes, and block
>> address assignments are out of scope. DHCP options developed in this
>> working group will be reviewed jointly with the DHC WG.  RADIUS
>> attributes developed in this working group will be reviewed jointly
>> with the RADEXT WG.  The MIB Doctors directorate will be asked to
>> review any MIB modules developed in the SOFTWIRE working group.  BGP
>> and other routing and signaling protocols developed in this group
>> will be reviewed jointly with the proper working groups and other
>> workings that may take interest (e.g. IDR, L3VPN, PIM, LDP, SAAG,
>> etc).
>> 
>> The specific work areas for this working group are:
>> 
>> 1. Developments for Mesh softwires topology; the Mesh topology work
>>   will be reviewed in the l3vpn and idr WGs
>>   - multicast
>>   - MIB module
>> 
>> 2. Developments for 6rd:
>>   - multicast
>>   - operational specification
>>   - RADIUS option for 6rd server
>>   - MIB module
>> 
>> 3. Developments for Dual-Stack Lite (DS-Lite):
>>   - multicast
>>   - operational specification
>>   - RADIUS option for AFTR
>>   - proxy extensions; GI-DS-Lite; DS-Lite with no NAT or NAT on the
>>     B4 element
>>   - MIB module
>> 
>> 4. Finalize discovery and configuration mechanisms for a gateway to
>>   use DS-Lite or 6rd; these discovery and configuration mechanisms
>>   must take into a account other operating environments such as
>>   dual-stack and tunneling mechanisms not defined by the softwire
>>   WG.  Development of new mechanisms will involve the dhc and/or
>>   v6ops WGs as appropriate
> 
> 5. Development for 4rd (stateless tunneling for IPv4 over IPv6)
> - architecture and protocol specification
> - operational specification
> - MIB module
>> 
>> Other work items would require WG approval and rechartering.
>> 
>> Goals and Milestones:
>> Apr 2011 Submit DS-lite RADIUS option for Proposed Standard
>> Apr 2011 Adopt DS-lite operational document as WG document   
>> Jul 2011 Submit 6rd RADIUS option for Proposed Standard
>> Jul 2011 Submit GI DS-lite for Proposed Standard
>> Jul 2011 Adopt B4NAT as WG document
> July 2011 Adopt the 4rd architecture an protocol document as WG document
>> Aug 2011 Adopt 6rd operational document as WG document
>> Aug 2011 Adopt Multicast extensions document as WG document
>> Aug 2011 Submit DS-lite operational document for Informational
>> Sep 2011 Submit B4NAT for Informational
>> Nov 2011 Submit Multicast extensions document for Informational
>> Nov 2011 Submit 6rd operational document for Informational
>> Nov 2011 Adopt 6rd MIB module as WG document
>> Nov 2011 Adopt DS-lite MIB module as WG document
>> Nov 2011 Adopt Mesh topology MIB module as WG document
> Nov 2011 Submit the 4rd architecture an protocol document for Proposed Standard
> Nov 2011 Adopt the 4rd operational document as WG document
> Nov 2011 Adopt the 4rd MIB module as WG document
>> Nov 2012 Submit 6rd MIB module for Proposed Standard
>> Nov 2012 Submit DS-lite MIB module for Proposed Standard
>> Nov 2012 Submit Mesh topology MIB module for Proposed Standard
> Nov 2012 Submit 4rd operational document for Informational
> Nov 2012 Submit 4rd MIB module for Proposed Standard
> 
> 
>> 
>> 
>> _______________________________________________
>> Softwires mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/softwires

---

From: Thomas Nadeau <[email-masked]>
Date: Thu, 24 Mar 2011 08:10:41 -0400

+1

---

From: Satoshi Usui <[email-masked]>
Date: Wed, 30 Mar 2011 11:18:20 +0900

Hi All,

+1
I also support 4rd as a chater item.

Regards
 Satoshi Usui

On Thu, 24 Mar 2011 08:10:41 -0400, Thomas Nadeau wrote:

> >> Le 21 mars 2011 a 22:29, IESG Secretary a ecrit :
> >>