Subject: Re: [Softwires] [BEHAVE] ***SPAM*** 5.548 (5) Is nat46 worth researching？

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 2 May 2011 08:18:08 -0700 (PDT)

This is good point.
But maybe this should be discussed in Softwires list.

Regards,

Behcet

> On 28 apr 2011, at 14:11, buptnoc wrote:

> 
> >     As described  in draft-ietf-behave-v6v4-framework-10#section-2.4 ， we 
>need nat46 translator. 
>
> >     But, do we really need this scenario？Is it worth to  deploy this 
>scenario?
> 
> >     In fact, this scenario appears  when we have v4-only client and v6-only 
>servers
> 
> My opinion is: no, this  is not worth the trouble. We know that NAT46 is a hard 
>problem, and it's  unlikely a solution would be very robust. Because of lack of 
>IPv4 addresses, a  relatively small pool of v4 addresses would have to map to 
>all possible v6  addresses, which means that the mappings have to be highly 
>dynamic. But  addresses are cached in many places, including often for a long 
>time in  applications. Having different applications react differently to NAT46 
>would be  a big deployment problem.
> 
> I would recommend (apart from upgrading to  IPv6) deploying HTTP and HTTPS 
>proxies, as those will allow HTTP and HTTPS from  IPv4-only clients to IPv6-only 
>servers (or the other way around!) and in  principle, it's possible to modify 
>any TCP-based application to work through an  HTTPS proxy, as those are 
>basically TCP relays.
> 
> It should be possible to  make an automatic proxy configuration so that a 
>browser only uses the proxy to  reach IPv6 destinations and connects to IPv4 
>destinations directly. However, I  haven't tried this myself  yet.
> 
> 
> _______________________________________________
> Behave  mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/behave
>

---

From: Iljitsch van Beijnum <[email-masked]>
Date: Mon, 2 May 2011 18:37:43 +0200

> But maybe this should be discussed in Softwires list.

Is softwires doing anything related to NAT46 then?

---

From: "Dan Wing" <[email-masked]>
Date: Mon, 2 May 2011 22:29:17 -0700

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Behcet Sarikaya
> Sent: Monday, May 02, 2011 8:18 AM
> To: Iljitsch van Beijnum; buptnoc
> Cc: [email-masked]; [email-masked]
> Subject: Re: [BEHAVE] ***SPAM*** 5.548 (5) Is nat46 worth researching？
> 
> This is good point.

NAT46 is in scope of BEHAVE, and is not in scope of SOFTWIRE.  The
BEHAVE charter is clear on that.

But I have not yet understood how or where we would see an IPv4-only
client needing to access an IPv6-only server (that is, a server
with only an IPv6 address).

-d