Subject: [Softwires] Motivation Analysis for 4via6 Stateless Solutions

From: GangChen <[email-masked]>
Date: Sun, 15 May 2011 19:30:53 +0800

Dear all,

Last IETF meeting, ADs required volunteers to draft the motivation for
stateless 4via6 mechanism.
We have updated a draft to state the motivation mostly from
operational perspectives.
We believe the concrete solution shall be decided by business
requirements, so it is essential to analyze 4via6 motivations from
network operations.

Please find the draft from the below link:
http://www.ietf.org/internet-drafts/draft-chen-softwire-4v6-motivation-00.txt

Any comments are welcome.
Many thanks

Gang

---

From: Tina Tsou <[email-masked]>
Date: Tue, 17 May 2011 19:20:31 -0700

Hi Gang,
I read the draft. It is clear from an operator's analysis. It provides
another angle from the operational point of view.

We keep our promises with one another - no matter what!

Best Regards,
Tina TSOU
http://tinatsou.weebly.com/contact.html

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of GangChen
Sent: Sunday, May 15, 2011 4:31 AM
To: [email-masked]
Subject: [Softwires] Motivation Analysis for 4via6 Stateless Solutions

Dear all,

Please find the draft from the below link:
http://www.ietf.org/internet-drafts/draft-chen-softwire-4v6-motivation-00.tx
t

Gang
_______________________________________________
Softwires mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/softwires

---

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 23 May 2011 09:20:33 -0700 (PDT)

I support this draft.

Having said that I saw 
draft-operators-softwire-stateless-4v6-motivation-01

which covers very similar scenarios.

I suggest the authors work together and possibly merge their documents.

Regards,

Behcet

---

From: Ole Troan <[email-masked]>
Date: Tue, 24 May 2011 10:23:57 +0200

> I suggest the authors work together and possibly merge their documents.

+1.

I would suggest incorporating the motivational parts of this document into stateless-4v6-motivation and the stateless issues part of the draft into draft-dec-stateless-4v6-01

one motivation analysis document is enough.

cheers,
Ole

---

From: Mark Townsley <[email-masked]>
Date: Tue, 24 May 2011 10:35:21 +0200

> I would suggest incorporating the motivational parts of this document into stateless-4v6-motivation and the stateless issues part of the draft into draft-dec-stateless-4v6-01

Excellent idea. 

> one motivation analysis document is enough.

One is already more than enough. So, yes, let's absolutely avoid having two.

- Mark

---

From: GangChen <[email-masked]>
Date: Wed, 25 May 2011 01:07:45 +0800

2011/5/24, Ole Troan <[email-masked]>:
>
> I would suggest incorporating the motivational parts of this document into
> stateless-4v6-motivation

If we are supposed to converge these two drafts, the below is my
proposal to reorganize the draft

1. Introduction

2. Operational Motivations Analysis

2.1 Improving Network Efficiency
Note: This section states the benefits for off-loading traffic
processing,  e.g. reduction of logging information, efficient
transmission of data packages, etc..

2.1.1 NAT Logging Consideration
2.1.2 Avoiding Centralized Traffic Bottleneck
2.1.3 Optimizing Encap/Decap and Translation
2.1.4 xxxxx

2.2 Simplifying Network Maintenance

Note: This section states the consideration for reducing subsequent
efforts of network maintenance.

2.2.1 High Availability(HA) Consideration
2.2.2 Relief Qualification Procedures
2.2.3 xxxxx

2.3 Decreasing Transition costs
Note: This section makes costs comparison analysis.
2.3.1 Transition Costs Consideration

2.4 Facilitating Service Evolution
Note: This section states the cooperation between stateless 4via6 and
service provisioning, e.g. the subsection "Implicit Host
Identification" and "No Organizational Impact" in
draft-operators-softwire-stateless-4v6-motivation-01.
2.4.1 xxxx
2.4.2 xxxx

3 Conclusions
Note: I suggest to give the explicit conclusion, which approach is
preferred and which has high-priority considering particular demands
from operators.

> and the stateless issues part of the draft into draft-dec-stateless-4v6-01

I support this idea.

---

From: Tetsuya Murakami <[email-masked]>
Date: Wed, 25 May 2011 01:22:19 -0700

Hi, 

+1.
One motivation draft should be fine.