Subject: [Softwires] Question about hub-and-spoke operation in MAP

From: Rémi Després <[email-masked]>
Date: Wed, 14 Mar 2012 14:24:04 +0100

Ole, Tomek,

I couldn't figure out by how CEs can be required to work hub-and-spoke without some DHCPv6 indication:
- If two CEs apply the same BMR to their delegated IPv6 prefixes, how do they know whether their ISP expects direct paths between them (mesh) or BR hairpinning (hub-and-spoke)?

Sorry for bothering you if I missed something obvious.
RD

---

From: Ole Trøan <[email-masked]>
Date: Wed, 14 Mar 2012 06:29:08 -0700

Remi,

> - If two CEs apply the same BMR to their delegated IPv6 prefixes, how do they know whether their ISP expects direct paths between them (mesh) or BR hairpinning (hub-and-spoke)?

that's correct it needs to be provisioned. either explicitly or implicitly (via the rules).

cheers,
Ole