Subject: [Softwires] Demo of draft-penno-softwire-sdnat-02 -- Sunday 25th from 15h30 to 17h00 room #201 at IETF in Paris

From: "Alistair Woodman" <[email-masked]>
Date: Sat, 24 Mar 2012 09:37:53 -0700

All, you are cordially invited.

Francis Dupont, Paul Selkirk and Alain Durant are hosting a live demo of
draft-penno-softwire-sdnat-02. 

The following will be shown:

1) Stateless DS-Lite

2) Stateless CPE B4 NAT

3) Anycast Failover

4) DHCPv4 proxy over v6

5) NAT Port range re-allocation via ICMP method.

When:                  Sunday the 25th from 15h30 to 17h00.

Where:                 Room #201 (Front left of Hall Maillot when facing
Porte Maillot), IETF 83, Paris

---

From: Francis Dupont <[email-masked]>
Date: Sat, 24 Mar 2012 16:41:07 +0000

Durand with a 'd' (as sensible as Dupont with a 't' :-)!

Francis Dupont <[email-masked]>

---

From: Peng Wu <[email-masked]>
Date: Sun, 25 Mar 2012 02:06:08 +0800

Great. So ISC already has DHCPv4 over IPv6 implementation now.
//Pity I couldn't make it on Sunday.

2012/3/25 Alistair Woodman <[email-masked]>:
> All, you are cordially invited…
>
>
>
> _______________________________________________
> Softwires mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/softwires
>

---

From: Yong Cui <[email-masked]>
Date: Sun, 25 Mar 2012 09:06:46 +0800

Thanks for the demo.
Would you please also give a summary to the mailing list, especially for
someone who cannot join the demo.

Yong

From:  Alistair Woodman <[email-masked]>
Date:  Sat, 24 Mar 2012 09:37:53 -0700
To:  <[email-masked]>
Cc:  <[email-masked]>
Subject:  [Softwires] Demo of draft-penno-softwire-sdnat-02 -- Sunday 25th
from 15h30 to 17h00 room #201 at IETF in Paris

> All, you are cordially invitedŠ
>  
> Where:                 Room #201 (Front left of Hall Maillot when facing Porte
> Maillot), IETF 83, Paris
> _______________________________________________ Softwires mailing list
> [email-masked] https://www.ietf.org/mailman/listinfo/softwires

---

From: Francis Dupont <[email-masked]>
Date: Sun, 25 Mar 2012 08:55:34 +0200

>  Great. So ISC already has DHCPv4 over IPv6 implementation now.

=> yes but it is experimental: we don't use the IANA assigned number
for CRA6ADDR for instance (as IANA will be involved later in the IETF
process) and there are some interesting technical problems raised
by the spec... Look at the DHC WG mailing list.

Regards

[email-masked]

---

From: Tassos Chatzithomaoglou <[email-masked]>
Date: Sun, 25 Mar 2012 15:31:44 +0200

Is this the same room as IAOC/IAD?

--
Tassos

On 24/3/2012 5:37 ??, Alistair Woodman wrote:
>
> All, you are cordially invited...
>
> Francis Dupont, Paul Selkirk and Alain Durant are hosting a live demo 
> of draft-penno-softwire-sdnat-02.
>
> When:                  Sunday the 25^th from 15h30 to 17h00.
>
> Where:                 Room #201 (Front left of Hall Maillot when 
> facing Porte Maillot), IETF 83, Paris
>
>

---

From: Francis Dupont <[email-masked]>
Date: Sun, 25 Mar 2012 23:44:37 +0200

>  someone who cannot join the demo.

=> we setup a SD-AFTR and a pair of SD-B4s (one Netgear WNDR3800
and one laptop) and a client attached to one of the SD-B4s with:
 - connection from the client to the Internet
 - connection from the Internet to the client using a port returned
  by PCP (server running on a SD-B4)
 - replacement of a SD-AFTR by a spare SD-AFTR with the same config
  (but without dynamic state sharing): connections still alive, in
  fact if you don't take care of the packets lost during the manual
  operation it is really transparent
 - we had not enough time to finish the DHCP client chaining
  (in theory the DHCPv6 client configures the IPv4-over-IPv6 tunnel
   and launches	 a DHCPv4 client	  and CRA pair, which configure
   the IPv4 part including the port range)
 - nor the ICMP 3/13 handling on the SD-B4 (renew the DHCPv4 lease).
 - nor a third WNDR3700v2 SD-B4 (should be the same than the WNDR3800
  one, and we didn't ask visitors to provide extra clients)

Regards

---

From: "Qi Sun" <[email-masked]>
Date: Mon, 26 Mar 2012 21:51:37 +0800

Hi Francis,
      i work out a topology of your system according to your description, and hopes to help those who can't make it to your demo with a quick understanding of the system.
      Please correct me if i'm missing anything or misunderstanding your points.
     The attachment is the txt version of the topology, editing with UltraEdit.
                                                      
Looking forward to your reply~

PS: Very sorry for failing to send out of the early email because of  mis-operation.  

Best Regards!

Qi Sun

From: Francis Dupont
Date: 2012-03-26 05:44
To: Yong Cui
CC: softwires; fdupont
Subject: Re: [Softwires] Demo of draft-penno-softwire-sdnat-02 -- Sunday 25th from 15h30 to 17h00 room #201 at IETF in Paris

Regards