Subject: [Softwires] Why a BR IPv4 address in MAP Default mapping rule?

From: Rémi Després <[email-masked]>
Date: Fri, 9 Mar 2012 17:42:42 +0100

Hi Ole,

Sec. 4.4 of draft-mdt-softwire-mapping-address-and-port-03 says:
 "Default Mapping Rule:
 {2001:db8:0001:0000:<interface-id>:/128 (Rule IPv6 prefix),
  0.0.0.0/0 (Rule IPv4 prefix),
  192.0.2.1 (BR IPv4 address)}

      Example 3: Default Mapping Rule

In most implementations of a routing table, the next-hop address must be of the same address family as the prefix.  To satisfy this requirement a BR IPv4 address is included in the rule.  Giving a default route in the IPv4 routing table: 
 0.0.0.0 -> 192.0.2.1, MAP-Interface0"

I must admit I found this very confusing:
- It seems to be a purely internal matter, having therefore no place in a proposed standard.
- In an internal IPv4 routing table, any never-assigned address seems sufficient (no need for dependence on the BR IPv4 address).
- How a MAP-T CE could get the BR IPv4 address isn't specified (no DHCPv6 parameter specified for its transmission).

Thanks for explaining,
RD

---

From: Ole Trøan <[email-masked]>
Date: Fri, 9 Mar 2012 17:48:31 +0100

Remi,

> - In an internal IPv4 routing table, any never-assigned address seems sufficient (no need for dependence on the BR IPv4 address).

the idea of the BR also being part of the domain has some benefits.
e.g. it is possible to IPv4 ping the default gateway. it isn't strictly necessary as you say, but I think it has value in troubleshooting.

> - How a MAP-T CE could get the BR IPv4 address isn't specified (no DHCPv6 parameter specified for its transmission).

manual configuration.

cheers,
Ole

---

From: Rémi Després <[email-masked]>
Date: Fri, 9 Mar 2012 17:52:01 +0100

>> - It seems to be a purely internal matter, having therefore no place in a proposed standard.

Not answered.

>> - How a MAP-T CE could get the BR IPv4 address isn't specified (no DHCPv6 parameter specified for its transmission).

Are you really suggesting that MAP-T CEs would be manually configured?

RD

---

From: Ole Trøan <[email-masked]>
Date: Fri, 9 Mar 2012 17:56:25 +0100

>>> - It seems to be a purely internal matter, having therefore no place in a proposed standard.

see two lines below.

> Are you really suggesting that MAP-T CEs would be manually configured?

no, sorry, I thought you asked how the BR was configured.
the CE can extract the BR IPv4 address from the BR IPv6 address.

Ole

---

From: Rémi Després <[email-masked]>
Date: Fri, 9 Mar 2012 18:13:33 +0100

>>>> - It seems to be a purely internal matter, having therefore no place in a proposed standard.

They don't explain why one would need "0.0.0.0 -> 192.0.2.1, MAP-Interface0" in a proposed standard.

> no, sorry, I thought you asked how the BR was configured.

No hurry is needed, but please answer THE question. Not only does it concern a CE (not a BR), but also a -T (not a -E).

> the CE can extract the BR IPv4 address from the BR IPv6 address.

The draft says:
"The Rule IPv6 prefix is the IPv6 address or prefix of the BR.  Which is used, is dependent on the mode used.  For example translation requires that the IPv4 destination address is encoded in the BR IPv6 address, so only a prefix is used in the DMR to allow for a generated interface identifier." 

Thanks,
RD