Subject: [Softwires] New Version Notification for draft-mdt-softwire-map-translation-01.txt

From: Wojciech Dec <[email-masked]>
Date: Fri, 09 Mar 2012 17:03:02 +0100

Hi All

A new version of I-D, draft-mdt-softwire-map-translation-01.txt has been
posted under:

http://tools.ietf.org/html/draft-mdt-softwire-map-translation-01

Filename:  draft-mdt-softwire-map-translation
Revision:  01
Title:   MAP Translation (MAP-T) - specification
Creation date:  2012-03-09
WG ID:   Individual Submission
Number of pages: 22

Abstract:
   This document specifies the &quot;Mapping of Address and Port&quot; (MAP)
   double stateless translation based solution (MAP-T) for providing
   IPv4 hosts connectivity to and across an IPv6 domain.

We welcome further WG feedback.

---

From: "Qi Sun" <[email-masked]>
Date: Mon, 19 Mar 2012 00:24:00 +0800

Hi Wojciech,
The draft gives out a great support for the MAP mechanism and is nicely written. Here are some confusions while I’m reading the draft. Please help me with understanding :-)
 
1, In section 7.4, the 4th paragraph:
Otherwise, the IPv6 destination address (IPv4-translateable address) MUST be derived from
the received IPv4 destination address per DMR.  The destination port number MUST be unchanged.
 
Considering the IPv6 destination address is derived from the received IPv4 destination address per DMR, why the IPv6 destination address is an IPv4-translatable address, not IPv4-converted address?
 
2, In section 7.5
   At the CE, the IPv4 source address MUST be derived from the IPv6
   source address (IPv6-converted address) as per the DMR, or as per the
   FMR.  The source port number MUST be unchanged.
 
   IPv4 Destination Address and Destination Port Number: At the CE, the
   IPv4 destination address MUST be derived from the IPv6 destination
   address (IPv6-translatable address) as per BMR.  The destination port
   number MUST be unchanged.

What is an IPv6- converted address and IPv6-translatable address? I’m a little lost here…
 
3, In section 6.2.1
The IPv6 source and destination addresses MUST then be derived as per Section 6 of this draft, and…..
 
IMHO the super link “Section 6” may be “Section 7”, referring to section 6.4.1 and 6.4.2. Did I understand right?
 
There are the same super link in section 6.2.2.

Please correct me if I misunderstood anything.
 
Best Regards!
 
Qi Sun
From: Wojciech Dec
Date: 2012-03-10 00:03
To: [email-masked]
Subject: [Softwires] New Version Notification for draft-mdt-softwire-map-translation-01.txt
Hi All

Abstract:

_______________________________________________
Softwires mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/softwires

---

From: Washam Fan <[email-masked]>
Date: Tue, 20 Mar 2012 14:06:03 +0800

Hi Authors,

In section 7.6, it states how to do ICMP/ICMPv6 query messages
translation. But it omits how to do ICMP/ICMPv6 error messages
translation. I think it should be expounded in this section.

Thanks,
washam