Subject: [Softwires] Result from the consensus call on Map vs 4rd-U and official way forward

From: Alain Durand <[email-masked]>
Date: Wed, 25 Apr 2012 18:41:23 -0700

The chairs and ADs met to look at the results of the consensus call that ended Wednesday and decide the way forward.

First, we would like to offer a couple observations on the raw results from the consensus call:

- We had a number of people responding more than once, sometime with different email addresses.
  Having their name and affiliation in the response helped us removed those duplicate/triplicate/...
- Number of unique response: 75
- Question 1: 75 yes, 0 No, few  responded put both on experimental track
- Question 2: 73 MAP 2 4rd-U

This does not reflect at all the results we had in the Paris meeting (about 30 MAP and 20 4rd-U):
a) It seems that some of the 4rd-U people who did express support for it in Paris when the same question was asked have not participated in this consensus call. 
b) the number of MAP responses seem to be inflated, we see a disproportionate number of response from some particular organizations. We also see a large number of responses coming from people who have not participated before in the working group. Also, it is apparent that a number of people have joined the mailing list for the sole purpose of expressing support for MAP.

None of the above behaviors do any favors for the working group. We do need participation in the official call for consensus from all the active participants of the working group. As we mentioned before, in such calls, silence is consent. Also, the inflated participation in the consensus call from 'new' members that have never participate in the discussion before, creates noise that makes the results harder to read.

Furthermore, we have observed that, even during the call, the analysis of both solutions did continue, and missing elements on both sides have been pointed out. We also observed a willingness of various participants to improve those specs to bring them to a level where we could start a working group last call.

As a result, we have decided to approve both MAP and 4rd-U as working group work items.  As work items, each document can be further refined until the working group reaches consensus about advancing the documents for IETF review.

Because of the history of MAP and 4rd-U, we will designate independent teams of volunteer reviewers to advise the working group about the state of the document sets.  Each set will be reviewed by an independent team who are not authors of the MAP and 4rd-U documents. Each review team will consist of three members and will determine when its document set is ready for working group last call. If you are interested in volunteering for one of the review teams, please respond directly to the chairs, indicating your preference for which document to review if you have one. The appointment of the review teams will be entirely up to the chairs. Aside from these appointed reviews, the chairs would naturally appreciate any and all reviews provided, regardless of whether the reviewer(s) participate on a review team.

When the document sets are ready for working group last call, the working group will reconsider the question of the publication status: Proposed Standard or Experimental. We will try to  consider all document sets for advancement at the same time, but we will not allow a delay in completing one document to hold up the working group indefinitely. 

   - Alain & Yong, WG co-chairs
   - Ralph & Biran, ADs

---

From: Leaf yeh <[email-masked]>
Date: Thu, 26 Apr 2012 02:58:08 +0000

Alan - As a result, we have decided to approve both MAP and 4rd-U as working group work items.  As work items, each document can be further refined until the working group reaches consensus about advancing the documents for IETF review.

Congratulations!

Best Regards,
Leaf

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Alain Durand
Sent: Thursday, April 26, 2012 9:41 AM
To: [email-masked] WG
Subject: [Softwires] Result from the consensus call on Map vs 4rd-U and official way forward

   - Alain & Yong, WG co-chairs
   - Ralph & Biran, ADs
_______________________________________________
Softwires mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/softwires

---

From: <[email-masked]>
Date: Thu, 26 Apr 2012 09:50:50 +0200

Chairs, ADs,

I regret this decision. *Whatever* the results of the poll, your text below explicitly suggests a discrimination between voters. 

Basically, you seem to distinguish between people who are entitled to vote because they have supposedly participated to the stateless specification effort (whatever the flavour) and people who are not entitled to vote because you clearly assume they have not participated to the said specification effort, let alone the discussions.

I think this decision is a shame for the IETF precisely because of this discrimination.

We all perfectly know how the IETF procedures have been working for many years. And we all perfectly know what kind of side effect the rough consensus motto can sometimes lead to.

But I don't think this is a good enough reason to speculate on the degree of participation to the WG effort of the people who have expressed an opinion.

I, for one, never sent a comment on either the MAP or the 4rd-U stuff on this list. Yet, I can assure you that I have extensively discussed both approaches with my colleagues internally.

Does that make me ineligible to respond to this poll? I certainly don't think so.

I don't think anyone of us is entitled to decide who has the right to vote and who hasn't.

Your corrected math clearly reflect a strong consensus to (1) standardize one and only one approach and (2) adopt the MAP effort as a softwire WG item.

Your decision contradicts the results of this poll.

I therefore strongly encourage you to revisit your position and accept the results of this poll.

If you stick to this decision, you will not only do any favor to the softwire WG, but also to the whole IETF. 

Cheers,

Christian.

-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de Alain Durand
Envoyé : jeudi 26 avril 2012 03:41
À : [email-masked] WG
Objet : [Softwires] Result from the consensus call on Map vs 4rd-U and official way forward

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
France Telecom - Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, France Telecom - Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: <[email-masked]>
Date: Thu, 26 Apr 2012 10:36:01 +0200

Dear all,

I personally regret this decision and reject the justifications provided. If you don't want people to contribute and express their opinion, it is easy: make it a close community.

If you insist to ignore what expressed the majority of individuals who participated to the poll, may I suggest: we stop all this stateless A+P work. It does not make sense at all to continue work on two parallel efforts having 90% of similarities.

Cheers,
Med 

>De : [email-masked] 
>[mailto:[email-masked]] De la part de Alain Durand
>The chairs and ADs met to look at the results of the consensus 
>call that ended Wednesday and decide the way forward.
>
>a) It seems that some of the 4rd-U people who did express 
>support for it in Paris when the same question was asked have 
>not participated in this consensus call. 
>b) the number of MAP responses seem to be inflated, we see a 
>disproportionate number of response from some particular 
>organizations. We also see a large number of responses coming 
>from people who have not participated before in the working 
>group. Also, it is apparent that a number of people have 
>joined the mailing list for the sole purpose of expressing 
>support for MAP.
>
>None of the above behaviors do any favors for the working 
>group. We do need participation in the official call for 
>consensus from all the active participants of the working 
>group. As we mentioned before, in such calls, silence is 
>consent. Also, the inflated participation in the consensus 
>call from 'new' members that have never participate in the 
>discussion before, creates noise that makes the results harder to read.
>
>Furthermore, we have observed that, even during the call, the 
>analysis of both solutions did continue, and missing elements 
>on both sides have been pointed out. We also observed a 
>willingness of various participants to improve those specs to 
>bring them to a level where we could start a working group last call.
>
>As a result, we have decided to approve both MAP and 4rd-U as 
>working group work items.  As work items, each document can be 
>further refined until the working group reaches consensus 
>about advancing the documents for IETF review.
>
>Because of the history of MAP and 4rd-U, we will designate 
>independent teams of volunteer reviewers to advise the working 
>group about the state of the document sets.  Each set will be 
>reviewed by an independent team who are not authors of the MAP 
>and 4rd-U documents. Each review team will consist of three 
>members and will determine when its document set is ready for 
>working group last call. If you are interested in volunteering 
>for one of the review teams, please respond directly to the 
>chairs, indicating your preference for which document to 
>review if you have one. The appointment of the review teams 
>will be entirely up to the chairs. Aside from these appointed 
>reviews, the chairs would naturally appreciate any and all 
>reviews provided, regardless of whether the reviewer(s) 
>participate on a review team.
>
>When the document sets are ready for working group last call, 
>the working group will reconsider the question of the 
>publication status: Proposed Standard or Experimental. We will 
>try to  consider all document sets for advancement at the same 
>time, but we will not allow a delay in completing one document 
>to hold up the working group indefinitely. 
>

---

From: Mark Townsley <[email-masked]>
Date: Thu, 26 Apr 2012 11:50:20 +0200

> Because of the history of MAP and 4rd-U, we will designate independent teams of volunteer reviewers to advise the working group about the state of the document sets.  Each set will be reviewed by a…

Seems like a pending procedural quagmire. 

Perhaps we would have been better off with the coin toss. 

- Mark

---

From: Edwin Cordeiro <[email-masked]>
Date: Thu, 26 Apr 2012 09:09:31 -0300

I'm new to the group, but I made my vote because I have studied both
solutions. I was unable to find any running code for 4rd-U that I could
test and verify, while I was able to do that with MAP.

I voted based on the quote about the IETF from David Clark: "We reject
kings, presidents and voting. We believe in rough consensus and running
code". As I was unable to find 4rd-U running code I voted against 4rd-U.

I believe that the author of 4rd-U should explore his idea and have
running code to prove it works. When the 4rd-U comes to this stage come
back to the group. This is similar to what happened with 6rd. If this
code already exist, please make it public so it could be verified.

Edwin Cordeiro

---

From: "Jan Zorz @ go6.si" <[email-masked]>
Date: Thu, 26 Apr 2012 16:50:58 +0200

> Perhaps we would have been better off with the coin toss.

+1

bingo.

Cheers, Jan

P.S: I'll not waste more bits on this topic as it's apparently a waste 
of bandwidth :)

P.P.S: Should we deprecate RFC6346?

---

From: Behcet Sarikaya <[email-masked]>
Date: Thu, 26 Apr 2012 10:40:15 -0500

Hi Jan,

> P.P.S: Should we deprecate RFC6346?

A+P is in  MAP T, MAP E and 4rd-U. I don't understand why you are
worried about it?

Having said that I for one think that A+P should be restricted to the CPEs.
Otherwise you are creating another NAT.

Regards,

Behcet

---

From: "Antonio M. Moreiras" <[email-masked]>
Date: Thu, 26 Apr 2012 15:14:48 -0300

> None of the above behaviors do any favors for the working group. We do need participation in the official call for consensus from all the active participants of the working group. As we mentioned b…

I regret so much this decision.

I, personaly, and also my team, have been following the work of this
IETF WG, and others regarding IPv6, for quite a long time. We are
involved with IPv6 dissemination. We do not participate actively here,
because we choose to prioritize other tasks. Sadly, the time and other
resources are always limited, and we can't contribute in all ways we
would like to.

I did choose to sign the list with this email address recently solely in
order to vote in this matter, because it is important and urgent, and I
wanted to express my support to MAP (but, more important than that, to
express my support on advancing only one of the options, MAP or 4rd-U),
and help the group to make the decision in a timely way. If I had the
slightest idea that this kind of behavior could prejudice the vote and
decision in any way, as it seems to have done, I wouldn't have voted. I
honestly thought the IETF was more open, and that newcomers were more
welcome. I am really, really sorry because I didn't know that it was not
expected that newcomers in a WG expressed their opnions, and that it
would be considered "noise", "inflating" the numbers.

Maybe it could be a bit more clear, when the vote was called, that
newcomers were not expected to express their opinions, and that only
those already discussing the question in the list for some time should
participate. I am not criticizing the process in anyway, just stating
that I could not understand it correctly before now.

Said that, I must add that I've not voted lightly. It was a choose based
on a careful reading and analysis of the proposals, of a technical point
of view, and on a good understanding of the current state of the IPv6
implementation, and current planning, in the local Internet market of
the country I live on, including local ISPs and local equipment
manufacturers.

I apologize for trying to contribute, helping the group to make what I
considered a very needed choose, based on my limited experience, and
ending up being just a noise generator, inflating the numbers.  I am
feeling really bad about that.

Anyway, seeing the 75 x 0 votes to the 1st question being ignored, and a
decision that lead us to more indefinition regarding a usable stateless
transition technique based on A+P is very, very, disappointing.

It seems to me that with this new way forward we will loose the timing.
We will end up with an optimal and very elegant solution that will not
be used by anyone. Sadly, it seems to be better to forget the whole
idea, and put our efforts elsewhere.

Antonio M. Moreiras.

---

From: "Joel M. Halpern" <[email-masked]>
Date: Thu, 26 Apr 2012 15:42:24 -0400

If I may, it seems to me that several of these replies miss some 
important points in the message from the chairs.

1) It became clear during the WG poll that the documents were not 
complete.  This is not a bad thing.  We need to finish them.
2) The poll did indicate that there is interest in the documents.
3) Given that the documents are not complete, they can not be sent to 
the IESG at this time.  Until they are complete, a final decision on 
what status they will be labelled with can not be made.

Hence, what can be done is either to adopt the documents as WG 
documents, or not.  Even if the chairs were to state an intended status 
for the documents upon completion, that would have to be verified when 
the final content was available.

The most important thing actually is the call for reviewers.  If you 
want to see any of the documents adopted by the working group, and 
worked on, we need folks to step forward as reviewers.  Folks who are 
not the authors.

Yours,
Joel M. Halpern
An observer without a preference on outcomes.

PS: I think there is also some confusion about IETF processes.  However, 
I will not belabor the list with a rant on that.  I will happily answer 
off-list questions if it i helpful to individuals.

---

From: Maoke <[email-masked]>
Date: Fri, 27 Apr 2012 07:37:46 +0900

the problems here are:

1. a lot of people were hurt by the chairs, IMHO, disparaging
language. wording like "inflate" "generate noise" is unfair and impolite.
2. it has been well known that documents were not complete. it was not
needed to make a poll to indicate it. they are not complete != they are not
mature at *same* level.
3. "call for reviewer", just like the previously "call for poll", sounds to
me another political trick of the chair. logically, "independent" vs. "we
will designate" are contradictory. if the majority poll failed to indicate
consensus, how the minority reviews can?

- maoke
2012/4/27 Joel M. Halpern <[email-masked]>

> If I may, it seems to me that several of these replies miss some important
> points in the message from the chairs.
>
> 3) Given that the documents are not complete, they can not be sent to the
> IESG at this time.  Until they are complete, a final decision on what
> status they will be labelled with can not be made.
>
> Hence, what can be done is either to adopt the documents as WG documents,
> or not.  Even if the chairs were to state an intended status for the
> documents upon completion, that would have to be verified when the final
> content was available.
>
> The most important thing actually is the call for reviewers.  If you want
> to see any of the documents adopted by the working group, and worked on, we
> need folks to step forward as reviewers.  Folks who are not the authors.
>
> Yours,
> Joel M. Halpern
> PS: I think there is also some confusion about IETF processes.  However, I
> will not belabor the list with a rant on that.  I will happily answer
>>> disproportionate number of response from some particular organizations. We
>>> also see a large number of responses coming from people who have not
>>> participated before in the working group. Also, it is apparent that a
>>> number of people have joined the mailing list for the sole purpose of
>>> expressing support for MAP.
>>>
>>> None of the above behaviors do any favors for the working group. We do
>>> need participation in the official call for consensus from all the active
>>> participants of the working group. As we mentioned before, in such calls,
>>> silence is consent. Also, the inflated participation in the consensus call
>>> from 'new' members that have never participate in the discussion before,
>>> creates noise that makes the results harder to read.
>>>
>>
>> ______________________________**_________________
>> Softwires mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/**listinfo/softwires<https://www.ietf.org/mailman/listinfo/softwires>
>>
>>  ______________________________**_________________
> Softwires mailing list
> [email-masked]
> https://www.ietf.org/mailman/**listinfo/softwires<https://www.ietf.org/mailman/listinfo/softwires>
>

---

From: Wojciech Dec <[email-masked]>
Date: Fri, 27 Apr 2012 08:36:49 +0200

Joel,

allow me to ask you as an observer some questions:

1. If this WG is not for the WG members, of all cuts & sizes, to work in
then what is it for?
2. If the chairs of this WG are unable to steer, form and then actually
measure consensus, and in due course also end up "disenfranchising" WG
members, then isn't this a point that needs to be addressed (sadly a
recurring theme in this particular WG)?
3. Is a regular way forward is to adopt every draft with "some interest",
even if nearly entirely overlapping in scope with other draft also adopted,
and is there a precedent?

Thanks,
Woj.

---

From: Leaf yeh <[email-masked]>
Date: Fri, 27 Apr 2012 06:34:07 +0000

I also believe the additional progress and the expert review on the draft will make thing better than today. Everyone got the chance to develop himself. So pls. keep to work on what you love. I meant the result of the last poll (73=2) have you continue your own story. Right?

Best Regards,
Leaf Yeh

Advanced Research, Network Product Line, Huawei Technologies Co., Ltd.
Phone: +86-755-28978851,  Mobile: +86-13600451075,  
Postal Address: F4-3A, Huawei, Bantian, Longgang District,Shenzhen 518129, P.R.China

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Joel M. Halpern
Sent: Friday, April 27, 2012 3:42 AM
To: Antonio M. Moreiras
Cc: [email-masked]
Subject: Re: [Softwires] Sorry for being a noise generator, inflating the results. Re: Result from the consensus call on Map vs 4rd-U and official way forward

Yours,
Joel M. Halpern

---

From: "Lee, Yiu" <[email-masked]>
Date: Sun, 29 Apr 2012 20:03:59 +0000

Well, even the WG decided to go with MAP, we would still need to coin toss
between MAP-T and MAP-E, wouldn't we?