Subject: [Softwires] map domain ; mesh BMR =>DHCP flag F

From: "Poscic, Kristian (Kristian)" <[email-masked]>
Date: Fri, 15 Mar 2013 16:57:16 +0000

1)      The MAP domain definition should be consolidated across the three drafts (map-e, map-t and map-deployment).

For example the map-e draft defines under the terminology section the MAP domain as:

MAP domain:             One or more MAP CEs and BRs connected to the
                           same virtual link.  A service provider may
                           deploy a single MAP domain, or may utilize
                           multiple MAP domains.

Map-t draft defines is as (under terminology section):

MAP domain:             One or more MAP CEs and BRs connected to the
                           same IPv6 network.  A service provider may
                           deploy a single MAP domain, or may utilize
                           multiple MAP domains.

While map-deployment draft (sec 4.2 Building the Map Domain) says:

One MAP domain shares a common BR and has the same set of
   BMRs, FMRs and DMR, and it can be further divided into multiple sub-
   domains when multiple IPv4 subnets are deployed in one MAP domain.

So we go from virtual link and the 'same IPv6 network' concept with multiple BRs per MAP domain (in map-e/t drafts) to a common BR per map domain and subdomains concepts in map-deployment draft.
What does 'same IPv6 network'  mean in the map-t draft? In other  words does this mean that multiple MAP domains cannot co-exists within the boundary of an IPv6 network and that an operator should construct a separate IPv6 network for another MAP domain? I don't think this is what 'same IPv6 network' means but it may come out as such.

Then the map-deployment draft says that the MAP domain should share common BR - which I don't think is correct (for redundancy and load sharing purposes).
And then the subdomains that are referred to in the map-deployment draft, they correspond simply to BMRs. But if this is so, then we should define subdomain as such (subdomain = BMR). Or keep referring to BMRs instead of subdomains.

Rather than trying to answer the question' what is the MAP domain?' I'm trying to ask myself 'what do I need in order to create multiple MAP domains?' I think the answer is that I need multiple (sets) of BRs (and corresponding CEs) on the same IPv6 or different IPv6 network, each such set of BRs  must contain distinct BMR and FMR rules (i.e. no overlapping of BMR/FMR rules between the sets of BRs to which MAP domains are tied to).

2)      Mesh topology is implicitly enabled in cases where FMRs are provisioned (configured). But the mesh topology can be also explicitly configured in case that we have only BMR.  Map-dhcp draft talks about this. Section 4.3 says this:
o  F-Flag: 1 bit field that specifies whether the rule is to be used
      for forwarding (FMR). 0x0 = This rule is NOT used as a FMR. 0x1 =
      This rule is also a FMR.

Maybe I missed this, but I think that map-e/t drafts do not talk about this very much.  Shouldn't this be specified as part of the optional MAP rule. We talk about the first 4bits (by default) of the port range being set to 0 (to exclude ports 0 - 4K-1) but we do not talk about this mesh bit in map-e/t

Thanks,
Kris

---

From: "Poscic, Kristian (Kristian)" <[email-masked]>
Date: Fri, 15 Mar 2013 17:03:27 +0000

BTW - section 3 of the map-dhcp draft says:

A Basic Mapping Rule (BMR).  This rule governs the MAP
      configuration of the CE, including that of completing the CE's MAP
      IPv6 address, as well as deriving the CEs IPv4 parameters.  Key
      parameters of a BMR include: i) The IPv4 Prefix - Used to derive
      the CE's IPv4 address; ii) The Embedded Address bit length - Used
      to derive how many, if any, of the CE's IPv6 address is mapped to
      the IPv4 address. iii) The IPv6 prefix - used to determine the
      CE's IPv6 MAP domain prefix that is to form the base for the CE's
      MAP address.  The BMR is an optional rule for a MAP CE.

Last sentence is not correct. It should state 'mandatory'.

From: [email-masked] [mailto:[email-masked]] On Behalf Of Poscic, Kristian (Kristian)
Sent: Friday, March 15, 2013 9:57 AM
To: [email-masked]
Subject: [Softwires] map domain ; mesh BMR =>DHCP flag F

Thanks,
Kris

---

From: Satoru Matsushima <[email-masked]>
Date: Sat, 16 Mar 2013 02:33:02 +0900

In my view, the MAP-E text, which should be followed by other MAP
related document.

cheers,
--satoru

On Sat, Mar 16, 2013 at 1:57 AM, Poscic, Kristian (Kristian)
<[email-masked]> wrote:
> 1)      The MAP domain definition should be consolidated across the three
> drafts (map-e, map-t and map-deployment).
>
>
>
> So we go from virtual link and the ‘same IPv6 network’ concept with multiple
> BRs per MAP domain (in map-e/t drafts) to a common BR per map domain and
> subdomains concepts in map-deployment draft.
>
> What does ‘same IPv6 network’  mean in the map-t draft? In other  words does
> this mean that multiple MAP domains cannot co-exists within the boundary of
> an IPv6 network and that an operator should construct a separate IPv6
> network for another MAP domain? I don’t think this is what ‘same IPv6
> network’ means but it may come out as such.
>
>
>
> Then the map-deployment draft says that the MAP domain should share common
> BR – which I don’t think is correct (for redundancy and load sharing
> purposes).
>
> And then the subdomains that are referred to in the map-deployment draft,
> they correspond simply to BMRs. But if this is so, then we should define
> subdomain as such (subdomain = BMR). Or keep referring to BMRs instead of
> subdomains.
>
>
>
> Rather than trying to answer the question’ what is the MAP domain?’ I’m
> trying to ask myself ‘what do I need in order to create multiple MAP
> domains?’ I think the answer is that I need multiple (sets) of BRs (and
> corresponding CEs) on the same IPv6 or different IPv6 network, each such set
> of BRs  must contain distinct BMR and FMR rules (i.e. no overlapping of
> BMR/FMR rules between the sets of BRs to which MAP domains are tied to).
>
>
>
>
>
> 2)      Mesh topology is implicitly enabled in cases where FMRs are
> provisioned (configured). But the mesh topology can be also explicitly
> configured in case that we have only BMR.  Map-dhcp draft talks about this.
> Section 4.3 says this:
>
> Maybe I missed this, but I think that map-e/t drafts do not talk about this
> very much.  Shouldn’t this be specified as part of the optional MAP rule. We
> talk about the first 4bits (by default) of the port range being set to 0 (to
> exclude ports 0 - 4K-1) but we do not talk about this mesh bit in map-e/t
>
>
>
> Thanks,
>
> Kris
>
>
>
>
> _______________________________________________
> Softwires mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/softwires
>