Subject: Re: [Softwires] I-D Action: draft-ietf-softwire-map-deployment-01.txt

From: Rémi Després <[email-masked]>
Date: Fri, 1 Mar 2013 14:16:51 +0100

2013-02-28  15:34, Qiong <[email-masked]> :

> ...
> Currently, the title of this draft is still MAP only, as we have not found a good term to call MAP-E, MAP-T and 4rd-u. So we would like to get advice from the working group to address this problem.

Thanks to Qiong for raising this question in a more general context than that of MAP-E issue # 18 (http://trac.tools.ietf.org/wg/softwire/trac/ticket/18)

AFAIK, Alain's intention before he left was to move from MAP-E/MAP-T/4rd-U to 4rd-E/4rd-T/4rd-H (with H for Hybrid). IMHO, this does make sense because:
- "IPv4 Residual Deployment" better reflects the solution scope than "Address and Port Mapping".
- This nicely conveys that there is commonality with 6rd.
 
The fact that "MAP" has been used for some time for both MAP-E and MAP-T can be considered an impediment, but:
- Now is a good time for making a consistent choice for the future.
- Editorial updates for this are essentially trivial.
NB: The original acronym for MAP-E was 4rd (and that of MAP-T was 4via6).

This is my 2-cents contribution on this naming issue (after so many contributions to build and improve the solution). 

Best regards,
RD

---

From: Rémi Després <[email-masked]>
Date: Fri, 1 Mar 2013 15:21:17 +0100

You were in the CC list of the mail below but, for some reason I don't know, your names disappeared  in the mail forwarded to the WG, and stored in the archive.
Sorry for that.
RD

Le 2013-03-01 à 14:16, Rémi Després <[email-masked]> a écrit :

> _______________________________________________
> Softwires mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/softwires

---

From: Behcet Sarikaya <[email-masked]>
Date: Fri, 1 Mar 2013 12:00:48 -0600

On Fri, Mar 1, 2013 at 7:16 AM, Rémi Després <[email-masked]>wrote:

> Currently, the title of this draft is still MAP only, as we have not found
> a good term to call MAP-E, MAP-T and 4rd-u. So we would like to get advice
> from the working group to address this problem.
>
>
> Thanks to Qiong for raising this question in a more general context than
> that of MAP-E issue # 18 (
> http://trac.tools.ietf.org/wg/softwire/trac/ticket/18)
>
> AFAIK, Alain's intention before he left was to move from MAP-E/MAP-T/4rd-U
> to 4rd-E/4rd-T/4rd-H (with H for Hybrid). IMHO, this does make sense
> because:
> This is my 2-cents contribution on this naming issue (after so many
> contributions to build and improve the solution).
>
>
I support this. I had the same problem in my multicast draft.
I think that using a unifying name like 4rd would be helpful.

Behcet