Subject: [Softwires] softwire-map-04

From: "Poscic, Kristian (Kristian)" <[email-masked]>
Date: Fri, 8 Mar 2013 21:58:00 +0000

I think the following needs to be corrected in the softwire-map draft:

MAP Configuration

   For a given MAP domain, the BR and CE MUST be configured with the

   following MAP elements.  The configured values for these elements are

   identical for all CEs and BRs within a given MAP domain.

   o  The End-User IPv6 prefix (Part of the normal IPv6 provisioning).

   o  The Basic Mapping Rule and optionally the Forwarding Mapping

      Rules, including the Rule IPv6 prefix, Rule IPv4 prefix, and

      Length of EA bits

   o  The IPv6 address of the MAP BR.

   o  Hub and spoke mode or Mesh mode.  (If all traffic should be sent

      to the BR, or if direct CE to CE traffic should be supported).

The end-user IPv6 prefix is not identical for all CEs. On the contrary, it must be unique per CE. For example uniqueness is reflected in EA bits in case of shared IPv4 address.
Kris.

---

From: "Rajiv Asati (rajiva)" <[email-masked]>
Date: Fri, 8 Mar 2013 22:04:48 +0000

Good catch, indeed. Needs to be updated.

Cheers,
Rajiv

Sent from my Phone

On Mar 8, 2013, at 4:58 PM, "Poscic, Kristian (Kristian)" <[email-masked]<mailto:[email-masked]>> wrote:

MAP Configuration

      Length of EA bits

_______________________________________________
Softwires mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/softwires

---

From: Ole Troan <[email-masked]>
Date: Wed, 13 Mar 2013 09:51:56 -0400

Kris,

> The end-user IPv6 prefix is not identical for all CEs. On the contrary, it must be unique per CE. For example uniqueness is reflected in EA bits in case of shared IPv4 address.

I have read through section 7 again, and I think that we can remove the first bullet.
the requirement for the End-User prefix is described separately already in 7.1

is that acceptable as a resolution to you?

Best regards,
Ole

---

From: "Poscic, Kristian (Kristian)" <[email-masked]>
Date: Wed, 13 Mar 2013 13:53:55 +0000

Sure. That will work.

-----Original Message-----
From: Ole Troan [mailto:[email-masked]] 
Sent: Wednesday, March 13, 2013 6:52 AM
To: Poscic, Kristian (Kristian)
Cc: [email-masked]
Subject: Re: [Softwires] softwire-map-04

Kris,

Best regards,
Ole