Subject: [Softwires] Fwd: [softwire] #28: Dealing with DHCPv4-over-DHCPv6

From: Cong Liu <[email-masked]>
Date: Tue, 29 Oct 2013 22:32:40 +0800

Dear all,

I have some concerns about current map-dhcp-05 document. From my
understanding, this draft has been changed to "softwire-dhcp", to cover all
DHCPv6-related provisioning for softwire mechanisms. But I'm confused with
the descriptions about lw4o6 and the provisioning.

In order to improve the document and push map, lw4o6 and softwire-dhcp
further, I think there should be some updates on it. Here are the
issues/suggestions:

0) MAP & lw4o6 are parallel solutions, rather than lw4o6 is a subset of
MAP. Softwire-dhcp should claim this, and remove "Lightweight 4over6 is a
strict subset of MAP-E".
1) MAP uses DHCPv6 as the provisioning mechanism. DHCPv6 is optional for
lw4over6, used for stateless provisioning (static mode)
2) Dynamic IPv4 address assignment uses DHCPv4-over-DHCPv6 (IMHO it's the
default case of lw4o6). DHCPv4-over-DHCPv6 enable & server address options
can be put into containers, to enable the function.
3) use DHCPv4-over-DHCPv6 to provision additional configuration information
for both lw4o6 & MAP.
4) Softwire-dhcp should make a normative reference to DHCPv4-over-DHCPv6.

I have also submitted two tickets to the tracker : #27 for the "subset"
issue, and #28 for DHCPv4-over-DHCPv6 issues.

I'd like to ask the WG whether these should be considered.

Thanks!

Best Regards,
Cong Liu

---------- Forwarded message ----------
From: softwire issue tracker <[email-masked]>
Date: 2013/10/29
Subject: [softwire] #28: Dealing with DHCPv4-over-DHCPv6
To: [email-masked], [email-masked]
Cc: [email-masked]

#28: Dealing with DHCPv4-over-DHCPv6

 The current map-dhcp-05 draft covers static IPv4 provisioning for lw4o6,
 but does not cover dynamic IPv4 provisioning.

 Dynamic IPv4 provisioning is an important part of lw4o6. Current
 lw4over6-02 document says "An lwB4 MUST support dynamic port-restricted
 IPv4 address provisioning." According to current specification, dynamic
 IPv4 provisioning is the default working mode of lw4o6. And there is
 consensus in dhc wg that DHCPv4-over-DHCPv6 is the best underlying
 approach for IPv4 provisioning over IPv6 network, especially for dynamic
 provisioning.

 Since map-dhcp has been changed into "softwire-dhcp" to cover both MAP and
 lw4o6, it should cover the dynamic mode of lw4o6 and have a description of
 using DHCPv4-over-DHCPv6.

 The document should make a normative reference to DHCPv4-over-DHCPv6.

--
-------------------------+-------------------------------------------------
 Reporter:               |      Owner:  draft-ietf-softwire-map-
  [email-masked]      |  [email-masked]
     Type:  defect       |     Status:  new
 Priority:  major        |  Milestone:
Component:  map-dhcp     |    Version:
 Severity:  Active WG    |   Keywords:
  Document               |
-------------------------+-------------------------------------------------

Ticket URL: <http://tools.ietf.org/wg/softwire/trac/ticket/28>
softwire <http://tools.ietf.org/softwire/>

---

From: Ted Lemon <[email-masked]>
Date: Tue, 29 Oct 2013 19:06:30 +0000

On Oct 29, 2013, at 10:32 AM, Cong Liu <[email-masked]> wrote:
> 0) MAP & lw4o6 are parallel solutions, rather than lw4o6 is a subset of MAP. Softwire-dhcp should claim this, and remove "Lightweight 4over6 is a strict subset of MAP-E".

I think the correct thing to say here is that lw4over6 is much simpler than MAP-E—the client doesn't need to do any math, and just takes the configuration from the server.

> 1) MAP uses DHCPv6 as the provisioning mechanism. DHCPv6 is optional for lw4over6, used for stateless provisioning (static mode)

How does the lw4over6 client know it's stateless without a DHCPv6 option that tells it?   If you mean that the absence of a DHCPv6 option configuring a static IP address/port set is what does it, then that solution still requires DHCPv6—it just doesn't require that specific option to be sent.

The difference here is not that lw4over6 doesn't require DHCPv6, but that it additionally requires DHCPv4 for dynamic allocation, if dynamic allocation is used.

I am sure that I am just restating what you already know, but I want to be sure that we don't start arguing about a point on which we don't actually disagree.

---

From: Cong Liu <[email-masked]>
Date: Wed, 30 Oct 2013 15:09:58 +0800

Hi Ted,

Thanks for your comments.

2013/10/30 Ted Lemon <[email-masked]>

> I think the correct thing to say here is that lw4over6 is much simpler
> than MAP-E—the client doesn't need to do any math, and just takes the
> configuration from the server.
>
[Cong] I agree.

> How does the lw4over6 client know it's stateless without a DHCPv6 option
> that tells it?   If you mean that the absence of a DHCPv6 option
> configuring a static IP address/port set is what does it, then that
> solution still requires DHCPv6—it just doesn't require that specific option
> to be sent.
>
> The difference here is not that lw4over6 doesn't require DHCPv6, but that
> it additionally requires DHCPv4 for dynamic allocation, if dynamic
> allocation is used.
>
[Cong] Yes, that's what I mean. DHCPv6 is required in both cases, and
DHCPv4-over-DHCPv6 is also in DHCPv6, so this document should make a
discussion on it.

>
> I am sure that I am just restating what you already know, but I want to be
> sure that we don't start arguing about a point on which we don't actually
> disagree.
>
[Cong] It seems not have been fully discussed in the mail list, so I just
want to make sure whether there's consensus on these points.

Thanks!

Best Regards,
Cong

---

From: Ole Troan <[email-masked]>
Date: Wed, 30 Oct 2013 14:50:45 +0100

Cong,

> I have some concerns about current map-dhcp-05 document. From my understanding, this draft has been changed to "softwire-dhcp", to cover all DHCPv6-related provisioning for softwire mechanisms. But I'm confused with the descriptions about lw4o6 and the provisioning.
> 
> In order to improve the document and push map, lw4o6 and softwire-dhcp further, I think there should be some updates on it. Here are the issues/suggestions:
> 
> 2) Dynamic IPv4 address assignment uses DHCPv4-over-DHCPv6 (IMHO it's the default case of lw4o6). DHCPv4-over-DHCPv6 enable & server address options can be put into containers, to enable the function.
> 3) use DHCPv4-over-DHCPv6 to provision additional configuration information for both lw4o6 & MAP.
> I have also submitted two tickets to the tracker : #27 for the "subset" issue, and #28 for DHCPv4-over-DHCPv6 issues.
> 

MAP is incompatible with dynamic IPv4 address assignment using DHCPv4.
either you can consider MAP DHCP as the building block used by a separate document describing the
DHCPv4 address assignment case. or we can split out LW46 provisioning from MAP DHCP altogether.

cheers,
Ole