Subject: [Softwires] port-forwards in MAP

From: "Poscic, Kristian (Kristian)" <[email-masked]>
Date: Tue, 12 Nov 2013 23:31:10 +0000

Just wanted to confirm one thing for MAP-E in regards to static port forwards.

Can it be assumed that excluded port-range (0-1023 and possibly more depending on the offset) will never be used in MAP? The port forwards will be allocated on the CPE in statefull NAT44 and the ports will be allocated according to the delegated PSID and not from the MAP excluded range (well-known ports for example).
Thanks.

---

From: "Rajiv Asati (rajiva)" <[email-masked]>
Date: Wed, 13 Nov 2013 18:12:57 +0000

Hi Kristian,

Yes, that's correct.

-- 
Cheers,
Rajiv  

-----Original Message-----
From: <Poscic>, Kristian Poscic <[email-masked]>
Date: Tuesday, November 12, 2013 6:31 PM
To: Softwires-wg list <[email-masked]>
Subject: [Softwires] port-forwards in MAP

>Can it be assumed that excluded port-range (0-1023 and possibly more
>depending on the offset) will never be used in MAP? The port forwards
>will be allocated on the CPE in statefull NAT44 and the ports will be
>allocated according to the
> delegated PSID and not from the MAP excluded range (well-known ports for
>example).
>Thanks.
>
>

---

From: Wojciech Dec <[email-masked]>
Date: Thu, 14 Nov 2013 10:48:20 +0100

Well, never say "never" :-) MAP allows via the a-bits/offset-bits setting
the range of "excluded ports" in a domain
 to be configured. Thus, while not set so as a default, ports <1024 can
also be used.

There is naturally the non-address-shared mode of MAP to consider (i.e.
when PSID length =0). Here each MAP user has a full IPv4 address and of
course also the corresponding full port range.

Cheers,
Wojciech

On 13 November 2013 19:12, Rajiv Asati (rajiva) <[email-masked]> wrote:

> _______________________________________________
> Softwires mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/softwires
>

---

From: "Rajiv Asati (rajiva)" <[email-masked]>
Date: Mon, 25 Nov 2013 18:15:01 +0000

Good point, Woj. What I described was indeed the default behavior.

-- 
Cheers,
Rajiv Asati
Distinguished Engineer, Cisco

-----Original Message-----
From: Wojciech Dec <[email-masked]>
Date: Thursday, November 14, 2013 4:48 AM
To: Rajiv Asati <[email-masked]>
Cc: Kristian Poscic <[email-masked]>, Softwires-wg
list <[email-masked]>
Subject: Re: [Softwires] port-forwards in MAP