Subject: Re: [Softwires] ***CAUTION_Invalid_Signature*** Re: Alignment between softwire-map-dhcp and dhc-dhcpv4-over-dhcpv6 drafts

From: <[email-masked]>
Date: Mon, 11 Nov 2013 12:54:16 +0100

Hi Ole,

How about:

--
The solution described in this document is suitable for provisioning IPv4
addressing and other configuration necessary for establishing softwire
connectivity using DHCPv6. This means that the lifetime of the IPv4
configuration is bound to the lifetime of the DHCPv6 lease. For MAP-E and
MAP-T, this is necessary due to the mapping between the IPv4 and the IPv6
address. Lightweight 4over6 allows for the de-coupling of the IPv4 and
IPv6 lease times. If this is required, then DHCPv4 over DHCPv6
[ietf-dhc-dhcpv4-over-dhcpv6] should be used for IPv4 address leasing.

Additional DHCPv4 options are not transported natively in DHCPv6. If these
are required for client provisioning, then DHCPINFORM transported in
DHCPv4 over DHCPv6 should be used.
‹

Does that cover it?

Cheers,
Ian

On 08/11/2013 00:24, "Ole Troan" <[email-masked]> wrote:

>Ian,
>
>> From a discussion with Bernie and Tomeck earlier: To give some clarity
>>about what the different 4o6 provisioning mechanisms are suitable for,
>>can we add in some text to bound the scope of map-dhcp to provisioning
>>static v4 configuration parameters (i.e. precluding dynamic v4 leasing)
>>with no additional DHCPv4 options and add in an informative pointer to
>>using DHCPv4 over DHCPv6 for dynamic/additional options?
>> 
>> Likewise, I¹m putting a similar back pointer to MAP-DHCP in the
>>dhc-v4-configuration draft:
>> 
>> For the most simple IPv4 provisioning case, where the client only needs
>>to receive a static IPv4 address range assignment (with no dynamic
>>address leasing or additional IPv4 configuration), DHCPv6 based
>>approaches [ietf-softwire-map-dhcp] may provide a suitable solution.
>> 
>> The DHCPv4oDHCPv6 doc should have a similar pointer to map-dhcp for
>>static as well.
>
>could you propose some text?
>I'm not quite sure what bounding of scope you'd like to see.
>all the lifetimes of configuration information defined in MAP DHCP are
>bounded by the lifetimes of the tunnel,
>i.e. the lifetime of the End-user IPv6 prefix.
>
>the IPv4 address assignment will be as dynamic as the underlaying IPv6
>assignment is.
>
>what using DHCPv4 address leases gets you, is separate lease times. given
>that, this mode is incompatible with MAP-T and -E,
>I'm not quite sure what this document can say about it?
>
>cheers,
>Ole
>

---

From: Ole Troan <[email-masked]>
Date: Mon, 11 Nov 2013 13:05:33 +0100

Ian,

> How about:

yes, that appears good. I'll add that to the next revision if I don't hear loud objections.

cheers,
Ole

---

From: "Wojciech Dec (wdec)" <[email-masked]>
Date: Mon, 11 Nov 2013 12:11:41 +0000

Hi,

>How about:

It's close, but not quite as MAP doesn't mandate stageful DHCP of any kind
(SLAAC can also be used).

>DHCPv4 over DHCPv6 should be used.

I would propose that only the above paragraph be added, restated as:

Additional DHCPv4 options are not transported natively in DHCPv6. If these
are required for client provisioning, then DHCPINFORM transported in
DHCPv4 over DHCPv6 [ietf-dhc-dhcpv4-over-dhcpv6] should be used.

Thanks,
Wocjeich.

---

From: Cong Liu <[email-masked]>
Date: Mon, 11 Nov 2013 20:26:57 +0800

Hi Wocjeich,

2013/11/11 Wojciech Dec (wdec) <[email-masked]>

> (SLAAC can also be used).

I think this paragraph should be added.
For your concern, I think the text can be modified to:
  "This means that the lifetime of the IPv4 configuration is bound to the
lifetime of the IPv6 configuration."

Best Regards,
Cong

---

From: "Wojciech Dec (wdec)" <[email-masked]>
Date: Mon, 11 Nov 2013 12:38:27 +0000

From: Cong Liu <[email-masked]<mailto:[email-masked]>>
Date: Monday, 11 November 2013 05:26
To: Wojciech Dec <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [dhcwg] ***CAUTION_Invalid_Signature*** Re: Alignment between softwire-map-dhcp and dhc-dhcpv4-over-dhcpv6 drafts

Hi Wocjeich,

2013/11/11 Wojciech Dec (wdec) <[email-masked]<mailto:[email-masked]>>

I think this paragraph should be added.
For your concern, I think the text can be modified to:
  "This means that the lifetime of the IPv4 configuration is bound to the lifetime of the IPv6 configuration."

Well, not quite: The lifetime of the IPv4 configuration in MAP *can*, but doesn't have to be bound the IPv6 configuration.
As I said before, I do not think that the above "explanatory" text is suitable for this specification. The essence is that if someone want to use DHCPv4 (for DHCPv4 options, or DHCPv4 leases) then they should use DHCPv4 over DHCPv6.

-Wojciech.

Best Regards,
Cong

---

From: <[email-masked]>
Date: Mon, 11 Nov 2013 15:03:56 +0100

Hi Woj,

I think that we need to have a pointer (see comments below). What about if the text read:

The solution described in this document is suitable for provisioning IPv4 addressing and other configuration necessary for solely for establishing softwire connectivity using DHCPv6. This means that the lifetime of the IPv4 configuration is bound to the lifetime of the DHCPv6 lease. If de-coupling of IPv4 and IPv6 lease times is required, then DHCPv4 over DHCPv6 [ietf-dhc-dhcpv4-over-dhcpv6] should be used, although extensions may be required to provision the necessary parameters for all softwire mechanisms.

Additional DHCPv4 options are not transported natively in DHCPv6. If these are required for client provisioning, then DHCPINFORM transported in DHCPv4 over DHCPv6 should be used.

Cheers
Ian

Hi Wocjeich,

[ian] But the draft only describes MAP provisioning related to stateful DHCP, so it doesn’t make any requirements for how it would work if it was stateless.

[ian] The point here is that if you’re provisioning any softwire over DHCPv6, then they’re coupled. If you want to decouple, then it needs to be DHCPv4 over DHCPv6. We could always open up the proposed wording so that it is applicable to any softwire mechanism (I only put in the limitation at Ole’s behest).

[ian] The reason that I requested it is that Bernie and Tomeck don’t want the map-dhcp draft to become a basis that people will then try and extend with DHCPv4 options in the future.

---

From: Qi Sun <[email-masked]>
Date: Mon, 11 Nov 2013 22:12:34 +0800

Hi Woj,

> Well, not quite: The lifetime of the IPv4 configuration in MAP *can*, but doesn't have to be bound the IPv6 configuration.

[Qi] Could you please elaborate? This is what I found in draft-ietf-softwire-map-08:

   The MAP provisioning parameters, and hence the IPv4 service itself,
   is tied to the End-user IPv6 prefix lease; thus, the MAP service is
   also tied to this in terms of authorization, accounting, etc.  The
   MAP IPv4 address, prefix or shared IPv4 address and port set has the
   same lifetime as its associated End-user IPv6 prefix.

> The essence is that if someone want to use DHCPv4 (for DHCPv4 options, or DHCPv4 leases) then they should use DHCPv4 over DHCPv6. 

[Qi] As I see, the text proposed reflects this essence (dynamic IPv4 address leasing  and DHCPv4 options).

Best Regards,
Qi

---

From: Ole Troan <[email-masked]>
Date: Mon, 11 Nov 2013 15:16:59 +0100

Ian,

> I think that we need to have a pointer (see comments below). What about if the text read:

why do you think a pointer is required?

what about simply:

"
 This document describes DHCPv6 options that are used to provision IPv4 over IPv6 softwires. The lifetime of the softwire
 and the derived configuration information (e.g. IPv4 shared address, IPv4 address or prefix) is bound to the lifetime of the
 DHCPv6 lease.

Other IPv4 configuration information must be provisioned using DHCPv4.
"

cheers,
Ole

---

From: "Wojciech Dec (wdec)" <[email-masked]>
Date: Mon, 11 Nov 2013 14:28:56 +0000

The descriptive text that was proposed is not essential to the spec (about a stateless DHCPv6 option), nor to comprehend it, (nor to comprehend MAP for that matter). The essence really is that, "if you one need DHCPv4 leases, use DHCPv4". This point has nothing to do with how MAP does or does not use stateful dhcp, etc.

Re your questions, most of the answers point the way back to MAP 1:1 mode, where whichever way it is done, the IPv4 address does NOT need to be coupled to the IPv6 address.

Thanks for bringing out the issue in draft-08, which ought to be fixed before publishing: The MAP architecture requires an IPv6 prefix for the CE. It does NOT dictate how that prefix is provisioned, and whether it is stateful or not. An RA or DHCP-PD prefix, or static config are all fine here (though some may prefer dhcp say).

Thanks,
Wojciech.

From: Qi Sun <[email-masked]<mailto:[email-masked]>>
Date: Monday, 11 November 2013 07:12
To: Wojciech Dec <[email-masked]<mailto:[email-masked]>>
Cc: Cong Liu <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [dhcwg] ***CAUTION_Invalid_Signature*** Re: Alignment between softwire-map-dhcp and dhc-dhcpv4-over-dhcpv6 drafts

Hi Woj,

Best Regards,
Qi