Subject: Re: [Softwires] [softwire] #27: lw4o6 is not a subset of map-e

From: Cong Liu <[email-masked]>
Date: Fri, 1 Nov 2013 15:40:16 +0800

Hi Ole,

2013/10/30 Ole Troan <[email-masked]>

> which documents describe these features?
>
> I've read https://tools.ietf.org/html/draft-ietf-softwire-lw4over6-01combined with how LW46 is proposed to be provisioned in MAP DHCP. I'm
> clearly missing some text somewhere.
>

The features are described in lw4o6-base
https://tools.ietf.org/html/draft-ietf-softwire-lw4over6-01:
About binding table:
In section 1, "Lightweight 4over6 features keeping per-subscriber state in
the service provider's network."
In section 3, "An lwAFTR is an IPv4-in-IPv6 tunnel endpoint which maintains
per-subscriber address binding only and does not perform a NAPT44 function."
In section 4, "The lwAFTR needs to know the binding between ... Note that
this is per-subscriber state as opposed to per-flow state in the regular
AFTR case."

About dynamic IPv4 provisioning:
In section 5.1, "An lwB4 MUST support dynamic port-restricted IPv4
address provisioning
..."
In section 7, "There are several dynamically provisioning protocols for
IPv4 address and port set ..."

Best Regards,
Cong

---

From: Ole Troan <[email-masked]>
Date: Fri, 1 Nov 2013 12:38:00 +0100

Cong,

> I've read https://tools.ietf.org/html/draft-ietf-softwire-lw4over6-01 combined with how LW46 is proposed to be provisioned in MAP DHCP. I'm clearly missing some text somewhere.
>  
> The features are described in lw4o6-base https://tools.ietf.org/html/draft-ietf-softwire-lw4over6-01:

[...]

> In section 5.1, "An lwB4 MUST support dynamic port-restricted IPv4 address provisioning ..."
> In section 7, "There are several dynamically provisioning protocols for IPv4 address and port set ..." 

yes, but where are those specified?
what is "dynamic" port-restricted IPv4 address provisioning?
how do you deal with the possible conflict with the OPTION_S46_IPV4ADDRESS option?

cheers,
Ole

---

From: Ted Lemon <[email-masked]>
Date: Fri, 1 Nov 2013 11:59:07 +0000

> how do you deal with the possible conflict with the OPTION_S46_IPV4ADDRESS option?

The v4 and v6 servers are in the same administrative domain.   Why would there be a conflict?

---

From: Ole Troan <[email-masked]>
Date: Fri, 1 Nov 2013 14:48:11 +0100

Ted,

> The v4 and v6 servers are in the same administrative domain.   Why would there be a conflict?

if we are creating two ways to provision an IPv4 address for LW46. one with DHCPv6
OPTION_S46_IPV4ADDRESS and the other being DHCPv4, then we are creating
the additional complexity for the client. it has to pick one of the mechanisms. or
should it use both IPv4 addresses and ranges? regardless this has to be specified somewhere.

if we follow the principle of DHCPv6 is used to provision the link-layer (aka tunnel),
DHCPv4 is used to configure the IPv4 protocol. then I wonder if we shouldn't really
_only_ use DHCPv4 for LW46 IPv4 configuration. does that make sense?

cheers,
Ole

---

From: Ted Lemon <[email-masked]>
Date: Fri, 1 Nov 2013 13:50:33 +0000

> _only_ use DHCPv4 for LW46 IPv4 configuration. does that make sense?

DHCPv6 would still deliver the AFTR address, right?   I don't personally see a lot of value in having two ways of delivering the IPv4 address for lw4over6, but maybe the authors can explain?

---

From: Ole Troan <[email-masked]>
Date: Fri, 1 Nov 2013 14:52:29 +0100

> DHCPv6 would still deliver the AFTR address, right?   I don't personally see a lot of value in having two ways of delivering the IPv4 address for lw4over6, but maybe the authors can explain?

absolutely, the AFTR address is part of link-layer provisioning, so that would be done with DHCPv6. but 'nothing' else.

cheers,
Ole

---

From: "Lee, Yiu" <[email-masked]>
Date: Fri, 1 Nov 2013 15:02:34 +0000

I agree there is no added value to have two ways to do the same thing. I
guess the discussion here is whether lw46 should use dhcpv4-over-dhcpv6 or
OPTION_S46_IPV4ADDRESS option in map-dhcp. No matter what we decide, we
should only need one. I tend to agree with Ole to take out S46 option from
the map-dhcp and let the map-dhcp draft focus on map.

On 11/1/13 9:50 AM, "Ted Lemon" <[email-masked]> wrote:

>DHCPv6 would still deliver the AFTR address, right?   I don't personally
>see a lot of value in having two ways of delivering the IPv4 address for
>lw4over6, but maybe the authors can explain?
>
>_______________________________________________
>Softwires mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/softwires

---

From: Cong Liu <[email-masked]>
Date: Fri, 1 Nov 2013 23:04:06 +0800

Hi Ole,

2013/11/1 Ole Troan <[email-masked]>

> absolutely, the AFTR address is part of link-layer provisioning, so that
> would be done with DHCPv6. but 'nothing' else.
>

Besides DHCPv4-based method, PCP is also proposed for lw4o6 IPv4
configuration. According to
http://tools.ietf.org/html/draft-perreault-softwire-lw4over6-pcp-00, the
provisioning process is the same:
(1) Provision AFTR address by DHCPv6 option;
(2) Provision (IPv4 address + ports) by PCP

Do you mean DHCPv6 in step(1) should be avoided ?

Best Regards,
 Cong

---

From: Ole Troan <[email-masked]>
Date: Fri, 1 Nov 2013 16:25:08 +0100

> Besides DHCPv4-based method, PCP is also proposed for lw4o6 IPv4 configuration. According to http://tools.ietf.org/html/draft-perreault-softwire-lw4over6-pcp-00, the provisioning process is the same:

no.

Ole