Subject: [Softwires] Mail regarding draft-tsou-softwire-bfd-ds-lite

From: "Nobo Akiya (nobo)" <[email-masked]>
Date: Thu, 17 Apr 2014 13:56:01 +0000

Hi Authors,

Couple of questions around proposed the BFD solution.

1. Is the goal for B4 to detect [lack of] reachability to AFTR? Or does the goal include AFTR to keep state of which B4s are *speaking to it*?

2. It's fairly clear how BFD session can be instantiated/maintained on B4 (to AFTR). However, I'm not clear on how BFD sessions are instantiated/maintained on AFTR (to B4s). Is there some sort of automatic mechanism, or is this configured?

-Nobo

---

From: "Zhouqian (Cathy)" <[email-masked]>
Date: Mon, 28 Apr 2014 09:29:58 +0000

Hi Nobo,
Sorry for late reply. Please see inline.

Best Regards,
Cathy

> -----Original Message-----
> From: Softwires [mailto:[email-masked]] On Behalf Of Nobo Akiya
> (nobo)
> Sent: Thursday, April 17, 2014 9:56 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: [Softwires] Mail regarding draft-tsou-softwire-bfd-ds-lite
> 
> Hi Authors,
> 
> 1. Is the goal for B4 to detect [lack of] reachability to AFTR? Or does the goal
> include AFTR to keep state of which B4s are *speaking to it*?

It depends on specific technology, e.g., if PCP is used, AFTR does not keep the state of which B4s it is speaking to .
But if some bidirectional technology is used, e.g., BFD, AFTR will keep the state.
> 
> 2. It's fairly clear how BFD session can be instantiated/maintained on B4 (to
> AFTR). However, I'm not clear on how BFD sessions are
> instantiated/maintained on AFTR (to B4s). Is there some sort of automatic
> mechanism, or is this configured?
BFD sessions could be sent from AFTR only after B4 firstly initiated the session. So the answer is that this is configured.
> 
> -Nobo
> 
> _______________________________________________
> Softwires mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/softwires

---

From: "Nobo Akiya (nobo)" <[email-masked]>
Date: Mon, 28 Apr 2014 22:00:40 +0000

Hi Cathy,

Thanks for replies on both of my questions. Your answers align exactly with my understanding of the proposed.

There's a new work brewing in the BFD WG: S-BFD. That might fit nicely to your needs: single-sided continuity check (from B4) where AFTR can remain stateless (no need to configure BFD sessions on AFTR for each B4).

https://datatracker.ietf.org/doc/draft-akiya-bfd-seamless-base/

-Nobo

> From: Zhouqian (Cathy) [mailto:[email-masked]]
> Sent: Monday, April 28, 2014 5:30 AM
> To: Nobo Akiya (nobo); [email-masked]
> Cc: [email-masked]
> Subject: RE: Mail regarding draft-tsou-softwire-bfd-ds-lite
> 
> Hi Nobo,
> > 1. Is the goal for B4 to detect [lack of] reachability to AFTR? Or
> > does the goal include AFTR to keep state of which B4s are *speaking to it*?
> 
> 
> It depends on specific technology, e.g., if PCP is used, AFTR does not keep
> the state of which B4s it is speaking to .
> > 2. It's fairly clear how BFD session can be instantiated/maintained on
> > B4 (to AFTR). However, I'm not clear on how BFD sessions are
> > instantiated/maintained on AFTR (to B4s). Is there some sort of
> > automatic mechanism, or is this configured?
> BFD sessions could be sent from AFTR only after B4 firstly initiated the
> session. So the answer is that this is configured.
> >
> > -Nobo
> >

---

From: "Zhouqian (Cathy)" <[email-masked]>
Date: Wed, 30 Apr 2014 00:55:50 +0000

Hi Nobo,
Thanks for the pointer. We will consider referring to this document in the next version.

Best Regards,
Cathy

> From: Nobo Akiya (nobo) [mailto:[email-masked]]
> Sent: Tuesday, April 29, 2014 6:01 AM
> To: Zhouqian (Cathy); [email-masked]
> Cc: [email-masked]
> There's a new work brewing in the BFD WG: S-BFD. That might fit nicely to your
> needs: single-sided continuity check (from B4) where AFTR can remain
> stateless (no need to configure BFD sessions on AFTR for each B4).
> 
> > It depends on specific technology, e.g., if PCP is used, AFTR does not
> > keep the state of which B4s it is speaking to .
> > BFD sessions could be sent from AFTR only after B4 firstly initiated
> > the session. So the answer is that this is configured.
> > >
> > > -Nobo
> > >

---

From: "Nobo Akiya (nobo)" <[email-masked]>
Date: Wed, 30 Apr 2014 01:21:28 +0000

Hi Cathy,

Thank you for considering my thoughts.
Please do reach out to S-BFD authors or the BFD WG list if you have any questions around its functionality.

-Nobo

> Sent: Tuesday, April 29, 2014 8:56 PM
> > > To: Nobo Akiya (nobo);
> > > [email-masked]
> > > Cc: [email-masked]
> > > It depends on specific technology, e.g., if PCP is used, AFTR does
> > > not keep the state of which B4s it is speaking to .