Subject: [Softwires] Conclusion of consensus call for text describing MAP-E lw4o6 relationship

From: Suresh Krishnan <[email-masked]>
Date: Fri, 9 May 2014 09:01:35 -0400

Hi all,
   Since there was no response at all to this call, it is hard to read 
WG consensus. I can only assume that nobody feels strongly about this 
specific issue. Since both MAP-E and lw4over6 have completed WGLC, I am 
inclined to just progress them as is. If I do not hear any objections to 
this by Monday May 12 2014, I will progress these drafts as is.

Thanks
Suresh

On 04/29/2014 01:48 AM, Suresh Krishnan wrote:
> Hi all,
>     The following text was added to version -08 of the lw4over6 draft to describe the relationship between MAP-E and lw4over6.
>
> "Lightweight 4over6 is a solution designed specifically for
> complete architecture only. It does not offer direct, meshed IPv4
> independence between IPv6 subnet prefix and IPv4 address with or
> connectivity between subscribers without packets traversing the
> AFTR.  without IPv4 address sharing. This is accomplished by
> maintaining If this type of meshed interconnectivity is required,
> state for each softwire (per-subscriber state) in the central
> lwAFTR [I-D.ietf-softwire-map] provides a suitable solution.  and
> a hub-and-spoke forwarding architecture. [I-D.ietf-softwire-map]
> also offers these capabilities or, alternatively, allows for a
> reduction of the amount of centralized state using rules to
> express IPv4/IPv6 address mappings. This introduces an
> algorithmic relationship between the IPv6 subnet and IPv4
> address. This relationship also allows the option of direct,
> meshed connectivity between users."
>
> There was an implicit expectation that similar text (pretty much reversing the order in which the mechanisms are described) would be added to the MAP-E draft as well. In order to do so, we need to do a short consensus check.
>
> If you believe such text is useful and should be added to the MAP-E draft as well please respond to this mail to say so. On the other hand, if you believe such text is *not useful* and should be instead removed from the lw4over6 draft, please respond and say so as well. This call will conclude on 6th May 2014.
>
> Thanks
> Suresh & Yong
>
> _______________________________________________
> Softwires mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/softwires
>

---

From: Qi Sun <[email-masked]>
Date: Mon, 12 May 2014 20:29:20 +0800

Hi all,

I think the similar text should be added to MAP-E as well. 

Here is the proposal for the text adding to MAP-E (which was agreed offline):

>   MAP offers the capability of independence between IPv6 
>   subnet prefix and IPv4 address or, alternatively, allows for a
>   reduction of the amount of centralized state using rules to express
>   IPv4/IPv6 address mappings.  This introduces an algorithmic
>   relationship between the IPv6 subnet and IPv4 address.  This
>   relationship also allows the option of direct, meshed connectivity
>   between users. [I.D.ietf-softwire-lw4over6] is a solution designed 
>   specifically for complete independence between IPv6 subnet prefix 
>   and IPv4 address with or without IPv4 address sharing.  This is 
>   accomplished by maintaining state for each softwire (per-subscriber state) 
>   in the central lwAFTR and a hub-and-spoke forwarding architecture. 

//Even though I don’t think this text would add much value to lw4o6/MAP (as it doesn’t affect vendors to implement the mechanism), I do not want to start over the discussions, nor block the progress.

Thanks,
Qi

On May 9, 2014, at 9:01 PM, Suresh Krishnan <[email-masked]> wrote:

> Hi all,
>  Since there was no response at all to this call, it is hard to read WG consensus. I can only assume that nobody feels strongly about this specific issue. Since both MAP-E and lw4over6 have completed WGLC, I am inclined to just progress them as is. If I do not hear any objections to this by Monday May 12 2014, I will progress these drafts as is.
> 
> Thanks
> Suresh
>