Subject: [Softwires] I-D Action: draft-ietf-softwire-lw4over6-13.txt

From: [email-masked]
Date: Thu, 13 Nov 2014 19:33:46 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Softwires Working Group of the IETF.

        Title           : Lightweight 4over6: An Extension to the DS-Lite Architecture
        Authors         : Yong Cui
                          Qiong Sun
                          Mohamed Boucadair
                          Tina Tsou
                          Yiu L. Lee
                          Ian Farrer
	Filename        : draft-ietf-softwire-lw4over6-13.txt
	Pages           : 22
	Date            : 2014-11-13

Abstract:
   Dual-Stack Lite (RFC 6333) describes an architecture for transporting
   IPv4 packets over an IPv6 network.  This document specifies an
   extension to DS-Lite called Lightweight 4over6 which moves the
   Network Address and Port Translation (NAPT) function from the
   centralized DS-Lite tunnel concentrator to the tunnel client located
   in the Customer Premises Equipment (CPE).  This removes the
   requirement for a Carrier Grade NAT function in the tunnel
   concentrator and reduces the amount of centralized state that must be
   held to a per-subscriber level.  In order to delegate the NAPT
   function and make IPv4 Address sharing possible, port-restricted IPv4
   addresses are allocated to the CPEs.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-softwire-lw4over6/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-softwire-lw4over6-13

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-softwire-lw4over6-13

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: <[email-masked]>
Date: Fri, 14 Nov 2014 04:44:05 +0100

Hi,

A small update to include text describing possible fragment ID problems, in line with the MAP-E draft as discussed in the Softwire meeting on Tuesday.

Ian

-----Original Message-----
From: Softwires [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Donnerstag, 13. November 2014 17:34
To: [email-masked]
Cc: [email-masked]
Subject: [Softwires] I-D Action: draft-ietf-softwire-lw4over6-13.txt

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

_______________________________________________
Softwires mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/softwires

---

From: Ted Lemon <[email-masked]>
Date: Thu, 13 Nov 2014 18:04:47 -1000

> A small update to include text describing possible fragment ID problems, in line with the MAP-E draft as discussed in the Softwire meeting on Tuesday.

I thought we walked away from that discussion having concluded that the likelihood of a collision of this type is vanishingly small, and that it would be corrected by retransmission.   Ole, what did you take away from the meeting as an action item, if anything?   Did we decide to leave the text in anyway?

---

From: Ole Troan <[email-masked]>
Date: Fri, 14 Nov 2014 12:28:58 -1000

Ted,

> I thought we walked away from that discussion having concluded that the likelihood of a collision of this type is vanishingly small, and that it would be corrected by retransmission.   Ole, what di…

yes, I also walked away with "this is a corner case of a corner case", but I also assumed that we should continue to describe the problem. without providing any normative solution.

are you fine with keeping it in? you could of course that we don't help anyone very much by hand waving about it... without providing a solution.

cheers,
Ole

---

From: Ted Lemon <[email-masked]>
Date: Fri, 14 Nov 2014 12:29:48 -1000

> are you fine with keeping it in? you could of course that we don't help anyone very much by hand waving about it... without providing a solution.

I don't think a solution is needed.

---

From: Ted Lemon <[email-masked]>
Date: Fri, 14 Nov 2014 12:30:27 -1000

> I don't think a solution is needed.

BTW, I say that without my AD hat on.   As AD I am fine with whatever you decide to do to address this (within reason, of course!).

---

From: Andrew 👽 Yourtchenko <[email-masked]>
Date: Fri, 21 Nov 2014 16:12:50 +0100

On 11/14/14, Ole Troan <[email-masked]> wrote:
> Ted,
>
>>> A small update to include text describing possible fragment ID problems,
>>> in line with the MAP-E draft as discussed in the Softwire meeting on
>>> Tuesday.
>>
>> I thought we walked away from that discussion having concluded that the
>> likelihood of a collision of this type is vanishingly small, and that it
>> would be corrected by retransmission.   Ole, what did you take away from
>> the meeting as an action item, if anything?   Did we decide to leave the
>> text in anyway?
>
> yes, I also walked away with "this is a corner case of a corner case", but I
> also assumed that we should continue to describe the problem. without
> providing any normative solution.

FWIW - this was my understanding as well.

--a

>
> are you fine with keeping it in? you could of course that we don't help
> anyone very much by hand waving about it... without providing a solution.
>
> cheers,
> Ole