Subject: [Softwires] small editing error in draft-ietf-softwire-map-t-06

From: "Poscic, Kristian (Kristian)" <[email-masked]>
Date: Wed, 5 Nov 2014 18:42:00 +0000

I think that the IPv6 destination address below should be
2001:db8:ffff:0:0:0a02:0304::

This is in Appendix A.

Example 3- FMR:

   An IPv4 host behind a MAP-T CE (configured as per the previous
   examples) corresponding with an IPv4 host 10.2.3.4 will have its
   packets converted into IPv6 using the DMR configured on the MAP-T
   CE as follows:

   Default Mapping Rule:         {2001:db8:ffff::/64 (Rule IPv6 prefix),
                                 0.0.0.0/0 (Rule IPv4 prefix)}

   IPv4 source address:          192.0.2.18
   IPv4 destination address:     10.2.3.4
   IPv4 source port:             1232
   IPv4 destination port:        80
   MAP-T CE IPv6 source address: 2001:db8:0012:3400:0000:c000:0212:0034
   IPv6 destination address:     2001:db8:ffff:0:000a:0203:0400::  ==> incorrect

---

From: Wojciech Dec <[email-masked]>
Date: Thu, 6 Nov 2014 12:10:23 +0100

Hi Kristian,

hmmm, the destination address should follow rfc6052, which for a /64
prefix, 8 "u-bits", and an address 10.2.3.4, should come to appear as
2001:db8:ffff:0:000a:0203:0400::
In your proposed change, there would be 16 "u-bits", unless I'm reading it
wrongly.

Let me know.
Wojciech.

On 5 November 2014 19:42, Poscic, Kristian (Kristian) <
[email-masked]> wrote:

>    IPv6 destination address:     2001:db8:ffff:0:000a:0203:0400::  è
> incorrect
>
>
>
> _______________________________________________
> Softwires mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/softwires
>
>

---

From: Xing Li <[email-masked]>
Date: Thu, 06 Nov 2014 23:08:10 +0800

Wojciech Dec 写道:
> In your proposed change, there would be 16 "u-bits", unless I'm 
> reading it wrongly.

Woj is correct. The document says:

The mapping of the IPv4
   destination behind the IPv6 prefix will by default follow the /64
   rule as per [RFC6052 <https://tools.ietf.org/html/rfc6052>].  Any trailing bits after the IPv4 address are
   set to 0x0.

Therefore the example is correct.
2001:db8:ffff:0:000a:0203:0400:: 

Best,

xing

>
> Let me know.
> Wojciech.
>
> On 5 November 2014 19:42, Poscic, Kristian (Kristian) 
> <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>                                      0.0.0.0/0 <http://0.0.0.0/0>
>     (Rule IPv4 prefix)}
>
>      
>
>        IPv6 destination address:     2001:db8:ffff:0:000a:0203:0400:: 
>     è incorrect
>
>      
>
>
>     [email-masked] <mailto:[email-masked]>
> ------------------------------------------------------------------------
>