Subject: [Softwires] Result//RE: WGLC for draft-ietf-softwire-yang-04 as Standard Track, closed by 27 June 2018

From: Sheng Jiang <[email-masked]>
Date: Mon, 2 Jul 2018 01:43:52 +0000

Hi, all,
We received no negative response to the WGLC on draft-ietf-softwire-yang-04 during the two-week WGLC and we did receive good reviews through the WG document stage, through the shepherd review process and WGLC period. The authors have provided 06 version, which have addressed most, if not all, of received comments. Considering the past history of this work, I, as the document shepherd, feel it has passed the WGLC and should advance.
Up to now, there is no IPR disclosure to this document.
Best regards,
Sheng (shepherd, both chair Yong Cui and Ian Farrer who as a co-author stayed neutral on the content side)

From: Softwires [mailto:[email-masked]] On Behalf Of Sheng Jiang
Sent: Wednesday, June 27, 2018 12:00 PM
To: Softwires WG <[email-masked]>
Cc: [email-masked]
Subject: Re: [Softwires] WGLC for draft-ietf-softwire-yang-04 as Standard Track, closed by 27 June 2018

As the document shepherd, I have reviewed this document. Document editors and WG chairs should treat these comments just like any other last call comments. In general, I think this document is in a good shape. The YANG model is well defined and clearly described.
Here are some minor issues, mostly editorial, although there is 1 error report by the IETF Yang validation tool. It should be easy to be fixed, I blieve

There are some minor comments below, most of them are editorial.

Section 2.1
It may be better to add the statement names in the description of choice statement:
  a choice statement 'ce-type' is included for ...
  a choice statement 'data-plane' is included to ...

"For each module, a choice statement is included for either 'binding' or 'algorithmic'."
But in Table 1 it is 'algorithm'. Maybe 'algorithmic' should be changed to 'algorithm'.

Section 2.2
The reference to Appendix A.3 should be Appendix A

Section 3.1
"for all of the softwire mechanisms listed in Section 1"
It may be bette to avoid self citation and just list the mechanisms here.

"Figure 1 describes the tree structure of the CE softwire YANG module"
It's better to unify the terminology as "Softwire CE YANG Module"

Section 3.2
In the paragraph of "softwire-path-mru:":
It's confusing here whether the MRU is for IPv4 or IPv6.

There are two "br-ipv6-addr" defined. It may be better to add different prefixes or suffixes into the names, but I'm also OK with the current names..

In the paragraph of "ce-binding-ipv6-addr-change:":
"binding-ipv6-address" is not defined in the whole document. It should be explained.

Section 4.2
"in Figure 1"
should be "in Section 3.2"

"for logging/data retention purposes" -> "for logging or data retention purposes"

"between 3-tuples, which contains the lwB4's IPv6 address..." -> "between 3-tuples: the lwB4's IPv6 address..."

"softwire-num-threshold"
>From the description, I think it may be better to rename it to "softwire-num-max".
In the paratraph of "invalid-entry, added-entry, modified-entry:":
"the client" -> "the NETCONF client"

Appendix A.1
"lwB4 IPv6 Address:          123"
What's the "lwB4 IPv6 Address" here?

Appendix A.2
"for the clients" -> "for the CEs"

Appendix A.3
The same "lwB4 IPv6 Address" issue
And the PSID and PSID offset should be provided in the example.

Cheers,

Sheng

From: Softwires [mailto:[email-masked]] On Behalf Of Sheng Jiang
Sent: Wednesday, June 13, 2018 5:44 PM
To: Softwires WG <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: [Softwires] WGLC for draft-ietf-softwire-yang-04 as Standard Track, closed by 27 June 2018

This email announces a Softwire Working Group Last Call (WGLC) on:

Since both chairs of softwire WG are the co-authors of this document. I am now acting as the document shepherd for this draft.

YANG Modules for IPv4-in-IPv6 Address plus Port Softwires

draft-ietf-softwire-yang-04

https://tools.ietf.org/html/draft-ietf-softwire-yang-04

This draft is intended to become a Standard Track RFC.

This WGLC will run through the end of the day on Wednesday, June 27, 2018.

Comments should be sent to the [email-masked]<mailto:[email-masked]> list, although purely

editorial comments may be sent directly to the author.

No IPR disclosures have been submitted directly on

draft-ietf-softwire-yang-04

Regards and thanks,

Sheng Jiang (document shepherd)

---

From: [email-masked]
Date: Mon, 2 Jul 2018 13:30:04 +0200

Hi Sheng,

Thank you for the summary below. I believe that -06 addresses all of the comments received during the WGLC. Please let me know if there is anything outstanding.

Best regards,
Ian 

> On 2. Jul 2018, at 03:43, Sheng Jiang <[email-masked]> wrote:
> 
> Hi, all, 
> 
> From: Softwires [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of Sheng Jiang
> To: Softwires WG <[email-masked] <mailto:[email-masked]>>
> Cc: [email-masked] <mailto:[email-masked]>
> There are two "br-ipv6-addr" defined. It may be better to add different prefixes or suffixes into the names, but I'm also OK with the current names...
>  
> From: Softwires [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of Sheng Jiang
> To: Softwires WG <[email-masked] <mailto:[email-masked]>>
> Cc: softwire-chairs@ietf..org <mailto:[email-masked]>
> https://tools.ietf.org/html/draft-ietf-softwire-yang-04 <https://tools.ietf.org/html/draft-ietf-softwire-yang-04>
>  
> Comments should be sent to the [email-masked] <mailto:[email-masked]> list, although purely
> _______________________________________________
> Softwires mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/softwires <https://www.ietf.org/mailman/listinfo/softwires>