Subject: Re: [lamps] WG Last Call for draft-ietf-lamps-pkix-shake-05

From: Russ Housley <[email-masked]>
Date: Mon, 17 Dec 2018 11:29:18 -0500

With no one raising any concerns, it seems that we have reached consensus on this document.

I will begin the shepherd write-up, and once that is posted in the datatracker, I will ask the IESG to publish the document.

Russ

> On Nov 30, 2018, at 5:38 PM, Russ Housley <[email-masked]> wrote:
> 
> This is the LAMPS WG Last Call for "Internet X.509 Public Key Infrastructure: Additional Algorithm Identifiers for RSASSA-PSS and ECDSA using SHAKEs” <draft-ietf-lamps-pkix-shake-05>.  Please review the document and send your comments to the list by 15 December 2018.
> 
> The datatracker page for the document is https://datatracker.ietf.org/doc/draft-ietf-lamps-pkix-shake/
> 
> Thanks,
> Russ & Tim

---

From: Russ Housley <[email-masked]>
Date: Mon, 17 Dec 2018 17:38:59 -0500

I observed three problems when working on the shepherd write-up.

(1) I observed that a informative references is missing:

 == Missing Reference: 'RFC5912' is mentioned in the ASN.1 module

(2) The ASN.1 module calls for the assignment of a module identifier by IANA.  The IANA considerations need to ask IANA to assign this value.

I suggest this text:

  One object identifier for the ASN.1 module in Appendix A was
  assigned in the SMI Security for PKIX Module Identifiers
  (1.3.6.1.5.5.7.0) registry:

    PKIXAlgsForSHAKE-2018 { iso(1) identified-organization(3) dod(6)
      internet(1) security(5) mechanisms(5) pkix(7) id-mod(0)
      id-mod-pkix1-shake-2018(TBD) }

(3) The ASN.1 module does not compile.  I already sent corrections (and simplifications).

Can the authors quickly update the document?

Russ

> On Dec 17, 2018, at 11:29 AM, Russ Housley <[email-masked]> wrote:
>

---

From: "Panos Kampanakis (pkampana)" <[email-masked]>
Date: Tue, 18 Dec 2018 22:45:39 +0000

Thank you Russ. 
I fixed all 3 and added blurb about Russ Housley in the Acknowledgements section. And re-uploaded. 

-----Original Message-----
From: Spasm <[email-masked]> On Behalf Of Russ Housley
Sent: Monday, December 17, 2018 5:39 PM
To: SPASM <[email-masked]>
Subject: Re: [lamps] WG Last Call for draft-ietf-lamps-pkix-shake-05

I suggest this text:

Russ

>> The datatracker page for the document is https://datatracker.ietf.org/doc/draft-ietf-lamps-pkix-shake/

_______________________________________________
Spasm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/spasm

---

From: Jim Schaad <[email-masked]>
Date: Tue, 18 Dec 2018 21:38:58 -0800

In the ASN.1 module

PARAMS TYPE NULL ARE absent

Should be

PARAMS ARE absent

IANA considerations is missing getting some OIDs assigned.

Same issues w/ cms draft.

> Sent: Monday, December 17, 2018 8:29 AM
> I will begin the shepherd write-up, and once that is posted in the datatracker, I
> will ask the IESG to publish the document.
> 
> Russ
> 
> 
> > This is the LAMPS WG Last Call for "Internet X.509 Public Key Infrastructure:
> Additional Algorithm Identifiers for RSASSA-PSS and ECDSA using SHAKEs”
> <draft-ietf-lamps-pkix-shake-05>.  Please review the document and send your
> comments to the list by 15 December 2018.
> >
> > The datatracker page for the document is
> https://datatracker.ietf.org/doc/draft-ietf-lamps-pkix-shake/
> >
> > Thanks,
> > Russ & Tim
>

---

From: "Panos Kampanakis (pkampana)" <[email-masked]>
Date: Wed, 19 Dec 2018 16:57:01 +0000

Hi Jim, 

Thanks. Will fix the ASN.1 nit as we get the IESG comments. 

The IANA Consideration change is not necessary because the OIDs will be assigned by NIST in  https://csrc.nist.gov/Projects/Computer-Security-Objects-Register/Algorithm-Registration 

Panos

-----Original Message-----
From: Spasm <[email-masked]> On Behalf Of Jim Schaad
Sent: Wednesday, December 19, 2018 12:39 AM
To: 'Russ Housley' <[email-masked]>; 'SPASM' <[email-masked]>
Subject: Re: [lamps] WG Last Call for draft-ietf-lamps-pkix-shake-05

In the ASN.1 module

Should be

PARAMS ARE absent

> I will begin the shepherd write-up, and once that is posted in the 
> datatracker, I will ask the IESG to publish the document.
> 
> Russ
> 
> 
> <draft-ietf-lamps-pkix-shake-05>.  Please review the document and send 
> your comments to the list by 15 December 2018.
> >