Subject: [lamps] I-D Action: draft-ietf-lamps-rfc6844bis-04.txt

From: [email-masked]
Date: Mon, 03 Dec 2018 10:21:48 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Limited Additional Mechanisms for PKIX and SMIME WG of the IETF.

        Title           : DNS Certification Authority Authorization (CAA) Resource Record
        Authors         : Phillip Hallam-Baker
                          Rob Stradling
                          Jacob Hoffman-Andrews
	Filename        : draft-ietf-lamps-rfc6844bis-04.txt
	Pages           : 19
	Date            : 2018-12-03

Abstract:
   The Certification Authority Authorization (CAA) DNS Resource Record
   allows a DNS domain name holder to specify one or more Certification
   Authorities (CAs) authorized to issue certificates for that domain.
   CAA Resource Records allow a public Certification Authority to
   implement additional controls to reduce the risk of unintended
   certificate mis-issue.  This document defines the syntax of the CAA
   record and rules for processing CAA records by certificate issuers.

   This document obsoletes RFC 6844.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-lamps-rfc6844bis/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-lamps-rfc6844bis-04
https://datatracker.ietf.org/doc/html/draft-ietf-lamps-rfc6844bis-04

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-lamps-rfc6844bis-04

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Jacob Hoffman-Andrews <[email-masked]>
Date: Mon, 3 Dec 2018 10:27:20 -0800

Changes in draft-04 vs draft-03:

Addresseshttps://www.rfc-editor.org/errata/eid4062

  - Updated the canonical presentation format for the value field to 
indicate that it's not length-limited.

Addresses https://www.rfc-editor.org/errata/eid4070

  - Fixed the example zones to make example.com absolute (ends in .)

Removes "Certification Authority Restriction Flags" subsection under 
"IANA Considerations." Now "IANA Considerations just reads:

IANA is requested to add [[[ RFC Editor: Please replace with this RFC ]]] as
a reference for the Certification Authority Restriction Flags and
Certification Authority Restriction Properties registries.

Adds Corey Bonnell and Tim Hollebeek to Acknowledgements.

https://github.com/jsha/caa-simplification/compare/draft-03...draft-04

---

From: Corey Bonnell <[email-masked]>
Date: Tue, 4 Dec 2018 11:44:24 +0000

Hi Jacob,
Minor typo in section Section 8: “In
   particular, it specifies that parameters are separated with hyphens“. “Hyphens” should be replaced with “semicolons”.

Thanks,
Corey

________________________________
From: Spasm <[email-masked]> on behalf of Jacob Hoffman-Andrews <[email-masked]>
Sent: Monday, December 3, 2018 13:27
To: [email-masked]
Subject: Re: [lamps] I-D Action: draft-ietf-lamps-rfc6844bis-04.txt

Addresses https://nam04.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.rfc-editor.org%2Ferrata%2Feid4070&amp;data=02%7C01%7C%7Cfe7fb747b60b495d50c408d6594cfb0d%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636794584490462918&amp;sdata=psQeV7gjJVqZ2XoA3YdInOhx7GoxHuoYYlKItOneHtg%3D&amp;reserved=0

https://nam04.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2Fjsha%2Fcaa-simplification%2Fcompare%2Fdraft-03...draft-04&amp;data=02%7C01%7C%7Cfe7fb747b60b495d50c408d6594cfb0d%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636794584490462918&amp;sdata=vDLMe0hSrMyuWmE%2BMhG6Ugiocw900DbjqLbTsYSobvo%3D&amp;reserved=0

_______________________________________________
Spasm mailing list
[email-masked]
https://nam04.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fspasm&amp;data=02%7C01%7C%7Cfe7fb747b60b495d50c408d6594cfb0d%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636794584490462918&amp;sdata=%2F4AyvpO3kckeZqvE5NlUv%2BsRFyM2v4iHpbMECyf%2B4X8%3D&amp;reserved=0

---

From: Jacob Hoffman-Andrews <[email-masked]>
Date: Tue, 4 Dec 2018 13:53:18 -0800

Thanks Corey! I've updated my working copy on GitHub, but I'll wait a 
little while before publishing a fresh draft in case more feedback comes 
in soon.

On 12/4/18 3:44 AM, Corey Bonnell wrote:
>    particular, it specifies that parameters are separated with 
> hyphens“. “Hyphens” should be replaced with “semicolons”.
>
> Thanks,
> Corey
> ------------------------------------------------------------------------
> *From:* Spasm <[email-masked]> on behalf of Jacob 
> Hoffman-Andrews <[email-masked]>
> *Sent:* Monday, December 3, 2018 13:27
> *To:* [email-masked]
> *Subject:* Re: [lamps] I-D Action: draft-ietf-lamps-rfc6844bis-04.txt
> Addresses 
> https://nam04.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.rfc-editor.org%2Ferrata%2Feid4070&amp;data=02%7C01%7C%7Cfe7fb747b60b495d50c408d6594cfb0d%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636794584490462918&amp;sdata=psQeV7gjJVqZ2XoA3YdInOhx7GoxHuoYYlKItOneHtg%3D&amp;reserved=0
>
> https://www.ietf.org/mailman/listinfo/spasm