Subject: Re: [lamps] Restricted use of subject names - draft-ietf-lamps-documentsigning-eku-00.txt

From: Sean Turner <[email-masked]>
Date: Thu, 10 Feb 2022 14:02:53 -0500

Stefan,

We have merged a PR that I believe addresses this concern. See:
https://github.com/lamps-wg/documentsigning-eku/pull/1/files/d84bd767379c2df79bc504580fa2da18bf0fcddf

spt

> On Jan 19, 2022, at 02:56, Stefan Santesson <[email-masked]> wrote:
> 
> Sean,
> 
> I have a hard time understanding what is actually meant by this sentence
> of the draft:
> 
> "Inclusion of this KeyPurposeId in a certificate indicates that the use
> of any Subject names in the certificate is restricted to use by ..."
> 
> 
> What does "Subject names" have to do with this, and what exactly is
> meant by this restriction?
> 
> If I have a certificate with the name "Stefan Santesson", am I allowed
> to have another certificate with the same name with another key for
> another purpose?
> 
> Or what is this sentence trying to tell me?
> 
> 
> My understanding of EKU is that this extension in practice tells me that
> this certificate (and its public key) is only valid when used in a way
> that is consistent with present EKUs. Nothing more and nothing less. How
> is that compatible with the sentence above?
> 
> 
> -- 
> ________________
> Stefan Santesson

---

From: Stefan Santesson <[email-masked]>
Date: Mon, 14 Feb 2022 12:22:30 +0100

Hi,

Thank you . The change clarified a lot for me.

However, and unfortunately, there is a new problem:

"Inclusion of this KeyPurposeId in a certificate indicates that the
Subject named in the certificate signed the document content"

This phrase unfortunately violates Einstein's principles of causality,
because this means that the CA will predict the future.

The certificate is signed before the document that the CA claims was
signed by the certified key.

I think this part of the sentence need to go. Just keep the CA claims in
what context this certificate can be relied upon for signature validation.

/Stefan

On 2022-02-10 20:02, Sean Turner wrote:
> _______________________________________________
> Spasm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spasm

---

From: Russ Housley <[email-masked]>
Date: Mon, 14 Feb 2022 08:04:18 -0500

RFC 5280 says:

   If the extension is present, then the certificate MUST only be used
   for one of the purposes indicated.  If multiple purposes are
   indicated the application need not recognize all purposes indicated,
   as long as the intended purpose is present.  Certificate using
   applications MAY require that the extended key usage extension be
   present and that a particular purpose be indicated in order for the
   certificate to be acceptable to that application.

I think something along these lines regarding document signing is the right way to go.

Russ

> On Feb 14, 2022, at 6:22 AM, Stefan Santesson <[email-masked]> wrote:
> 
> Hi,
> 
>

---

From: Stefan Santesson <[email-masked]>
Date: Mon, 14 Feb 2022 15:10:54 +0100

+1