Subject: Re: [lamps] [Anima] /.well-known/brski reference to brski-registry

From: "Brockhaus, Hendrik" <[email-masked]>
Date: Thu, 31 Mar 2022 16:20:56 +0000

Thank you Michael for rising the questions.

> Von: Anima <[email-masked]> Im Auftrag von Michael Richardson
> Gesendet: Donnerstag, 31. März 2022 17:48
> 
> 
> We were discussing the /.well-known/cmp that is in being proposed in draft-ietf-
> lamps-cmp-updates, We were comparing it to /.well-known/brski and /.well-
> known/est.
> 
> Question 2)
>    Should the CMP document be establishing a registry or not?
> 
As discussed during IETF 113 I plan to do these things in CMP Updates
- register 'cmp' in the "Well-Known URIs" registry
- define a protocol registry group "Certificate Management Protocol (CMP)"
- define a registry for "CMP Well-Known Arbitrary Label URI Segments" defining 'p' to be followed by a <profileLabel>.
In addition I would define a registry for "CMP Well-Known Operation Label URI Segments" in Lightweight CMP Profile containing the path segments defined three for http and coap use.

Does this makes sense?

Hendrik

---

From: Russ Housley <[email-masked]>
Date: Thu, 31 Mar 2022 13:52:51 -0400

> On Mar 31, 2022, at 12:20 PM, Brockhaus, Hendrik <[email-masked]> wrote:
> 

Hendrik:

That is consistent with the discussion lat week.

Russ