Subject: RE: [Speechsc] speechsc protocol issues

From: "Skip Cave" <[email-masked]>
Date: Wed, 18 Dec 2002 13:13:27 -0600

A quote from " Guidelines for Authors of Extensions to the Session Initiation Protocol (SIP)"
http://www.ietf.org/internet-drafts/draft-ietf-sip-guidelines-06.txt

"SIP is a poor control protocol. It is not meant to be used for one entity to tell another to pick up or answer a phone, send audio using  a particular codec, or to provide a new value for a configuration parameter. Control protocols have different trust relationships than is assumed in SIP, and are more centralized in architecture than SIP,  which is a very distributed protocol."

On another note, one requirement for speechsc would be the capability to allow commands to be sent to a speech server with no media invoilved. For example one may want to send a grammar to an ASR server before establishing a call. You don't want to set up media yet, just pre-load some grammars. SIP typically sets up media at the initial INVITE message, which is not what we want to do.

Skip Cave 
Sr. Principal Engineer
Intervoice

---

From: "Brian Wyld" <[email-masked]>
Date: Mon, 30 Dec 2002 10:35:43 +0100

Hi,

wrt Skip's comment below, I note that RTSP (for example) allows use of
configuration setup messages outside of a media session (including for
instance the ANNOUNCE message used in the current MRCP/RTSP submission)

Brian
  [Skip]
   On another note, one requirement for speechsc would be the capability to
allow commands to be sent to a speech server with no media invoilved. For
example one may want to send a grammar to an ASR server before establishing
a call. You don't want to set up media yet, just pre-load some grammars. SIP
typically sets up media at the initial INVITE message, which is not what we
want to do.