Subject: [Speechsc] Fwd: Question for "accept" in VoiceXML 2.0 using MRCP V2

From: Madhu Gindi <[email-masked]>
Date: Wed, 23 Mar 2005 19:18:30 -0800

I am forwarding on Jenny's behalf since Jenny's message bounced back with error. 

/madhu
====================================
>Reply-To: <[email-masked]>
>From: "Jenny Yao \(jyao\)" <[email-masked]>
>To: <[email-masked]>
>Cc: "'Sunitha Krishna'" <[email-masked]>, <[email-masked]>,
>        "'Madhu Gindi'" <[email-masked]>
>Subject: Question for "accept" in VoiceXML 2.0 using MRCP V2
>Date: Wed, 23 Mar 2005 16:36:04 -0800
>
>Our VoiceXML 2.0 interpreter uses MRCP to communicate with ASR/TTS server. In VoiceXML 2.0, there is an attribute "accept" for "menu" and "choice" elements. "accept" can be set to "exact" or "approximate" . If the accept attribute is "exact" then the user must say the entire phrase in the same order in which they occur in the choice phrase.If the accept attribute is "approximate", then the choice may be matched when a user says a subphrase of the expression . We don't see MRCP V2 draft address this capability. We would like to know if there is any solution other than adding this to MRCP V2 draft. If not, we would like to propose adding this feature in MRCP V2. 
> 
>Thanks.
> 
>Jenny 
> 
>---
>Jenny Yao
>Cisco Systems
>Mail Stop SJ-22/2, 170 W. Tasman Drive, San Jose, CA 95134
>Voice: (408)525-3879

________________________________________________________________
Madhu Gindi  Software Development Manager MCEBU ph: 408-525-5571 

_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

---

From: "Dave Burke" <[email-masked]>
Date: Thu, 24 Mar 2005 14:44:25 +0100

The "accept" attribute mechanism described in VoiceXML calls for the generation of a grammar which will be language and platform dependent. 

The content of SRGS grammars is orthogonal to the MRCP protocol and does not belong in it.

-- Dave
  ----- Original Message ----- 
  From: Madhu Gindi 
  To: [email-masked] 
  Cc: [email-masked] 
  Sent: Thursday, March 24, 2005 4:18 AM
  Subject: [Speechsc] Fwd: Question for "accept" in VoiceXML 2.0 using MRCP V2

  /madhu

     
    Thanks.
     
    Jenny 
     
    ---
    Jenny Yao
    Cisco Systems

------------------------------------------------------------------------------