Subject: RE: [Speechsc] Fwd: Question for "accept" in VoiceXML 2.0 using MRCPV2

From: "Shanmugham, Saravanan" <[email-masked]>
Date: Thu, 24 Mar 2005 08:41:13 -0800

This is assuming the MRCP client will be generating the different
grammar options for approximate. The grammar that needs to be generated
for the approximate case is language dependent. As the system is much of
the language intellegience and capbilities is on the server side. 
 
So would the system benefit from an accept=exact/approximate header,
that allows the recogniton/grammar engine on the server to use its
language intelligence to render an equivalent approximate grammar?
 
In implementations such as a VoiceXML browser that depends on back end
MRCP server, there may not be much language intelligence on the server
to do this generation for different languages.
 
And if we do decide to provide this header, the question is where?
Regular header in the DEFINE-GRAMMAR or RECOGNIZE? Or a Content header
like Content-Match similar to the Content-Weight that is being proposed.
I am thinking the later.
 
any thoughts,
Sarvi  

  _____  

From: [email-masked] [mailto:[email-masked]] On
Behalf Of Dave Burke
Sent: Thursday, March 24, 2005 5:44 AM
To: [email-masked]; Madhu Gindi
Cc: [email-masked]
Subject: Re: [Speechsc] Fwd: Question for "accept" in VoiceXML 2.0 using
MRCPV2

The "accept" attribute mechanism described in VoiceXML calls for the
generation of a grammar which will be language and platform dependent. 
 
The content of SRGS grammars is orthogonal to the MRCP protocol and does
not belong in it.
 
-- Dave

	----- Original Message ----- 
	From: Madhu Gindi <mailto:[email-masked]>  
	To: [email-masked] 
	Cc: [email-masked] 
	Sent: Thursday, March 24, 2005 4:18 AM
	Subject: [Speechsc] Fwd: Question for "accept" in VoiceXML 2.0
using MRCP V2

	I am forwarding on Jenny's behalf since Jenny's message bounced
back with error. 
	
	/madhu
	====================================

		Reply-To: <[email-masked]>
		From: "Jenny Yao \(jyao\)" <[email-masked]>
		To: <[email-masked]>
		Cc: "'Sunitha Krishna'" <[email-masked]>,
<[email-masked]>,
		        "'Madhu Gindi'" <[email-masked]>
		Subject: Question for "accept" in VoiceXML 2.0 using
MRCP V2
		Date: Wed, 23 Mar 2005 16:36:04 -0800
		
		Our VoiceXML 2.0 interpreter uses MRCP to communicate
with ASR/TTS server. In VoiceXML 2.0, there is an attribute "accept" for
"menu" and "choice" elements. "accept" can be set to "exact" or
"approximate" . If the accept attribute is "exact" then the user must
say the entire phrase in the same order in which they occur in the
choice phrase.If the accept attribute is "approximate", then the choice
may be matched when a user says a subphrase of the expression . We don't
see MRCP V2 draft address this capability. We would like to know if
there is any solution other than adding this to MRCP V2 draft. If not,
we would like to propose adding this feature in MRCP V2. 
		 
		Thanks.
		 
		Jenny 
		 
		---
		Jenny Yao
		Cisco Systems
		Mail Stop SJ-22/2, 170 W. Tasman Drive, San Jose, CA
95134
		Voice: (408)525-3879

	________________________________________________________________
	Madhu Gindi  Software Development Manager MCEBU ph: 408-525-5571

  _____  

	_______________________________________________
	Speechsc mailing list
	[email-masked]
	https://www1.ietf.org/mailman/listinfo/speechsc

_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

---

From: "Shanmugham, Saravanan" <[email-masked]>
Date: Thu, 24 Mar 2005 09:37:34 -0800

Or do you see it becoming part of the W3C XML grammar definition. In
which case, has this been considered there.

Sarvi

  _____  

From: [email-masked] [mailto:[email-masked]] On
Behalf Of Shanmugham, Saravanan
Sent: Thursday, March 24, 2005 8:41 AM
To: Dave Burke; [email-masked]; Madhu Gindi
Cc: [email-masked]
Subject: RE: [Speechsc] Fwd: Question for "accept" in VoiceXML 2.0 using
MRCPV2

 

any thoughts,
Sarvi  

  _____  

 
 
-- Dave

	----- Original Message ----- 
	From: Madhu Gindi <mailto:[email-masked]>  
	To: [email-masked] 
	Cc: [email-masked] 
	Sent: Thursday, March 24, 2005 4:18 AM
	Subject: [Speechsc] Fwd: Question for "accept" in VoiceXML 2.0
using MRCP V2

	/madhu

		 
		Thanks.
		 
		Jenny 
		 
		---
		Jenny Yao
		Cisco Systems

	
  _____