Subject: [Speechsc] confidence range in NLSML

From: "Reifenrath, Klaus" <[email-masked]>
Date: Tue, 22 Mar 2005 08:25:56 -0500

Hi Sarvi,

the 06 draft is still not consistent regarding NLSML:
DTD and Schema specify a range of 0.0 to 1.0 for interpretation
confidences (and most examples are now using this range), 
while the text (page 79) and the examples on page 79 use a range of 0 to
100.

In NLSML confidence always was an integer from 0 to 100.

It may look sort of weird, because the MRCP header fields (e.g.
Confidence-Threshold)
that deal with confidences are floats from 0.0 to 1.0. On the one hand we
decided not 
to change NLSML but at the same time choose floats for confidences in header
fields 
with respect to EMMA that will soon replace NLSML.

Regards,
Klaus

-----Original Message-----
From: Sarvi Shanmugham [mailto:[email-masked]]
Sent: Dienstag, 22. Februar 2005 05:24
To: Dan Burnett; David R. Oran; Eric Burger; [email-masked]
Subject: [Speechsc] draft mrcpv2 -06 is out

Hi,
      The -06 version of the draft was submitted last night.  This 
addresses the following.

1. Baggia Paolo's review comments.
2. Klaus's feedback on NLSML addressed.
3.  Jeff Kusnitz's concern for supporting grammar weights.
     - As described in the email discussions.
4. Some ABNF cleanup
5. The Secutiry considerations section
6. The IANA considerations section.
      - SCTP and SCTP+TLS SDP media type is not supported in this draft, 
and is defered to a separate specification.
      - All other necessary registrations have been addressed.

Thanks,
Sarvi

_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

---

From: Dan Burnett <[email-masked]>
Date: Tue, 22 Mar 2005 05:30:27 -0800 (PST)

We should be using 0.0 to 1.0 everywhere.

-- dan

--- "Reifenrath, Klaus"
>       - All other necessary registrations have been

__________________________________ 
Do you Yahoo!? 
Yahoo! Mail - now with 250MB free storage. Learn more. 
http://info.mail.yahoo.com/mail_250

---

From: "Reifenrath, Klaus" <[email-masked]>
Date: Tue, 22 Mar 2005 08:34:31 -0500

But in case of NLSML that will break backwards compatibility, because today
NLSML uses 0 to 100!

Klaus

-----Original Message-----
From: Dan Burnett [mailto:[email-masked]]
Sent: Dienstag, 22. März 2005 14:30
To: Reifenrath, Klaus; 'Sarvi Shanmugham'
Cc: [email-masked]; Dan Burnett
Subject: Re: confidence range in NLSML

-- dan

--- "Reifenrath, Klaus"

---

From: "Shanmugham, Saravanan" <[email-masked]>
Date: Tue, 22 Mar 2005 08:13:13 -0800

I think I agree with Dan. 
If we think 0.0 - 1.0 is the right way long term, I think that's what we should do.

This is a new protocol, though we have leveraged a lot of work from the MRCPv1.  So there should not be any backward compatibility issues.
Also the NLSML markup compatibility should also not be a problem, considering that we have officially only defined NLSML in this document and this would be the official version 1.0 of NLSML. 

My 2c,
Sarvi

-----Original Message-----
From: Reifenrath, Klaus [mailto:[email-masked]] 
Sent: Tuesday, March 22, 2005 5:35 AM
To: 'Dan Burnett'; Shanmugham, Saravanan
Cc: [email-masked]
Subject: RE: confidence range in NLSML

But in case of NLSML that will break backwards compatibility, because today NLSML uses 0 to 100!

Klaus

-----Original Message-----
From: Dan Burnett [mailto:[email-masked]]
Sent: Dienstag, 22. März 2005 14:30
To: Reifenrath, Klaus; 'Sarvi Shanmugham'
Cc: [email-masked]; Dan Burnett
Subject: Re: confidence range in NLSML

-- dan

--- "Reifenrath, Klaus"
<[email-masked]> wrote:
> confidences (and most examples are now using this range), while the 
> text (page 79) and the examples on page 79 use a range of 0 to 100.
> 
> that deal with confidences are floats from 0.0 to 1.0. On the one hand 
> we decided not to change NLSML but at the same time choose floats for 
> confidences in header fields with respect to EMMA that will soon 
> replace NLSML.
> 
> Regards,
> Klaus
> 
> 5. The Secutiry considerations section 6. The IANA considerations 
> section.
>       - SCTP and SCTP+TLS SDP media type is not supported in this 
> draft, and is defered to a separate specification.

---

From: "Reifenrath, Klaus" <[email-masked]>
Date: Tue, 22 Mar 2005 11:36:28 -0500

We decided at the San Diego F2F not to change NLSML, which by that time was
already a de facto standard, despite the fact that we knew of several(!)
shortcomings! I think we should stick to this decision to avoid lengthy
discussion on all the other issues.

Klaus

-----Original Message-----
From: Shanmugham, Saravanan [mailto:[email-masked]]
Sent: Dienstag, 22. März 2005 17:13
To: Reifenrath, Klaus; Dan Burnett
Cc: [email-masked]
Subject: RE: confidence range in NLSML

I think I agree with Dan. 
If we think 0.0 - 1.0 is the right way long term, I think that's what we
should do.

This is a new protocol, though we have leveraged a lot of work from the
MRCPv1.  So there should not be any backward compatibility issues.
Also the NLSML markup compatibility should also not be a problem,
considering that we have officially only defined NLSML in this document and
this would be the official version 1.0 of NLSML. 

My 2c,
Sarvi

-----Original Message-----
From: Reifenrath, Klaus [mailto:[email-masked]] 
Sent: Tuesday, March 22, 2005 5:35 AM
To: 'Dan Burnett'; Shanmugham, Saravanan
Cc: [email-masked]
Subject: RE: confidence range in NLSML

Klaus

-----Original Message-----
From: Dan Burnett [mailto:[email-masked]]
Sent: Dienstag, 22. März 2005 14:30
To: Reifenrath, Klaus; 'Sarvi Shanmugham'
Cc: [email-masked]; Dan Burnett
Subject: Re: confidence range in NLSML

-- dan

--- "Reifenrath, Klaus"