Subject: [Speechsc] Version header in responses

From: Eric Burger <[email-masked]>
Date: Tue, 17 May 2005 17:16:16 -0400

The current text (Section 5.2) states that the response to a request MUST
have the same version header as the request.

Why?  If we have a version header at all, shouldn't it convey the actual
version of the server?  Clearly, the server understands the client if it
generates a response at all.  Moreover, the client can then chose if the
server is of the 'right' version to do the transaction.

Conversely, I would offer that if we can deal with this loss of information
(the actual server version), then the version header itself is redundant and
should be dropped from the specification.

_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

---

From: "Shanmugham, Saravanan" <[email-masked]>
Date: Tue, 17 May 2005 17:07:25 -0700

I believe what the text intended to mean was that the version string
sent by the client in the request MUST match the version string sent by
the server in the response for the 2 entities to fully understand each
other. It does not mean that the server MUST respond with the same exact
string sent by the client. It just means that they MUST match for them
to completely understand each other.

We can clarify this in the text.

Thanks,
Sarvi

     -----Original Message-----
     From: [email-masked] 
     [mailto:[email-masked]] On Behalf Of Eric Burger
     Sent: Tuesday, May 17, 2005 2:16 PM
     To: [email-masked]
     Subject: [Speechsc] Version header in responses
     
     The current text (Section 5.2) states that the response to 
     a request MUST have the same version header as the request.
     
     Why?  If we have a version header at all, shouldn't it 
     convey the actual version of the server?  Clearly, the 
     server understands the client if it generates a response 
     at all.  Moreover, the client can then chose if the server 
     is of the 'right' version to do the transaction.
     
     Conversely, I would offer that if we can deal with this 
     loss of information (the actual server version), then the 
     version header itself is redundant and should be dropped 
     from the specification.