Subject: RE: [Speechsc] MRCPv2 requirements for VoiceXML "inputmodes" property

From: "Shanmugham, Saravanan" <[email-masked]>
Date: Wed, 4 May 2005 09:15:53 -0700

Each recongize that specify which grammars should be active for the
RECOGNIZE.
So, can this not be achieved by choosing which grammars to activate? 

I do see that there is one issue though, that the current spec is
defined in a way the client may not have to parse the grammar content at
all. An this would mean that the client would have to parse atleast the
initial portion of the grammar doucment to figure if the mode is DTMF or
not.

I don't see any issue in adding support for a header field that
specifies this option for the RECOGNIZE method. Anyone opposed to this
proposal?

Thx,
Sarvi

PS: This then begs the question regarding the "accept" attribute in VXML
2.1. Which also puts the client in a similar possition, only worse. It
has to parse through the entire grammar and construct additional
grammars that meet the "accept" criteria. In general the philosohy of
MRCP has been to keep much of the grammar and language processing on the
server side and keep the client simple. I propose that we add a header
to support this as well. But define it in such a way that we leave room
for recognition vendors that may not want to support it.

     -----Original Message-----
     From: [email-masked] 
     [mailto:[email-masked]] On Behalf Of Brett Gavagni
     Sent: Wednesday, May 04, 2005 8:58 AM
     To: [email-masked]
     Subject: [Speechsc] MRCPv2 requirements for VoiceXML 
     "inputmodes" property
     
     Have there been any MRCPv2 requirements raised to include 
     support for VoiceXML 2.x "inputmodes" property? 
     
     How would a VoiceXML vendor implement support for the "inputmodes" 
     property utilizing the current MRCPv2 specification, and 
     should this be added as a change request for a future 
     MRCPv2 revision?
     
     The definition of VoiceXML 'inputmodes' is as follows:
     
     inputmodes
     This property determines which input modality to use. The 
     input modes to
     enable: dtmf and voice. On platforms that support both 
     modes, inputmodes defaults to "dtmf voice". To disable 
     speech recognition, set inputmodes to "dtmf". To disable 
     DTMF, set it to "voice". One use for this would be to turn 
     off speech recognition in noisy environments. Another 
     would be to conserve speech recognition resources by 
     turning them off where the input is always expected to be 
     DTMF. This property does not control the activation of 
     grammars. For instance, voice-only grammars may be active 
     when the inputmode is restricted to DTMF. Those grammars 
     would not be matched, however, because the voice input 
     modality is not active. 

     Thanks,
     
     Brett Gavagni
     WebSphere Voice Server Development
     http://www-306.ibm.com/software/pervasive/voice_server/
     [email-masked]

     _______________________________________________
     Speechsc mailing list
     [email-masked]
     https://www1.ietf.org/mailman/listinfo/speechsc

_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

---

From: Brett Gavagni <[email-masked]>
Date: Wed, 4 May 2005 14:41:38 -0400

Hi Sarvi,

I agree with your proposal.

You were following exactly where I was going with this point.

Another potentially useful addition to the specification, for a MRCP 
server to specify the grammar mode in the response to a DEFINE-GRAMMAR 
request.

Thanks,

Brett Gavagni 

"Shanmugham, Saravanan" <[email-masked]> 
05/04/2005 12:15 PM

To
Brett Gavagni/West Palm Beach/IBM@IBMUS, <[email-masked]>
cc

Subject
RE: [Speechsc] MRCPv2 requirements for VoiceXML "inputmodes" property

Thx,
Sarvi

     -----Original Message-----
     From: [email-masked] 
     [mailto:[email-masked]] On Behalf Of Brett Gavagni
     Sent: Wednesday, May 04, 2005 8:58 AM
     To: [email-masked]
     Subject: [Speechsc] MRCPv2 requirements for VoiceXML 
     "inputmodes" property

 
 
     inputmodes

     Thanks,
 
     Brett Gavagni