Subject: RE: [Speechsc] EMMA: Extensible MultiModalAnnotation markuplanguagesupport?

From: "Shanmugham, Saravanan" <[email-masked]>
Date: Wed, 28 Sep 2005 11:35:50 -0700

Would something like the HTTP "Accept" header address these and other
similar concerns.
The RECOGNIZE request can then carry this header in it to specify an
alternative to NLSML.

Sarvi 

     -----Original Message-----
     From: [email-masked] 
     [mailto:[email-masked]] On Behalf Of Brett Gavagni
     Sent: Saturday, September 24, 2005 7:51 AM
     To: Jerry Carter
     Cc: IETF SPEECHSC (E-mail); [email-masked]; Baggia Paolo
     Subject: Re: [Speechsc] EMMA: Extensible 
     MultiModalAnnotation markuplanguagesupport?
     
     Hi,
     
     I agree that the ability for a client to request the 
     format of the recognizer result data content would be useful.
     
     I would prefer to see this function defined in a 
     consistent manner with the current draft specification; by 
     a client request to enable a session parameter via a 
     header (ie. "Result-Data-Type") in a SET-PARAMS or 
     RECOGNIZE request, rather than an attribute used for 
     RECOGNIZER session negotiation/update. The server should 
     then respond with an accept or reject response as it does 
     today for other client requested parameter values. 
     Currently, the draft specification doesn't expose the MRCP 
     resource configurable parameters in the SDP.
     
     I don't think that enabling platform-specific formats 
     facilitates the adoption of a standard specification for 
     speech resources. I  believe that the specification should 
     continue to address the required supported formats and 
     require new draft iterations including the updated 
     specifications. The updated draft iterations would 
     continue to assist with potential client/server 
     interoperability issues.
     
     Thanks,
     
     Brett Gavagni
     WebSphere Voice Server Development
     http://www-306.ibm.com/software/pervasive/voice_server/
     [email-masked]

     
     Jerry Carter <[email-masked]>
     Sent by: [email-masked]
     09/23/2005 11:42 PM
     
     To
     Baggia Paolo <[email-masked]> cc "IETF SPEECHSC 
     \(E-mail\)" <[email-masked]> Subject
     Re: [Speechsc] EMMA: Extensible MultiModal Annotation 
     markuplanguagesupport?

     
     I agree that minor changes made today will prevent the need for an 
     amended document in the very near future.  Providing for content 
     negotiation solves both the EMMA issue and allows for future or 
     platform-specific return formats without requiring that the 
     specification be iterated.
     
     Of the two suggestions, I prefer the SDP extension as the 
     return format 
     is analogous to other SIP media type negotiations.

     On Sep 23, 2005, at 4:55 AM, Baggia Paolo wrote:
     > the last answers and discussions in this thread seems to confirm
     > that the direction of MRCPv2 is to allow the use of EMMA when
     > it will become a W3C Recommendation. Some text should be added
     > in the future release to say that.
     > This is fine from us point of view, but a mechanism for asking
     > a different result format is not present in the current draft.
     >
     > We think to add that mechanism will allow a smooth transition
     > from the current situation: always result in 
     "application/nlsml+xml",
     > to a future one with results in EMMA.
     >
     > Would it be possible to consider this "negotiation" of the output
     > result in the next draft?
     >
     > There are different options to implement it:
     > a) to extend SDP to leave taht outside of MRCPv2 core protocol
     > E.g.
     > a=recogResultFormat:application/nlsml+xml
     > if present it sets the recognition result for a whole MRCP
     > session.
     >
     > b) to add a new recognizer header to set the result format
     >    for that specific recognition turn.
     >
     > What do you think?
     >
     > We are aware the draft is near to be closed, but we think this
     > will help the passage from NLSML to EMMA.
     >
     > Regards,
     > Paolo Baggia, Vittorio Manzone, Patrizio Bergallo (Loquendo)

     _______________________________________________
     Speechsc mailing list
     [email-masked]
     https://www1.ietf.org/mailman/listinfo/speechsc

     _______________________________________________
     Speechsc mailing list
     [email-masked]
     https://www1.ietf.org/mailman/listinfo/speechsc

_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

---

From: Brett Gavagni <[email-masked]>
Date: Wed, 28 Sep 2005 14:49:55 -0400

Sounds good to me.

Thanks,

Brett Gavagni 

"Shanmugham, Saravanan" <[email-masked]> 
09/28/2005 02:35 PM

To
Brett Gavagni/West Palm Beach/IBM@IBMUS, "Jerry Carter" 
<[email-masked]>
cc
"IETF SPEECHSC \(E-mail\)" <[email-masked]>, 
<[email-masked]>, "Baggia Paolo" <[email-masked]>
Subject
RE: [Speechsc] EMMA: Extensible MultiModalAnnotation 
markuplanguagesupport?

Sarvi 

     -----Original Message-----
     From: [email-masked] 
     [mailto:[email-masked]] On Behalf Of Brett Gavagni
     Sent: Saturday, September 24, 2005 7:51 AM
     To: Jerry Carter
     Cc: IETF SPEECHSC (E-mail); [email-masked]; Baggia Paolo
     Subject: Re: [Speechsc] EMMA: Extensible 
     MultiModalAnnotation markuplanguagesupport?
 
     Hi,

 
 
     Thanks,
 
     Brett Gavagni

 
 
     To

 

     "application/nlsml+xml",