Subject: [Speechsc] Recording size and duration: open issue

From: "Bergallo Patrizio" <[email-masked]>
Date: Tue, 15 Nov 2005 17:58:11 +0100

Hello group,

in a previous thread
(http://www1.ietf.org/mail-archive/web/speechsc/current/msg01531.html)
there was a discussion about size and duration of recorded audio.
In draft 08, size and duration values have been added to the recog-only
"waveform-uri" header (9.4.8),
but to fully support a VoiceXML 2.0 interpreter implementation, these
values should be added to the recorder "record-uri" header (10.4.7) too,
I suppose with same syntax and semantics. In fact they directly map the
size and duration record shadow variable of the VoiceXML 2.0 record
element (2.3.6 of VoiceXML 2.0 recommendation).
Furthermore, although not yet in the VoiceXML recommendation, I think
these values should be added to the verification "waveform-uri" header
(11.4.12) too.

Any thought?

Patrizio Bergallo, Loquendo.

Gruppo Telecom Italia - Direzione e coordinamento di Telecom Italia S.p.A.

================================================
CONFIDENTIALITY NOTICE
This message and its attachments are addressed solely to the persons above and may contain confidential information. If you have received the message in error, be informed that any use of the content hereof is prohibited. Please return it immediately to the sender and delete the message. Should you have any questions, please send an e_mail to <mailto:[email-masked]>[email-masked]. Thank you<http://www.loquendo.com>www.loquendo.com
================================================

_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

---

From: "Shanmugham, Saravanan" <[email-masked]>
Date: Tue, 15 Nov 2005 09:40:00 -0800

That was the intent. The definition was not meant for Recognition only.
 
I will clarify.
 
Thanks,
Sarvi

________________________________

	From: [email-masked]
[mailto:[email-masked]] On Behalf Of Bergallo Patrizio
	Sent: Tuesday, November 15, 2005 8:58 AM
	To: [email-masked]
	Subject: [Speechsc] Recording size and duration: open issue

	Hello group,
	
	in a previous thread
	
(http://www1.ietf.org/mail-archive/web/speechsc/current/msg01531.html)
	there was a discussion about size and duration of recorded
audio.
	In draft 08, size and duration values have been added to the
recog-only
	"waveform-uri" header (9.4.8),
	but to fully support a VoiceXML 2.0 interpreter implementation,
these
	values should be added to the recorder "record-uri" header
(10.4.7) too,
	I suppose with same syntax and semantics. In fact they directly
map the
	size and duration record shadow variable of the VoiceXML 2.0
record
	element (2.3.6 of VoiceXML 2.0 recommendation).
	Furthermore, although not yet in the VoiceXML recommendation, I
think
	these values should be added to the verification "waveform-uri"
header
	(11.4.12) too.
	
	Any thought?

	Gruppo Telecom Italia - Direzione e coordinamento di Telecom
Italia S.p.A.
	
	================================================
	CONFIDENTIALITY NOTICE
	This message and its attachments are addressed solely to the
persons
	above and may contain confidential information. If you have
received
	the message in error, be informed that any use of the content
hereof
	is prohibited. Please return it immediately to the sender and
delete
	the message. Should you have any questions, please send an
e_mail to
	<mailto:[email-masked]>[email-masked].
Thank you
	<http://www.loquendo.com>www.loquendo.com
	================================================