Subject: [Speechsc] Voice parameters too restrictive

From: Jerry Carter <[email-masked]>
Date: Sun, 12 Mar 2006 21:36:56 -0500

The current values for voice parameters are restricted to VCHAR.  This 
does not work for the 'name' attribute on the SSML <voice> element 
which allows a list of 'voicename' tokens having the following 
definition.

<xsd:simpleType name="voicename.datatype">
  <xsd:restriction base="xsd:token">
    <xsd:pattern value="\S+"/>
  </xsd:restriction>
</xsd:simpleType>

Instead, the 'voice-param-value' should use the UTFCHAR class proposed 
in an earlier email or the SSML voice elements should be broken out 
individually.

-=- Jerry

_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

---

From: "Shanmugham, Saravanan" <[email-masked]>
Date: Wed, 15 Mar 2006 17:18:04 -0800

This seems reasonable. 
Will add to the issue tracker.
This change will be made unless I hear specific objects on the list.

Sarvi 

     -----Original Message-----
     From: Jerry Carter [mailto:[email-masked]] 
     Sent: Sunday, March 12, 2006 6:37 PM
     To: IETF SPEECHSC (E-mail)
     Subject: [Speechsc] Voice parameters too restrictive
     
     The current values for voice parameters are restricted to 
     VCHAR.  This does not work for the 'name' attribute on the 
     SSML <voice> element which allows a list of 'voicename' 
     tokens having the following definition.

     Instead, the 'voice-param-value' should use the UTFCHAR 
     class proposed in an earlier email or the SSML voice 
     elements should be broken out individually.
     
     -=- Jerry