Subject: RE: [Speechsc] Media stream synchronization in RECOGNIZE method

From: "Shanmugham, Saravanan" <[email-masked]>
Date: Thu, 16 Mar 2006 10:10:27 -0800

I should let some of the server implementors respond to it.
 
>From the standards point of view. The server should not buffer audio
received before the RECOGNIZE command.
This is mainly because we wouldn't know how much to buffer, and if we
buffer too long we would end up using audio segments received before the
RECOGNIZE command. Which could be from a previous utterance.
 
Sarvi 

________________________________

	From: Ilya Knyazhansky [mailto:[email-masked]] 
	Sent: Wednesday, March 01, 2006 7:31 AM
	To: [email-masked]
	Subject: [Speechsc] Media stream synchronization in RECOGNIZE
method

	Hi All,
	 
	I am currently implementing the MRCP interface for an ASR
developed by our company and came across a problem of 
	synchronizing media stream (RTP packets) with the recognition
request (RECOGNIZE method) as the protocol draft states:
	 
	(Somewhere around page 100 of draft-ietf-speechsc-mrcpv2-09.txt)
	<<
	   A number of
	   mechanisms exist to resolve this condition and the mechanism
chosen
	   is left to the implementers of recognition resource.  The
recognizer
	   SHOULD expect the media to start flowing when it receives the
	   recognize request, but SHOULD NOT buffer anything it receives
	   beforehand.
	 
	I have a couple of questions regarding this statement:
	 
	1. What the proposed mechanisms - I would appreciate getting any
pointer to some sort of solution/algorithm
	2. How this can be achieved w/o buffering packets received
before recognition request
	 
	Thanks,
	Ilya Knyazhansky
	ilyak at nscspeech.com
	 
_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

---

From: David R Oran <[email-masked]>
Date: Fri, 17 Mar 2006 09:15:00 -0500

On Mar 16, 2006, at 1:10 PM, Shanmugham, Saravanan wrote:

> From the standards point of view. The server should not buffer  
> audio received before the RECOGNIZE command.
> This is mainly because we wouldn't know how much to buffer, and if  
> we buffer too long we would end up using audio segments received  
> before the RECOGNIZE command. Which could be from a previous  
> utterance.
>
If we want to solve this deterministically, we could put an NTP  
timestamp in the RECOGNIZE request to indicate the instant in the  
media stream before which input should not be considered. This would  
not require the server to buffer, but if the server does buffer it  
would need to keep track of RTP/NTP timestamp correlation and throw  
away stale buffered audio.

I'm also happy to leave sleeping dogs lie here.

Dave. (chair hat off).

> Subject: [Speechsc] Media stream synchronization in RECOGNIZE method
>
> Hi All,
>
>
>
> I am currently implementing the MRCP interface for an ASR developed  
> by our company and came across a problem of
>
>    A number of   mechanisms exist to resolve this condition and the  
> mechanism chosen   is left to the implementers of recognition  
> resource.  The recognizer   SHOULD expect the media to start  
> flowing when it receives the   recognize request, but SHOULD NOT  
> buffer anything it receives   beforehand.
> >>
>
>
>
> 1. What the proposed mechanisms – I would appreciate getting any  
> 2. How this can be achieved w/o buffering packets received before  
> recognition request
>
>
>
> Thanks,
>
> Ilya Knyazhansky
>
> ilyak at nscspeech.com
>
>
>

---

From: Brett Gavagni <[email-masked]>
Date: Thu, 16 Mar 2006 14:13:32 -0500

I agree with Sarvi.

I think that draft 9 covers spells out the required support in section: 
9.9.  RECOGNIZE
   "The recognizer SHOULD expect the media to start flowing when it 
receives the
   recognize request, but SHOULD NOT buffer anything it receives
   beforehand."

The only exception would be for DTMF as described in section: 9.4.32. 
DTMF-Buffer-Time

Thanks,

Brett Gavagni 
WebSphere Voice Server Development 
http://www-306.ibm.com/software/pervasive/voice_server/
[email-masked]

"Shanmugham, Saravanan" <[email-masked]> 
03/16/2006 01:10 PM

To
<[email-masked]>, <[email-masked]>
cc

Subject
RE: [Speechsc] Media stream synchronization in RECOGNIZE method

 
Sarvi 

Hi All,
 
I am currently implementing the MRCP interface for an ASR developed by our 
company and came across a problem of 
synchronizing media stream (RTP packets) with the recognition request 
(RECOGNIZE method) as the protocol draft states:
 
(Somewhere around page 100 of draft-ietf-speechsc-mrcpv2-09.txt)
<<
   A number of
   mechanisms exist to resolve this condition and the mechanism chosen
   is left to the implementers of recognition resource.  The recognizer
   SHOULD expect the media to start flowing when it receives the
   recognize request, but SHOULD NOT buffer anything it receives
   beforehand.

1. What the proposed mechanisms ? I would appreciate getting any pointer 
to some sort of solution/algorithm
2. How this can be achieved w/o buffering packets received before 
recognition request
 
Thanks,
Ilya Knyazhansky
ilyak at nscspeech.com