Subject: [Speechsc] I18N violations (e.g. Vendor-Specific-Parameters)

From: Jerry Carter <[email-masked]>
Date: Sun, 12 Mar 2006 21:31:30 -0500

The 'Vendor-Specific-Parameters' improperly restrict values to ASCII 
characters (VCHAR).  This prevents vendors from localizing parameter 
names using local characters.  A new character class should be defined 
for use by 'vendor-av-pair-name'.

UTFCHAR            =    %x21-7E   /   UTF8-NONASCII
vendor-av-pair-name     = 1* UTFCHAR

In addition, the following parameters should probably use UTFCHAR:
* Logging-Tag
* Speech-Marker
* Completion-Cause
* Jump-Size
* Interpret-Text
* Phrase-NL

There are likely others.  A full review should be in order.

-=- Jerry

_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

---

From: "Shanmugham, Saravanan" <[email-masked]>
Date: Wed, 15 Mar 2006 17:16:10 -0800

I can see that the value for these headers could be UTFCHAR.
I don't see why the vendor-pair-name needs to be, but I don't have
specific objection to it either. I would like to see if anyone has an
objection to this.

I will add this to the issue tracker list to do the following
   1. modify the value to be UTFCHAR.
   2. We will wait to get some feed back on the vendor-pair-name portion
to be changed to UTFCHAR.

Thx,
Sarvi

     -----Original Message-----
     From: Jerry Carter [mailto:[email-masked]] 
     Sent: Sunday, March 12, 2006 6:32 PM
     To: IETF SPEECHSC (E-mail)
     Subject: [Speechsc] I18N violations (e.g. 
     Vendor-Specific-Parameters)
     
     The 'Vendor-Specific-Parameters' improperly restrict 
     values to ASCII characters (VCHAR).  This prevents vendors 
     from localizing parameter names using local characters.  A 
     new character class should be defined for use by 
     'vendor-av-pair-name'.

     
     
     -=- Jerry

---

From: "Carter, Jerry" <[email-masked]>
Date: Thu, 16 Mar 2006 15:51:38 -0500

What is the harm to allowing UTF-8 characters in vendor pair names?  There
are clear benefits and little cost to supporting them.

Imagine a case where a local vendor in China wants to implement an MRCP
server.  Presumably, the implementer would prefer to use names not limited
by ASCII characters.  That is impossible in the current spec.

Consider a case where a vendor wants to reference named components.  Headers
like

    Vendor-Specific-Parameters: TTS-José-model-bitrate=8000 

are currently not allowed.

> From: Shanmugham, Saravanan [mailto:[email-masked]]
> Sent: Wednesday, March 15, 2006 8:16 PM
> To: Jerry Carter; IETF SPEECHSC (E-mail)
> Subject: RE: [Speechsc] I18N violations (e.g. Vendor-Specific-Parameters)
>