Subject: [speechsc] Fix status code response in 8.4.1 / 8.4.16

From: "Dave Burke" <[email-masked]>
Date: Mon, 8 May 2006 12:02:18 +0100

If a unit for Jump-Size is not supported, I think the response should use status code 409 Unsupported header value and not 404 as is described in 8.4.1. Similarly for Speak-Length in 8.4.16

Dave

_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

---

From: "Carter, Jerry" <[email-masked]>
Date: Mon, 8 May 2006 10:35:05 -0400

The table in 5.4 defines separate returns for illegal and unsupported header
values.  The text in 8.4.x and 6.1.1 is inconsistent with the description
for these status codes.  Adjusting the text for consistency would be nice.

6.1.1: Should instead mention both 404 and 409?
8.4.1: I agree that 409 is more appropriate.
8.4.16: I agree that 409 is more appropriate.
10.6: Fine as is.

-=- Jerry

5.4

    404 : Illegal Value for Header
    409 : Unsupported Header Value

6.1.1

   "404 Bad Parameter"

8.4.1

    404 "Illegal or Unsupported value for parameter"

8.4.16

    404 "Illegal or Unsupported value for header"

10.6

   If the recording-uri is not valid, a status code of 404, "Illegal
   Value for Header", is returned in the response.  If it is impossible
   for the server to create the requested stored content, a status code
   of 407, "Method or Operation Failed", is returned.

Dave Burke wrote:
> If a unit for Jump-Size is not supported, I think the response
> should use status code 409 Unsupported header value and not 
> 404 as is described in 8.4.1. Similarly for Speak-Length in 8.4.16
> 
> Dave

---

From: "Carter, Jerry" <[email-masked]>
Date: Thu, 11 May 2006 09:31:18 -0400

The 404 message is a general purpose, syntax error sort of message.  Saying

            Max-time: abcd

should clearly be a 404.  Whereas values that exceed platform capabilities
or expectations such as

            Max-time: 20000000000000000

might well generate a 409.

Another case is dtmf-term-char.  If the server encounters a
'dtmf-term-char:@', a 404 would not be valid since the value is legal within
the ABNF

   dtmf-term-char           =  "DTMF-Term-Char" ":" VCHAR CRLF

and so a 409 would be appropriate.  On the other hand, 'dtmf-term-char:12'
would be a 404.

  _____  

From: Shanmugham, Saravanan [mailto:[email-masked]] 
Sent: Wednesday, May 10, 2006 2:37 PM
To: Dave Burke; [email-masked]
Subject: RE: [speechsc] Fix status code response in 8.4.1 / 8.4.16

Does anybodyelse see a distinction between illegal(404) and unsupported(409)
header values?

If so, can you point in what scenarios u see them being used. 

Else I suggest eliminating 409 and clarifying 404 for both illegal and
unsupported values. 

My concern is if we have 404 and 409 we need to clarify in the document
where each one is used. If we do then I am fine with the proposal below.

Sarvi

  _____  

From: Dave Burke [mailto:[email-masked]] 
Sent: Monday, May 08, 2006 4:02 AM
To: [email-masked]
Subject: [speechsc] Fix status code response in 8.4.1 / 8.4.16

If a unit for Jump-Size is not supported, I think the response should use
status code 409 Unsupported header value and not 404 as is described in
8.4.1. Similarly for Speak-Length in 8.4.16

Dave

---

From: "Shanmugham, Saravanan" <[email-masked]>
Date: Thu, 11 May 2006 07:17:02 -0700

Your first example would be an ABNF parse error, right? so its more than
an illegal parameter.
In your second example 12 would again be an ABNF violation of VCHAR.
 
Shouldn't all ABNF violations treated together as an error?
 
Sarvi

________________________________

	From: Carter, Jerry [mailto:[email-masked]] 
	Sent: Thursday, May 11, 2006 6:31 AM
	To: Shanmugham, Saravanan; Dave Burke; [email-masked]
	Subject: RE: [speechsc] Fix status code response in 8.4.1 /
8.4.16

	The 404 message is a general purpose, syntax error sort of
message.  Saying

	            Max-time: abcd

	should clearly be a 404.  Whereas values that exceed platform
capabilities or expectations such as

	 

	Another case is dtmf-term-char.  If the server encounters a
'dtmf-term-char:@', a 404 would not be valid since the value is legal
within the ABNF

	and so a 409 would be appropriate.  On the other hand,
'dtmf-term-char:12' would be a 404.

	
________________________________

	From: Shanmugham, Saravanan [mailto:[email-masked]] 
	Sent: Wednesday, May 10, 2006 2:37 PM
	To: Dave Burke; [email-masked]
	Subject: RE: [speechsc] Fix status code response in 8.4.1 /
8.4.16

	Does anybodyelse see a distinction between illegal(404) and
unsupported(409) header values?

	Else I suggest eliminating 409 and clarifying 404 for both
illegal and unsupported values. 

	My concern is if we have 404 and 409 we need to clarify in the
document where each one is used. If we do then I am fine with the
proposal below.

	Sarvi

________________________________

		From: Dave Burke [mailto:[email-masked]] 
		Sent: Monday, May 08, 2006 4:02 AM
		To: [email-masked]
		Subject: [speechsc] Fix status code response in 8.4.1 /
8.4.16

		If a unit for Jump-Size is not supported, I think the
response should use status code 409 Unsupported header value and not 404
as is described in 8.4.1. Similarly for Speak-Length in 8.4.16

		Dave

---

From: "Carter, Jerry" <[email-masked]>
Date: Thu, 11 May 2006 11:41:28 -0400

Certainly, but how should the server respond?

I assume that 403 indicates that the parameter name is not legal and 404
that the parameter value is not legal.  As such, 'Tempus-Maximus:12' would
be a 403 and 'Max-Time:abcd' would be a 404.

  _____  

From: Shanmugham, Saravanan [mailto:[email-masked]] 
Sent: Thursday, May 11, 2006 10:17 AM
To: Carter, Jerry; Dave Burke; [email-masked]
Subject: RE: [speechsc] Fix status code response in 8.4.1 / 8.4.16

Your first example would be an ABNF parse error, right? so its more than an
illegal parameter.

Sarvi

  _____  

            Max-time: abcd

 

 

  _____  

Sarvi

  _____  

Dave