Subject: RE: [speechsc] Fix status code response in 8.4.1 / 8.4.16

From: "Shanmugham, Saravanan" <[email-masked]>
Date: Wed, 10 May 2006 11:36:41 -0700

Does anybodyelse see a distinction between illegal(404) and
unsupported(409) header values?
 
If so, can you point in what scenarios u see them being used. 
 
Else I suggest eliminating 409 and clarifying 404 for both illegal and
unsupported values. 
 
My concern is if we have 404 and 409 we need to clarify in the document
where each one is used. If we do then I am fine with the proposal below.
 
Sarvi

________________________________

	From: Dave Burke [mailto:[email-masked]] 
	Sent: Monday, May 08, 2006 4:02 AM
	To: [email-masked]
	Subject: [speechsc] Fix status code response in 8.4.1 / 8.4.16

	If a unit for Jump-Size is not supported, I think the response
should use status code 409 Unsupported header value and not 404 as is
described in 8.4.1. Similarly for Speak-Length in 8.4.16
	 
	Dave

_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

---

From: "Dave Burke" <[email-masked]>
Date: Thu, 11 May 2006 10:32:05 +0100

Am fine with this suggestion.

Dave
  ----- Original Message ----- 
  From: Shanmugham, Saravanan 
  To: Dave Burke ; [email-masked] 
  Sent: Wednesday, May 10, 2006 7:36 PM
  Subject: RE: [speechsc] Fix status code response in 8.4.1 / 8.4.16

  Does anybodyelse see a distinction between illegal(404) and unsupported(409) header values?

  Else I suggest eliminating 409 and clarifying 404 for both illegal and unsupported values. 

  My concern is if we have 404 and 409 we need to clarify in the document where each one is used. If we do then I am fine with the proposal below.

  Sarvi

----------------------------------------------------------------------------
    From: Dave Burke [mailto:[email-masked]] 
    Sent: Monday, May 08, 2006 4:02 AM
    To: [email-masked]
    Subject: [speechsc] Fix status code response in 8.4.1 / 8.4.16

    If a unit for Jump-Size is not supported, I think the response should use status code 409 Unsupported header value and not 404 as is described in 8.4.1. Similarly for Speak-Length in 8.4.16

    Dave