Subject: RE: [Speechsc] Minor error in synthesizer state diagram

From: "Shanmugham, Saravanan" <[email-masked]>
Date: Mon, 1 May 2006 12:05:48 -0700

I had a slightly different intepration of what the state machine should
reflect.

The state-machine in mind reflects the state of the recognizer based on
the methods that have moved to IN-PROGRESS or COMPLETE states. 

PENDING requests essentially have not affected the resource yet, they
are in queue to be processed and hence is not reflected in the
state-machine.

Sarvi

     -----Original Message-----
     From: Dave Burke [mailto:[email-masked]] 
     Sent: Monday, May 01, 2006 10:23 AM
     To: Carter, Jerry; [email-masked]
     Subject: Re: [Speechsc] Minor error in synthesizer state diagram
     
     Agreed. Also, while on the subject, I think we should 
     remove the Stop auto-transition in Idle State if the 
     diagram is intended to show useful transitions.  
     Otherwise, we need to leave that one as is but add the 
     Control auto-transition in Idle State, the 
     BARGE-IN-OCCURRED auto-transition in Idle State, the Pause 
     auto-transition in Paused State, and the Resume 
     auto-transition in Speaking State, etc. That would just 
     result in a lot of clutter.
     
     Dave
     
     ----- Original Message -----
     From: "Carter, Jerry" <[email-masked]>
     To: <[email-masked]>
     Sent: Monday, May 01, 2006 3:19 PM
     Subject: [Speechsc] Minor error in synthesizer state diagram

     > On the state machine diagram in 8.1, SPEAK from the 
     'Speaking' state 
     > should
     > map back to 'Speaking'.  This is legal according to 8.6.
     >
     > _______________________________________________
     > Speechsc mailing list
     > [email-masked]
     > https://www1.ietf.org/mailman/listinfo/speechsc
     > 

     _______________________________________________
     Speechsc mailing list
     [email-masked]
     https://www1.ietf.org/mailman/listinfo/speechsc

_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

---

From: "Dave Burke" <[email-masked]>
Date: Mon, 1 May 2006 22:22:03 +0100

So in that case (I'm OK with that interpretation too), we need to:
- delete the SPEAK auto-transition in the Paused State
- add the RESUME auto-transition in the Speaking State
- add the BARGE-IN-OCCURRED auto-transition in the Idle State

Dave

----- Original Message ----- 
From: "Shanmugham, Saravanan" <[email-masked]>
To: "Dave Burke" <[email-masked]>; "Carter, Jerry" 
<[email-masked]>; <[email-masked]>
Sent: Monday, May 01, 2006 8:05 PM
Subject: RE: [Speechsc] Minor error in synthesizer state diagram

Sarvi

     -----Original Message-----
     From: Dave Burke [mailto:[email-masked]]
     Sent: Monday, May 01, 2006 10:23 AM
     To: Carter, Jerry; [email-masked]
     Subject: Re: [Speechsc] Minor error in synthesizer state diagram

     Dave

     ----- Original Message -----
     From: "Carter, Jerry" <[email-masked]>
     To: <[email-masked]>
     Sent: Monday, May 01, 2006 3:19 PM
     Subject: [Speechsc] Minor error in synthesizer state diagram

     'Speaking' state

---

From: Jerry Carter <[email-masked]>
Date: Mon, 1 May 2006 17:59:33 -0400

And maybe add a small note early in the specification explaining what 
the state machines diagrams represent.

On May 1, 2006, at 5:22 PM, Dave Burke wrote:

> ----- Original Message ----- From: "Shanmugham, Saravanan" 
> <[email-masked]>