Subject: RE: [speechsc] Speech-Marker issues x 2

From: "Shanmugham, Saravanan" <[email-masked]>
Date: Wed, 10 May 2006 11:17:03 -0700

On Issue 1 about format of the ABNF not allowing null and unicodes. I am
fine with Jerry's proposal. If there are no other objects to that
proposal, that change can be accomodated in the specification.
 
On Issue 2, the marker header in a STOP or CONTROL response and
SPEAK-COMPLETE events allow the client to know exactly where in the
speak request the STOP/CONTROL method was received and enforced or in
the case of SPEAK-COMPLETE timestamp where it finished the SPEAK
request.. Both in terms of time(timestamp) as well the last marker that
was hit(which may be redundant assuming an associated SPEECH-MARCKER
event was received by the client).

Thx,
Sarvi

     -----Original Message-----
     From: Dave Burke [mailto:[email-masked]] 
     Sent: Saturday, May 06, 2006 4:31 AM
     To: [email-masked]
     Subject: [speechsc] Speech-Marker issues x 2
     
     Issue 1:
     
     A SPEECH-MARKER event is generated when a PENDING SPEAK 
     request becomes IN-PROGRESS. In this case, the 
     corresponding Speech-Marker header field has a "null 
     string" and a timestamp. What does that look like? -
     
         Speech-Marker: ;timestamp=123456
     
     or
     
         Speech-Marker: null;timestamp=123456
     
     The ABNF will not allow the former. However, the latter is 
     dangerous for obvious reasons  (<mark name="null"/>). So, 
     perhaps go with the former and change 1*VCHAR to *VCHAR in 
     the speech-marker expansion.
     
     Issue 2:
     
     Why should Speech-Marker be returned in CONTROL / STOP 
     responses and SPEAK-COMPLETE events? Seems redundant to me 
     and I don't see any race-condition (e.g. if on receipt of 
     a STOP the resource still has a mark to send then send 
     SPEECH-MARKER before the response to STOP etc). Besides, 
     none of the examples are showing this today.
     
     Dave

     _______________________________________________
     Speechsc mailing list
     [email-masked]
     https://www1.ietf.org/mailman/listinfo/speechsc

_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

---

From: "Dave Burke" <[email-masked]>
Date: Thu, 11 May 2006 10:28:23 +0100

Comments inline.

Thanks, Dave

----- Original Message ----- 
From: "Shanmugham, Saravanan" <[email-masked]>
To: "Dave Burke" <[email-masked]>; <[email-masked]>
Sent: Wednesday, May 10, 2006 7:17 PM
Subject: RE: [speechsc] Speech-Marker issues x 2

--------
DB:

Thanks for the clarification. Few issues with this:

1. The text in 8.4.8 could be improved to explain that the Speech-Marker 
header is used *both* for carrying bookmarks encountered in the markup and 
for carrying timestamp information associated with important events within 
the lifecycle of a request (start of SPEAK processing, end of SPEAK 
processing, receipt of CONTROL/STOP/BARGE-IN-OCCURRED) - certainly would 
make the overloaded intent of the header field clearer.

2. We also need Speech-Marker on BARGE-IN-OCCURRED response.

3. Having Speech-Marker in SPEAK-COMPLETE is a little non-symmetrical 
because we don't always know the timestamp when the SPEAK started. 
Interestingly, we do if the SPEAK request state goes from PENDING to 
IN-PROGRESS but not if it goes to IN-PROGRESS directly. This would mean we 
add Speech-Marker to a IN-PROGRESS SPEAK response also.
.
4. None of the examples show the Speech-Marker for 
CONTROL/STOP/BARGE-IN-OCCURRED responses or SPEAK-COMPLETE events.

5. Using NTP timestamps assumes one has already received an RTCP SR to be 
able to do the correlation. However, given the current minimum of 5 seconds 
inter-packet interval for RTCP, there's no guarantee one will have been 
received a SR for a first, short prompt. I would have gone for the RTP 
timestamp instead - MRCP just needs to provide information to do correlation 
between the control channel and media stream - the client can worry about 
whether it wants that time absolute... (that said, I can live with NTP).

--------

Thx,
Sarvi

     -----Original Message-----
     From: Dave Burke [mailto:[email-masked]]
     Sent: Saturday, May 06, 2006 4:31 AM
     To: [email-masked]
     Subject: [speechsc] Speech-Marker issues x 2

     Issue 1:

     or

     Issue 2:

     Dave