Subject: RE: [speechsc] Content-Length: 0

From: "Shanmugham, Saravanan" <[email-masked]>
Date: Sat, 13 May 2006 17:54:26 -0700

We do have alength field in the header of every message. 
 
Doesn't that alleviate this concern.
 
Sarvi

________________________________

	From: Dave Burke [mailto:[email-masked]] 
	Sent: Saturday, May 13, 2006 5:27 AM
	To: Dave Burke; [email-masked]
	Subject: Re: [speechsc] Content-Length: 0

	Ahem - we have CRLF so down-grade this to minor ;-) However,
note that SIP mandates Content-Length for stream protocols so MRCP is
somewhere in between HTTP and SIP as far as its Content-Length
requirements are...
	 
	Dave

		----- Original Message ----- 
		From: Dave Burke <mailto:[email-masked]>  
		To: [email-masked] 
		Sent: Saturday, May 13, 2006 1:22 PM
		Subject: [speechsc] Content-Length: 0

		For all the discussions about protocol parsing
efficiency, I think we could be missing something more serious.
Currently, for Content-Length, we say
		 
		   ...it MUST be included in all messages that carry
content beyond
		   the header portion of the message...
		 
		MRCP runs over stream-oriented protocols so how do you
delimit the end of the message if their is no body? Right now, it would
appear you need to wait for the next one to appear! The obvious fix is
to change the spec so that Content-Length must appear on all messages,
i.e. including those without a message body. Thus Content-Length: 0
delimits the end of a message.
		 
		Dave

_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

---

From: "Dave Burke" <[email-masked]>
Date: Sun, 14 May 2006 13:16:06 +0100

The mechanism works fine as is so no need to change it. (I was a little trigger happy with my send button, sorry!). 

Dave

  ----- Original Message ----- 
  From: Shanmugham, Saravanan 
  To: Dave Burke ; [email-masked] 
  Sent: Sunday, May 14, 2006 1:54 AM
  Subject: RE: [speechsc] Content-Length: 0

  Sarvi

----------------------------------------------------------------------------

    Ahem - we have CRLF so down-grade this to minor ;-) However, note that SIP mandates Content-Length for stream protocols so MRCP is somewhere in between HTTP and SIP as far as its Content-Length requirements are...

    Dave
      ----- Original Message ----- 
      From: Dave Burke 
      To: [email-masked] 
      Sent: Saturday, May 13, 2006 1:22 PM
      Subject: [speechsc] Content-Length: 0

      For all the discussions about protocol parsing efficiency, I think we could be missing something more serious. Currently, for Content-Length, we say

         ...it MUST be included in all messages that carry content beyond
         the header portion of the message...

      MRCP runs over stream-oriented protocols so how do you delimit the end of the message if their is no body? Right now, it would appear you need to wait for the next one to appear! The obvious fix is to change the spec so that Content-Length must appear on all messages, i.e. including those without a message body. Thus Content-Length: 0 delimits the end of a message.

      Dave

------------------------------------------------------------------------------