Subject: [speechsc] uri-list not defined for Lexicon-Search-Order

From: "Dave Burke" <[email-masked]>
Date: Mon, 8 May 2006 12:02:26 +0100

ABNF says we've got uri-list as the value of Lexicon-Search-Order but this 
is not defined (sure we've got a MIME type text/uri-list but that's a 
different thing).

Not sure that a comma delimited list makes sense here since a comma is a 
reserved character for URIs (RFC2396)... unless the URIs are enclosed in 
angle brackets...

Dave 

_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

---

From: "Shanmugham, Saravanan" <[email-masked]>
Date: Thu, 11 May 2006 06:41:54 -0700

I like the angle brackets idea considering it is a standard used in a
lot of places to mark URI and  or a list of URI.

Thx,
Sarvi 

     -----Original Message-----
     From: Dave Burke [mailto:[email-masked]] 
     Sent: Thursday, May 11, 2006 2:32 AM
     To: Shanmugham, Saravanan; [email-masked]
     Subject: Re: [speechsc] uri-list not defined for 
     Lexicon-Search-Order
     
     Problem with the ";" delimiter is that it could (and 
     actually very likely) will be part of the URI. For example,
     
     http://example.com/file1.xml;jsessionid=1
     http://example.com/file2.xml;jsessionid=2
     
     would result in
     
     Lexicon-Search-Order: 
     http://example.com/file1.xml;jsessionid=1;http://example.co
     m/file2.xml;jsessionid=2
     
     thus causing parsing problems. Was thinking we could do 
     something like (i.e. 
     using angle brackets around the URIs):
     
        lexicon-search-order  =    "Lexicon-Search-Order" ":"
                                   "<" absoluteURI ">" *[";<" 
     absoluteURI ">" ] CRLF Dave

     ----- Original Message ----- 
     From: "Shanmugham, Saravanan" <[email-masked]>
     To: "Dave Burke" <[email-masked]>; <[email-masked]>
     Sent: Wednesday, May 10, 2006 7:26 PM
     Subject: RE: [speechsc] uri-list not defined for 
     Lexicon-Search-Order

     The ABNF specified under the header definition is not upto-date and
     needs to be fixed.
     The normative ABNF in section 15 is defined as follows.
     
        lexicon-search-order  =    "Lexicon-Search-Order" ":"
                                   absoluteURI *[";" absoluteURI] CRLF
     
     Lets have the header section corrected to reflect this definition.
     
     Sarvi
     
          -----Original Message-----
          From: Dave Burke [mailto:[email-masked]]
          Sent: Monday, May 08, 2006 4:02 AM
          To: [email-masked]
          Subject: [speechsc] uri-list not defined for 
     Lexicon-Search-Order
     
          ABNF says we've got uri-list as the value of
          Lexicon-Search-Order but this is not defined (sure we've
          got a MIME type text/uri-list but that's a different thing).
     
          Not sure that a comma delimited list makes sense here
          since a comma is a reserved character for URIs
          (RFC2396)... unless the URIs are enclosed in angle brackets...
     
          Dave

---

From: "Carter, Jerry" <[email-masked]>
Date: Thu, 11 May 2006 10:02:56 -0400

Where?

The 'uri-list' in HTML 4.01 is space separated. [1]
Eric Berger's lemonade specification used a space separated list. [2]

[1] http://www.w3.org/TR/html4/struct/objects.html
[2]
http://www3.ietf.org/proceedings/03jul/I-D/draft-ietf-lemonade-imap-channel-
00.txt

> From: Shanmugham, Saravanan [mailto:[email-masked]]
> Sent: Thursday, May 11, 2006 9:42 AM
> To: Dave Burke; [email-masked]
> Subject: RE: [speechsc] uri-list not defined for Lexicon-Search-Order
>

---

From: "Shanmugham, Saravanan" <[email-masked]>
Date: Thu, 11 May 2006 07:27:48 -0700

You look at most headers where they use a URI such as in SIP and even in
our MRCP examples URI are encapsulated in a "<" and ">" pair. That's
what I am refering to. 

Examples: WaveForm-URI
          URI-list mimetype definition etc.

Sarvi
     -----Original Message-----
     From: Carter, Jerry [mailto:[email-masked]] 
     Sent: Thursday, May 11, 2006 7:03 AM
     To: Shanmugham, Saravanan; Dave Burke; [email-masked]
     Subject: RE: [speechsc] uri-list not defined for 
     Lexicon-Search-Order
     
     Where?
     
     The 'uri-list' in HTML 4.01 is space separated. [1] Eric 
     Berger's lemonade specification used a space separated list. [2]
     
     [1] http://www.w3.org/TR/html4/struct/objects.html
     [2]
     http://www3.ietf.org/proceedings/03jul/I-D/draft-ietf-lemon
     ade-imap-channel-
     00.txt

     Lexicon-Search-Order

---

From: "Burger, Eric" <[email-masked]>
Date: Tue, 16 May 2006 12:33:01 -0400

Imap-channel is long dead and forgotten.  Even if it is by Dr. Burger,
it's wrong ;)

--
Dr. Eric Burger, Ph.D.
[Really!]

-----Original Message-----
From: Carter, Jerry [mailto:[email-masked]] 
Sent: Thursday, May 11, 2006 10:03 AM
To: Shanmugham, Saravanan; Dave Burke; [email-masked]
Subject: RE: [speechsc] uri-list not defined for Lexicon-Search-Order

Where?

[1] http://www.w3.org/TR/html4/struct/objects.html
[2]
http://www3.ietf.org/proceedings/03jul/I-D/draft-ietf-lemonade-imap-chan
nel-
00.txt