Subject: RE: [speechsc] uri-list not defined for Lexicon-Search-Order

From: "Shanmugham, Saravanan" <[email-masked]>
Date: Wed, 10 May 2006 11:26:14 -0700

The ABNF specified under the header definition is not upto-date and
needs to be fixed.
The normative ABNF in section 15 is defined as follows.

   lexicon-search-order  =    "Lexicon-Search-Order" ":"
                              absoluteURI *[";" absoluteURI] CRLF

Lets have the header section corrected to reflect this definition.

Sarvi 

     -----Original Message-----
     From: Dave Burke [mailto:[email-masked]] 
     Sent: Monday, May 08, 2006 4:02 AM
     To: [email-masked]
     Subject: [speechsc] uri-list not defined for Lexicon-Search-Order
     
     ABNF says we've got uri-list as the value of 
     Lexicon-Search-Order but this is not defined (sure we've 
     got a MIME type text/uri-list but that's a different thing).
     
     Not sure that a comma delimited list makes sense here 
     since a comma is a reserved character for URIs 
     (RFC2396)... unless the URIs are enclosed in angle brackets...
     
     Dave 

     _______________________________________________
     Speechsc mailing list
     [email-masked]
     https://www1.ietf.org/mailman/listinfo/speechsc

_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

---

From: "Dave Burke" <[email-masked]>
Date: Thu, 11 May 2006 10:31:31 +0100

Problem with the ";" delimiter is that it could (and actually very likely) 
will be part of the URI. For example,

http://example.com/file1.xml;jsessionid=1
http://example.com/file2.xml;jsessionid=2

would result in

Lexicon-Search-Order: 
http://example.com/file1.xml;jsessionid=1;http://example.com/file2.xml;jsessionid=2

thus causing parsing problems. Was thinking we could do something like (i.e. 
using angle brackets around the URIs):

   lexicon-search-order  =    "Lexicon-Search-Order" ":"
                              "<" absoluteURI ">" *[";<" absoluteURI ">" ] 
CRLF
Dave

----- Original Message ----- 
From: "Shanmugham, Saravanan" <[email-masked]>
To: "Dave Burke" <[email-masked]>; <[email-masked]>
Sent: Wednesday, May 10, 2006 7:26 PM
Subject: RE: [speechsc] uri-list not defined for Lexicon-Search-Order

Sarvi

     -----Original Message-----
     From: Dave Burke [mailto:[email-masked]]
     Sent: Monday, May 08, 2006 4:02 AM
     To: [email-masked]
     Subject: [speechsc] uri-list not defined for Lexicon-Search-Order

     Dave

---

From: Jerry Carter <[email-masked]>
Date: Thu, 11 May 2006 06:08:29 -0400

Space (0x20) is probably the best delimiter for the uri list.

On May 11, 2006, at 5:31 AM, Dave Burke wrote:

> Problem with the ";" delimiter is that it could (and actually very  
> likely) will be part of the URI. For example,
>
> thus causing parsing problems. Was thinking we could do something like  
> (i.e. using angle brackets around the URIs):
>
>                              "<" absoluteURI ">" *[";<" absoluteURI  
> ">" ] CRLF
> Dave
>
>
> ----- Original Message ----- From: "Shanmugham, Saravanan"  
> <[email-masked]>

---

From: "Dave Burke" <[email-masked]>
Date: Thu, 11 May 2006 11:20:20 +0100

That's true! So it's:

lexicon-search-order  =    "Lexicon-Search-Order" ":"
                                       absoluteURI  *[" " absoluteURI ] CRLF

Dave