Subject: RE: [speechsc] Speech-Marker issues x 2

From: "Carter, Jerry" <[email-masked]>
Date: Mon, 8 May 2006 11:24:10 -0400

I agree with your second issue, but the first is incomplete.  Today, the
ABNF for SPEECH-MARKER does not allow MRCP servers to fully support SSML.

As I've noted previously [1], the ABNF does not allow characters outside a
subset of Latin-1.  The <mark> tag in SSML in contrast supports nearly
arbitrary Unicode character sequences in the 'name' attribute [2].
Specifically, the 'name' attribute has type 'xsd:token' which is essentially
any sequence of 

	[#x20-#xD7FF] | [#xE000-#xFFFD] | [#x10000-#x10FFFF]

excluding without leading or trailing spaces (#x20) and with internal space
characters collapsed.  As such, xsd:token is not a token in the traditional
sense [3].

Hence, your first example

	Speech-Marker: ;timestamp=123456

could correspond to an

	<mark name=";timestamp=123456"/>

element embedded within the SSML.

The ABNF should probably be changed to the more verbose but more flexible

   speech-marker = "Speech-Marker" ":" 
                   "timestamp" "=" [time-stamp-value] ";"
                   [1*UTFCHAR] CRLF

using the UTFCHAR definition from [1].

[1] http://www1.ietf.org/mail-archive/web/speechsc/current/msg01666.html
[2] http://www.w3.org/TR/2004/REC-speech-synthesis-20040907/#edef_mark 
[3] http://books.xmlschemata.org/relaxng/ch19-77319.html 

> -----Original Message-----
> From: Dave Burke [mailto:[email-masked]]
> Sent: Saturday, May 06, 2006 7:31 AM
> To: [email-masked]
> Subject: [speechsc] Speech-Marker issues x 2
> 
> Issue 1:
> 
> A SPEECH-MARKER event is generated when a PENDING SPEAK request becomes
> IN-PROGRESS. In this case, the corresponding Speech-Marker header field
> has
> a "null string" and a timestamp. What does that look like? -
> 
>     Speech-Marker: ;timestamp=123456
> 
> or
> 
>     Speech-Marker: null;timestamp=123456
> 
> The ABNF will not allow the former. However, the latter is
> dangerous for obvious reasons  (<mark name="null"/>). So, perhaps
> go with the former and change 1*VCHAR to *VCHAR in the
> speech-marker expansion.
> 
> Issue 2:
> 
> Why should Speech-Marker be returned in CONTROL / STOP responses and
> SPEAK-COMPLETE events? Seems redundant to me and I don't see any
> race-condition (e.g. if on receipt of a STOP the resource still has a mark
> to send then send SPEECH-MARKER before the response to STOP etc). Besides,
> none of the examples are showing this today.
> 
> Dave
> 
> 
> _______________________________________________
> Speechsc mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/speechsc

_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

---

From: "Dave Burke" <[email-masked]>
Date: Mon, 8 May 2006 17:25:25 +0100

Works for me.

Dave