Subject: RE: [Speermint] RE: [Enum] RE: [voipeer] I-D: Publishing SIP PeeringPolicy

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Thu, 12 Jan 2006 11:36:09 -0500

It would provide a better user experience if the L3 and L5 peering could
be only loosely coupled so that the media and signaling paths are not so
tightly bound and the media path takes the shortest geographically,
least number of L3 networks path.

Mike

> -----Original Message-----
> From: Stastny Richard [mailto:[email-masked]] 
> Sent: Thursday, January 12, 2006 3:56 AM
> To: Pfautz, Penn L, NEO; Tom-PT Taylor; Michael Hammer (mhammer)
> Cc: [email-masked]
> Subject: RE: [Speermint] RE: [Enum] RE: [voipeer] I-D: 
> Publishing SIP PeeringPolicy
> 
> Penn wrote:
> > If I think IMS, as best I understand it, the P-CSCF in the visited 
> > network gets and stays involved in SIP signaling.
> 
> As long as only L5 signalling/peering is involved, I have no 
> problem with This. This would be equivalent to the enterprise 
> example by Tom
> 
> The real goal of IMS is also to introduce L3 peering in the same way:
> the
> media stream is also tromboned from the originating visited 
> network to the visited destination network via the two home networks.
> 
> This would keep the existing vertical silo philosophy intact 
> also on IP-based networks. The arguments brought forward are 
> QoS, LI, etc., the real answer is money (the roaming rip-off)
> 
> Today, if your home network is in Austria and you are roaming 
> in Germany (or the US) and call somebody also from Austria 
> standing beside you, the Call is routed via the two home 
> networks, so both parties pay an international call each 
> including additional roaming charges. 
> 
> Technically a local call would do, and this could easily be 
> implemented since more then 10 years, but the work was 
> stopped by the MOs (I was involved in tromboning prevention 
> in the early 90ties)
> 
> Same if you access the Internet via GPRS/UMTS while roaming: 
> the connection to the Internet is not done by the visiting 
> network, it is tunnelled though the visited network to the 
> home network and delivered there (as one can easily see from 
> the IP address (just to charge you 10 Euro per MB data)
> 
> This is what they call the New Internet
> 
> Remark: Roaming is not such an issue for the US, but in 
> Europe you are always roaming. The equivalent in the US would 
> be roaming by state:
> The providers have state licences and if your home provider 
> is in New York, you would have to pay roaming charges if you 
> are in New Jersey.
> 
> > I haven't quite thought out what that means to VoIP peering.
> Presumably
> > the peering relationship is still between the home networks of 
> > originator and terminator.
> 
> Yes, L5 AND L3
> 
> Richard
> 
> > -----Original Message-----
> > From: Pfautz, Penn L, NEO [mailto:[email-masked]]
> > Sent: Wednesday, January 11, 2006 10:23 PM
> > To: Stastny Richard; Tom-PT Taylor; Michael Hammer (mhammer)
> > Cc: [email-masked]
> > Subject: RE: [Speermint] RE: [Enum] RE: [voipeer] I-D: 
> Publishing SIP 
> > PeeringPolicy
> > 
> > If I think IMS, as best I understand it, the P-CSCF in the visited 
> > network gets and stays involved in SIP signaling.
> > I haven't quite thought out what that means to VoIP peering.
> Presumably
> > the peering relationship is still between the home networks of 
> > originator and terminator.
> > 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]]
> On
> > Behalf Of Stastny Richard
> > Sent: Wednesday, January 11, 2006 1:46 PM
> > To: Tom-PT Taylor; Michael Hammer (mhammer)
> > Cc: [email-masked]; [email-masked]; [email-masked]
> > Subject: Re: [Speermint] RE: [Enum] RE: [voipeer] I-D: 
> Publishing SIP 
> > PeeringPolicy
> > 
> > Again
> > 
> > Can anybody please explain to me what the term "visited" originating
> or
> > terminating
> > network means on L5
> > 
> > Both end-users are registered at their respective home 
> networks (aka 
> > SIP servers). I always thought the SIP model is a trapezoid 
> and not a 
> > hexagon
> > 
> > QoS happens at or below L3 and should be negotiated by the end-user 
> > with his acces provider.
> > 
> > Richard
> > 
> > ________________________________
> > 
> > Von: Tom-PT Taylor [mailto:[email-masked]]
> > Gesendet: Mi 11.01.2006 19:01
> > An: Michael Hammer (mhammer)
> > Cc: Otmar Lendl; Henry Sinnreich; [email-masked]; 
> > [email-masked]; Stastny Richard; [email-masked]
> > Betreff: Re: [Speermint] RE: [Enum] RE: [voipeer] I-D: 
> Publishing SIP 
> > Peering Policy
> > 
> > 
> > 
> > The MSF is defining a scenario they hope to demonstrate, 
> where media 
> > paths cross different domains from signalling. The signalling may be
> of
> > the form visited originating network - home originating 
> network - home 
> > terminating network - visited terminating network.  This typical 
> > scenario is an obvious example of L5 transit. Then the 
> media path is 
> > optimized to run directly between the visited networks, possibly by
> way
> > of a different transit network offering QoS based on 
> diffserv markings 
> > at the egress points of the visited networks.
> > 
> > L5 and L3 are linked in the originating and terminating visited 
> > networks, but not in between.
> > 
> > Michael Hammer (mhammer) wrote:
> > > There MUST be some association of IP layer protocol 
> elements to L5 
> > > traffic needs, such as low delay, packet loss etc.  If the L5 need
> is
> > > real-time transmission, and that translates to a DSCP 
> marking, then
> > the
> > > IP network needs to meet that need one way or another or 
> very simply
> > the
> > > real-time service breaks.  The alternative is that the peering
> always
> > > must include both L5 and L3 and you get a half-step instead of
> > full-step
> > > in evolution from PSTN to IP.
> > >
> > > Put another way, is it really necessary to have L5 
> transit networks?
> > If
> > > you insist that L3 always be paired with L5 for real-time, that is
> > what
> > > you get.
> > >
> > > Mike
> > >
> > >
> > >
> > >>-----Original Message-----
> > >>From: [email-masked] 
> > >>[mailto:[email-masked]] On Behalf Of Otmar Lendl
> > >>Sent: Monday, January 09, 2006 6:06 PM
> > >>To: Henry Sinnreich
> > >>Cc: 'Michael Haberler'; 'Richard Shockey'; 'David Meyer'; 
> > >>[email-masked]; [email-masked]; [email-masked]; 
> > >>'Stastny Richard'
> > >>Subject: Re: [Enum] RE: [voipeer] I-D: Publishing SIP 
> Peering Policy
> > >>
> > >>On 2006/01/09 19:01, Henry Sinnreich <[email-masked]> wrote:
> > >>
> > >>>Otmar,
> > >>>
> > >>>You say:
> > >>>
> > >>>
> > >>>>All current protocols regarding proxy and transport
> > >>
> > >>selection for SIP
> > >>
> > >>>>are only based on the domain. I don't want to diverge from
> > >>
> > >>that model.
> > >>
> > >>>What business has the broadband provider to mess with the
> > >>
> > >>user preferences?
> > >>
> > >>>Users and enterprises pay for a certain bandwidth and
> > >>
> > >>hopefully will
> > >>
> > >>>have the choice to pay extra for Diff Serv and that's the end of
> it.
> > >>
> > >>In an ideal world, yes.
> > >>
> > >>
> > >>>If one domain has DiffServ and the other does not, it's 
> up to the 
> > >>>users to continue the call or switch over to some other
> > >>
> > >>networks, such
> > >>
> > >>>as mobile or PSTN. And also to tell the other party to please 
> > >>>subscribe to better broadband :-)
> > >>>
> > >>>What do you think?
> > >>>
> > >>
> > >>My problem with this idea is that "domain" in the sense of 
> > >>SIP-servers is an application layer notion.
> > >>
> > >>DiffServ is a layer 3 issue. My layer 3 network does not 
> > >>neccessarily know which applications I run over them.
> > >>
> > >>If my ISP also acts as my SIP provider, then yes: one can 
> link these 
> > >>two layers into one integrated QoS solution. AFAIK this is one of 
> > >>the aims of the IMS. One of the local Austrian ISPs uses this for 
> > >>his VoIP service: they use separate VLANs/QoS planes for 
> their VoIP 
> > >>offering.
> > >>
> > >>My private playground is quite different: I use an Asterisk 
> > >>installation on a box (the same one I write this mail on) 
> colocated 
> > >>at ISP A whereas my SIP-phone at home is connected via ISP B. The 
> > >>gateway to the PSTN is operated by a commercial provider who uses 
> > >>ISP C.
> > >>If you add my ENUM nameservers, you get one more ISP into the
> picture.
> > >>To top it off, I could add a SIP line to my office phone 
> which would 
> > >>bring our office connectivity into the game were we basically run 
> > >>own multihomed network.
> > >>
> > >>I really don't know how to get seamless QoS in such a setting.
> > >>
> > >>(As you mentioned before: layer3 networks can't just trust each 
> > >>other's DiffServ settings.)
> > >>
> > >>/ol
> > >>--
> > >>< Otmar Lendl ([email-masked]) | nic.at Systems Engineer > 
> > >>______________________________________________________________
> > >>_______________
> > >>List Archive: http://darkwing.uoregon.edu/~llynch/voipeer/
> > >>User Tools: http://darkwing.uoregon.edu/~llynch/voipeer.html
> > >>
> > >
> > >
> > > _______________________________________________
> > > Speermint mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/speermint
> > >
> > >
> > 
> > 
> > 
> > 
> > _______________________________________________
> > Speermint mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/speermint
> 

_______________________________________________
Speermint mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speermint

---

From: Dean Willis <[email-masked]>
Date: Thu, 12 Jan 2006 17:02:40 -0600

> least number of L3 networks path.

This sounds good, and I think we've had a general agreement to not  
tightly bind L5 routing to L3 routing. Incidental binding is of  
course going to occur, since

However, it may be worth considering that L3 peering often doesn't  
follow the model of "shortest geographically, least number of L3  
networks path".

L3 peering often follows elaborate rules of business policy including  
termination/origination ratios, contract or SLA agreements, route  
redundancy exercise, etc.

--
Dean

---

From: David Meyer <[email-masked]>
Date: Thu, 12 Jan 2006 16:27:19 -0800

> redundancy exercise, etc.

	Exactly.

	Dave

---

From: Richard Shockey <[email-masked]>
Date: Thu, 12 Jan 2006 19:30:48 -0500

Dean Willis wrote:
> tightly bind L5 routing to L3 routing. Incidental binding is of course 
> going to occur, since
> 

This again was Dave Oran point in Vancouver. There are clearly user 
requirements for L3 to L5 linkage but do we want/need to go there right now.

-- 

Richard Shockey, Director - Member of Technical Staff
NeuStar Inc.
46000 Center Oak Plaza  -   Sterling, VA  20166
sip:rshockey(at)iptel.org   sip:57141(at)fwd.pulver.com
ENUM +87810-13313-31331
PSTN Office +1 571.434.5651 PSTN Mobile +1 703.593.2683
Fax: +1 815.333.1237
<mailto:richard(at)shockey.us> or
<mailto:richard.shockey(at)neustar.biz>
<http://www.neustar.biz> ; <http://www.enum.org>
<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<