Subject: [Speermint] Speermint Charter

From: "Khan, Sohel Q [CTO]" <[email-masked]>
Date: Thu, 30 Mar 2006 14:03:00 -0600

IMHO,  IETF community wants to solve VoIP peering problem in two major
ways: e2e/p2p and interprovider/interdomain.

I hope that IETF will try to address those separately as follows:

P2P SIP BOF/WG:  E2E/p2p peering

SPEERMINT WG: Interprovider/interdomain peering

Thank you.

Sohel Khan

_______________________________________________
Speermint mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speermint

---

From: "Malas, Daryl" <[email-masked]>
Date: Thu, 30 Mar 2006 13:20:25 -0700

Agreed.  Thanks...

Daryl M.
[email-masked]

-----Original Message-----
From: Khan, Sohel Q [CTO] [mailto:[email-masked]] 
Sent: Thursday, March 30, 2006 1:03 PM
To: Khan, Sohel Q [CTO]
Cc: [email-masked]
Subject: [Speermint] Speermint Charter

Thank you.

Sohel Khan

---

From: "Stastny Richard" <[email-masked]>
Date: Thu, 30 Mar 2006 22:34:18 +0200

Hi Sohel,
 
This is no so simple
 
1. P2P SIP has a complete different charter
2. What if a P2P network is provided by a provider who wants to peer
with another provider?
 
Richard

________________________________

Von: Khan, Sohel Q [CTO] [mailto:[email-masked]]
Gesendet: Do 30.03.2006 22:03
An: Khan, Sohel Q [CTO]
Cc: [email-masked]
Betreff: [Speermint] Speermint Charter

Thank you.

Sohel Khan

---

From: "Malas, Daryl" <[email-masked]>
Date: Thu, 30 Mar 2006 13:45:22 -0700

Richard,

I responded to soon before.  You have a good point.  So what you are
suggesting is peering can encompass multiple SIP based services (P2P,
ENUM, SIMPLE, etc.), and should not be limited to basic SIP telephony?

Thanks...

Daryl M.

-----Original Message-----
From: Stastny Richard [mailto:[email-masked]] 
Sent: Thursday, March 30, 2006 1:34 PM
To: Khan, Sohel Q [CTO]
Cc: [email-masked]
Subject: Re: [Speermint] Speermint Charter

Hi Sohel,
 
This is no so simple

Richard

Thank you.

Sohel Khan

---

From: "Shai Mohaban" <[email-masked]>
Date: Thu, 30 Mar 2006 12:54:25 -0800

I think p2p SIP has nothing to do with e2e... e2e is a general
fundamental principle of the Internet that the IETF is trying to
maintain and I don't think Speermint would get a relief on that front...

-----Original Message-----
From: Khan, Sohel Q [CTO] [mailto:[email-masked]] 
Sent: Thursday, March 30, 2006 12:03 PM
To: Khan, Sohel Q [CTO]
Cc: [email-masked]
Subject: [Speermint] Speermint Charter

Thank you.

Sohel Khan

---

From: "Stastny Richard" <[email-masked]>
Date: Thu, 30 Mar 2006 23:14:46 +0200

Daryl,

>ENUM, SIMPLE, etc.), and should not be limited to basic SIP telephony?

Thank you for bringing this up again and in focus
 
The basic idea of SPEERMINT is to bring an SIP INVITE from Provider
(or admin domain) A to B without immediately being rejected.
 
If one follows this discussion, one gets the impression that the buzzwords
immediately are traffic, QoS, managed networks, billing, accounting, charging, 
so basically the main task of the SIP INVITE seems to trigger a meter.
 
So most here are immediately putting their Bell-hat on and thinking voice calls
 
But at that point of time it is not even defined what the purpose of the session will be
 
Of course we are talking about ALL SIP services. Do I need a guarantied QoS
and managed network for an IM or a filetransfer?
 
Richard

-----Original Message-----
From: Stastny Richard [mailto:[email-masked]]
Sent: Thursday, March 30, 2006 1:34 PM
To: Khan, Sohel Q [CTO]
Cc: [email-masked]
Subject: Re: [Speermint] Speermint Charter

Hi Sohel,

This is no so simple

Richard

Thank you.

Sohel Khan

---

From: "Reinaldo Penno" <[email-masked]>
Date: Thu, 30 Mar 2006 16:31:21 -0500

> Sent: Thursday, March 30, 2006 1:15 PM
> To: Malas, Daryl; Khan, Sohel Q [CTO]
> Cc: [email-masked]
[[Reinaldo]] 

Hello Richard,

If all we need is what you said above, then what we need is already
defined in SIP/SIPPING, right? They already standardized procedures for
DNS lookup, etc, etc

Let me rephrase the question by asking what is missing instead of what
is already defined. If we have two SIP domains, with the DNSs properly
SIPpenized, where the SIP border proxies are configured to talk to each
other, is there anything else needed besides what is in SIP/SIPPING?

Is the policy piece the missing link? 

Sorry, I'm trying to peel another layer to look under "enabling to SIP
messages between the two domains", "Layer 5 peering" and other
expressions. 

I'm trying to understand what exactly is missing if all we want is to
enable Sip messages from domain A to reach B. Are today VoIP peering
points just exchange of media or there is signaling going on as well?

I think we should rephrase the charter to be much, much more specific on
what our goals are, the drafts we need and milestones.

Thanks,

Reinaldo

> So most here are immediately putting their Bell-hat on and thinking
voice
> calls
> 
> But at that point of time it is not even defined what the purpose of
the
> session will be
> 
> Of course we are talking about ALL SIP services. Do I need a
guarantied
> QoS