Subject: Re: [Speermint] Comments on reqs-and-terminology-01 andpolicy-dds-00(Peerign concepts and others..)

From: "Stastny Richard" <[email-masked]>
Date: Wed, 29 Mar 2006 19:15:37 +0200

Now are finally at the point
 
I have only one problem here:
 
>The drafts I wrote are targetted at that setting. They assume
>that we start with zero IP-based interconnection. Calls between
>different service providers may be possible over the PSTN,
>but universal connectivity based on SIP AoRs is *not* assumed
 
If you start with zero IP-based Interconnection, how
do you get to the DNS to query the policy records in the
DNS in the first place?
 
>On the other hand, if we're assuming that the SIP AoRs are PUBLIC, ...
 
BTW, even in 3GPP and TISPAN the AoR are called PUBLIC
User Identities, although they also have some problemy to
comprehend what this implies.
 
>Are we dealing with public user identities in the meaning
>of "reachable by anybody via the public Internet" or not?

I thought speermint is an IETF WG
 
>On the other hand, if we're assuming that the SIP AoRs are PUBLIC,
>then I wonder what real world problem Speermint is supposed to solve.
>Basic interconnection is very well specified by the relevant SIP RFCs.
 
good point ;-)
 
>There is hardly any work to do. 
 
As I pointed out earlier BCP setting minimum requiremnets
and givin guidance along the sibley draft from the SIPforum
could be very useful. 

I also still see your policy draft useful for additional
agreement above basic interconnect

Richard

________________________________

Von: Otmar Lendl [mailto:[email-masked]]
Gesendet: Mi 29.03.2006 18:54
An: [email-masked]
Betreff: Re: [Speermint] Comments on reqs-and-terminology-01 andpolicy-dds-00(Peerign concepts and others..)

This is a valuable discussion.

On 2006/03/29 00:03, Stastny Richard <[email-masked]> wrote:
> 
> Lets reconsider what we are talking about:
> 
> Speermint is primarily about interconnecting sip proxies at L5
> the L5 in SIP is a location service
> 
> two SP have the task to find out for their users (customers) the
> IP addresses to allow them to establish a session and finally
> exchange IP packets on L3.
> 
> We also could define this in another way: a SP is giving out
> to their customers a public user identity, in SIP also called
> an Address-of-Record. Note the term PUBLIC.

This is a critical element for the Speermint charter.

Are we dealing with public user identities in the meaning
of "reachable by anybody via the public Internet" or not?

> If I get a public user identity from a SP, I assume to be able to give this
> to somebody else and he/she is able to reach me via a public
> communications network (note that I do not mention here
> the Internet, also a walled garden network such as Vonage
> is a public communications network)- Ok they are not giving out AoRs

What I see right now is that some big service providers

* give customers telephone numbers (as their _public_ identity)
* use SIP AoRs internally.

[The same is true for a lot of corporate PBX systems: Internally they
use SIP but all communication with the outside world is done via the PSTN.]

The drafts I wrote are targetted at that setting. They assume
that we start with zero IP-based interconnection. Calls between
different service providers may be possible over the PSTN,
but universal connectivity based on SIP AoRs is *not* assumed.

I try to offer a path to do better than this 0% IP-based
interconnection. Universal reachability on SIP basis may be
a goal, but not reaching it isn't failure. *Any* SIP-based
interconnection is progress if you start at 0%.

On the other hand, if we're assuming that the SIP AoRs are PUBLIC,
then I wonder what real world problem Speermint is supposed to solve.
Basic interconnection is very well specified by the relevant SIP RFCs.
There is hardly any work to do. Maybe some L3 interactions to
enhance QoS. Maybe some SIP profiles.

Maybe we should ask ourselves who will implement the results
of the Speermint WG. Who are our "customers"? What are their assumptions
and what issues need to be addressed so that they will agree to
use our work? And why aren't the current SIP RFCs enough for them?

I'd really appreciate consensus on that question.

/ol
--
< Otmar Lendl ([email-masked]) | nic.at Systems Engineer >

_______________________________________________
Speermint mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speermint

_______________________________________________
Speermint mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speermint

---

From: Otmar Lendl <[email-masked]>
Date: Wed, 29 Mar 2006 22:14:33 +0200

> Now are finally at the point

Indeed.

> do you get to the DNS to query the policy records in the

I probably should have written "IP-based Interconnection for voice calls". 
The problem isn't that any of those service providers isn't connected
to the Internet, the problem is that they refuse to use their
Internet connection (or even a private IP link) for VoIP interconnection 
with other server providers.

In the case of Vonage, they do use the public Internet as their
access network. So basic IP connectivity isn't the issue. It's getting
their SIP border elements to talk to each other. And in that respect
I guess it's more a business decision than a technical one.

> I thought speermint is an IETF WG

So the IETF protocol police will hunt down those closed network
operators and force them to open up their border elements?

Or are we going to give those operators tools with which they
can selectively open up their networks?

IMHO we need to break through this all-or-nothing dilemma.

Unless you get regulators to force all VoIP service providers
to accept all SIP calls from anybody, none of the big ones
will choose to open up their network.

> and givin guidance along the sibley draft from the SIPforum

That SIPforum draft has a very different fundamental assumption:

* IP-PBX and SIP service provider enter a contractual relationship.
  
  One part of that relationship is an agreement on the technical details
  of their interconnection (i.e. the sibley document). 
  If things don't work out there are the usual dispute resolution 
  mechanisms (i.e. courts) which can deal with these problems.

Contrast that to (using the universal connectivity assumption):

* As anybody must be able to place a call over the public Internet,
  there need not be a contractual relationship between originating
  and terminating network. The terminating side doesn't even know
  who the originating side is. We're in e-mail land here.

If you want universal SIP connectivity AND contractual relationships
between peering/interconnection partners, then you need transit
networks. That way lies either PSTN version 2 (The IP version), or
you replicate the BGP model at the SIP layer.

> agreement above basic interconnect

Thanks.

/ol

---

From: "Henry Sinnreich" <[email-masked]>
Date: Wed, 29 Mar 2006 21:18:17 -0600

Otmar,

I believe you have nailed it right on target:

>The problem isn't that any of those service providers isn't connected to
>the Internet, the problem is that they refuse to use their Internet
>connection (or even a private IP link) for VoIP interconnection with other
>server providers.

If this is so, why should the IETF bother with this problem? 

Thanks, Henry

-----Original Message-----
From: Otmar Lendl [mailto:[email-masked]] 
Sent: Wednesday, March 29, 2006 2:15 PM
To: Stastny Richard
Cc: [email-masked]
Subject: Re: [Speermint] Comments on
reqs-and-terminology-01andpolicy-dds-00(Peerign concepts and others..)

Indeed.

  

Thanks.

/ol

---

From: "Hadriel Kaplan" <[email-masked]>
Date: Thu, 30 Mar 2006 10:48:52 -0500

Hi Henry,
Comments inline...

> From: Henry Sinnreich [mailto:[email-masked]]
> Sent: Wednesday, March 29, 2006 10:18 PM
> To: 'Otmar Lendl'; 'Stastny Richard'
> Cc: [email-masked]
> Subject: RE: [Speermint] Comments onreqs-and-terminology-01andpolicy-dds-
> 00(Peerign concepts and others..)
> 
> Otmar,
> 

Well, for one, because it's not true, as I think you know.  VoIP Peering
happens all over the place today.  Even over the public Internet.  

But it is an excellent question, and I think we need to determine the answer
as soon as possible, to save time and energy if it is not appropriate for
the IETF; or to focus on what aspects are appropriate, and do the work.  I
believe there is no point in working on something if service providers won't
use it, or the IESG won't approve it, or other members of the IETF community
harass us.  ;)

But I think we need to at least get terminology done so we can talk the same
language, and get some base requirements identified - so we can all figure
out the answer to your question.  I'm fairly confident we'll end up with
something relevant to providers _and_ acceptable to the IETF to specify.

Cheers,
Hadriel

---

From: "Hadriel Kaplan" <[email-masked]>
Date: Thu, 30 Mar 2006 12:29:55 -0500

Hi Henry,
I am not sure we can come to an agreement on this, but I will try my best
because I respect your views and I think there may be confusion simply
because we say similar words but don't mean the same things.  I believe that
is why a terminology document is so critical to starting this process.

I was not referring to your email comment when I said "harass".  I was
unfortunately not at IETF 65, but from what I hear presenters were not given
the same level of respect as I have personally seen in previous IETF's for a
community approach to a problem.  Rather than ignore that, which was my
first reaction, I would like to understand and discuss the objections in an
open forum.  Based on the second-hand description of the arguments raised by
attendees at the session, I genuinely believe there is a misunderstanding
among the community that a baseline terminology and communication would help
clear up.  Terms such as "walled-gardens" are used which are ambiguous at
best, and misleading at worst.

Perhaps that is not the case, and we really have a fundamental difference of
opinion.  But I would like to find out if that is the case; because I don't
think it will be constructive if a majority of the IETF shares the views of
the dissenters.  There will always be people with differing viewpoints, as
there are in every working group and even among working groups.  No working
group would be able to function if simply the fact of differing viewpoints
were to mean work could not progress - so I am not saying we should stop if
we simply discover basic human nature exists.  BUT, if a significant
minority of the IETF shares that then I think it will cause chaos and
potentially failure which I would rather avoid at the outset.

If you would like, we can discuss them in email exchanges on this list, but
I fear the exchange would be long and difficult for people to follow.  I
would rather get a terminology document done so we can at least start from a
documented definition of terms.

Regards,
Hadriel

> Sent: Thursday, March 30, 2006 11:21 AM
> To: 'Hadriel Kaplan'; 'Otmar Lendl'; 'Stastny Richard'
> Cc: [email-masked]
> Hadriel,
> >I believe there is no point in working on something if service providers
> >won't use it, or the IESG won't approve it, or other members of the IETF
> >community harass us.  ;)
> 
> I believe you are right on this item. It appears VoIP peering is just a
> business model in conflict with the e2e nature of the Internet.
> 
> Defending e2e against balkanizing business models is not "harassment".
> 
> VoIP businesses are free to take VoIP peering to market, but trying to
> legitimize the breakup of e2e in the IETF itself is not OK.
> 
> Thanks, Henry

---

From: "Henry Sinnreich" <[email-masked]>
Date: Thu, 30 Mar 2006 10:20:40 -0600

Hadriel,

Thanks, Henry

-----Original Message-----
From: Hadriel Kaplan [mailto:[email-masked]] 
Sent: Thursday, March 30, 2006 9:49 AM
To: [email-masked]; 'Otmar Lendl'; 'Stastny Richard'
Cc: [email-masked]
Subject: RE: [Speermint] Comments
onreqs-and-terminology-01andpolicy-dds-00(Peerign concepts and others..)

Hi Henry,
Comments inline...

Cheers,
Hadriel