Subject: More concrete proposals (was RE: [Speermint] Speermint proposal)

From: "Reinaldo Penno" <[email-masked]>
Date: Thu, 30 Mar 2006 17:10:01 -0500

More concrete proposals:

The "routing architecture" part of draft-bathia and draft-khan could
possibly be combined in one draft.

This would present an overall of the parts, functions, etc

We should then have another draft that details the "message flows and
routing" as stated in the charter. For example (this is my quick and
dirt version to get something going):

[email-masked] registers, decides to call [email-masked].

alice sends a invite to proxy.ispa.com, which performs a DNS lookup on
ispb.com, finds out the ispb.com's proxy is proxy.ispb.com.

At this point we have two scenarios:

Ispa and ispb have an established commercial agreement and a
configuration as a consequence of that (which is out of scope).

proxya and proxyb never talked to each other and then will determine if
they meet the "minimum requirements" as stated in the charter to talk
each other. This could be establishing a TLS connection or whatever.

thanks,

Reinaldo

> -----Original Message-----
> From: Reinaldo Penno
> Sent: Thursday, March 30, 2006 1:56 PM
> To: [email-masked]
> Subject: [Speermint] Speermint proposal
> 
> I mentioned in a different message that we should try to rephrase the
> charter to be more specific/focused.
> 
> Today the charter states
> 
> " More specifically, SPEERMINT focuses on real-time session
> routing architectures and their associated use cases.
> Deliverables here include the specification of the various
> types of application flows, such as signaling and media flows, in
> such networks, and includes both trunking and peer-to-peer
> flows. In addition, SPEERMINT considers and documents requirements
> for the feedback of operational conditions (e.g., congestion control)
> that enables the application of dynamic policy and recognizes
> that various mechanisms for achieving this should be studied as
> a potential part of any architecture."
> 
> This seems quite broad; much more than enabling Sip message from
domain
> A to reach B.
> 
> Further down it states:
> 
> " The most focused deliverables of SPEERMINT are best current
practices
> regarding exchange of real-time sessions among VoIP and other
> real-time application service providers and, in particular, how
> such calls are routed."
> 
> I believe maybe this should be our focus, i.e., "in particular how
such
> calls are routed".  We should solidify the terminology draft, which is
> the starting point and in parallel work on the scenarios on how such
> calls would be routed. Let's put the "new" requirements aside for the
> time being. If we identify a missing piece, then we could work it as
> necessary.
> 
> On the other hand, it might be that we come up with a routing
> scenarios/message flows documents and find out that the important
pieces
> are there. This would not be wasted work, I'm sure these would be very
> important documents.
> 
> It seems very hard to make progress without some document to base our
> discussions.
> 
> My 2 cents,
> 
> Reinaldo
> 
> 
> > -----Original Message-----
> > From: Malas, Daryl [mailto:[email-masked]]
> > Sent: Thursday, March 30, 2006 12:45 PM
> > To: Stastny Richard; Khan, Sohel Q [CTO]
> > Cc: [email-masked]
> > Subject: RE: [Speermint] Speermint Charter
> >
> > Richard,
> >
> > I responded to soon before.  You have a good point.  So what you are
> > suggesting is peering can encompass multiple SIP based services
(P2P,
> > ENUM, SIMPLE, etc.), and should not be limited to basic SIP
telephony?
> >
> > Thanks...
> >
> > Daryl M.
> >
> >
> > -----Original Message-----
> > From: Stastny Richard [mailto:[email-masked]]
> > Sent: Thursday, March 30, 2006 1:34 PM
> > To: Khan, Sohel Q [CTO]
> > Cc: [email-masked]
> > Subject: Re: [Speermint] Speermint Charter
> >
> > Hi Sohel,
> >
> > This is no so simple
> >
> > 1. P2P SIP has a complete different charter
> > 2. What if a P2P network is provided by a provider who wants to peer
> > with another provider?
> >
> > Richard
> >
> > ________________________________
> >
> > Von: Khan, Sohel Q [CTO] [mailto:[email-masked]]
> > Gesendet: Do 30.03.2006 22:03
> > An: Khan, Sohel Q [CTO]
> > Cc: [email-masked]
> > Betreff: [Speermint] Speermint Charter
> >
> >
> >
> > IMHO,  IETF community wants to solve VoIP peering problem in two
major
> > ways: e2e/p2p and interprovider/interdomain.
> >
> > I hope that IETF will try to address those separately as follows:
> >
> > P2P SIP BOF/WG:  E2E/p2p peering
> >
> > SPEERMINT WG: Interprovider/interdomain peering
> >
> >
> >
> > Thank you.
> >
> > Sohel Khan
> >
> >
> >
> >
> > _______________________________________________
> > Speermint mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/speermint
> >
> >
> >
> > _______________________________________________
> > Speermint mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/speermint
> >
> > _______________________________________________
> > Speermint mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/speermint
> 
> _______________________________________________
> Speermint mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/speermint

_______________________________________________
Speermint mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speermint

---

From: "Malas, Daryl" <[email-masked]>
Date: Thu, 30 Mar 2006 15:21:51 -0700

Okay, so I have an additional proposal, which I think will be necessary
as well:

A draft for "peering authentication", with an example continued within
your's below...

"Ispa and ispb have an established commercial agreement and a
configuration as a consequence of that (which is out of scope)."

ISPA sends a PROXY REGISTER message to ISPB.  ISPB responds with a 401
Unauthorized.  ISPA sends a PROXY REGISTER with HTTP/AUTH credentials to
ISPB.  ISPB responds with 200 OK and "Proxy-auth" key.  The auth key is
cached by ISPA.

"[email-masked] registers, decides to call [email-masked]."

"alice sends a invite to proxy.ispa.com, which performs a DNS lookup on
ispb.com, finds out the ispb.com's proxy is proxy.ispb.com."

proxy.ispa.com includes "Proxy-auth" key in INVITE from alice as
authorization for the peering relationship.  ISPB looks for "Proxy-auth"
key and allows alice's call to continue to bob.

I know this is overly simplistic, but I think this WG must define a
mechanism similar to this.  This will be critical for securing SIP
signaling between peers.

Daryl M.
[email-masked]

Ernest Hemingway - "Never mistake motion for action."

-----Original Message-----
From: Reinaldo Penno [mailto:[email-masked]] 
Sent: Thursday, March 30, 2006 3:10 PM
To: [email-masked]
Subject: More concrete proposals (was RE: [Speermint] Speermint
proposal)

More concrete proposals:

thanks,

Reinaldo

domain
practices
such
pieces
(P2P,
telephony?
major

---

From: "Reinaldo Penno" <[email-masked]>
Date: Thu, 30 Mar 2006 17:33:20 -0500

That's perfectly fine. These were my proposals to get things going so we
do not get stuck.

The charter states that "Where these domains peer,
or meet, the establishment of trust, security, and a resistance to
abuse and attack are all important considerations". Your proposal
tackles these.

Regards,

Reinaldo

> Sent: Thursday, March 30, 2006 2:22 PM
> To: Reinaldo Penno; [email-masked]
> Subject: RE: More concrete proposals (was RE: [Speermint] Speermint
> proposal)
>

---

From: "Khan, Sohel Q [CTO]" <[email-masked]>
Date: Fri, 31 Mar 2006 10:54:08 -0600

I think, we need to extend Daryl's proposed draft to a "peering
security" draft that addresses all security issues in addition to
authentication.

-----Original Message-----
From: Malas, Daryl [mailto:[email-masked]] 
Sent: Thursday, March 30, 2006 4:22 PM
To: Reinaldo Penno; [email-masked]
Subject: RE: More concrete proposals (was RE: [Speermint] Speermint
proposal)

Daryl M.
[email-masked]

-----Original Message-----
From: Reinaldo Penno [mailto:[email-masked]]
Sent: Thursday, March 30, 2006 3:10 PM
To: [email-masked]
Subject: More concrete proposals (was RE: [Speermint] Speermint
proposal)

More concrete proposals:

thanks,

Reinaldo

> " More specifically, SPEERMINT focuses on real-time session routing 
> architectures and their associated use cases.
> Deliverables here include the specification of the various types of 
> application flows, such as signaling and media flows, in such 
> networks, and includes both trunking and peer-to-peer flows. In 
> addition, SPEERMINT considers and documents requirements for the 
> feedback of operational conditions (e.g., congestion control) that 
> enables the application of dynamic policy and recognizes that various 
> mechanisms for achieving this should be studied as a potential part of

> any architecture."
domain
practices
> real-time application service providers and, in particular, how such 
> calls are routed."
> 
such

pieces

(P2P,
telephony?
> > 1. P2P SIP has a complete different charter 2. What if a P2P network

> > is provided by a provider who wants to peer with another provider?
> >
> > Richard
> >
major

---

From: "Khan, Sohel Q [CTO]" <[email-masked]>
Date: Fri, 31 Mar 2006 10:58:19 -0600

>From my side, you are welcome to be an author to combine these two
drafts as you mentioned to create another draft.

-----Original Message-----
From: Reinaldo Penno [mailto:[email-masked]] 
Sent: Thursday, March 30, 2006 4:10 PM
To: [email-masked]
Subject: More concrete proposals (was RE: [Speermint] Speermint
proposal)

More concrete proposals:

thanks,

Reinaldo

domain
practices
such

pieces

(P2P,
telephony?

major