Subject: RE: [Speermint] Definition of "Peering"

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Thu, 30 Mar 2006 08:51:52 -0500

Otmar,

While default paths may be a good idea, that is an implementation detail
that should not be the focus of such definitions.

SIP Peering is the enablement of direct connection between SIP providers
offering essential experience-enhancing services, without the need to
resort to transit middlemen providing solely route discovery.

Your list of QoS, cost, features, security are examples of useful
criteria to identify value-added.

Mike

> -----Original Message-----
> From: Otmar Lendl [mailto:[email-masked]] 
> Sent: Thursday, March 30, 2006 4:12 AM
> To: Reinaldo Penno
> Cc: [email-masked]
> Subject: [Speermint] Definition of "Peering"
> 
> On 2006/03/28 23:03, Reinaldo Penno <[email-masked]> wrote:
> > Hello,
> > 
> > I've been reading "reqs and terminology" and I would like 
> to step back 
> > and ask some questions about some of the definitions.
> 
> Good idea. Here is my answer.
> 
> > Peering:
> > ========
> > 
> > In layer 3 peering two routers exchange their routing 
> tables, reach a 
> > steady state, and after that data packets can flow between the two 
> > domains.
> 
> I think this definition is too broad: it applies to any BGP 
> connection.
> 
> A Layer 3 peering is a shortcut connection established to 
> avoid sending the traffic via the default upstream networks. 
> Such a direct connection saves money (upstream is more 
> expensive) and improves the network performance.
> 
> L3 peering is not about reachability per se. For that, one 
> single interconnect to an upstream networks suffices.
> 
> I'll use the term "interconnection" below in a very generic 
> sense, and not in the one used in the PSTN world. I'm very 
> much open to alternative wordings.
> 
> So what about:
> 
> -----
> SIP Peering is the establishement of an alternative 
> communication path between the SIP elements of two entities 
> (service providers, corporations, ...) to improve over the 
> service offered by the default interconnection. The 
> improvements offered by this new path can include (but are 
> not limited to)
>   * better QoS
>   * cost benefits (e.g. if the default path is billed by minute)
>   * additional features (e.g. wideband codecs or IM)
>   * abuse handling.
> 
> The default interconnection between two parties is out of 
> scope for the Speermint WG. 
> -----
> 
> I don't think we should care whether the default 
> interconnection mechanism is SIP according to RFC3261, the 
> PSTN, SIP via a transit network, or simply no default 
> interconnection at all.
> 
> All we need to focus on here in Speermint is to define a 
> framework which can be used to establish more direct and thus 
> better crosslinks between two SIP service providers.
> 
> /ol
> --
> < Otmar Lendl ([email-masked]) | nic.at Systems Engineer >
> 
> _______________________________________________
> Speermint mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/speermint
> 

_______________________________________________
Speermint mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speermint

---

From: Otmar Lendl <[email-masked]>
Date: Thu, 30 Mar 2006 16:28:59 +0200

> resort to transit middlemen providing solely route discovery.

Michael,

So in the absence of an established SIP Peering: can users of SIP provider A call
customers of SIP provider B?

If yes, how is that achieved?

-----------

I have the feeling that the members of this WG doesn't agree on 
what the status quo is. No wonder that we have difficulties to 
agree on what problem Speermint is supposed to solve.

/ol

---

From: "Patrick Melampy" <[email-masked]>
Date: Thu, 30 Mar 2006 13:53:10 -0500

There is currently only one type of peering with one set of reciprocal
values that IP Network Owners have in the internet today. The real work of
this group should be to provide a method to exchange packets where there are
different reciprocal values based on a subset of the total packets
associated with a service (such as SIP signaled media). This must be done in
such a way that no existing services or reciprocal relationships are
affected. Additionally, the prevalent protocols used for Layer 3 networking
will not be easily extended -- thus the assumption should be made that an
architecture that assumes no major changes to BGP4 will be possible.

The requirements start at Layer 3 (IP Connectivity, and reachability) and
extend to addressing and location of endpoints in adjacent networks and
paths to endpoints more than one network hop away. The billing and business
models are just the icing on the cake.

Even in a world of e2e free internet-hippy style networking, the value of
each packet will be different based on the service the packet is part of.
This value will be a function of the layer 3 IP-IP interconnection. The
IETF's mission is to "make the internet better", and an internet that offers
each managed network participant the ability to extract maximum value is a
better internet.

No solution proposed by anybody will ever remove the best-efforts e2e
internet (Your safe Henry). Free services will always be available. The
reciprocal value of free services is just that -- exactly equal to the
reciprocal value or maximum routing efficiency. Thus the only time the value
exchange of peering relations for specific services matches exactly best
efforts exchanges is when the service is a zero cost, best efforts service.
In these cases, the network owner has no incentive to modify routing of
packets. Nor does the service provider have any incentive to deploy any
equipment other than the minimum requirements for best efforts.

Balkanized? Walled gardens? Net-Neutrality? How about a better, more useful
internet that can enable differentiated services -- yet retains the
neutrality and openness as core values. 

-----Original Message-----
From: Otmar Lendl [mailto:[email-masked]] 
Sent: Thursday, March 30, 2006 9:29 AM
To: Michael Hammer (mhammer)
Cc: [email-masked]
Subject: Re: [Speermint] Definition of "Peering"

Michael,

So in the absence of an established SIP Peering: can users of SIP provider A
call
customers of SIP provider B?

-----------

/ol

---

From: "Henry Sinnreich" <[email-masked]>
Date: Thu, 30 Mar 2006 15:23:22 -0600

Patrick Melampy wites:

>Even in a world of e2e free internet-hippy style networking,

Where is this world?

Users pay for Internet access service, which seems to be a booming business.

What does the hippie comment mean on this list?

Thanks, Henry

-----Original Message-----
From: Otmar Lendl [mailto:[email-masked]] 
Sent: Thursday, March 30, 2006 9:29 AM
To: Michael Hammer (mhammer)
Cc: [email-masked]
Subject: Re: [Speermint] Definition of "Peering"

Michael,

-----------

/ol