Subject: RE: [Speermint] Updated Draft: SPEERMINT Peering Architecture

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Fri, 26 May 2006 11:28:00 -0400

Duane,

Your argument depends on the assertion that it is only 20 more bytes of
data.  I don't think we are at a point yet to be able to conclude that
conclusively.  There may be a range of data from very simply to more
complex.  We need to work through this.

Mike

> -----Original Message-----
> From: Duane [mailto:[email-masked]] 
> Sent: Friday, May 26, 2006 5:49 AM
> To: Stastny Richard
> Cc: [email-masked]; Michael Hammer (mhammer); Otmar Lendl; 
> Khan, Sohel Q [CTO]; [email-masked]
> Subject: Re: [Speermint] Updated Draft: SPEERMINT Peering Architecture
> 
> Stastny Richard wrote:
> 
> > Could you please elaborate a bit more in detail what 
> exeactly you mean 
> > with "overloading the DNS"?
> 
> That's usually a term thrown in by "purists" when they run 
> out of other arguments, we store a lot of information in 
> e164.org other then just SIP and we're no where near 
> overloaded, actually we're heavily under utilised, although I 
> tend to draw the line at storing redundant information (that 
> could be found out from a SIP connection for example) unless 
> there is a good reason otherwise.
> 
> > The root servers? the query types? the clients? specific 
> servers? the Internet as a whole?
> 
> If the DNS system is this fragile that it can't cope with 
> another 20 bytes of data (that is only accessed on demand) we 
> should all call it a day and go home :)
> 
> -- 
> 
> Best regards,
>   Duane
> 
> http://www.cacert.org - Free Security Certificates 
> http://www.nodedb.com - Think globally, network locally 
> http://www.sydneywireless.com - Telecommunications Freedom 
> http://e164.org - Because e164.arpa is a tax on VoIP
> 
> "In the long run the pessimist may be proved right,
>      but the optimist has a better time on the trip."
> 

_______________________________________________
Speermint mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speermint

---

From: Duane <[email-masked]>
Date: Fri, 26 May 2006 12:49:18 -0400

> complex.  We need to work through this.

When I said 20 bytes I was being facetious, it could be 2000 bytes or 5M 
for all it really matters because at the end of the day DNS for the most 
part is pulled not pushed so the user only asks for what they need and 
only gets what they asked for.

The problem most have with the idea of a directory service rather then 
some kind of replication of the PSTN network is tradition telco type 
guys are used to collecting interconnect fees and so they want to come 
up with some other way so they can still perform settlements. It's 
possible to keep operating in this manner, although it's going to need a 
BGP style system (or least cost rather then shortest path, or perhaps a 
mixing of the two) and some kind of clearing house to facilitate 
settlements between carriers.

-- 

Best regards,
  Duane

---

From: David Meyer <[email-masked]>
Date: Fri, 26 May 2006 11:08:15 -0700

> only gets what they asked for.

	I'd check that assumption with any of the root server
	operators. You might find that many of them have a
	different concept of what the issues are (at scale). 

> settlements between carriers.

	Not to be too much of a contrarian (or perhaps heretic),
	but what happens when someone puts up "simpletelco.com"
	which is just just a few SIP proxies and a PSTN g/w, and
	is done with it? Seems to me that such a service could be
	made much cheaper (given the mechanisms being bantered
	around here...just consider the OPEX involved), and more
	reliable (again, consider the comparative complexity). 

	Now, of course there are quality issues if you're running
	media over skinny access pipes (that will be true in
	every case, physics and all), and there are the obvious
	security, reliability ,etc issues, but the point is that
	all of this stuff could be OBE'ed in a very simple and
	straightforward way.

	Then what?

	--dmm
 
	[Oh yeah, and I forgot to mention that simpletelco.com
	 works with webundleyourservices.com to give you voice,
	 TV, wireless, and Internet, all on one bill, integrated
	 help desk, etc...  --dmm]