Subject: RE: [speermint] minimum set of requirements forSIP-basedVoIPinterconnection and emergency calling

From: "Jean-Francois Mule" <[email-masked]>
Date: Fri, 16 Jun 2006 06:10:15 -0600

Adam,

   I'm generally interested in what folks believe should be in-scope and
out of scope for the wg deliverable identified as "the minimum set of
requirements for SIP-based VoIP interconnection (BCP)", and especially
re: emergency calling.

   If the goal is a BCP and if today, various providers do have SIP
interconnect agreements that include emergency calling, I thought it may
be in scope, at least from a SIP requirement point of view per my email
yesterday.

Jean-Francois

> -----Original Message-----
> From: Uzelac, Adam [mailto:[email-masked]]
> Sent: Friday, June 16, 2006 5:50 AM
> To: Jean-Francois Mule; Stastny Richard
> Cc: [email-masked]
> Subject: RE: [speermint] minimum set of requirements forSIP-
> basedVoIPinterconnection and emergency calling
> 
> Jean-Francois,
> 
> Is this to mean that you believe emergency calling should be addressed
> within the scope of general peering arrangements, or you would like to
> see emergency requirements addressed in a specific emergency-like
> peering arrangement (possibly other services as well)?  I think I
> could
> see that and one would not exclude the other.
> 
> -AU
> 
> -----Original Message-----
> From: Jean-Francois Mule [mailto:[email-masked]]
> Sent: Friday, June 16, 2006 7:39 AM
> To: Stastny Richard
> Cc: [email-masked]
> Subject: RE: [speermint] minimum set of requirements
> forSIP-basedVoIPinterconnection and emergency calling
> 
> Stastny Richard wrote:
> > >Some VSPs do have gateways connected to the PSTN and the whole
> > selective routers thingy in the North American system for >example
> to
> > do this; some don't and hand off the call to another VSP. The
> question
> 
> > of who does the ECRIT mapping protocol >resolution is also not
> > relevant here.
> >
> > Ok, but you mention here two issues out of speermint scope: gateways
> > to the PSTN and North American selective router stuff
> 
> And that is clearly out of scope.
> Per my earlier email, the scope question was related to the other case
> where emergency calls are not handled within a single VSP domain (or
> for
> that matter, the case of an enterprise using a SIP interconnect
> service
> and handing off all calls to the VSP).
> 
> Jean-Francois.
> 
> 
> _______________________________________________
> Speermint mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/speermint

_______________________________________________
Speermint mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speermint

---

From: "Jean-Francois Mule" <[email-masked]>
Date: Fri, 16 Jun 2006 07:38:44 -0600

Penn and Hannes,

   Thanks for the input. Here is an attempt to clarify what could be in
scope of speermint. 

Hannes wrote:
> It might be good to clearly describe what you want to accomplish with
> emgerency services in the context of peering.

The potential goal would be to write the minimum requirements a VSP
should comply with when handing off an emergency call to another
administrative domain over IP through a VoIP interconnect point (SIP
call termination to another third-party provider which in turn does
terminate the call to a PSAP).

   Folks assume the work in GEOPRIV and ECRIT takes care of the above.
The requirement gap I can see so far is based on:
a) the requirement work in ECRIT is for IP-enabled PSAPs (US/nena i3).
The ECRIT requirement document states:
| This document only focuses on end-to-end IP-based calls, i.e., where
| the emergency call originates from an IP end system and terminates
| into an IP-capable PSAP, conveyed entirely over an IP network.

b) GEOPRIV, ECRIT and SIPPING are concerned with location determination,
emergency context resolution, location-based routing of the SIP call to
the PSAP URI, location conveyance in SIP.

c) SPEERMINT is about "architectures to identify, signal, and route
delay-sensitive (real-time) communication sessions."... "These sessions
use the SIP signaling protocol to enable peering between two or more
administrative domains over IP networks."

So, for example, the speermint requirement doc could state things like:
	- any applicable ECRIT requirements for exchanging emergency sip
calls between 2 or more domains,
	- any SIP requirements that should be taken into consideration.
For e.g. if available, convey location using sipping location
conveyance. But also special handling of things like p-asserted-id when
handing off emergency calls (if privacy is on in the originating domain,
some VSPs remove p-asserted-id when handing out the call to another
provider). In the case of an emergency call, for psap callback,
p-asserted-id must/should be left in... so that the terminating VSP that
connects to the PSAPs can identify the ANI.

These are first thoughts to provide more examples. We could just have a
couple of sentences highlighting the key requirements and giving
pointers to consider when the handoff of emergency calls is possible.

Penn wrote:
> > I think we'd be better served NOT to take up the emergency use case
> for
> > now, until the other groups (GEOPRIV and ECRIT) solidify their
> > requirements.
This is fine and I'm ok not taking if we think we should just not take
this for *now* but as Hannes points out, and as I tried to highlight
above, we should not assume there will be a lot more requirement work in
other IETF groups around the SIP interconnects and there may be some
gaps (hence the scope question).

Jean-Francois

> From: Hannes Tschofenig [mailto:[email-masked]]
> Sent: Friday, June 16, 2006 6:10 AM
> To: Pfautz, Penn L, GBLAM
> Cc: Jean-Francois Mule; Stastny Richard; [email-masked]
> Subject: Re: [speermint] minimum set of requirements forSIP-
> The requirements work in ECRIT is finished. Here is the most recent
> document:
> http://www.ietf.org/internet-drafts/draft-ietf-ecrit-requirements-
> 10.txt
> 
> It might be good to clearly describe what you want to accomplish with
> emgerency services in the context of peering.
> 
> Ciao
> Hannes
> 
> 
> Pfautz, Penn L, GBLAM wrote:
> > I think we'd be better served NOT to take up the emergency use case
> for
> > now, until the other groups (GEOPRIV and ECRIT) solidify their
> > requirements.
> >
> > Penn
> >

---

From: "Livingood, Jason" <[email-masked]>
Date: Mon, 19 Jun 2006 19:15:16 -0400

Always interesting to see the WG pounce on a pretty innocent question.  ;-)  To wit, should there be special emergency calling requirements for interdomain calls?  Nothing more and nothing less.  One answer is NO, all calls are treated the same.  The other answer is YES, we believe emergency calls should somehow be treated differently between two domains OR at least have minimially different requirements.  

I believe there is a line between ECRIT and SPEERMINT on this as with ENUM and SPEERMINT.  We just want to know if there may be any additional requirements if we get a URI that clearly (in whatever manner) indicates an emergency call.  Not so controversial a question? ;-)

So perhaps now, we'll leave it as a placeholder question and Dave and I will chat up the ECRIT chairs in Montreal to get their thoughts.  We're clearly not at consensus yet I think.  

Regards
Jason

> Sent: Friday, June 16, 2006 5:04 AM
> To: Stastny Richard
> Cc: [email-masked]
> > Sorry, but I doubt that emergency services is within the scope of 
> > speermint
> >
> > For emergency services normally either the UA itself or the 
> first hop 
> > proxy is responsible, so it never reaches the peering point at all
>         ^^^^^
> There are examples of VSP providers that do offer sip-based 
> VoIP interconnect services today including 9-1-1. So your 
> assertion that emergency calls do not reach "peering points" 
> between VSPs is simply not true (based on current practices e
> and this is by no means cable-specific).
> 
> > For emergency services normally either the UA itself or the 
> first hop 
> > proxy is responsible
> I presume you mean responsible for "invoking the special 
> routing procedures caused by an emergency dialed string or 
> use of SOS URN".
> This is ok but it does not necessarily mean that, upon 
> determination that the call is an emergency call, the 
> originating VSP does have to handle the SIP call to the PSAP 
> within its own domain. 
> Some VSPs do have gateways connected to the PSTN and the 
> whole selective routers thingy in the North American system 
> for example to do this; some don't and hand off the call to 
> another VSP. The question of who does the ECRIT mapping 
> protocol resolution is also not relevant here.
> 
> My first question was:
>    - should there be any minimal set of requirements (and 
> ones applicable beyond national standards) for handling 
> emergency calls that should be captured in a speermint 
> requirement doc for SIP-based VoIP interconnect?
> 
> Jean-François
> 
>