Subject: RE: [Speermint] Updated Draft: SPEERMINT Peering Architecture

From: "Livingood, Jason" <[email-masked]>
Date: Thu, 15 Jun 2006 12:32:12 -0400

Very interesting response.  I think you have highlighted again why the
co-chairs feel that security and trust are major areas of concern and
work for the group.

Jason 

> -----Original Message-----
> From: Uzelac, Adam [mailto:[email-masked]] 
> Sent: Tuesday, June 13, 2006 9:49 PM
> To: Michael Hammer (mhammer); Patrick Melampy; Stastny 
> Richard; Reinaldo Penno; Otmar Lendl
> Cc: [email-masked]
> Subject: RE: [Speermint] Updated Draft: SPEERMINT Peering Architecture
> 
> Piping in here to make a point or two - Two realistic 
> requirements that oftentimes are overlooked in global peering 
> bar-napkin discussions, and possibly assumed in the PSTN 
> world, are trust and scale.  I argue that the P2P world of 
> direct interconnection/peering, though preferred for obvious 
> technical reasons, can't be realized practically due to scale 
> limitations and an inherent lack of trust. Therefore these 2 
> items should be kept in mind when scheming up a solution for 
> global peering dominance. (/me puts pinky finger to mouth and 
> mutters, "1 million dollars"!  muhahaha)  ;)  
> 
> A service provide would be best served to provide its 
> subscribers a way to contact anyone else.  The burden to 
> facilitate that session is on the SP.  Will a SP in Topeka 
> trust a SP in Oslo enough to establish a direct peering 
> arrangement?  Without that direct peer, how will the 
> subscribers of the Topeka SP access the folks in Oslo?  An 
> intermediary most likely will be involved with the value 
> being reachability and trust that should a call be sent to 
> the transit provider, it will be completed as intended by the 
> calling party. At the end of the day, it will be the one that 
> will complete the call that gets the buck.  Unfortunately 
> it's the PSTN that facilitates that Topeka to Oslo call today 
> more often than not.
> 
> -Adam
> 
> -----Original Message-----
> From: Michael Hammer (mhammer) [mailto:[email-masked]]
> Sent: Tuesday, June 13, 2006 10:38 AM
> To: Patrick Melampy; Stastny Richard; Reinaldo Penno; Otmar Lendl
> Cc: [email-masked]
> Subject: RE: [Speermint] Updated Draft: SPEERMINT Peering Architecture
> 
> Patrick,
> 
> Let us take these one at a time.  Inline. 
> 
> > -----Original Message-----
> > From: Patrick Melampy [mailto:[email-masked]]
> > Sent: Monday, June 12, 2006 9:34 PM
> > To: Michael Hammer (mhammer); 'Stastny Richard'; 'Reinaldo Penno'; 
> > 'Otmar Lendl'
> > Cc: [email-masked]
> > Subject: RE: [Speermint] Updated Draft: SPEERMINT Peering 
> Architecture
> > 
> > I'd like to comment as follows:
> > 
> > You said:
> > >  I believe the reality will be that there will ultimately
> > be two options:
> > >   - from one SP (carrier/enterprise) to another there is
> > direct peering,
> > >   - from one SP to another there is no direct peering and a
> > "Tier 1" 
> > > SP  will be used for transit.
> > 
> > Unless somebody representing a carrier makes this 
> statement, it's safe
> 
> > to say we are just guessing. I find this statement your 
> making to lack
> 
> > any backing. How many Autonomous Systems do your communications go 
> > through today? When you're at work?
> > When you're at home? I'm guessing you have no idea. Why should this 
> > group ever designate a role for a Tier 1 SP as a required 
> > internetworking element? If you worked at a competitive Tier 2 you 
> > might take exception to your statement.
> 
> The basis for this statement is an assumption that for 
> security and economic reasons, you must have rules of 
> engagement in order to connect to a peer.  If there is a 
> business arrangement, you can directly connect, if not then 
> an intermediary is used.  This is rather simple and straight 
> forward.  This does not preclude you creating a 
> wide-open-to-the-Internet federation through which anyone can 
> connect to you.
> 
> I am simply stating there are two options:  direct and 
> indirect.  Is there a third possibility?
> 
>  
> > > My thinking, if it is not obvious is that the optimal
> > number of SPs is
> > > 2 (direct peering).
> > 
> > Optimal in whose frame of reference? The internet's? The 
> caller? The 
> > callee?
> > The carrier(s)? My guess is your thinking of the internet. 
> 
> The most optimal is directly from client to client, ie. true 
> P2P.  But, I am relaxing that here to the assumption that an 
> end device may "outsource" some degree of features and 
> functionality to a SP, be that enterprise PBX or carrier system.
> 
> It is optimal because we are talking about two parties, the 
> caller and called parties.  For that you could have an 
> origination system and a termination system.  Anything beyond 
> that is extraneous middlemen that add cost into the picture, 
> but not much in the way of added value, and a lot of 
> possibility for unintended consequences to screw up the 
> signaling or media.
> 
> Case in point:  Every additional signaling point on the path 
> will exacerbate call setup delay and increase the complexity 
> of the interactions amongst all these components.
> 
> Case in point:  Every additional media anchor will add delay 
> to the RTP stream, thus negatively affecting QoS.
> 
> So, from the perspective of the caller and callee, the 
> service experience will be better if SPs can minimize the 
> number of extra moving parts in the system.
> 
> And, from the perspective of the SP, the fewer middlemen in 
> the picture, the fewer the profits to share amongst those middlemen.
> 
> I am just applying Occam's Razor to get the minimalist set.
> 
>  
> > > Second best is 3 (one transit).  
> > Why is one transit carrier better than 2 or 3? Is it cost? 
> > Quality? Where did this conclusion come from? Are there any 
> IP based 
> > models where a single backbone carrier is considered 
> optimal? Doesn't 
> > this limit competition and choice? Wouldn't it be anti-competitive, 
> > and thus not be net-neutral?
> 
> I am suggesting that if both caller and callee have the good 
> fortune to prefer the same transit carrier, then the savings 
> from avoiding a second SP can be shared.  This is what is 
> experienced when a call stays within a single enterprise.  
> This is what happens when you have a "friends and family" scenario.
> 
> It is both a business advantage and a technical advantage to 
> have only one SP's policies to care about.  No interworking!
> 
>  
> > >Maximum number is 4 (one originating and one terminating transit).
> > 
> > Why is this the maxium? 
> 
> What would a third tranist carrier provide that could not be 
> better provided if transit carrier 1 and 2 had a direct 
> signaling agreement between them?  How is sharing revenues 
> amongst 3 carriers better than shared betweeen 2?
> 
> 
> > I hate to argue with your statements, but they should be better 
> > defended.
> 
> Hopefully, I have done so. :)
> 
> 
> > There are a lot of managed networks that are both legislated and or 
> > pre-existing.
> 
> I don't want our creativity to be limited by arbitrary 
> government fiat, nor by lack of imagination constrained to 
> repeat simply what already exists.
> 
> 
> > The owners of long haul fiber networks want to use them for 
> signaled 
> > media.
> 
> Nothing precludes this.  This is a layer 3 issue.  I am not 
> saying that to connect one signaling point to another that 
> there can not be a VPN over a third IP carrier.  Don't 
> confuse Layer 5 with Layer 3 issues.
> 
> 
> > My guess is we will not
> > only have One Tier 1 to choose from, but the following:
> > 
> > 1.) Each Enterprise will desire at least 2 interconnect carriers to 
> > ensure they have the lowest cost and best level of service with 
> > redundancy.
> 
> My statements don't preclude this.
> 
>  
> > 2.) Each Tier 1 Carrier will want to purchase termination 
> services for
> 
> > its customers and have multiple paths to each major 
> desination domain
> 
> Not precluded.
> 
>  
> > 3.) Many Tier 2 and Tier 3 carriers will exist by selecting 
> specific 
> > target markets and verticals.
> 
> Define Tier 2 and 3.  I think you have descended into Layer 3 here.
> 
>  
> > 4.) Governments will continue to try to enforce regulations 
> > guaranteeing a competitive landscape for communication 
> interconnects 
> > (requiring access for 2nd and 3rd carrier options.
> 
> See previous.
> 
>  
> > I could go on and on. I would suggest that we embrace the 
> realities of
> 
> > our world as requirements for this standards group.
> 
> Belive me, I am being very realistic.  Allow room for 
> arbitrage and it will occur.  Economics will drive out an 
> inefficiency in routing, so long as a better path exists.
> 
> If you do go on and on, would you please also indicate what 
> added value any such intermediaries provide?  So far, you 
> have only indicated that they have existed in the past.  
> While their value may have been grounded in the regulatory 
> and business climate of the past, past history that does not 
> take into account new technical realities amounts to just 
> rebuilding the PSTN because that's the way we did it with 
> TDM.  I don't find such arguments persuasive.
> 
> Mike
> 
> _______________________________________________
> Speermint mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/speermint
> 
> _______________________________________________
> Speermint mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/speermint
> 

_______________________________________________
Speermint mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speermint

---

From: Paul Kyzivat <[email-masked]>
Date: Sat, 17 Jun 2006 16:11:50 -0400

>> it's the PSTN that facilitates that Topeka to Oslo call today 

Assuming the provider for the caller can determine the provider for the 
callee, then I fail to see how introducing an intermediary can improve 
trust. No matter how many intermediaries are involved, ultimately the 
callee's provider will be involved in the call. Establishing a direct 
peering relationship seems at least as good, if not better.

	Paul

---

From: "Patrick Melampy" <[email-masked]>
Date: Sun, 18 Jun 2006 19:51:11 -0400

Paul,

It's clear that most of us Engineers (including me) don't understand what's
required to establish a business relationship for telephonic communications.
I'm guessing there are issues with taxation, regulation, service level
agreements, minimum usage, billing issues, currency issues, credit, and
more. Although I've never seen a peering agreement for voice traffic, I'm
guessing they are comprehensive. I personally am aware of IP Peering
relationships for voice that even have damage clauses for periods of service
interruption.

Maybe somebody who understands why these relationships are so difficult to
establish and maintain could shed some light on this. If anybody could
easily and quickly establish a new peering relationship, then your position
is correct. Maybe you can help resolve all of the business issues to enable
"easy and quick" peering with on contracts, no taxes or regulation, and no
service level agreements.

I do believe that Adam is correct that trust will depend on the signaling
infrastructure being open only to those networks that are trust worthy --
with pre-established contractual guarantees. Any network that would break
the SIPS chain of trust MUST be excluded, or we need to find a way to ensure
that every party in the communication knows that the call is leaving the
trusted world and entering into untrusted networks. As far as I know, there
is no way currently to know that a SIP communication has followed a SIPS
trusted set of proxies from end-to-end.
-----Original Message-----
From: Paul Kyzivat [mailto:[email-masked]] 
Sent: Saturday, June 17, 2006 4:12 PM
To: Livingood, Jason
Cc: [email-masked]; Uzelac, Adam
Subject: Re: [Speermint] Updated Draft: SPEERMINT Peering Architecture

	Paul

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 19 Jun 2006 15:44:43 -0400

Patrick,

I can see that there may be many reasons why the calling SP does not 
have, and cannot establish a peering relationship with the called SP, 
and would indeed need to use an intermediary.

But if SP-A lacks trust that SP-B will deliver the call to Bob, then 
adding an intermediary cannot fix that.

	Paul