Subject: RE: [Speermint] Terminology draft - Peering

From: "Livingood, Jason" <[email-masked]>
Date: Thu, 13 Jul 2006 13:20:00 -0400

Sounds like this could certainly be the case of enterprise domains, if
there was some kind of federation aggregating them up and perhaps
providing network services.  Is that a fair example?

Jason 

> -----Original Message-----
> From: Reinaldo Penno [mailto:[email-masked]] 
> Sent: Thursday, July 13, 2006 11:20 AM
> To: Stastny Richard; David Meyer
> Cc: [email-masked]
> Subject: RE: [Speermint] Terminology draft - Peering
> 
> Richard,
> 
> I think you are assuming the domain part of AORs maps to the 
> VSP that actually host his VoIP service and this relationship 
> is not well defined.
> 
> I can be in VSP A and make a DNS query for 
> [email-masked] and get as a result a proxy server at 
> VSP B. Now, some-company.com is actually served by VSP C, but 
> the DNS returns VSP B because that's where you need to send 
> your signaling to get to some-company.com
> 
> In this case, VSP A has no way of knowing that 
> some-company.com is actually "hosted" (for a lack of a better 
> term) in VSP C. 
> 
> A VSP can serve many domains. Just because the VSP is called 
> vspb.com does not mean it cannot serve, e.g., supervoip.com, 
> voip'r'us.com, voipathome.com, etc, etc
> 
> Thanks,
> 
> Reinaldo
> 
> 
> 
> > -----Original Message-----
> > From: Stastny Richard [mailto:[email-masked]]
> > Sent: Thursday, July 13, 2006 8:02 AM
> > To: Reinaldo Penno; David Meyer
> > Cc: [email-masked]
> > Subject: Re: [Speermint] Terminology draft - Peering
> > 
> > >VSPA <-----> VSP B <-----> VSP C
> > 
> > >Is VSP B providing layer 5 "transit" or we can just say it 
> peers with
> A
> > and B?
> > 
> > >VSP A might not even know that is talking with VSP C through VSP B.
> For
> > >all purposes, VSP B is VSP C...
> > 
> > VSP A must know that the call terminates at VSP C, because he
> basically
> > has
> > an AoR for VSP C.
> > 
> > He looks up VSP C and sees he cannot peer with VSP C directly, but
> gets
> > the pointer to VSP B (somehow)
> > 
> > Now he peers with VSP B and VSP B peers with VSP C
> > 
> > Richard
> > 
> > ________________________________
> > 
> > Von: Reinaldo Penno [mailto:[email-masked]]
> > Gesendet: Do 13.07.2006 15:49
> > An: Stastny Richard; David Meyer
> > Cc: [email-masked]
> > Betreff: RE: [Speermint] Terminology draft - Peering
> > 
> > 
> > 
> > I thought at some point we kind of agreed to get rid of the transit 
> > term, wasn't it?
> > 
> > Anyway, in the following case
> > 
> > VSPA <-----> VSP B <-----> VSP C
> > 
> > Is VSP B providing layer 5 "transit" or we can just say it 
> peers with
> A
> > and B?
> > 
> > VSP A might not even know that is talking with VSP C through VSP B.
> For
> > all purposes, VSP B is VSP C...
> > 
> > Thanks,
> > 
> > Reinaldo
> > 
> > 
> > 
> > > -----Original Message-----
> > > From: Stastny Richard [mailto:[email-masked]]
> > > Sent: Wednesday, July 12, 2006 9:18 PM
> > > To: Reinaldo Penno; David Meyer
> > > Cc: [email-masked]
> > > Subject: Re: [Speermint] Terminology draft - Peering
> > >
> > > >[[Reinaldo]]
> > >
> > > >SPs or VSPs?
> > >
> > > Both
> > >
> > > >Is this transit network just providing IP transit or it 
> is actually
> a
> > > >Layer 5 transit network? I think the requirements are 
> different in
> > the
> > > >two scenarios.
> > >
> > > L5
> > >
> > > Richard
> > >
> > >
> > > ________________________________
> > >
> > > Von: Reinaldo Penno [mailto:[email-masked]]
> > > Gesendet: Do 13.07.2006 04:32
> > > An: Stastny Richard; David Meyer
> > > Cc: [email-masked]
> > > Betreff: RE: [Speermint] Terminology draft - Peering
> > >
> > >
> > >
> > > Hello Richard,
> > >
> > > > -----Original Message-----
> > > > From: Stastny Richard [mailto:[email-masked]]
> > > > Sent: Wednesday, July 12, 2006 3:55 PM
> > > > To: David Meyer
> > > > Cc: [email-masked]
> > > > Subject: [Speermint] Terminology draft - Peering
> > > >
> > > > Proposed wording for Peering
> > > >
> > > > 4.2.  Layer 5 Peering or Session Peering
> > > >    Layer 5 peering or Session Peering refers to 
> interconnection of
> > > >    two (VoIP) service providers for the purposes of routing
> > real-time
> > > >    (or quasi-real time) secure call signaling between their
> > respective
> > > >    customers using SIP methods.  Such interconnection may be
> direct
> > or
> > > >    indirect.
> > > >    Media streams associated with this signaling (if any) are not
> > > >    constrained to follow the same set of paths.
> > > > 4.3.  Direct Peering
> > > >    Direct Peering covers all cases where the two SPs
> > > [[Reinaldo]]
> > >
> > > SPs or VSPs?
> > >
> > > interconnect without
> > > >    using an intervening L5 network. Both SP must have a trust
> > > relationship
> > > >    established (e.g. know they belong to the same 
> federation (see
> > > below)
> > > >    before opening up a secure communication path on L5.
> > > > 4.4   Indirect or Transit Peering
> > > >    Indirect or transit peering is the establishment of a secure
> > > signalling
> > > >    path via one (or more) referral or transit 
> network(s). In this
> > case
> > > it
> > > > is
> > > >    required that a trust relationship is established 
> between the 
> > > > originating
> > > >    SP and the transit network on one side and the 
> transit network
> > and
> > > the
> > > >    termination network on the other side before opening up a
> secure
> > > >    communication path on L5.
> > > [[Reinaldo]]
> > >
> > > Is this transit network just providing IP transit or it 
> is actually
> a
> > > Layer 5 transit network? I think the requirements are different in
> the
> > > two scenarios.
> > >
> > > >
> > > > In addition,
> > > > I suggest to delete the old section 4.4. on private peering
> because
> > > > it is confusing and and out of scope anyway
> > > >
> > > >
> > > >
> > > > _______________________________________________
> > > > Speermint mailing list
> > > > [email-masked]
> > > > https://www1.ietf.org/mailman/listinfo/speermint
> 
> _______________________________________________
> Speermint mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/speermint
> 

_______________________________________________
Speermint mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speermint

---

From: "Reinaldo Penno" <[email-masked]>
Date: Thu, 13 Jul 2006 14:29:15 -0400

Yes.

> From: Livingood, Jason [mailto:[email-masked]]
> Sent: Thursday, July 13, 2006 10:20 AM
> To: Reinaldo Penno; Stastny Richard; David Meyer
> Cc: [email-masked]