Subject: [Speermint] TLs performance

From: Klaus Darilion <[email-masked]>
Date: Mon, 24 Jul 2006 19:59:51 +0200

Hi!

I made some tests with sipp+openser:

scenario:

UAC <-TLS-> openser <-TLS-> UAS (all of them got its own 2xP3 1,26GHz 
machine, linked with 100MBit). Simple forwarding configuration (like a 
loadbalancer), no DNS lookups or DB queries.

UDP: ~620 cps
TLS: ~680 cps (single TLS connection)

cps=calls per second = INVITE-180-200-OK-ACK-BYE-200

I think TLS performs better as because of UDP retransmissions, which 
"kills" the proxy if it becomes slow.

More data when I have it.

regards
klaus

_______________________________________________
Speermint mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speermint

---

From: "Henry Sinnreich" <[email-masked]>
Date: Mon, 24 Jul 2006 12:54:50 -0700

Hi Klaus,

This is a good beginning, but you may want to include the 2-3 DNS
lookups from the originating UAC and the additional 3-4 DNS lookups for
ENUM, NAPTR, etc.

Can you add such a test?

Thanks, Henry

-----Original Message-----
From: Klaus Darilion [mailto:[email-masked]] 
Sent: Monday, July 24, 2006 1:00 PM
To: [email-masked]
Subject: [Speermint] TLs performance

Hi!

scenario:

UDP: ~620 cps

regards
klaus