Subject: RE: [Speermint] I-D ACTION:draft-ietf-speermint-requirements-00.t xt

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Fri, 28 Jul 2006 10:30:13 -0400

I suspect a Federation of like-minded users will be used and setup/agree
to a media policy that specifies that set of codecs that they know and
love.

Mike

> -----Original Message-----
> From: Reinaldo Penno [mailto:[email-masked]] 
> Sent: Monday, July 24, 2006 1:23 PM
> To: Klaus Darilion; Stastny Richard
> Cc: [email-masked]
> Subject: RE: [Speermint] I-D 
> ACTION:draft-ietf-speermint-requirements-00.t xt
> 
> I tend to agree. One thing is to specify a behavior over a 
> peering interface that affects only the peering devices. 
> Another is to specify a behavior that affects possibly 
> millions of phones (or alternatively a requirement to install 
> many of transcoders).
> 
> I cannot imagine Sprint changing all its phones to support 
> G.711 or Comcast changing all of its phones to support some 
> wireless codec because Speermint mandates it. 
> 
> That leaves only three alternatives:
> 
> 1) Do not specify anything in the RFCs and the peers work in 
> out whether through some transcoding devices, or some common 
> coder when possible.
> 
> 2) Specify a minimum set (Can it be done and make everybody happy?)
> 
> 3) Let offer/answer decide. I believe this might fall back 
> into 1) since I do not believe carriers will just "wing it" 
> when it comes to peering. 
> 
> Regards,
> 
> Reinaldo
> 
> > -----Original Message-----
> > From: Klaus Darilion [mailto:[email-masked]]
> > Sent: Monday, July 24, 2006 8:06 AM
> > To: Stastny Richard
> > Cc: [email-masked]
> > Subject: Re: [Speermint] I-D
> ACTION:draft-ietf-speermint-requirements-00.t
> > xt
> > 
> > Stastny Richard wrote:
> > >> And finally they can't interconnect as A uses AMR and B 
> uses G.711.
> > >
> > > They can, if one provides transcoding
> > >
> > > If we say G.711 is mandatory, it is provider A who has to provide
> the
> > transcoding
> > 
> > 
> > Thus, we have to mandate a minimum set of codecs.
> > 
> > regards
> > klaus
> > 
> > _______________________________________________
> > Speermint mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/speermint
> 
> _______________________________________________
> Speermint mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/speermint
> 

_______________________________________________
Speermint mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speermint

---

From: "Richard Shockey" <[email-masked]>
Date: Fri, 28 Jul 2006 10:47:32 -0400

> From: Michael Hammer (mhammer) [mailto:[email-masked]]
> Sent: Friday, July 28, 2006 10:30 AM
> To: Reinaldo Penno; Klaus Darilion; Stastny Richard
> Cc: [email-masked]
> Subject: RE: [Speermint] I-D ACTION:draft-ietf-speermint-requirements-00.t
> xt
> 

I agree. This whole discussion of CODEC's is one reason we are all wandering
in the weeds trying to define requirements.

I don't believe that there should be any discussion of media policy at all
or any type of policy.

ITS OUT OF SCOPE!!! You are trying to boil the ocean here.

Now it might make sense eventually to have a protocol mechanism to discover
"what is the media policy" of a federation and define what constitutes the
minimum set of media parameters the federation requires that makes sense.

I'm wondering if folks could just try and divide up the problem ( do we know
what the problem is) into manageable chunks.

We were talking first about discovery, then security and authentication, 

Long history in IETF circles tells me that anything that looks or smells
like a policy protocol or policy decision mechanism is a rat hole we don't
want to go into at least not until we knock off the easy stuff which IMHO is
discovery and security and authentication.

Frankly I would start to carve up the requirements document into Phases or
dare I say it Implementation Profiles.

---

From: David Meyer <[email-masked]>
Date: Fri, 28 Jul 2006 08:10:09 -0700

> ITS OUT OF SCOPE!!! You are trying to boil the ocean here.

	I believe this is correct as well. And has been pointed
	out to me (and others) on several occasions, the
	selection of a default codec is an absolutely unsolvable
	problem. It has an intractable set of IPR issues, and
	(learning from history) many other SDOs have stumbled all
	over this issue and in the process have failed to select
	a codec baseline. Let's not add SPEERMINT to that list.

	A lot of WG email list b/w has been spent on this, with
	little resolution (on the contrary, I would posit). Let's
	not fall down this (rat) hole again.

	--dmm

---

From: Daryl Malas <[email-masked]>
Date: Fri, 28 Jul 2006 10:39:14 -0600

Comments in-line...

> > to a media policy that specifies that set of codecs that they know and

YES!!  Agreed!  Agreed!
> ITS OUT OF SCOPE!!! You are trying to boil the ocean here.

YES!!  Agreed!  Agreed!

---

From: "Reinaldo Penno" <[email-masked]>
Date: Fri, 28 Jul 2006 12:38:58 -0400

Exactly. And just like Daryl said, carriers/SP/VSPs will just work out
their differences whether because they discover somehow they support a
common denominator codec or through the use of transcoding.

In the case of a federation maybe it is enough that, for example, only
one member supports AMR to G.711 conversion. This member will take care
of inter-federation calls that need that.

That's why some emails/threads ago I said the sum of the capabilities of
each member of the federation is important, besides having a common
denominator.

> Sent: Friday, July 28, 2006 7:30 AM