Subject: RE: [Speermint] Voice codecs

From: "Lipford, Mark A [CTO]" <[email-masked]>
Date: Thu, 27 Jul 2006 15:27:09 -0500

See inline

-----Original Message-----
From: Henry Sinnreich [mailto:[email-masked]] 
Sent: Thursday, July 27, 2006 3:01 PM
To: Lipford, Mark A [CTO]
Cc: Khan, Sohel Q [CTO]; [email-masked]; Greg Herlein; Francois
Menard; Ed Okerson
Subject: RE: [Speermint] Voice codecs

Mark Lipford writes:

> Can we support some mechanism for support codec negotiations with 
> a default "fall back" to G.711

Technically, the uncompressed G.711 (1960's PCM) is definitely the worst
choice for a default:

- Narrow band telephony at 3.1 kHz audio bandwidth (why do we have BB?)
- Highest bandwidth consumed: Almost 90 kb/s with RTP/UDP/IP overhead
- There are better mechanisms for Fax.

Why do you avoid SPEEX and iLBC (RFC 3951 and RFC 3952) and what are
your selection criteria? Can you explain?
[Lipford, Mark A [NTK]] I am OK with SPEEX and iLBC as defaults, I used
G.711 due to 19 years in Telco :-)  The main point I was wanting to try
and gain some agreement around is that narrowband (i.e. 3GPP and 3GPP2
3G networks) is/are deploying IMS networks and using EVRC and AMR.  The
I-D I am looking at is about Requirements for VoIP interconnection.  If
this is the case it appears that support for these codecs seems to make
some sense.  Again, as far as SEEX and iLBC are concerned that's OK, I'm
just an old telco guy.

Thanks, Henry

-----Original Message-----
From: Lipford, Mark A [CTO] [mailto:[email-masked]] 
Sent: Thursday, July 27, 2006 1:46 PM
To: Francois Menard; Henry Sinnreich
Cc: Khan, Sohel Q [CTO]; [email-masked]; Greg Herlein; Ed Okerson
Subject: RE: [Speermint] Voice codecs

This is in response to the question to Sohel regarding Broadband.

Yes, we are very involved in broadband, and believe wireless broadband
will become extremely active in the next few years, but the reality is
that in the 3G work both EVRC and AMR are both widely deployed and with
IMS deployments starting to "spring up" around the global it is probably
important to also consider these needs.

Can we support some mechanism for support codec negotiations with a
default "fall back" to G.711 or some other well known default?

I do believe that we need to also consider the narrowband deployments.

Thanks

-----Original Message-----
From: Francois Menard [mailto:[email-masked]] 
Sent: Thursday, July 27, 2006 1:41 PM
To: Henry Sinnreich
Cc: Khan, Sohel Q [CTO]; [email-masked]; Greg Herlein; Ed Okerson
Subject: Re: [Speermint] Voice codecs

I come from Sherbrooke and you know I vote hands down for Speex

Jean-Marc Valin prof @ U Sherbrooke has done more for the Internet than 
people are willing to give him credit for.

F.

--
Francois D. Menard
Project Manager/Charge de projet
Xit telecom inc.
1350 Royale # 800
Trois-Rivieres, QC, G9A 4J4
Tel: +1 819 374 2556 x 268
Cell: +1 819 692 1383
[email-masked]

On Thu, 27 Jul 2006, Henry Sinnreich wrote:

> Sohel,
>
>> A minimum set of Codecs needs to be supported that includes EvRC.
>
> How does the EvRC codec compare to the 'Internet Codecs' iLBC and
SPEEX?
>
> - Open source code?
> - Licensing fees?
> - Audio bandwidth?
> - Audio quality package?
> - APIs and codec abstraction for developers?
> - Independent lab quality assessments, etc.?
>
> More generic:
>
> How do all such closed, licensed, _narrowband voice only_ codecs
benefit
> global Internet communications and why should the IETF care?
>
> Have you heard of broadband? :-)
> (Note: I am a happy EVDO Sprint user).
>
> Thanks, Henry
>
> -----Original Message-----
> From: Khan, Sohel Q [CTO] [mailto:[email-masked]]
> Sent: Thursday, July 27, 2006 10:28 AM
> To: Jean-Francois Mule; [email-masked]
> Subject: [Speermint] Draft-ietf-speermint-requirements-00.txt
>
>
> These issues were discussed before; however, I am trying to reopen the
> discussion.
>
> Section 3.3:
>
> On Codec requirements:
> A minimum set of Codecs needs to be supported that includes EvRC.
>
> On Editor's note:
> Fax, DTMF signaling, TTY/TDD, instant messaging, and presence need to
be
> supported.
>
>
> Thank you.
>
> Sohel Khan, Ph.D.
> Technology Strategist
> Sprint-Nextel
> 913-794-1470 (office)
> 913-486-3145 (cell)
>
>
>
>
>
>
> _______________________________________________
> Speermint mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/speermint
>
> _______________________________________________
> Speermint mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/speermint
>

_______________________________________________
Speermint mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speermint

_______________________________________________
Speermint mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speermint

_______________________________________________
Speermint mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speermint

---

From: "Henry Sinnreich" <[email-masked]>
Date: Thu, 27 Jul 2006 13:59:07 -0700

Mark Lipford writes:

> I am OK with SPEEX and iLBC as defaults

Thanks and I am very happy we can come closer to an agreement on this!

Are there any other opinions on using SPEEX and iLBC (RFC 3951 and RFC
3952) as defaults for IP-IP broadband?

Thanks again, Henry

-----Original Message-----
From: Lipford, Mark A [CTO] [mailto:[email-masked]] 
Sent: Thursday, July 27, 2006 3:27 PM
To: Henry Sinnreich
Cc: Khan, Sohel Q [CTO]; [email-masked]; Greg Herlein; Francois
Menard; Ed Okerson

See inline

-----Original Message-----
From: Henry Sinnreich [mailto:[email-masked]] 
Sent: Thursday, July 27, 2006 3:01 PM
To: Lipford, Mark A [CTO]
Cc: Khan, Sohel Q [CTO]; [email-masked]; Greg Herlein; Francois
Menard; Ed Okerson

Thanks, Henry

-----Original Message-----
From: Lipford, Mark A [CTO] [mailto:[email-masked]] 
Sent: Thursday, July 27, 2006 1:46 PM
To: Francois Menard; Henry Sinnreich
Cc: Khan, Sohel Q [CTO]; [email-masked]; Greg Herlein; Ed Okerson
Subject: RE: [Speermint] Voice codecs

Thanks

-----Original Message-----
From: Francois Menard [mailto:[email-masked]] 
Sent: Thursday, July 27, 2006 1:41 PM
To: Henry Sinnreich
Cc: Khan, Sohel Q [CTO]; [email-masked]; Greg Herlein; Ed Okerson
Subject: Re: [Speermint] Voice codecs

F.

SPEEX?
benefit
be

---

From: "Klaus Darilion" <[email-masked]>
Date: Fri, 28 Jul 2006 00:58:02 +0200 (CEST)

> 3952) as defaults for IP-IP broadband?

Yes. Please count the number of terminal adaptor and SIP hardphones that
support SPEEX and iLBC versus G.711.

regards
klaus