Subject: RE: [Speermint] Policy Definition

From: "Jean-Francois Mule" <[email-masked]>
Date: Wed, 18 Oct 2006 08:47:43 -0600

Reinaldo wrote:
> I believe when the SIPPING folks defined session-dependent and
> session-independent polcies they knew that static policies existed.
> When
> you sign a VoIP contract with a Cable providers there are static
> policies in place and when two VSPs peer they also sign a contract. It
> is no different, the question we need to ask is how much text real
> estate we need to give to static policies. Does a IETF WG need to care
> if there are policies driven by a contract? I wonder if there are
> similar considerations in Inter Domain Routing WG.
> 
> Anyway, I just want to make it consistent with other IETF work.
> 
> As far as the definition below, I do not believe it is "globally"
> defined. Not even static policies might be global. Many dynamic
Ok, deleted "globally"

> policies
> (whether session dependent or independent) are local to a specific
> peering point (assuming VSPs peer at more than one location) and/or
> even
> a proxy (calls per second, bw, etc).

Any more specific comments on the policy def?
Folks seem to be so focused on "static" vs. "dynamic", even when we are
trying to define what is that 'thing' that could be statically or
dynamically exchanged. 

Jean-Francois.

> 
> Thanks,
> 
> Reinaldo
> 
> > -----Original Message-----
> > From: Jean-Francois Mule [mailto:[email-masked]]
> > Sent: Tuesday, October 17, 2006 8:55 AM
> > To: Brian Rosen; Reinaldo Penno; Daryl Malas; David Schwartz
> > Cc: [email-masked]
> > Subject: RE: [Speermint] Policy Definition
> >
> > Here is another try based on yesterday's dialogs:
> >
> > --- Session peering 'policy' definition:
> > "In the context of session peering, a policy is globally
> > defined as the set of parameters and other information needed
> > by one VSP/ASP to connect to another.
> > Some of the session policy parameters may be statically
> > exchanged and set throughout the lifetime of the peering
> > relationship. Others parameters may be discovered and updated
> > dynamically using by some explicit protocol mechanisms. These
> > dynamic parameters may also relate to a VSP/ASP's
> > session-dependent or session independent policies as defined
> > in [ID-sipping-policy].
> >
> > Notes:
> >  - this revised text injects the notions of 'static' vs.
> > dynamic policy params Brian proposed; the addressing/routing
> > is part of the session-dependent and session-independent
> > policies of a domain (as you proposed Brian).
> >  - it links speermint's policy def (focused on inter-domain)
> > with the sipping's def (focused on intra-domain) per
> > Reinaldo's proposal.
> >
> > Thoughts? Good enough for now or not?
> >
> > Jean-Francois.
> >
> >

_______________________________________________
Speermint mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speermint

---

From: "Reinaldo Penno" <[email-masked]>
Date: Wed, 18 Oct 2006 13:19:53 -0400

Jean-Francois,

If all we want is the definition of policy, we can get that from RFC3198
"Terminology for Policy-Based Management
".

"$ policy
      (P) "Policy" can be defined from two perspectives:
          -  A definite goal, course or method of action to guide and
             determine present and future decisions.  "Policies" are
             implemented or executed within a particular context (such
             as policies defined within a business unit).
          -  Policies as a set of rules to administer, manage, and
             control access to network resources [RFC3060].

          Note that these two views are not contradictory since
          individual rules may be defined in support of business goals.
          (See also "policy goal", "policy abstraction" and "policy
          rule".)"

As far as what can be exchanged, I would say any parameters that can
affect CRD (Call Routing Data). There is no need to list which
parameters at this point but just state the purpose of a policy
exchange.

Regards,

Reinaldo

> Sent: Wednesday, October 18, 2006 7:48 AM
> To: Reinaldo Penno; Brian Rosen; Daryl Malas; David Schwartz
> Cc: [email-masked]
> > even a proxy (calls per second, bw, etc).
> 
> Folks seem to be so focused on "static" vs. "dynamic", even 
> when we are trying to define what is that 'thing' that could 
> be statically or dynamically exchanged. 
> 
> Jean-Francois.
> 
> > 
> > Thanks,
> > 
> > Reinaldo
> > 
> defined as 
> > > the set of parameters and other information needed by one 
> VSP/ASP to 
> > > connect to another.
> > > Some of the session policy parameters may be statically exchanged 
> > > and set throughout the lifetime of the peering 
> relationship. Others 
> > > parameters may be discovered and updated dynamically 
> using by some 
> > > explicit protocol mechanisms. These dynamic parameters may also 
> > > relate to a VSP/ASP's session-dependent or session independent 
> > > policies as defined in [ID-sipping-policy].
> > >
> > > Notes:
> > > dynamic policy params Brian proposed; the 
> addressing/routing is part 
> > > of the session-dependent and session-independent policies of a 
> > > domain (as you proposed Brian).
> > >  - it links speermint's policy def (focused on inter-domain) with 
> > > the sipping's def (focused on intra-domain) per 
> Reinaldo's proposal.
> > >