Subject: RE: [Speermint] comments on draft-ietf-speermint-terminology-06.txt

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Mon, 2 Oct 2006 10:48:47 -0400

Inline. 

> -----Original Message-----
> From: Klaus Darilion [mailto:[email-masked]] 
> Sent: Friday, September 29, 2006 9:56 AM
> To: [email-masked]
> Subject: [Speermint] comments on 
> draft-ietf-speermint-terminology-06.txt
> 
> Hi David!
> 
> Some comments to the terminology draft:

[snip]

>  > 3.8.  Service Provider
>  >
>  > A Service Provider (or SP) is defined to be an entity that 
> provides  > layer 3 (IP) transport of SIP signaling and media packets.
> 
> Thus this would be every ISP which do not block SIP traffic?

I thought SP included both ISP and VSP.

>  > 3.9.  Voice Service Provider
>  >
>  > A Voice Service Provider (or VSP) is an entity that 
> provides  > transport of SIP signaling to its customers.  In 
> the event that the
>    ^^^^^^^^^^
> Does a Voice server Provider needs transport? Thus every ISP 
> which do not block SIP would be a voice service provider? I 
> think this is not the intended definition. What about:
> 
>        A Voice Service Provider (or VSP) is an entity that provides
>        SIP signaling to its customers.

Agree with the problem.  It is not about transport, it is about
processing L5 traffic.  Provides is also vague.  How about "processes
SIP siganling for its customers."

>  > VSP is also an SP, it may also provide media streams to 
> its  > customers.  Such a service provider may additionally 
> be  > interconnected with other service providers; that is, 
> it may "peer"
>  > with other service providers.  A VSP may also interconnect 
> with the  > PSTN.
> 
> What do you mean with "peering" here. L3 oder L5?
 
[snip]
 
> Maybe a figure would be helpful:
> 
> A: VSP A
> B: VSP B
> T: Transit VSP
> 
>          A <---direct peering ---> T <--- direct peering ---> B
> 
>          ^                                                    ^
>          |                                                    |
>          \--------- indirect peering between A and B ---------/

This is backwards.  
Direct peering is between A and B.
Indirect peering is between A and B indirectly through T.

>  > 4.2.3.  Assisted Peering
>  >
>  > In this case, some entity (usually a federation, see 
> Section 5)  > employs a central SIP proxy (which is not 
> itself a VSP) to bridge  > calls between participating networks.
> 
>                                 ^^^^^
> IMO "participating peering networks" would add clarity.
> 
>  > 5.  Federations
>  >
> ...
>  >
>  > Finally, note that a SP can be a member of  >
>  >    *  No federation (e.g., the SP has only bilateral peering
>  >       agreements)
>  >
>  >    *  A single federation
>  >
>  >    *  Multiple federations
>  >
>  > and an SP can have any combination of bi-lateral and 
> multi-lateral  > (i.e., federated) interconnections.

Another thought is to put for first option above:

* Degenerate federation (2 members = bilateral peering)

Mike

> 
> SP should be replaced with VSP (3 times)
> 
> regards
> Klaus
> 
> --
> Klaus Darilion
> nic.at
> 
> _______________________________________________
> Speermint mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/speermint
> 

_______________________________________________
Speermint mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speermint

---

From: "James McEachern" <[email-masked]>
Date: Thu, 5 Oct 2006 08:28:54 -0400

Mike,

[snip]

  > Indirect peering is between A and B indirectly through T.

Changing the labels on this diagram will still be misleading.  How about the following?

               A <------------------------------------------------> B
                        A-B "direct peering"

               A <---------------------> T <----------------------> B
                        A-B "indirect peering"

Jim

---

From: Klaus Darilion <[email-masked]>
Date: Thu, 05 Oct 2006 16:59:18 +0200

>                A <---------------------> T <----------------------> B

This looks fine.

regards
klaus

---

From: Daryl Malas <[email-masked]>
Date: Thu, 05 Oct 2006 09:04:36 -0600

I like the change. --Daryl