Subject: Re: [Speermint] Source-based routing

From: "Shawn Pouliotte" <[email-masked]>
Date: Wed, 08 Nov 2006 22:20:53 -0800

Hi Richard,
    
    Not sure I am completely clear on what you are saying...
    
    Do you mean the ip address (if the originator is even IP) of the  calling party or the ip address of the querying entity? If you mean the  originating subscriber, can you explain why you would care? If this is  a peering app, I would think you care who is presenting the call in  terms of determining what element to bring the call in on and not  whether the original caller was in Germany or Uganda. Likelyhood is you  would not even know depending on the way topology hiding was done.  Unless I am missing something, the traffic exchange agreements are  based on where the interconnect wants to terminate and not what the  originating geography was of the originator. 
    
    If I misunderstood you, please clarify. If not - and you do mean  originating subscriber ip address then please give a use case and  elaborate.
    
    Thanks and sorry if I misunderstood
    Shawn  _____  

From: Stastny Richard [mailto:[email-masked]]
To:  Uzelac, Adam [mailto:[email-masked]], Pfautz, Penn L,  GBLAM [mailto:[email-masked]], Reinaldo Penno  [mailto:[email-masked]], [email-masked]
Sent: Wed, 08 Nov 2006 21:46:53 -0800
Subject: Re: [Speermint] Source-based routing

>I am thinking originating network not user, at this stage.
   
  But it is the user what counts in L3 mediastream
  For signalling the location of the proxies is irrelevant
   
  We have to be very carefull here and really exactly define the requirements
   
  Richard
  
  ________________________________
  
  Von: Uzelac, Adam [mailto:[email-masked]]
  Gesendet: Do 09.11.2006 05:33
  An: Pfautz, Penn L, GBLAM; Reinaldo Penno; [email-masked]
  Betreff: RE: [Speermint] Source-based routing

  Penn,
  
  Thanks for setting me straight with regards to the requirements  citation. I believe that we indeed do need to add a provision in the  requirements to account for geography. That criteria would not pertain  to mobile scenarios, but in geographically static environments where  the request originates is pertinent. I am thinking originating network  not user, at this stage.
  
  -AU
  
   -----Original Message-----
  From:   Pfautz, Penn L, GBLAM [mailto:[email-masked]]
  Sent:   Wed Nov 08 22:07:54 2006
  To:     Reinaldo Penno; Uzelac, Adam; [email-masked]
  Subject:        RE: [Speermint] Source-based routing
  
  I thought we did have a requirement that addressed at least part of this
  issue in
  draft-ietf-speermint-requirements-01.txt:
  
  o  Variability of the Call Address Data:
        A terminating VSP/ASP or user SHOULD be able to indicate its
        domain ingress points (Signaling Path Border Element(s)) based on
        the identity of the originating VSP/ASP or user.
        The mechanisms recommended for the use and resolution of the call
        addressing data SHOULD allow for variability or customization of
        the response(s) depending on various elements, such as the
        identity of the originating or terminating user or user domain.
  
  Are you asking just to add geographic origin info to this?
  I see originating entity and location info helping to determine routing
  but it's not clear to me that this isn't a multi-stage (and maybe
  multi-protocol) process.
  And by location, are we talking originating user location  or
  originating network element location?
  
  Penn
  -----Original Message-----
  From: Reinaldo Penno [mailto:[email-masked]]
  Sent: Wednesday, November 08, 2006 7:24 PM
  To: Uzelac, Adam; [email-masked]
  Subject: RE: [Speermint] Source-based routing
  
  Although I'm not a VSP I agree. At some point we discussed on this the
  fact that identity/geography/others should be taken into account when
  discovering/returning next-hop. That kind of faded way but seems a real
  problem to be tackled.
  
  Regards,
  
  Reinaldo
  
  > -----Original Message-----
  > From: Uzelac, Adam [mailto:[email-masked]]
  > Sent: Wednesday, November 08, 2006 4:18 PM
  > To: [email-masked]
  > Subject: [Speermint] Source-based routing
  >
  > Folks,
  >
  > I would like to propose that we add to the list of
  > requirements for SPEERMINT that any session routing proposal
  > that is proposed take into account the ability to use some
  > source criteria to return next-hop routes. I just re-read the
  > requirements draft, and I did not see anything specifically
  > addressing source-based routing.
  >
  > Speaking as a VSP, it's important that the ingress session
  > border element that is returned to the originator of the
  > request be based on, among other things, who's asking and
  > from where.  In practice, we do not return next-hop
  > information irrespective if the request comes from Alice/Bob,
  > or from China/Brazil.  This may be a matter of local policy,
  > but the tools and IDs that address session next-hop
  > determination need to account for this.
  >
  > -AU
  >
  > _______________________________________________
  > Speermint mailing list
  > [email-masked]
  > https://www1.ietf.org/mailman/listinfo/speermint
  >
  
  _______________________________________________
  Speermint mailing list
  [email-masked]
  https://www1.ietf.org/mailman/listinfo/speermint

  _______________________________________________
  Speermint mailing list
  [email-masked]
  https://www1.ietf.org/mailman/listinfo/speermint

_______________________________________________
Speermint mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speermint

---

From: "Stastny Richard" <[email-masked]>
Date: Thu, 9 Nov 2006 08:46:30 +0100

What I wanted to say is that 
 
1. the whole issue is only relevant in the collapsed peering picture
(figure 2 in draft-ietf-speermint-flows). In the basic peering
picture the media goes directly from user to user
 
2.in figure 2 this makes sense, but also raises a lot of questions
- who is taking the lead - the originating or terminating part
(IMO the terminating part, but the decision has to be done be
the originating part)
- what are the criteria?
distance
function
domain
codec
...
 
Richard

Von: Shawn Pouliotte [mailto:[email-masked]]
Gesendet: Do 09.11.2006 07:20
An: [email-masked]
Betreff: Re: [Speermint] Source-based routing

Hi Richard,

Shawn 

	

	
	Richard

	
	Penn,

	-AU
	
	-----Original Message-----
	From: Pfautz, Penn L, GBLAM [mailto:[email-masked]]
	Sent: Wed Nov 08 22:07:54 2006
	To: Reinaldo Penno; Uzelac, Adam; [email-masked]
	Subject: RE: [Speermint] Source-based routing

	
	
	Penn
	-----Original Message-----
	From: Reinaldo Penno [mailto:[email-masked]]
	Sent: Wednesday, November 08, 2006 7:24 PM
	To: Uzelac, Adam; [email-masked]
	Subject: RE: [Speermint] Source-based routing

	Regards,
	
	Reinaldo

---

From: "David Schwartz" <[email-masked]>
Date: Thu, 9 Nov 2006 11:04:13 +0200

I think the idea to define requirements for provisioning data format will address this issue. For example, one piece of information that MUST be provisioned is the resultant URI for a given E.164 number. While typically this is a 1-1 relationship there is no reason for this to be so as there can be many reasons why different requesting entities resolve to different URIs. I will say that the reasons are not always geographical.
 
I think therefore that this thread should wait for a draft on this. Getting this draft out quickly is essential. I hope to publish to the list in the next few days (weeks?) some information on what data we require when uploading to our registries.
 
David

From: Stastny Richard [mailto:[email-masked]]
Sent: Thu 11/9/2006 9:46 AM
To: Shawn Pouliotte; [email-masked]
Subject: Re: [Speermint] Source-based routing

Richard

Hi Richard,

       

       
        Richard

       
        Penn,

        -AU
       
        -----Original Message-----
        From: Pfautz, Penn L, GBLAM [mailto:[email-masked]]
        Sent: Wed Nov 08 22:07:54 2006
        To: Reinaldo Penno; Uzelac, Adam; [email-masked]
        Subject: RE: [Speermint] Source-based routing

       
       
        Penn
        -----Original Message-----
        From: Reinaldo Penno [mailto:[email-masked]]
        Sent: Wednesday, November 08, 2006 7:24 PM
        To: Uzelac, Adam; [email-masked]
        Subject: RE: [Speermint] Source-based routing

        Regards,
       
        Reinaldo