Subject: RE: [Speermint] Source-based routing

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Sat, 11 Nov 2006 15:37:08 -0500

So, the media now follows a non-optimal path?

Mike

> -----Original Message-----
> From: Reinaldo Penno [mailto:[email-masked]] 
> Sent: Thursday, November 09, 2006 3:36 PM
> To: Shawn Pouliotte; Patrick Melampy; Michael Haberler
> Cc: [email-masked]; Uzelac, Adam
> Subject: RE: [Speermint] Source-based routing
> 
> Hello Shawn,
> 
> the reverse is also true. If you _do not_ have a collapsed 
> peering scheme (signaling and media crossing at the same 
> point through media anchoring), chances are media is going to 
> follow layer 3 routing and signaling Layer 5 (route headers, 
> outbound proxy, etc, etc). And they might in fact go to two 
> different completely locations.
> 
> So, maybe what you actually like is for media to follow 
> signaling after you discover the "best" (whatever that means) 
> signaling crossing point.
> 
> Regards,
> 
> Reinaldo
> 
> > -----Original Message-----
> > From: Shawn Pouliotte [mailto:[email-masked]]
> > Sent: Thursday, November 09, 2006 12:19 PM
> > To: Patrick Melampy; 'Michael Haberler'; Reinaldo Penno
> > Cc: [email-masked]; 'Uzelac, Adam'
> > Subject: Re: [Speermint] Source-based routing
> > 
> > I think the biggest question for me is what is important at the 
> > peering point - there are a lot of things that could 
> theoretically be 
> > signaled but what is important? You are trying to decide 
> if, how and 
> > where to admit traffic into a network.
> > 
> > 
> > For this chain, yes, I was thinking about a collapsed BG model. You 
> > are alluding to a mid-com model as I read it. I only know 
> of 1 vendor 
> > offering
> > H.248 controlled ip to ip gateways and they are not seeing much 
> > success. I know of one other vendor that is developing in 
> this area. 
> > The general driver for this as I understood was 
> streamlining resources 
> > by splitting signaling and media, offering a better scaling model, 
> > better resource selection model, and h/a model. That said, 
> I have not 
> > run into anyone that actually wanted media path in a vastly 
> different 
> > geography from signaling. Nothing would preclude it. I am 
> curious to 
> > hear thoughts from the carrier representatives on the list.
> > 
> > So, with all that I certainly don't disagree that source based 
> > parameters play a role in route selection. When the group makes 
> > recommendations on those, we should understand the use 
> cases and why 
> > they are important (in a deployable network).
> > 
> > Shawn
> > 
> > 
> > On 11/9/06 11:20 AM, "Patrick Melampy" 
> > <[email-masked]> wrote:
> > 
> > > The real issue here affects signaling and media. It appears
> > to me that
> > > the correct algorithm to use would be based on the offered
> > addresses
> > > in the SDP, and which border signaling point is closest. 
> > The reasons for this are:
> > > 
> > > 1.) The signaling originator may not be co-located with the
> > source of media.
> > > This is often the case with Softswitch/Media Gateway sources of 
> > > traffic. Its also like to be true with Softswitch Based endpoints
> > > (MGCP/NCS) where the call controller is centrally 
> located, but the 
> > > endpoints are widely distributed.
> > > 
> > > 2.) The signaling crossing point that is closes to the
> > source of the
> > > media provides a "best crossing point" for the media as well.
> > > 
> > > Although I've resisted talking about the media --- its truly 
> > > important. The location of the media crossing point, and
> > the control
> > > of the media, are as important as any other aspect in peering.
> > > 
> > > There are some that would suggest the signaling crossing 
> points and 
> > > media crossing points are un-related. But to subsequently setup, 
> > > manage, and control the media with a middle box requires the same 
> > > determination of the best media crossing point. The 
> mechanisms for 
> > > doing this "locate the best middle box" are weak at best.
> > Some say use
> > > a policy server. However none of the policy server
> > interfaces I have
> > > seen proposed by ETSI TISPAN, 3GPP, seem to include a "source ip 
> > > address" in the request to help choose a destination ip
> > address. While
> > > out of the scope of this working group, one should consider
> > the utility of the following suggestion.
> > > 
> > > I propose that the best signaling crossing point be
> > determined based
> > > on the source of the media. This would provide for a
> > defined crossing
> > > point that then could manage the media flows by association.
> > > 
> > > -----Original Message-----
> > > From: Michael Haberler [mailto:[email-masked]]
> > > Sent: Thursday, November 09, 2006 2:38 AM
> > > To: Reinaldo Penno
> > > Cc: [email-masked]; Uzelac, Adam
> > > Subject: Re: [Speermint] Source-based routing
> > > 
> > > Reinaldo Penno schrieb:
> > >> I guess the problem statement is:
> > >> 
> > >> For a certain call, how to I find the most appropriate
> > egress/ingree
> > >> peering point?
> > >>   
> > > 
> > > I'm not sure wether that was what Adam meant - need to clarify
> > > 
> > > I see two interpretations:
> > > - topological optimization of next hop (IP adress, distance..)
> > > - a parameter into policy application - for resolution
> > services which
> > > might give different answers to different originators
> > > 
> > > 
> > > 
> > > -Michael
> > > 
> > > _______________________________________________
> > > Speermint mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/speermint
> > > 
> > > 
> > > _______________________________________________
> > > Speermint mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/speermint
> > 
> > 
> > 
> 
> _______________________________________________
> Speermint mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/speermint
> 

_______________________________________________
Speermint mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speermint

---

From: "Reinaldo Penno" <[email-masked]>
Date: Sat, 11 Nov 2006 17:10:23 -0500

Hello Mike,

As I said later in the thread from a layer 3 perspective (pure routing)
that might not be optimal, but maybe optimal from a media services or
business perspective. So, it can go both ways.   

In the IETF cases were presented where media egress was controlled by
media relay based on who as sending the INVITE and location.

Regards,

Reinaldo

> From: Michael Hammer (mhammer) [mailto:[email-masked]] 
> Sent: Saturday, November 11, 2006 12:37 PM
> To: Reinaldo Penno; Shawn Pouliotte; Patrick Melampy; Michael Haberler
> > the reverse is also true. If you _do not_ have a collapsed peering 
> > scheme (signaling and media crossing at the same point 
> through media 
> > anchoring), chances are media is going to follow layer 3 
> routing and 
> > signaling Layer 5 (route headers, outbound proxy, etc, 
> etc). And they 
> > might in fact go to two different completely locations.
> > 
> > So, maybe what you actually like is for media to follow signaling 
> > after you discover the "best" (whatever that means) 
> signaling crossing 
> > point.
> > 
> > Regards,
> > 
> > Reinaldo
> >

---

From: "Hadriel Kaplan" <[email-masked]>
Date: Sun, 12 Nov 2006 22:00:09 -0500

I don't mean to jump in on this thread's ultimate topic, but in reference to
the statement below, you and I and the UA's have no idea what the optimal
path is.  It is NOT necessarily the BGP/IGP path, for example.  As you well
know, BGP/IGP do not determine/create the optimal path for latency, jitter,
nor even bandwidth.  The border element path may be more optimal, the same,
or less.  The only one who could know the optimal path is the network
operator.  Whether they do know it or not, and whether they take advantage
of it, depends on them and their network design.

-hadriel

> Sent: Saturday, November 11, 2006 3:37 PM

---

From: "Stastny Richard" <[email-masked]>
Date: Mon, 13 Nov 2006 12:00:05 +0100

Simple question
 
Regarding source based routing and what "close" means, do we really
want to be involved in this discussion:

  http://potaroo.net/ispcol/2006-11/raw.html <http://potaroo.net/ispcol/2006-11/raw.html> 
 
or leave this to other people and groups?
 
Richard

---

From: "Henry Sinnreich" <[email-masked]>
Date: Mon, 13 Nov 2006 06:59:34 -0800

Stastny Richard writes:

> Regarding source based routing and what "close" means, 
> do we really want to be involved in this discussion

This is an excellent question and points to the fact that we don't have
in SIP any reasonably simple routing protocols, such as exist in IP.
Instead of a routing protocol, at this point in time there is a big list
of RFCs and I-Ds with countless rules that keep changing and that only
very few implementers could have the expertise to follow - assuming
there was agreement on all the rules, which isn't. Provisioned SBCs seem
to rule in interdomain routing instead.

The complexity of SIP routing makes also multi-vendor interoperability
rather unlikely in infrastructure based VoIP networks.

If there is to be a SIP routing protocol, it must be simple as stated in
the papers quoted here below.

This is the reason why P2P SIP (which has clear cut routing protocols)
and the simple trapezoid model for interdomain SIP routing make more
sense IMHO.

True SIP routing protocols beyond the trapezoid model may be better
developed however in the SIP WG.

Thanks, Henry

-----Original Message-----
From: Stastny Richard [mailto:[email-masked]] 
Sent: Monday, November 13, 2006 5:00 AM
To: [email-masked]
Subject: Re: [Speermint] Source-based routing

Simple question

  http://potaroo.net/ispcol/2006-11/raw.html
<http://potaroo.net/ispcol/2006-11/raw.html> 

Richard