Subject: RE: [Speermint] Source-based routing

From: "Uzelac, Adam" <[email-masked]>
Date: Wed, 8 Nov 2006 23:33:00 -0500

Penn,

Thanks for setting me straight with regards to the requirements citation.  I believe that we indeed do need to add a provision in the requirements to account for geography.  That criteria would not pertain to mobile scenarios, but in geographically static environments where the request originates is pertinent.  I am thinking originating network not user, at this stage.

-AU

 -----Original Message-----
From: 	Pfautz, Penn L, GBLAM [mailto:[email-masked]]
Sent:	Wed Nov 08 22:07:54 2006
To:	Reinaldo Penno; Uzelac, Adam; [email-masked]
Subject:	RE: [Speermint] Source-based routing

I thought we did have a requirement that addressed at least part of this
issue in
draft-ietf-speermint-requirements-01.txt:

o  Variability of the Call Address Data:
      A terminating VSP/ASP or user SHOULD be able to indicate its
      domain ingress points (Signaling Path Border Element(s)) based on
      the identity of the originating VSP/ASP or user.
      The mechanisms recommended for the use and resolution of the call
      addressing data SHOULD allow for variability or customization of
      the response(s) depending on various elements, such as the
      identity of the originating or terminating user or user domain.

Are you asking just to add geographic origin info to this?
I see originating entity and location info helping to determine routing
but it's not clear to me that this isn't a multi-stage (and maybe
multi-protocol) process.
And by location, are we talking originating user location  or
originating network element location?

Penn
-----Original Message-----
From: Reinaldo Penno [mailto:[email-masked]] 
Sent: Wednesday, November 08, 2006 7:24 PM
To: Uzelac, Adam; [email-masked]
Subject: RE: [Speermint] Source-based routing

Although I'm not a VSP I agree. At some point we discussed on this the
fact that identity/geography/others should be taken into account when
discovering/returning next-hop. That kind of faded way but seems a real
problem to be tackled.

Regards,

Reinaldo

> -----Original Message-----
> From: Uzelac, Adam [mailto:[email-masked]] 
> Sent: Wednesday, November 08, 2006 4:18 PM
> To: [email-masked]
> Subject: [Speermint] Source-based routing
> 
> Folks,
> 
> I would like to propose that we add to the list of 
> requirements for SPEERMINT that any session routing proposal 
> that is proposed take into account the ability to use some 
> source criteria to return next-hop routes. I just re-read the 
> requirements draft, and I did not see anything specifically 
> addressing source-based routing. 
> 
> Speaking as a VSP, it's important that the ingress session 
> border element that is returned to the originator of the 
> request be based on, among other things, who's asking and 
> from where.  In practice, we do not return next-hop 
> information irrespective if the request comes from Alice/Bob, 
> or from China/Brazil.  This may be a matter of local policy, 
> but the tools and IDs that address session next-hop 
> determination need to account for this.
> 
> -AU
> 
> _______________________________________________
> Speermint mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/speermint
> 

_______________________________________________
Speermint mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speermint
_______________________________________________
Speermint mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speermint

---

From: "Stastny Richard" <[email-masked]>
Date: Thu, 9 Nov 2006 06:46:53 +0100

>I am thinking originating network not user, at this stage.
 
But it is the user what counts in L3 mediastream
For signalling the location of the proxies is irrelevant
 
We have to be very carefull here and really exactly define the requirements
 
Richard

________________________________

Von: Uzelac, Adam [mailto:[email-masked]]
Gesendet: Do 09.11.2006 05:33
An: Pfautz, Penn L, GBLAM; Reinaldo Penno; [email-masked]
Betreff: RE: [Speermint] Source-based routing

Penn,

-AU

 -----Original Message-----
From:   Pfautz, Penn L, GBLAM [mailto:[email-masked]]
Sent:   Wed Nov 08 22:07:54 2006
To:     Reinaldo Penno; Uzelac, Adam; [email-masked]
Subject:        RE: [Speermint] Source-based routing

Penn
-----Original Message-----
From: Reinaldo Penno [mailto:[email-masked]]
Sent: Wednesday, November 08, 2006 7:24 PM
To: Uzelac, Adam; [email-masked]
Subject: RE: [Speermint] Source-based routing

Regards,

Reinaldo

---

From: "Reinaldo Penno" <[email-masked]>
Date: Thu, 9 Nov 2006 01:59:04 -0500

Well put Richard. We keep putting media to the side. I think Adam did
not do it on purpose, it is just force of habit (;-) since he has
collpased peering points. 

So, by call we mean signaling and media.

> From: Stastny Richard [mailto:[email-masked]] 
> Sent: Wednesday, November 08, 2006 9:47 PM
> To: Uzelac, Adam; Pfautz, Penn L, GBLAM; Reinaldo Penno; 
> [email-masked]
> Subject: Re: [Speermint] Source-based routing
> 
> But it is the user what counts in L3 mediastream For 
> signalling the location of the proxies is irrelevant
>  
> Thanks for setting me straight with regards to the 
> requirements citation.  I believe that we indeed do need to 
> add a provision in the requirements to account for geography. 
>  That criteria would not pertain to mobile scenarios, but in 
> geographically static environments where the request 
> originates is pertinent.  I am thinking originating network 
> not user, at this stage.
> 
> -AU
> 
> I thought we did have a requirement that addressed at least 
> part of this issue in
> I see originating entity and location info helping to 
> determine routing but it's not clear to me that this isn't a 
> multi-stage (and maybe
> multi-protocol) process.
> Although I'm not a VSP I agree. At some point we discussed on 
> this the fact that identity/geography/others should be taken 
> into account when discovering/returning next-hop. That kind 
> of faded way but seems a real problem to be tackled.
> 
> Regards,
> 
> Reinaldo
> 
> > I would like to propose that we add to the list of requirements for 
> > SPEERMINT that any session routing proposal that is 
> proposed take into 
> > account the ability to use some source criteria to return next-hop 
> > routes. I just re-read the requirements draft, and I did not see 
> > anything specifically addressing source-based routing.
> >
> > Speaking as a VSP, it's important that the ingress session border 
> > element that is returned to the originator of the request 
> be based on, 
> > among other things, who's asking and from where.  In 
> practice, we do 
> > not return next-hop information irrespective if the request 
> comes from 
> > Alice/Bob, or from China/Brazil.  This may be a matter of local 
> > policy, but the tools and IDs that address session next-hop

---

From: "Uzelac, Adam" <[email-masked]>
Date: Thu, 9 Nov 2006 14:20:55 -0500

Richard - I absolutely understand the use case that you are referring to
- it is the roaming user that is registered to a "home" proxy from afar.
It's positively true that we can't assume anything about the user's
location based on any assumed location of the proxy that initiates
requests on behalf of that user.  That point might need to be included
in the requirements, but it should go without saying.  

I think that the requirement as it reads in the current requirements
draft needs a little noodling:

First sentence currently reads: A terminating VSP/ASP or user SHOULD be
able to indicate its domain ingress points (Signaling Path Border
Element(s)) based on the identity of the originating VSP/ASP or user.

Proposed change: <removal of the above and only state> The mechanisms
recommended for the use and resolution of the call addressing data
SHOULD allow for variability or customization of the response(s)
depending on various elem the most appropriate egress/ingree
> peering point? 

I'm not sure wether that was what Adam meant - need to clarify

I see two interpretations:
- topological optimization of next hop (IP adress, distance..)
- a parameter into policy application - for resolution services which
might give different answers to different originators

-Michael

---

From: "Uzelac, Adam" <[email-masked]>
Date: Thu, 9 Nov 2006 14:20:55 -0500

Proposed change: <removal of the above and only state> The mechanisms
recommended for the use and resolution of the call addressing data
SHOULD allow for variability or customization of the response(s)
depending on various elements, such as the source and/or identity of the
originating or any relevant terminating information of the user or user
domain. 

To address a comment Penn makes - I don't believe that this suggested
change necessitates "multi-stage (and maybe multi-protocol) process".

-AU

-----Original Message-----
From: Stastny Richard [mailto:[email-masked]] 
Sent: Wednesday, November 08, 2006 9:47 PM
To: Uzelac, Adam; Pfautz, Penn L, GBLAM; Reinaldo Penno;
[email-masked]

>I am thinking originating network not user, at this stage.
 
But it is the user what counts in L3 mediastream For signalling the
location of the proxies is irrelevant
 
We have to be very carefull here and really exactly define the
requirements
 
Richard

Penn,

Thanks for setting me straight with regards to the requirements
citation.  I believe that we indeed do need to add a provision in the
requirements to account for geography.  That criteria would not pertain
to mobile scenarios, but in geographically static environments where the
request originates is pertinent.  I am thinking originating network not
user, at this stage.

-AU

 -----Original Message-----
From:   Pfautz, Penn L, GBLAM [mailto:[email-masked]]
Sent:   Wed Nov 08 22:07:54 2006
To:     Reinaldo Penno; Uzelac, Adam; [email-masked]
Subject:        RE: [Speermint] Source-based routing

Penn
-----Original Message-----
From: Reinaldo Penno [mailto:[email-masked]]
Sent: Wednesday, November 08, 2006 7:24 PM
To: Uzelac, Adam; [email-masked]
Subject: RE: [Speermint] Source-based routing

Regards,

Reinaldo

> SPEERMINT that any session routing proposal that is proposed take into

> element that is returned to the originator of the request be based on,

> among other things, who's asking and from where.  In practice, we do 
> not return next-hop information irrespective if the request comes from

> determination need to account for thents, such as the source and/or identity of the
originating or any relevant terminating information of the user or user
domain. 

To address a comment Penn makes - I don't believe that this suggested
change necessitates "multi-stage (and maybe multi-protocol) process".

-AU

-----Original Message-----
From: Stastny Richard [mailto:[email-masked]] 
Sent: Wednesday, November 08, 2006 9:47 PM
To: Uzelac, Adam; Pfautz, Penn L, GBLAM; Reinaldo Penno;
[email-masked]

>I am thinking originating network not user, at this stage.
 
But it is the user what counts in L3 mediastream For signalling the
location of the proxies is irrelevant
 
We have to be very carefull here and really exactly define the
requirements
 
Richard

Penn,

Thanks for setting me straight with regards to the requirements
citation.  I believe that we indeed do need to add a provision in the
requirements to account for geography.  That criteria would not pertain
to mobile scenarios, but in geographically static environments where the
request originates is pertinent.  I am thinking originating network not
user, at this stage.

-AU

 -----Original Message-----
From:   Pfautz, Penn L, GBLAM [mailto:[email-masked]]
Sent:   Wed Nov 08 22:07:54 2006
To:     Reinaldo Penno; Uzelac, Adam; [email-masked]
Subject:        RE: [Speermint] Source-based routing

Penn
-----Original Message-----
From: Reinaldo Penno [mailto:[email-masked]]
Sent: Wednesday, November 08, 2006 7:24 PM
To: Uzelac, Adam; [email-masked]
Subject: RE: [Speermint] Source-based routing

Regards,

Reinaldo

> SPEERMINT that any session routing proposal that is proposed take into

> element that is returned to the originator of the request be based on,

> among other things, who's asking and from where.  In practice, we do 
> not return next-hop information irrespective if the request comes from

is.

---

From: "Pfautz, Penn L, GBLAM" <[email-masked]>
Date: Thu, 9 Nov 2006 14:34:17 -0500

Adam:
Re the point below, I'm not sure that at least multi-stage isn't
necessary but maybe it's a matter of semantics.
I look to, for example, an ENUM query returning a URI which different
entities might resolve differently.

Penn

-----Original Message-----
From: Uzelac, Adam [mailto:[email-masked]] 
Sent: Thursday, November 09, 2006 2:21 PM
To: Stastny Richard; Pfautz, Penn L, GBLAM; Reinaldo Penno;
[email-masked]

....

-AU

---

From: "Stastny Richard" <[email-masked]>
Date: Thu, 9 Nov 2006 21:05:07 +0100

>originating or any relevant terminating information of the user or user

Sounds good
 
Richard

Von: Uzelac, Adam [mailto:[email-masked]]
Gesendet: Do 09.11.2006 20:20
An: Stastny Richard; Pfautz, Penn L, GBLAM; Reinaldo Penno; [email-masked]
Betreff: RE: [Speermint] Source-based routing

-AU

-----Original Message-----
From: Stastny Richard [mailto:[email-masked]]
Sent: Wednesday, November 08, 2006 9:47 PM
To: Uzelac, Adam; Pfautz, Penn L, GBLAM; Reinaldo Penno;
[email-masked]

Richard

Penn,

-AU

 -----Original Message-----
From:   Pfautz, Penn L, GBLAM [mailto:[email-masked]]
Sent:   Wed Nov 08 22:07:54 2006
To:     Reinaldo Penno; Uzelac, Adam; [email-masked]
Subject:        RE: [Speermint] Source-based routing

Penn
-----Original Message-----
From: Reinaldo Penno [mailto:[email-masked]]
Sent: Wednesday, November 08, 2006 7:24 PM
To: Uzelac, Adam; [email-masked]
Subject: RE: [Speermint] Source-based routing

Regards,

Reinaldo