Subject: RE: [Speermint] RE: I-D ACTION:draft-elwell-speermint-enterprise- usecases-00.txt

From: "Elwell, John" <[email-masked]>
Date: Mon, 19 Feb 2007 16:27:02 +0000

Richard,

In-line.

John 

> -----Original Message-----
> From: Stastny Richard [mailto:[email-masked]] 
> Sent: 19 February 2007 14:54
> To: Elwell, John; [email-masked]
> Subject: RE: [Speermint] RE: I-D 
> ACTION:draft-elwell-speermint-enterprise-usecases-00.txt
> 
> Hi John,
> 
> > >
> > > Is it also possible that an Enterprise A may peer
> > > with more than one carrier. And if yes,
> > > how does Enterprise A distinguish between the carriers
> > [JRE] This would have to be based on policy. So policy 
> might say that
> for
> > certain enterprises B, use carrier I, for certain other 
> enterprises B
> used
> > carrier J, for example. This could vary according to other factors,
> e.g.,
> > time of day. Where the starting point is an E.164 number, different
> > prefixes
> > could require different carriers according to policy, e.g., 
> depending
> on
> > country code.
> 
> OK.
> I just wonder if enterprise A is using E.164 numbers and 
> ENUM, what type
> 
> of ENUM they use. 
[JRE] Possibly, but doesn't have to be ENUM. If it is ENUM, I guess it would
be something similar to infrastructure ENUM.

> 
> > > 3. In 5.3 Routing you mention that Enterprises
> > > want to use domain names on their own (example.com)
> > >
> > > OTOH, if using E.164 numbers, you will also have
> > > to use the domain of the peering Carrier for incoming calls
> > > I think this issue requires further study, especially in the
> > > context of Infrastructure ENUM and also with Calling and
> > > Connected Identities.
> > [JRE] It depends exactly what you mean by using E.164 numbers.
> > I assume you mean something like the following:
> > - the caller in enterprise A generates a request to tel:+123456789;
> > - enterprise A determines that it needs to go to carrier.net;
> > - carrier.net will somehow need to forward the request to 
> enterprise B
> > using
> > either sip:[email-masked] or tel:+123456789. It 
> is no good
> > sending a request to enterprise B using sip:[email-masked],
> > because
> > that can't be interpreted by enterprise B.
> > So please explain. Of course, the request from enterprise A 
> to carrier
> > might
> > use sip:[email-masked].
> > 
> OK
> If you start with an E.164 number in Enterprise A, you may not know
> that the E.164 number is finally going to an Enterprise B. So 
> the first
> ENUM mapping will be to carrier.net. So the carrier needs to have an 
> indication somewhere that this E.164 number is not going to a
> residential
> subscriber UA, but to an enterpriseB.com
[JRE] The various DNS look-ups might take you to a server within
carrier.net, but this doesn't mean that the SIP Request-URI gets overwritten
with SIP:[email-masked], because that is not really where you are
trying to get to. Maybe the Route header field is used, if there really is a
need to put that SIP:[email-masked] (as opposed to
sip:[email-masked]) in the request.

> Richard

_______________________________________________
Speermint mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speermint

---

From: "Stastny Richard" <[email-masked]>
Date: Tue, 20 Feb 2007 09:45:32 +0100

John,

> trying to get to. Maybe the Route header field is used, if there
really is
> a

I understood it the other way round:
You start with SIP:[email-masked] and end
up in carrier.net with a mapping to SIP:[email-masked]

Richard