Subject: RE: [Speermint] RE: I-D ACTION:draft-elwell-speermint-enterprise- usecases-00.txt

From: "Elwell, John" <[email-masked]>
Date: Mon, 19 Feb 2007 14:27:14 +0000

Richard,

Thanks for reading it and sending your comments. See below.

John 

> -----Original Message-----
> From: Stastny Richard [mailto:[email-masked]] 
> Sent: 19 February 2007 13:06
> To: [email-masked]
> Subject: [Speermint] RE: I-D 
> ACTION:draft-elwell-speermint-enterprise-usecases-00.txt
> 
> Many thanks to the authors for this draft,
> claryfing the position of enterprise peering
> 
> This fits very well to the recent discussions
> on the list if enterprise peering should be 
> treated differently or not.
> 
> Some questions and comments:
> 
> 1. I assume that Enterprise A may select the
> peering based on analysing the domain name of
> the SIP URI. Some domains may peer directly, some
> may peer via a carrier I.
[JRE] Yes
> 
> Is it also possible that an Enterprise A may peer
> with more than one carrier. And if yes,
> how does Enterprise A distinguish between the carriers
[JRE] This would have to be based on policy. So policy might say that for
certain enterprises B, use carrier I, for certain other enterprises B used
carrier J, for example. This could vary according to other factors, e.g.,
time of day. Where the starting point is an E.164 number, different prefixes
could require different carriers according to policy, e.g., depending on
country code.

> 
> 2. In section 5.1 you mention E.164-based URIs
> and non-E.164-based URI. I assume you mean here
> plain SIP URIs. The term non-E.164-bases URIs
> is ambiguous, because there are also non-E.164 
> phone numbers.
[JRE] Yes, SIP URIs.

> 
> 3. In 5.3 Routing you mention that Enterprises
> want to use domain names on their own (example.com)
> 
> OTOH, if using E.164 numbers, you will also have
> to use the domain of the peering Carrier for incoming calls
> I think this issue requires further study, especially in the
> context of Infrastructure ENUM and also with Calling and 
> Connected Identities.
[JRE] It depends exactly what you mean by using E.164 numbers.
I assume you mean something like the following:
- the caller in enterprise A generates a request to tel:+123456789;
- enterprise A determines that it needs to go to carrier.net;
- carrier.net will somehow need to forward the request to enterprise B using
either sip:[email-masked] or tel:+123456789. It is no good
sending a request to enterprise B using sip:[email-masked], because
that can't be interpreted by enterprise B.
So please explain. Of course, the request from enterprise A to carrier might
use sip:[email-masked].

> 
> Best regards
> Richard
> 
> 
> 
> 
> 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]]
> > Sent: Friday, February 16, 2007 9:50 PM
> > To: [email-masked]
> > Subject: I-D 
> ACTION:draft-elwell-speermint-enterprise-usecases-00.txt
> > 
> > A New Internet-Draft is available from the on-line Internet-Drafts
> > directories.
> > 
> > 
> > 	Title		: Use cases for Enterprise Peering using the
> Session
> > Initiation Protocol (SIP)
> > 	Author(s)	: J. Elwell, B. Rodrig
> > 	Filename	:
> draft-elwell-speermint-enterprise-usecases-00.txt
> > 	Pages		: 15
> > 	Date		: 2007-2-16
> > 
> >    Work in the SPEERMINT Working Group has focused to some extent on
> >    peering between carrier VoIP Service Providers (VSP).  This draft
> >    describes some use cases involving SIP peering between enterprise
> >    VSPs, with and without the involvement of carrier VSPs, and also
> >    peering between enterprise VSPs and carrier VSPs.  It also
> discusses
> >    some of the key technical considerations applicable to these use
> >    cases.
> > 
> >    This work is being discussed on the [email-masked] mailing
> list.
> > 
> > 
> > A URL for this Internet-Draft is:
> >
> http://www.ietf.org/internet-drafts/draft-elwell-speermint-ent
> erprise-us
> ecases-00.txt
> 
> > 
> > To remove yourself from the I-D Announcement list, send a message to
> > [email-masked] with the word unsubscribe in 
> the body of
> > the message.
> > You can also visit 
> https://www1.ietf.org/mailman/listinfo/I-D-announce
> > to change your subscription settings.
> > 
> > Internet-Drafts are also available by anonymous FTP. Login with the
> > username "anonymous" and a password of your e-mail address. After
> > logging in, type "cd internet-drafts" and then
> > "get draft-elwell-speermint-enterprise-usecases-00.txt".
> > 
> > A list of Internet-Drafts directories can be found in
> > http://www.ietf.org/shadow.html
> > or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> > 
> > Internet-Drafts can also be obtained by e-mail.
> > 
> > Send a message to:
> > 	[email-masked].
> > In the body type:
> > 	"FILE
> /internet-drafts/draft-elwell-speermint-enterprise-usecases-
> > 00.txt".
> > 
> > NOTE:	The mail server at ietf.org can return the document in
> > 	MIME-encoded form by using the "mpack" utility.  To use this
> > 	feature, insert the command "ENCODING mime" before the "FILE"
> > 	command.  To decode the response(s), you will need "munpack" or
> > 	a MIME-compliant mail reader.  Different MIME-compliant mail
> readers
> > 	exhibit different behavior, especially when dealing with
> > 	"multipart" MIME messages (i.e. documents which have been split
> > 	up into multiple messages), so check your local documentation on
> > 	how to manipulate these messages.
> > 
> > Below is the data which will enable a MIME compliant mail reader
> > implementation to automatically retrieve the ASCII version of the
> > Internet-Draft.
> 
> _______________________________________________
> Speermint mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/speermint
> 

_______________________________________________
Speermint mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speermint

---

From: "Stastny Richard" <[email-masked]>
Date: Mon, 19 Feb 2007 15:53:52 +0100

Hi John,

> could require different carriers according to policy, e.g., depending
on

OK.
I just wonder if enterprise A is using E.164 numbers and ENUM, what type

of ENUM they use. 

> use sip:[email-masked].
OK
If you start with an E.164 number in Enterprise A, you may not know
that the E.164 number is finally going to an Enterprise B. So the first
ENUM mapping will be to carrier.net. So the carrier needs to have an 
indication somewhere that this E.164 number is not going to a
residential
subscriber UA, but to an enterpriseB.com

Richard