Subject: Re: [Speermint] Re-making or Un-making the PSTN

From: Sukanta ganguly <[email-masked]>
Date: Wed, 18 Apr 2007 08:48:39 -0700 (PDT)

Mike,
    I understand the point that you are trying to make here. What is your suggestion? Are you suggesting that some higher level sender checks at a higher than layer 3/4 needs to be performed so that a decision is made at the application level whether the connection needs to be accepted or not? Many VOIP applications and infrastructure provider provides these are their value-add already.

SG

----- Original Message ----
From: Michael Hammer (mhammer) <[email-masked]>
To: "Uzelac, Adam" <[email-masked]>; Stastny Richard <[email-masked]>; Paul Kyzivat (pkyzivat) <[email-masked]>; Otmar Lendl <[email-masked]>; [email-masked]
Sent: Wednesday, April 18, 2007 8:40:03 AM
Subject: RE: [Speermint] Re-making or Un-making the PSTN

Adam,

The Internet moves packets.  The question is when communicating over the
Internet between VoIP platforms, I may want to have some authentication
mechanisms in place to enable the called user to have white list control
(by way of example).

If a network, in its own policy, refuses to support any means of
identifying the caller, even if it is as "anonymous, contact me later if
there is problem with this particular user", are you saying I should
submit my network to abuse?

I am not masochistic and assume each network has the right to protect
itself and its users, as it sees fit.  I also assume the customers will
judge the trade-offs made.

Mike

> -----Original Message-----
> From: Uzelac, Adam [mailto:[email-masked]] 
> Sent: Wednesday, April 18, 2007 10:20 AM
> To: Michael Hammer (mhammer); Stastny Richard; Paul Kyzivat 
> (pkyzivat); Otmar Lendl; [email-masked]
> Subject: RE: [Speermint] Re-making or Un-making the PSTN
> 
> Don't a connect to a known-garbage-spewing network today 
> called the Internet?  Not to sound coy or not, I am thinking 
> along the same lines as Paul K. - that being, there's a 
> certain amount of responsibility as end-users to bear the 
> burden of "spew reduction".  I think that it's more of a 
> shared responsibility between the end-users and the SP. 
> 
> Adam  
> 
> > -----Original Message-----
> > From: Michael Hammer (mhammer) [mailto:[email-masked]]
> > Sent: Wednesday, April 18, 2007 10:06 AM
> > To: Stastny Richard; Paul Kyzivat (pkyzivat); Otmar Lendl; 
> > [email-masked]
> > Subject: RE: [Speermint] Re-making or Un-making the PSTN
> > 
> > Richard,
> > 
> > What happens when one end-user wants to receive from anywhere, and 
> > everyone else doesn't want unsolicited garbage?
> > 
> > Do you connect with known garbage spewing networks?
> > 
> > The carrier has a responsibility to act in the interests of all the 
> > users.
> > 
> > Mike
> > 
> > 
> > > -----Original Message-----
> > > From: Stastny Richard [mailto:[email-masked]]
> > > Sent: Wednesday, April 18, 2007 3:41 AM
> > > To: Paul Kyzivat (pkyzivat); Otmar Lendl; [email-masked]
> > > Subject: RE: [Speermint] Re-making or Un-making the PSTN
> > > 
> > > Paul wrote
> > > > The SP ought to be the agent for the end user's policies of
> > > whether to
> > > > restrict the sources or destinations of calls.
> > > > 
> > > > It may be that better guarantees of service can be given
> > > when there is
> > > a
> > > > peering agreement between source and destination. But it
> > > seems absurd
> > > to
> > > > enforce that the only alternative is no service at all.
> > > 
> > > This is what I always said and what is always forgotten in the
> > > discussion: The service provider is acting as an agent of the 
> > > end-user. If an end-user wants to accept calls from anywhere
> > > - fine If the end-user only accepts calls with proper
> > identification -
> > > fine
> > > 
> > > But this can only be evaluated after the service provider
> > accepts the
> > > INVITE and looks up the profile of the requested user.
> > > 
> > > Richard
> > > 
> > > > -----Original Message-----
> > > > From: Paul Kyzivat [mailto:[email-masked]]
> > > > Sent: Tuesday, April 17, 2007 5:31 PM
> > > > To: Otmar Lendl; [email-masked]
> > > > Subject: Re: [Speermint] Re-making or Un-making the PSTN
> > > > 
> > > > 
> > > > 
> > > > Otmar Lendl wrote:
> > > > > On 2007/04/13 22:04, "Uzelac, Adam" 
> > > <[email-masked]>
> > > > wrote:
> > > > >> As I sit here working on the VoIP use-case draft, I
> > > can't help but
> > > > >> thinking if we aren't just re-making the PSTN, instead
> > > of un-making
> > > it.
> > > > >> The crux of this issue lies with the routing.  At some
> > > of the basic
> > > > >> constructs of next-hop routing decisions that border
> > > elements need
> > > to
> > > > >> do, these use-cases are starting to smell more and more like
> > > PSTN-based
> > > > >> routing look-ups.
> > > > >
> > > > > Not just PSTN routing. IP routing is another example.
> > > > >
> > > > > The source is IMHO the following:
> > > > >
> > > > > * With the email-model, no multihop L7 routing is needed: 
> > > The source
> > > > >   contacts the destination directly and relies on the
> > > underlying IP
> > > > >   network to do the heavy lifting in terms of routing.
> > > > >
> > > > > * The email model has been (mostly) rejected by the real life
> > > > >   VoIP deployments. The reason seems to be that most carriers
> > > > >   simply will not accept incoming SIP calls from the wide open
> > > > >   Internet.
> > > > 
> > > > IMO this needs to change. Maybe it will take legislation,
> > > or maybe the
> > > > free market will fix it (if we ever get a free market),
> > but it needs
> > > to
> > > > change. The SP ought to be the agent for the end user's
> > policies of
> > > > whether to restrict the sources or destinations of calls.
> > > > 
> > > > It may be that better guarantees of service can be given
> > > when there is
> > > a
> > > > peering agreement between source and destination. But it
> > > seems absurd
> > > to
> > > > enforce that the only alternative is no service at all.
> > > > 
> > > > So it seems to me that the purpose of the peering
> > > agreements ought to
> > > be
> > > > to assist in obtaining the degree of service that the
> > caller is and
> > > > callee desire, or coming as close as possible.
> > > > 
> > > >     Paul
> > > > 
> > > > > The rest follows:
> > > > >
> > > > > A source network cannot be sure that the destination
> > network will
> > > > > accept INVITES it sends via the Internet.
> > > > >
> > > > > It thus needs to employ the help of "transit" services.
> > > > >
> > > > > Once there are competing operators who offer transit
> > services, the
> > > set
> > > > > of carriers and their links form a text-book example of a
> > > graph. Go
> > > > > to any Networking 101 class to learn about solutions to
> > > such an old
> > > > > fashioned routing problem.
> > > > >
> > > > > ----
> > > > >
> > > > > Summary: If GC/Level3/DT/ATT/... and all the other 
> carriers can
> > > agree to
> > > > > directly accept calls from all VoIP operators (regardless
> > > of country
> > > of
> > > > > origin), and thus implicitly also from other operators
> > with which
> > > they
> > > > > haven't signed a contract, THEN AND ONLY THEN can we avoid the
> > > routing
> > > > > problem.
> > > > >
> > > > > I consider this to be pretty unlikely.
> > > > >
> > > > > I've written up a draft on this topic which will be
> > > submitted to the
> > > > > archives soon.
> > > > >
> > > > > /ol
> > > > 
> > > > _______________________________________________
> > > > Speermint mailing list
> > > > [email-masked]
> > > > https://www1.ietf.org/mailman/listinfo/speermint
> > > 
> > > _______________________________________________
> > > Speermint mailing list
> > > [email-masked]
> > > https://www1.ietf.org/mailman/listinfo/speermint
> > > 
> > 
> > _______________________________________________
> > Speermint mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/speermint
> > 
> 

_______________________________________________
Speermint mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speermint

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 

_______________________________________________
Speermint mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speermint

---

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Wed, 18 Apr 2007 12:02:40 -0400

I am suggesting we don't lose that value-add.
 
Mike

________________________________

	From: Sukanta ganguly [mailto:[email-masked]] 
	Sent: Wednesday, April 18, 2007 11:49 AM
	To: Michael Hammer (mhammer); Uzelac, Adam; Stastny Richard;
Paul Kyzivat (pkyzivat); Otmar Lendl; [email-masked]
	Subject: Re: [Speermint] Re-making or Un-making the PSTN

	Mike,
	    I understand the point that you are trying to make here.
What is your suggestion? Are you suggesting that some higher level
sender checks at a higher than layer 3/4 needs to be performed so that a
decision is made at the application level whether the connection needs
to be accepted or not? Many VOIP applications and infrastructure
provider provides these are their value-add already.
	 
	SG

	----- Original Message ----
	From: Michael Hammer (mhammer) <[email-masked]>
	To: "Uzelac, Adam" <[email-masked]>; Stastny
Richard <[email-masked]>; Paul Kyzivat (pkyzivat)
<[email-masked]>; Otmar Lendl <[email-masked]>; [email-masked]
	Sent: Wednesday, April 18, 2007 8:40:03 AM
	Subject: RE: [Speermint] Re-making or Un-making the PSTN

	Adam,
	
	The Internet moves packets.  The question is when communicating
over the
	Internet between VoIP platforms, I may want to have some
authentication
	mechanisms in place to enable the called user to have white list
control
	(by way of example).
	
	If a network, in its own policy, refuses to support any means of
	identifying the caller, even if it is as "anonymous, contact me
later if
	there is problem with this particular user", are you saying I
should
	submit my network to abuse?
	
	I am not masochistic and assume each network has the right to
protect
	itself and its users, as it sees fit.  I also assume the
customers will
	judge the trade-offs made.
	
	Mike

________________________________

	Ahhh...imagining that irresistible "new car" smell?
	Check out new cars at Yahoo! Autos.
<http://us.rd.yahoo.com/evt=48245/*http://autos.yahoo.com/new_cars.html;
_ylc=X3oDMTE1YW1jcXJ2BF9TAzk3MTA3MDc2BHNlYwNtYWlsdGFncwRzbGsDbmV3LWNhcnM
->