Subject: [Speermint] Re-making or Un-making the PSTN

From: "Uzelac, Adam" <[email-masked]>
Date: Fri, 13 Apr 2007 16:18:44 -0400

As I sit here working on the VoIP use-case draft, I can't help but
thinking if we aren't just re-making the PSTN, instead of un-making it.
The crux of this issue lies with the routing.  At some of the basic
constructs of next-hop routing decisions that border elements need to
do, these use-cases are starting to smell more and more like PSTN-based
routing look-ups.  A simple determination of who owns the SIP-URI of the
intended recipient can not be determined definitively, so it's just
punted off to the next chain in the link.  The ultimate end-point
determination needs to occur before the next-hop decision can be made.
If we then consider B2BUAs in the mix, it's more likely than not that
the original calling and called parties are changed.  I realize some of
this changes due to local policy, but that still doesn't get to the root
of the problem.

For instance, say there were 2 federations where Bob registered his
SIP-URI, so that according to members of both federation, to reach bob
sessions should be targeted to [email-masked].  Now if Alice is part of
a an external domain to those federations, and with both feds
"advertising" reachablity to Bob, how does Alice determine next-hop?
Basically, who owns Bob's uri?  

If we were to bring ENUM into the discussion, it even get's worse more
wrought with concern due to starting with regulated e164.  I just
sharing out some thoughts.

-AU

_______________________________________________
Speermint mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speermint

---

From: "Stastny Richard" <[email-masked]>
Date: Fri, 13 Apr 2007 23:20:13 +0200

Hi Adam,
 
welcome to the bell-heads club ;-)
 
I think yoe (we all) should be very careful to go down this
road. Others went down this road already -> and out came
the IMS. One sip proxy is replaced by ten boxes (ok functions).
IMS is rebuilding the PSTN
 
The real problem in IMS is that they have now their boxes, but still
no solution for interconnect. One way out is done by 3GPP, it is the
IPX. The IPX is a separate internet for signalling and eventually also
for voice media. 
 
TISPANs NGN (the IMS for fixed network) has no solution yet for
interconnect beside bilateral interconnect.
 
>sessions should be targeted to [email-masked]
 
I always thought Bob registers within an administrative domain and
not within a federation. An administrative domain may be part of one
or more federations
 
>Now if Alice is part of
 
random, cheapest termination rate, ...

>Basically, who owns Bob's uri? 

company.com

It is still a DNS domain name.
 
Please Un-make the PSTN
 
Richard

________________________________

Von: Uzelac, Adam [mailto:[email-masked]]
Gesendet: Fr 13.04.2007 22:18
An: [email-masked]
Betreff: [Speermint] Re-making or Un-making the PSTN

-AU

---

From: Otmar Lendl <[email-masked]>
Date: Tue, 17 Apr 2007 17:09:30 +0200

On 2007/04/13 22:04, "Uzelac, Adam" <[email-masked]> wrote:
> routing look-ups.  

Not just PSTN routing. IP routing is another example.

The source is IMHO the following:

* With the email-model, no multihop L7 routing is needed: The source
  contacts the destination directly and relies on the underlying IP
  network to do the heavy lifting in terms of routing.

* The email model has been (mostly) rejected by the real life 
  VoIP deployments. The reason seems to be that most carriers
  simply will not accept incoming SIP calls from the wide open
  Internet.

The rest follows:

A source network cannot be sure that the destination network
will accept INVITES it sends via the Internet.

It thus needs to employ the help of "transit" services.

Once there are competing operators who offer transit services, the set
of carriers and their links form a text-book example of a graph. Go
to any Networking 101 class to learn about solutions to such an old
fashioned routing problem.

----

Summary: If GC/Level3/DT/ATT/... and all the other carriers can agree to
directly accept calls from all VoIP operators (regardless of country of
origin), and thus implicitly also from other operators with which they
haven't signed a contract, THEN AND ONLY THEN can we avoid the routing
problem.

I consider this to be pretty unlikely.

I've written up a draft on this topic which will be submitted to
the archives soon.

/ol
-- 
/ Otmar Lendl <[email-masked]>, T: +43 1 5056416 - 33, F: - 933 \
| nic.at Internet Verwaltungs- und Betriebsgesellschaft m.b.H |
\ http://www.nic.at/  LG Salzburg, FN 172568b, Sitz: Salzburg /

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 17 Apr 2007 11:30:44 -0400

>   simply will not accept incoming SIP calls from the wide open

IMO this needs to change. Maybe it will take legislation, or maybe the 
free market will fix it (if we ever get a free market), but it needs to 
change. The SP ought to be the agent for the end user's policies of 
whether to restrict the sources or destinations of calls.

It may be that better guarantees of service can be given when there is a 
peering agreement between source and destination. But it seems absurd to 
enforce that the only alternative is no service at all.

So it seems to me that the purpose of the peering agreements ought to be 
to assist in obtaining the degree of service that the caller is and 
callee desire, or coming as close as possible.

	Paul

---

From: Otmar Lendl <[email-masked]>
Date: Tue, 17 Apr 2007 17:54:32 +0200

> enforce that the only alternative is no service at all.

IMHO the single most important reason for the current state of affairs
is the fact that there *is* an alternative: the PSTN. Walling off your
SIP service does not mean that your customers are not reachable. It only
implies that calls have to be routed via the PSTN.

That's the main difference to email: if you reject the incoming SMTP
connection, then you don't get this email. There is no automatic
fallback to snail-mail. New entrants into the email space thus had no
other choice but accept SMTP connections from almost all hosts on the
Internet. Those are the rules of email: you can take them or risk losing
your reachability.

E.164 based VoIP is different: there has always been the PSTN as a
backup, as a default interconnection fabric.

> callee desire, or coming as close as possible.

In an ideal world: yes. 

For now, I'd settle for "peering agreement ought to make direct
interconnection possible".

/ol

---

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Tue, 17 Apr 2007 12:43:45 -0400

Otmar,

Eventually, the PSTN as backup will go away.

The issue here is trust and accountability of from whom one accepts
calls. 

The same could be said for email.  Folks are working on that, I think.

I'd rather not get calls from systems that are purposely avoiding
accountability.  They tend to be spammers.

Mike

> -----Original Message-----
> From: Otmar Lendl [mailto:[email-masked]] 
> Sent: Tuesday, April 17, 2007 11:55 AM
> To: Paul Kyzivat (pkyzivat)
> Cc: [email-masked]
> Subject: Re: [Speermint] Re-making or Un-making the PSTN
> 
> > free market will fix it (if we ever get a free market), but 
> it needs 
> > to change. The SP ought to be the agent for the end user's 
> policies of 
> > It may be that better guarantees of service can be given 
> when there is 
> > a peering agreement between source and destination. But it seems 
> > absurd to enforce that the only alternative is no service at all.
> 
> IMHO the single most important reason for the current state 
> of affairs is the fact that there *is* an alternative: the 
> PSTN. Walling off your SIP service does not mean that your 
> customers are not reachable. It only implies that calls have 
> to be routed via the PSTN.
> 
> That's the main difference to email: if you reject the 
> incoming SMTP connection, then you don't get this email. 
> There is no automatic fallback to snail-mail. New entrants 
> into the email space thus had no other choice but accept SMTP 
> connections from almost all hosts on the Internet. Those are 
> the rules of email: you can take them or risk losing your 
> reachability.
> 
> E.164 based VoIP is different: there has always been the PSTN 
> as a backup, as a default interconnection fabric.
> 
> > So it seems to me that the purpose of the peering 
> agreements ought to 
> > be to assist in obtaining the degree of service that the 
> caller is and 
> For now, I'd settle for "peering agreement ought to make 
> direct interconnection possible".
> 
> /ol
> --

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 17 Apr 2007 12:53:35 -0400

> accountability.  They tend to be spammers.

It would be great to have that kind of control over who you receive 
calls from. But its *policy*, and the same policy is not right for 
everybody.

In the case of spam, I'd rather get it all than have the decision of 
what I get be made by my service provider. Just think how bad it would 
be if the only way you could choose your spam filter was by which SP you 
signed up with. I'd like the same degree of control over VoIP and IM.

	Paul

---

From: Otmar Lendl <[email-masked]>
Date: Tue, 17 Apr 2007 19:06:32 +0200

> Eventually, the PSTN as backup will go away.

The TDM technology: yes. I'm not sure about the organisational structure.

> The issue here is trust and accountability of from whom one accepts

Yes. Plus the financial aspects (cf. termination fees).

> The same could be said for email.  Folks are working on that, I think.

Oh, they've been working on that for ages now. The ratio of spam vs.
ham keeps increasing nevertheless. Where are we now? 80% SPAM?

Is this the success we can afford to emulate?

> accountability.  They tend to be spammers.

Can you envision a system where this accountability works all over the
globe? Across jurisdiction?  Across cultures and economic systems?

Yes, I'd like to have such a system as well. 

This seems to be a rather non-trivial problem.  Do you have concrete
ideas on how this could be implemented?

/ol

---

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Tue, 17 Apr 2007 13:13:32 -0400

Paul,

This is not about stopping individual calls.  It is about accountability for those calls.  You may still get the call, but there can be consequences.

This is developing a network without the naïve assumption that everyone is trustworthy.  The Internet itself assumed that and now some folks are questioning the wisdom of that fundamental assumption and wanting to design the next generation of Internet with different assumptions due to DDoS and Spam and other miscreant behavior.

This is in effect the PSTN redefining itself as an IP-based network.  Should it follow that same naïve assumption?

Remember the definition of insanity: Doing the exact same thing over again and expecting a different result. :)

Mike

> From: Paul Kyzivat (pkyzivat) 
> Sent: Tuesday, April 17, 2007 12:54 PM
> To: Michael Hammer (mhammer)
> Cc: Otmar Lendl; [email-masked]
> It would be great to have that kind of control over who you 
> receive calls from. But its *policy*, and the same policy is 
> not right for everybody.
> 
> In the case of spam, I'd rather get it all than have the 
> decision of what I get be made by my service provider. Just 
> think how bad it would be if the only way you could choose 
> your spam filter was by which SP you signed up with. I'd like 
> the same degree of control over VoIP and IM.
> 
> 	Paul
> 
> > Mike
> > 
> > 
> >>>> * The email model has been (mostly) rejected by the real 
> life  VoIP 
> >>>> deployments. The reason seems to be that most carriers  
> simply will 
> >>>> not accept incoming SIP calls from the wide open  Internet.
> >> IMHO the single most important reason for the current state of 
> >> affairs is the fact that there *is* an alternative: the 
> PSTN. Walling 
> >> off your SIP service does not mean that your customers are not 
> >> reachable. It only implies that calls have to be routed 
> via the PSTN.
> >>
> incoming SMTP 
> >> connection, then you don't get this email.
> into the 
> >> email space thus had no other choice but accept SMTP 
> connections from 
> >> almost all hosts on the Internet. Those are the rules of 
> email: you 
> >> can take them or risk losing your reachability.
> >>

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 17 Apr 2007 13:27:43 -0400

> Remember the definition of insanity: Doing the exact same thing over again and expecting a different result. :)

I agree that we don't want the spam problems that have been aggravated 
by the assumptions of the email system.

But that doesn't mean that even the short term answer should be 
restriction to members of the old boys network. Some simple policies 
that customers can select would be a fine start.

If there are settlement issues, then it could be that part of the deal 
is that you must pay to accept calls from callers the SP has no 
settlement agreement with.

	Paul

---

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Tue, 17 Apr 2007 14:03:13 -0400

It is about answering the question:  

If a hundered thousand of your customers are getting SPIT, complain, and
threaten to change service providers, what can you do about it?

If you can trace the problem to a given SP in the federation, then you
can ask that SP to do something.  If they don't you ostracize them,
which reduces the value of their network.  It would then be in their
interest to address the problem.  They can go elsewhere, but may
eventually find them selves in federation only with other spammers.

Age-old solution.

Mike

> Sent: Tuesday, April 17, 2007 1:07 PM
> To: [email-masked]
> Can you envision a system where this accountability works all 
> over the globe? Across jurisdiction?  Across cultures and 
> economic systems?
> 
> This seems to be a rather non-trivial problem.  Do you have 
> concrete ideas on how this could be implemented?
> 
> /ol
> --

---

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Tue, 17 Apr 2007 14:07:37 -0400

There are regulatory issues around malicious call identification and rules about who can call and who can not call you, at least in the U.S.

At the very least white-list mechanisms require one to have authentication mechanisms that work across service providers with some degree of mathematic certainty.

Let's not muddy the waters with legacy charging and settlement rules.  A given federation may wish to include that, but others may choose not to.  Each could charge equally for their call half. :)

Mike

> Sent: Tuesday, April 17, 2007 1:28 PM
> > This is not about stopping individual calls.  It is about 
> accountability for those calls.  You may still get the call, 
> but there can be consequences.
> > 
> > This is developing a network without the naïve assumption 
> that everyone is trustworthy.  The Internet itself assumed 
> that and now some folks are questioning the wisdom of that 
> fundamental assumption and wanting to design the next 
> generation of Internet with different assumptions due to DDoS 
> and Spam and other miscreant behavior.
> > 
> > This is in effect the PSTN redefining itself as an IP-based 
> network.  Should it follow that same naïve assumption?
> > 
> > Remember the definition of insanity: Doing the exact same 
> thing over 
> > again and expecting a different result. :)
> 
> I agree that we don't want the spam problems that have been 
> aggravated by the assumptions of the email system.
> 
> But that doesn't mean that even the short term answer should 
> be restriction to members of the old boys network. Some 
> simple policies that customers can select would be a fine start.
> 
> If there are settlement issues, then it could be that part of 
> the deal is that you must pay to accept calls from callers 
> the SP has no settlement agreement with.
> 
> 	Paul
> 
> > Mike
> > 
> > 
> decision of 
> >> what I get be made by my service provider. Just think how bad it 
> >> would be if the only way you could choose your spam filter was by 
> >> which SP you signed up with. I'd like the same degree of 
> control over 
> >> VoIP and IM.
> >>
> >> 	Paul
> >>
> >>> Mike
> >>>
> >>>

---

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Tue, 17 Apr 2007 14:10:50 -0400

p.s.  The old boys network worked because each was held accountable for the behavior it brought to the table.

I suspect the club will expand, but decorum must be maintained. :)

Mike

---

From: "Stastny Richard" <[email-masked]>
Date: Wed, 18 Apr 2007 09:40:59 +0200

Paul wrote
> The SP ought to be the agent for the end user's policies of

This is what I always said and what is always forgotten in the 
discussion: The service provider is acting as an agent of the
end-user. If an end-user wants to accept calls from anywhere - fine
If the end-user only accepts calls with proper identification - fine

But this can only be evaluated after the service provider accepts
the INVITE and looks up the profile of the requested user.

Richard

> From: Paul Kyzivat [mailto:[email-masked]]
> Sent: Tuesday, April 17, 2007 5:31 PM
> To: Otmar Lendl; [email-masked]

---

From: "Stastny Richard" <[email-masked]>
Date: Wed, 18 Apr 2007 09:45:05 +0200

> backup, as a default interconnection fabric.

As you say, there HAS BEEN

How long will the PSTN be available and what are you doing already
now with video and IM?

We should not look backwards (there may be lampposts ahead ;-), 
we should look forward

Richard

> Sent: Tuesday, April 17, 2007 5:55 PM
> To: Paul Kyzivat
> Cc: [email-masked]

---

From: "Stastny Richard" <[email-masked]>
Date: Wed, 18 Apr 2007 09:47:22 +0200

> accountability.  They tend to be spammers.

Agree

But with you - do you mean you as an end-user or 
you as a service provider?

Richard

> From: Michael Hammer (mhammer) [mailto:[email-masked]]
> Sent: Tuesday, April 17, 2007 6:44 PM
> To: Otmar Lendl; Paul Kyzivat (pkyzivat)
> Cc: [email-masked]
> Subject: RE: [Speermint] Re-making or Un-making the PSTN
> 
> Otmar,
>

---

From: "Stastny Richard" <[email-masked]>
Date: Wed, 18 Apr 2007 09:56:24 +0200

> ideas on how this could be implemented?

Agreed

But who wants to solve trivial problems ;-)

Richard

> Sent: Tuesday, April 17, 2007 7:07 PM
> To: [email-masked]

---

From: Otmar Lendl <[email-masked]>
Date: Wed, 18 Apr 2007 10:44:43 +0200

> We should not look backwards (there may be lampposts ahead ;-), 

We have to be aware that the protocols and standards we here in the IETF
define will not per se define what the industry does. Each carrier will
by itself decide whether to adopt the proposed solution.

It may well be that we come up with a great proposal which would
revolutionize the landscape and everybody will live happy ever after.
But unless this system yields immediate benefits for the first handful
of operators which decide to implement it, no one will make the plunge.

In this case, carriers will not switch to open peering as that
implies a loss of termination fee revenue. That would not matter
if *everybody* moved to open peering at the same time. 

Both termination-fee and sender-keeps-all systems are stable states in
the ecosystem. If the majority of carriers operate under one of these
rules, then the rest are more or less forced to do the same. Managing
a transition from one system to the other is *hard*. The only option I
see is a regulator's mandate. I can't see it happening by pure market
forces.

The effect of the PSTN is similar: As long as it exists, it will
affect the VoIP-peering choices carriers will take. And as long
as these choices rely on the PSTN, I doubt that the PSTN (whether
TDM-based or not does not matter) will go away.

Summary: any plan that does not include a clear transition path
(both technological and economical) from the current status quo
will fail. We're not doing green-field design work, we have to
take the current phone network and its ecosystem into consideration.

[Just have a look at how IPv6 is doing. They're facing similar issues.]

/ol

---

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Wed, 18 Apr 2007 10:05:43 -0400

Richard,

What happens when one end-user wants to receive from anywhere, 
and everyone else doesn't want unsolicited garbage?

Do you connect with known garbage spewing networks?

The carrier has a responsibility to act in the interests of all the
users.

Mike

> From: Stastny Richard [mailto:[email-masked]] 
> Sent: Wednesday, April 18, 2007 3:41 AM
> To: Paul Kyzivat (pkyzivat); Otmar Lendl; [email-masked]
> whether to 
> > restrict the sources or destinations of calls.
> > 
> a
> > peering agreement between source and destination. But it 
> seems absurd
> to
> end-user. If an end-user wants to accept calls from anywhere 
> - fine If the end-user only accepts calls with proper 
> identification - fine
> 
> But this can only be evaluated after the service provider 
> accepts the INVITE and looks up the profile of the requested user.
> 
> Richard
> 
> > > On 2007/04/13 22:04, "Uzelac, Adam" 
> <[email-masked]>
> > wrote:
> > >> thinking if we aren't just re-making the PSTN, instead 
> of un-making
> it.
> > >> constructs of next-hop routing decisions that border 
> elements need
> to
> a
> > peering agreement between source and destination. But it 
> seems absurd
> to
> be
> > > A source network cannot be sure that the destination network will 
> > > accept INVITES it sends via the Internet.
> > >
> > > directly accept calls from all VoIP operators (regardless 
> of country
> of
> > > I've written up a draft on this topic which will be 
> submitted to the 
> > > archives soon.
> > >
> > > /ol
> >

---

From: "Medhavi Bhatia" <[email-masked]>
Date: Wed, 18 Apr 2007 10:11:06 -0400

> if *everybody* moved to open peering at the same time.
I think there is something wrong in this argument, even though it sounds
quite practical. The flaw seems to me that we are creating a vicious circle
here. Once the standard is there, it creates more incentives for the
industry to use it and spiral downwards. Business models which use the
technology only become more ingrained and "solid".
_______________________________________________
Speermint mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speermint

---

From: "Uzelac, Adam" <[email-masked]>
Date: Wed, 18 Apr 2007 10:20:16 -0400

Don't a connect to a known-garbage-spewing network today called the
Internet?  Not to sound coy or not, I am thinking along the same lines
as Paul K. - that being, there's a certain amount of responsibility as
end-users to bear the burden of "spew reduction".  I think that it's
more of a shared responsibility between the end-users and the SP. 

Adam  

> Sent: Wednesday, April 18, 2007 10:06 AM
> To: Stastny Richard; Paul Kyzivat (pkyzivat); Otmar Lendl; 
> [email-masked]
> What happens when one end-user wants to receive from 
> anywhere, and everyone else doesn't want unsolicited garbage?
> 
> The carrier has a responsibility to act in the interests of 
> all the users.
> 
> Mike
> 
> 
> identification - 
> > fine
> accepts the 
> > INVITE and looks up the profile of the requested user.
> > 
> > Richard
> > 
> > > free market will fix it (if we ever get a free market), 
> but it needs
> > to
> > > > Once there are competing operators who offer transit 
> services, the
> > set
> > > > origin), and thus implicitly also from other operators 
> with which
> > they

---

From: Otmar Lendl <[email-masked]>
Date: Wed, 18 Apr 2007 16:22:14 +0200

> technology only become more ingrained and "solid".

There is no need to be that pessimistic.

This argument implies that we need to thing about a transition strategy.
e.g. that the standard works in a world where the old and the new
co-exist. Thinking only about "this is how the world should operate" is
not enough. There needs to be viable path from the status quo towards
that vision.

For the example with the settlement regimes: The protocol needs to be
flexible enough so that sender-keeps-all federations and termination-fee
federations can co-exist without danger to the carriers. The market will
then decide which type of federation will see more traffic.

/ol

---

From: Otmar Lendl <[email-masked]>
Date: Wed, 18 Apr 2007 16:50:34 +0200

> I've written up a draft on this topic which will be submitted to

I finally submitted the draft. If you don't want to wait for it to make
it to the archives, have a look at:

http://www.enum.at/ietf/draft-lendl-speermint-background-00.txt
http://www.enum.at/ietf/draft-lendl-speermint-background-00.html

Let the discussion begin.

/ol

---

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Wed, 18 Apr 2007 11:40:03 -0400

Adam,

The Internet moves packets.  The question is when communicating over the
Internet between VoIP platforms, I may want to have some authentication
mechanisms in place to enable the called user to have white list control
(by way of example).

If a network, in its own policy, refuses to support any means of
identifying the caller, even if it is as "anonymous, contact me later if
there is problem with this particular user", are you saying I should
submit my network to abuse?

I am not masochistic and assume each network has the right to protect
itself and its users, as it sees fit.  I also assume the customers will
judge the trade-offs made.

Mike

> From: Uzelac, Adam [mailto:[email-masked]] 
> Sent: Wednesday, April 18, 2007 10:20 AM
> To: Michael Hammer (mhammer); Stastny Richard; Paul Kyzivat 
> (pkyzivat); Otmar Lendl; [email-masked]
> Don't a connect to a known-garbage-spewing network today 
> called the Internet?  Not to sound coy or not, I am thinking 
> along the same lines as Paul K. - that being, there's a 
> certain amount of responsibility as end-users to bear the 
> burden of "spew reduction".  I think that it's more of a 
> shared responsibility between the end-users and the SP. 
> 
> Adam  
> 
> > What happens when one end-user wants to receive from anywhere, and 
> > everyone else doesn't want unsolicited garbage?
> > 
> > > > > Summary: If GC/Level3/DT/ATT/... and all the other 
> carriers can
> > > agree to

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 18 Apr 2007 11:42:53 -0400

> The carrier has a responsibility to act in the interests of all the

It would be quite reasonable for the provider to have an optional 
(perhaps default) filter policy that rejects calls from untrusted 
sources (with trust defined by the SP). Its just that this needs to be 
applied on a per target basis rather than on a per-SP basis.

Admittedly if the SP has 10m subscribers and only one of them wants this 
then they probably won't be incented to do it. But I think there will be 
more than that who want it.

	Paul

---

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Wed, 18 Apr 2007 12:01:06 -0400

Paul,

Yes.  I am hoping that service providers can agree on some set of
operating rules/practices that enable the finer grain control to happen.
The problem comes if a particular SP doesn't want to operate with any
degree of civility.

The high level goal for me is that the PSTN has a certain level of trust
and moving to a level of trust as problematic as that of email seems
like a step in the wrong direction.

Mike

> Sent: Wednesday, April 18, 2007 11:43 AM
> Cc: Stastny Richard; Otmar Lendl; [email-masked]
> It would be quite reasonable for the provider to have an 
> optional (perhaps default) filter policy that rejects calls 
> from untrusted sources (with trust defined by the SP). Its 
> just that this needs to be applied on a per target basis 
> rather than on a per-SP basis.
> 
> Admittedly if the SP has 10m subscribers and only one of them 
> wants this then they probably won't be incented to do it. But 
> I think there will be more than that who want it.
> 
> 	Paul
> 
> 
> > Mike
> > 
> > 
> identification 
> >> - fine

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 18 Apr 2007 12:17:22 -0400

> submit my network to abuse?

If your network receives an incoming request and cannot acccurately 
identify the caller, then it can simply treat the caller identification 
as "unknown". Callee policies can then reject calls with unknown 
identification if they wish.

> judge the trade-offs made.

If there was an open market, where I could choose a "big brother" 
provider that filters my traffic, or a lenient provider that allows me 
to make my own filtering rules, then I wouldn't have too much of a 
problem. But it seems that we aren't likely to have that.

Also, what about the flip side of this. Is the SP "protecting the 
customers" by preventing them from calling a destination when it has no 
service agreement with that destination?

	Paul

---

From: Daryl Malas <[email-masked]>
Date: Wed, 18 Apr 2007 10:33:25 -0600

I saw earlier the comment that an end-user wouldn't want to change SP's
just to change the level of filtering (if I recall correctly).  I find
this interesting considering most open-email providers (e.g. Yahoo,
Google, AOL, etc.) provide, on behalf of, their subscribers spam
filtering.  If you don't like Google's spam filter, you can either shut
it off completely (in comes the garbage) or go to Yahoo, for example.
Isn't this exactly the situation you were suggesting would be bad in
VoIP environments?  Isn't this the example correlation you are making
regarding the email world?

BTW, if an email arrives a little late to a end-user, due to a spam
blast on an email server, then no on really cares that much.  They just
think, "Oh well...the internet is slow again."  If someone child is
getting a "fast busy" trying to call home, because someone is "spamming"
their home phone....how do you think that will fly?

--Daryl

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 18 Apr 2007 12:24:15 -0400

> The problem comes if a particular SP doesn't want to operate with any

I may or may not agree with you depending on exactly what you mean.

If one SP mounts a DoS attack on another then it makes sense to 
blacklist it. But if it simply doesn't provide some unusual sort of 
identity information, or doesn't support settlement, then I think it 
should be the option for the target user to make the decision.

	Paul

---

From: Daryl Malas <[email-masked]>
Date: Wed, 18 Apr 2007 10:38:33 -0600

IMO, I think the PSTN becoming IP-enabled is far more likely than the
PSTN becoming an extension of the Internet.  What I think we are doing
here is adding capabilities, which can exist in an IP world that the
TDM-PSTN cannot or would not want to adopt if it even wanted to.  I
think this is what we are trying to do.  Sure we might dabble with open
end-to-end (e.g. P2P, etc.), stuff, but I believe the IP-PSTN (;-)) will
exist in a highly regulated walled off arena for quite some time.  Many
efficiencies and capabilities can be made to make it much better by the
work we are doing though, in the mean time.

---

From: Daryl Malas <[email-masked]>
Date: Wed, 18 Apr 2007 10:41:24 -0600

Comments in-line...

> service agreement with that destination?
FYi...The PSTN does this today...carriers block their customers from
calling some NPA's that have a bad reputation for seriously ripping off
customers of 100's of dollars.  I would believe this would continue to
occur whether it's IP or not.

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 18 Apr 2007 12:37:19 -0400

> regarding the email world?

Its not analogous, because you *can* shut the filtering off. Then you 
can implement your own filter using your own rules.

It seems that for SIP peering as being discussed you won't have any 
option to turn it off.

Ideally there would be some simple rule-based filters that could be 
*optionally* enabled for the target account to minimize the traffic that 
gets sent all the way to the phone.

> their home phone....how do you think that will fly?

As I mentioned, I don't object to a SP blocking a DoS attack. (As long 
as it is careful how that is defined.) I realize that is in some sense a 
spam filter, but it seems qualitatively different to me.

	Paul

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 18 Apr 2007 12:56:19 -0400

Michael Hammer (mhammer) wrote:
> Filters are only as good as the information upon which to filter.
> 
> Garbage in, garbage out.

The carrier should be free to tag the message with contextual info, such 
as that this is from an unknown and untrusted source, and the filter can 
choose to act based on that.

	Paul

>> Sent: Wednesday, April 18, 2007 12:37 PM
>> To: Daryl Malas
>> Cc: Michael Hammer (mhammer); Stastny Richard; Otmar Lendl; 
>> [email-masked]
>>> I saw earlier the comment that an end-user wouldn't want to change 
>>> SP's just to change the level of filtering (if I recall 
>> correctly).  I 
>>> find this interesting considering most open-email providers (e.g. 
>>> Yahoo, Google, AOL, etc.) provide, on behalf of, their subscribers 
>>> spam filtering.  If you don't like Google's spam filter, you can 
>>> either shut it off completely (in comes the garbage) or go 
>> to Yahoo, for example.
>> Its not analogous, because you *can* shut the filtering off. 
>> Then you can implement your own filter using your own rules.
>>
>> It seems that for SIP peering as being discussed you won't 
>> have any option to turn it off.
>>
>> *optionally* enabled for the target account to minimize the 
>> traffic that gets sent all the way to the phone.
>>
>>> blast on an email server, then no on really cares that much.  They 
>>> just think, "Oh well...the internet is slow again."  If 
>> someone child 
>>> is getting a "fast busy" trying to call home, because 
>> someone is "spamming"
>> As I mentioned, I don't object to a SP blocking a DoS attack. 
>> (As long as it is careful how that is defined.) I realize 
>> that is in some sense a spam filter, but it seems 
>> qualitatively different to me.
>>
>> 	Paul
>>
>>> --Daryl
>>>
>>>>>> free market will fix it (if we ever get a free market), but it 
>>>>>> needs
>>>>> to

---

From: "Uzelac, Adam" <[email-masked]>
Date: Wed, 18 Apr 2007 12:52:41 -0400

I read this as a vote that the Speermint activities are a re-making,
possibly with added stuff, but a re-making nonetheless, of the PSTN -
versus un-making.  Did I read this incorrectly?

Adam 

> From: Daryl Malas [mailto:[email-masked]] 
> Sent: Wednesday, April 18, 2007 12:39 PM
> Cc: [email-masked]; Otmar Lendl
> IMO, I think the PSTN becoming IP-enabled is far more likely 
> than the PSTN becoming an extension of the Internet.  What I 
> think we are doing here is adding capabilities, which can 
> exist in an IP world that the TDM-PSTN cannot or would not 
> want to adopt if it even wanted to.  I think this is what we 
> are trying to do.  Sure we might dabble with open end-to-end 
> (e.g. P2P, etc.), stuff, but I believe the IP-PSTN (;-)) will 
> exist in a highly regulated walled off arena for quite some 
> time.  Many efficiencies and capabilities can be made to make 
> it much better by the work we are doing though, in the mean time.
> 

<snipped>

---

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Wed, 18 Apr 2007 12:48:53 -0400

Garbage in, garbage out.

Mike

---

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Wed, 18 Apr 2007 12:45:09 -0400

I hope that the IETF defines mechanisms such that they are not deemed
"unusual".

Mike

> Sent: Wednesday, April 18, 2007 12:24 PM
> If one SP mounts a DoS attack on another then it makes sense 
> to blacklist it. But if it simply doesn't provide some 
> unusual sort of identity information, or doesn't support 
> settlement, then I think it should be the option for the 
> target user to make the decision.
> 
> 	Paul
> 
> > The high level goal for me is that the PSTN has a certain level of 
> > trust and moving to a level of trust as problematic as that 
> of email 
> > seems like a step in the wrong direction.
> > 
> > Mike
> >  
> > 
> anywhere, and 
> >> sources (with trust defined by the SP). Its just that this 
> needs to 
> >> be applied on a per target basis rather than on a per-SP basis.
> >>
> >> Admittedly if the SP has 10m subscribers and only one of 
> them wants 
> >> this then they probably won't be incented to do it. But I 
> think there 
> >> will be more than that who want it.
> >>
> >> 	Paul
> >>
> >>
> >>> Mike
> >>>
> >>>

---

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Wed, 18 Apr 2007 12:41:38 -0400

> Sent: Wednesday, April 18, 2007 12:17 PM
> Cc: Uzelac, Adam; Stastny Richard; Otmar Lendl; [email-masked]

[snip]
 
> Also, what about the flip side of this. Is the SP "protecting 
> the customers" by preventing them from calling a destination 
> when it has no service agreement with that destination?
> 
> 	Paul

I would hope not.  But, the route to get there may require some common
middleman carrier who has a relationship with both the originating and
terminating networks.  This raises an interesting question though, as to
the symmetricity of the direction of calls allowed and how such an SP
intermediates.

Also, are you assuming some form of regulation that requires SPs to
interconnect? :)

Mike

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 18 Apr 2007 12:54:24 -0400

> the symmetricity of the direction of calls allowed and how such an SP

Yes. Asymetric calling would get lots of complaints. ("What do you mean 
I can't call back?")

> Also, are you assuming some form of regulation that requires SPs to

I'm not assuming anything. Whatever it takes. Ideally this would happen 
via the open market, but that currently appears unlikely. Regulation is 
a possibility, though in the current climate (in the USA anyway) it 
seems unlikely to happen.

This seems somewhat analogous to the Carterphone ruling.

	Paul

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 18 Apr 2007 12:42:37 -0400

> occur whether it's IP or not.

That is only relevant because of settlement agreements that allow the 
callee to impose a bill on the caller.

As has been mentioned elsewhere, opening up to calling or being called 
by anybody means that, at least in cases where there is no peering 
agreement there can be no settlement, and so no financial risk to the 
caller if the call is allowed.

So all that would be needed is to refuse to establish a settlement 
agreement with those "evil" carriers.

In cases where there is a peering agreement there could still be 
settlement. Presumably this would be for value added, such as guaranteed 
bandwidth.

	Paul

---

From: Daryl Malas <[email-masked]>
Date: Wed, 18 Apr 2007 11:16:14 -0600

So, you are saying the carrier would insert into the PAI header or From
field a calling name of "Unknown Caller" or similar?  Wow...I can think
of a lot of ways very valid calls get tagged with something like this in
the PSTN's CNAM methodology.

Do we think we would be able to improve on these databases with IP?
(That's not sarcastic...I'm actually asking the questions genuinely.)

---

From: Daryl Malas <[email-masked]>
Date: Wed, 18 Apr 2007 11:19:18 -0600

I want to respond to this carefully, because my knee jerk reaction is to
say, "No.  I wasn't trying to say we are re-making the PSTN."  However,
I think aspects of the PSTN will be inherently added to the peering
architecture.  I'll provide a more thought out answer later when I have
more time.  --Daryl

---

From: Otmar Lendl <[email-masked]>
Date: Wed, 18 Apr 2007 19:45:34 +0200

> seems unlikely to happen.

fyi, the Austrian regulator requires that all (normal) Austrian numbers
must be reachable from all Austrian carriers.

They usually don't interfere how the carriers arrange this (except
some financial matters plus obligations put on the incumbent).

/ol

---

From: "Richard Shockey" <[email-masked]>
Date: Wed, 18 Apr 2007 14:35:06 -0400

You might think that but just a reminder from the charter.

"The most focused deliverables of SPEERMINT are best current practices
regarding exchange of real-time sessions among VoIP and other
real-time application service providers and, in particular, how
such calls are routed."

I love a good discussion as much as the next person but I'm not sure of our
competency to deal with Layer 8-10 issues.

Remember SPIT issues are specifically NOT part of the WG charter.

Something interesting would be what are the minimum authentication and
authorization techniques necessary for SIP service provider A to trust,
route and terminate SIP traffic from Service Provider B.

Something we tried to do in SIPConnect BTW.

-----Original Message-----
From: Uzelac, Adam [mailto:[email-masked]] 
Sent: Wednesday, April 18, 2007 12:53 PM
To: Daryl Malas; Michael Hammer (mhammer)
Cc: [email-masked]; Otmar Lendl
Subject: RE: [Speermint] Re-making or Un-making the PSTN

Adam 

<snipped>

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 18 Apr 2007 15:25:41 -0400

> the PSTN's CNAM methodology.

I wasn't trying to suggest anything specific.
I only meant that if the SP has information that might be useful for a 
filter decision, it could make it available in some way to the user 
provided (or chosen or configured) filter. If the filter does its 
matching against the message then adding info to the message would be a 
good way to make it available.

Certain attributes of the peering agreement, if any, might be useful 
information to provide. (With the simple presence or absence of a 
peering agreement being a most basic example of this.) "Reputation" 
information about the source (which might include having received DoS 
attacks from this source) might also be useful.

Whether to take this info into account when filtering would then be up 
to the recipient or his agent running within the SP.

The CNAM mechanism is only applicable for phone numbers. How it fits 
into this is TBD. But something else is needed when the addresses aren't 
phone numbers.

Also, CNAM only applies to the actual caller and callee. Here info about 
the previous hop of the request is likely to be as, or more, important.

> (That's not sarcastic...I'm actually asking the questions genuinely.)

These seem largely orthogonal to me.

For instance SP1 may have a peering agreement with SP2, including 
agreements to support transitive trust of PAI, and agreements that the 
sender will only include PAI when it can in fact vouch for the validity 
of the ID.

When SP2 receives a message from SP1 it might honor the PAI if present.

If SP2 receives a message over an insecure connection from a source with 
which it has no peering agreement, it will likely remove any PAI that is 
present, and add none. Or it may add an Unknown Caller PAI as you 
suggest. It might also add some other header with info indicating that 
the reputation of this source is low due to recent DoS attacks from it.

	Paul

---

From: "Michael Hammer \(mhammer\)" <[email-masked]>
Date: Wed, 18 Apr 2007 16:34:39 -0400

In the US, some service providers do not consider themselves carriers, 
to be free from certain regulatory requirements.

Mike

> Sent: Wednesday, April 18, 2007 1:46 PM
> To: [email-masked]
> > I'm not assuming anything. Whatever it takes. Ideally this would 
> > happen via the open market, but that currently appears unlikely. 
> > Regulation is a possibility, though in the current climate 
> (in the USA 
> > anyway) it seems unlikely to happen.
> 
> fyi, the Austrian regulator requires that all (normal) 
> Austrian numbers must be reachable from all Austrian carriers.
> 
> They usually don't interfere how the carriers arrange this 
> (except some financial matters plus obligations put on the incumbent).
> 
> /ol
> --

---

From: Otmar Lendl <[email-masked]>
Date: Thu, 19 Apr 2007 16:28:27 +0200

> competency to deal with Layer 8-10 issues.

Agreed. We just need to make sure that whatever rules these layers come
up with can be implemented on layers 5-7 with the tools we are trying to
develop.

> route and terminate SIP traffic from Service Provider B.

That's certainly the crux of the problem.

> Something we tried to do in SIPConnect BTW.

Can you summarize the results?

/ol

---

From: "Richard Shockey" <[email-masked]>
Date: Thu, 19 Apr 2007 12:00:07 -0400

-----Original Message-----
From: Otmar Lendl [mailto:[email-masked]] 
Sent: Thursday, April 19, 2007 10:28 AM
To: [email-masked]
Subject: Re: [Speermint] Re-making or Un-making the PSTN

The Charter 

http://www.sipforum.org/content/view/179/213/

The Specification...

http://www.sipforum.org/component/option,com_docman/task,doc_download/gid,83
/Itemid,75/

The attempt was a simple "profile" of how a PBX could interconnect with a
service provider network for the purpose of session termination. No new
standards were developed P-Asserted Identity is used, TLS must be supported
..but the problem statement address is pretty similar between the
interconnection of a PBX to a Service Provider Domain and a SP to SP
transaction.  The issue is how do networks interconnect or "peer" with each
other. Peering BTW does not in my mind imply "settlement free" those are
bilateral agreements between capitalistic elements singular or federated and
totally outside the scope of this WG.

/ol

---

From: "Livingood, Jason" <[email-masked]>
Date: Sat, 21 Apr 2007 13:45:48 -0400

>   simply will not accept incoming SIP calls from the wide open

This is rehashing another arguement that we tried to close awhile ago.
Recall we will address several stages of peering: direct/bi-lateral,
multi-lateral/federated, and then open/public Internet.  It is natural
that most SPs will start with the first and move to the last.  How long
it takes to get there is anyone's guess, but we'll try to address each
of those use cases.  We've already said this several times, so why does
this point keep coming up?  Do some people just not like that SPs won't
start at the end?  

Jason

---

From: Andrew Newton <[email-masked]>
Date: Sat, 21 Apr 2007 20:45:32 -0400

> this point keep coming up?  Do some people just not like that SPs  

Being that I am one of the dim bulbs that asked this question some  
time ago after it had been answered some time before that,  I think  
the reason it keeps coming up is that the answer you gave above is  
not easy to find.  One has to wade in to long email threads of  
esoteric conversations on peering to find that there is a  
conclusion.  It would be great if the charter or milestones hinted at  
this, but they don't.  Short of that, perhaps the chairs can, in a  
separate email thread, state that the working group will address  
these different stages and lay out a timetable or method for doing  
so.  Hopefully that would stop this from coming up over and over again.

-andy

---

From: "Livingood, Jason" <[email-masked]>
Date: Mon, 23 Apr 2007 13:29:41 -0400

Okay -  

> Being that I am one of the dim bulbs that asked this question 
> some time ago after it had been answered some time before 
> that,  I think the reason it keeps coming up is that the 
> answer you gave above is not easy to find.  One has to wade 
> in to long email threads of esoteric conversations on peering 
> to find that there is a conclusion.  It would be great if the 
> charter or milestones hinted at this, but they don't.  Short 
> of that, perhaps the chairs can, in a separate email thread, 
> state that the working group will address these different 
> stages and lay out a timetable or method for doing so.  
> Hopefully that would stop this from coming up over and over again.
> 
> -andy
> 

Okay - Here it is from my message to the list on 16 Feb 2007:

* There are 3 likely stages or levels of deployment that should be
accomodated: DIRECT, FEDERATED, and OPEN (e.g., over the open Internet).
Depending upon the implementer, the maturity of their
app/business/users/regulations/etc., one may make sense.  In general,
the lifecycle is Direct --> Federated --> Open.  It is impossible for us
to predict or guide when the market or implementers will go to each
stage; we should try to describe how to do each and let implementers
figure out the rest.  This also recognizes that this is not a battle of
direct vs. federated vs. open, as each has a place and a role.

Jason

---

From: "Henry Sinnreich" <[email-masked]>
Date: Mon, 23 Apr 2007 10:40:28 -0700

Jason,

This makes a lot of sense. Thanks for the good guidance.

Just keep presence, IM and multimedia in mind :-)

Henry

-----Original Message-----
From: Livingood, Jason [mailto:[email-masked]] 
Sent: Monday, April 23, 2007 12:30 PM
To: Andrew Newton
Cc: [email-masked]; Otmar Lendl
Subject: RE: [Speermint] Re-making or Un-making the PSTN

Jason

---

From: "Livingood, Jason" <[email-masked]>
Date: Mon, 23 Apr 2007 13:44:11 -0400

Agreed!  And from that same Feb email:

* This recognizes that VoIP (TN-based URIs and voice apps) and IM
(username-based URIs and various apps) have very different use cases and
requirements.  Continuing to try to jam them together is
counter-productive.  Separating them will accelerate each track of work.

* This recognizes that it is not for us to decide if TN or name-based
URIs win/lose in the end.  We work to accomodate applications that use
both; the market and implementers will ultimately decide upon success or
failure.

JL 

> From: Henry Sinnreich [mailto:[email-masked]] 
> Sent: Monday, April 23, 2007 1:40 PM
> To: Livingood, Jason; [email-masked]; Otmar Lendl
> app/business/users/regulations/etc., one may make sense.  In 
> general, the lifecycle is Direct --> Federated --> Open.  It 
> is impossible for us to predict or guide when the market or 
> implementers will go to each stage; we should try to describe 
> how to do each and let implementers figure out the rest.  
> This also recognizes that this is not a battle of direct vs. 
> federated vs. open, as each has a place and a role.
> 
> Jason
>

---

From: Andrew Newton <[email-masked]>
Date: Mon, 23 Apr 2007 14:10:15 -0400

Jason,

This sounds good.  I'll note that when I asked about this last year,  
I was under the impression that there was a priority order for doing  
the work: direct, then federation, then open.  I see there is no such  
priority order now, which I think is a good thing.

How do you envision each of these stages being addressed  
simultaneously in the drafts under consideration?  Should each draft  
have an applicability statement about each stage?  The method for  
addressing these stages was what I was daftly hinting at.

-andy

---

From: "Livingood, Jason" <[email-masked]>
Date: Mon, 23 Apr 2007 15:40:25 -0400

The way we address each is by having use cases for each...  Without use
cases, it won't move ahead.

Jason 

> From: Andrew Newton [mailto:[email-masked]] 
> Sent: Monday, April 23, 2007 2:10 PM
> To: Livingood, Jason
> This sounds good.  I'll note that when I asked about this 
> last year, I was under the impression that there was a 
> priority order for doing the work: direct, then federation, 
> then open.  I see there is no such priority order now, which 
> I think is a good thing.
> 
> simultaneously in the drafts under consideration?  Should 
> each draft have an applicability statement about each stage?  
> The method for addressing these stages was what I was daftly 
> hinting at.
> 
> -andy
>