Subject: Re: [Speermint] I-D Action:draft-lendl-speermint-background-01.txt

From: Hadriel Kaplan <[email-masked]>
Date: Mon, 25 Feb 2008 18:24:02 -0500

Awesome draft. (I missed it the first time 'round)

I agree with your statement of "The obvious solution is to add an on-demand mapping step ahead of the routing protocol."  The trick will be how that works/scales, and how it interacts with a routing protocol.  The easy case is the non-transit bilateral peering - the very hard case is transit.

One very minor nit: I don't think TRIP failed due to being prefix-based and thus needing aggregation.  I think it failed because the market wasn't ready for it (the problem didn't need to be fixed for most people yet), the idea of implementing/using BGP scared off voip vendors, and it didn't cover some of the routing selection models people need.

-hadriel

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> On Behalf Of [email-masked]
> Sent: Monday, February 25, 2008 4:15 PM
> To: [email-masked]
> Subject: I-D Action:draft-lendl-speermint-background-01.txt
>
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
>
>         Title           : VoIP Peering: Background and Assumptions
>         Author(s)       : O. Lendl
>         Filename        : draft-lendl-speermint-background-01.txt
>         Pages           : 15
>         Date            : 2008-02-25
>
> This documents provides background for the work on VoIP peering and
> tries to provide guidance on what kind of work is needed to
> facilitate widespread SIP-based peering of telephony networks.  It is
> intended to spur discussion on the work about peering and should also
> serve as input to the ongoing discussions on reducing Spam for
> Internet Telephony (SPIT).
>
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-lendl-speermint-background-
> 01.txt
>
> To remove yourself from the I-D Announcement list, send a message to
> [email-masked] with the word unsubscribe in the body of
> the message.
> You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce
> to change your subscription settings.
>
> Internet-Drafts are also available by anonymous FTP. Login with the
> username "anonymous" and a password of your e-mail address. After
> logging in, type "cd internet-drafts" and then
>         "get draft-lendl-speermint-background-01.txt".
>
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>
> Internet-Drafts can also be obtained by e-mail.
>
> Send a message to:
>         [email-masked].
> In the body type:
>         "FILE /internet-drafts/draft-lendl-speermint-background-01.txt".
>
> NOTE:   The mail server at ietf.org can return the document in
>         MIME-encoded form by using the "mpack" utility.  To use this
>         feature, insert the command "ENCODING mime" before the "FILE"
>         command.  To decode the response(s), you will need "munpack" or
>         a MIME-compliant mail reader.  Different MIME-compliant mail
> readers
>         exhibit different behavior, especially when dealing with
>         "multipart" MIME messages (i.e. documents which have been split
>         up into multiple messages), so check your local documentation on
>         how to manipulate these messages.
>
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
_______________________________________________
Speermint mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/speermint

---

From: "Richard Shockey" <[email-masked]>
Date: Mon, 25 Feb 2008 20:25:48 -0500

>  I agree with your statement of "The obvious solution is to add an on-
>  demand mapping step ahead of the routing protocol."  The trick will be
>  how that works/scales, and how it interacts with a routing protocol.
>  The easy case is the non-transit bilateral peering - the very hard
>  case is transit.
>  
>  One very minor nit: I don't think TRIP failed due to being prefix-
>  based and thus needing aggregation.  I think it failed because the
>  market wasn't ready for it (the problem didn't need to be fixed for
>  most people yet), the idea of implementing/using BGP scared off voip
>  vendors, and it didn't cover some of the routing selection models
>  people need.

IMHO TRIP failed because it was using a 120 mm howitzer to deal with a
problem better dealt with a BB gun. There were enough issues with BGP as it
was.

---

From: Hadriel Kaplan <[email-masked]>
Date: Mon, 25 Feb 2008 22:30:53 -0500

Well... working for one of only two vendors who implemented it, afaict, it failed for multiple reasons.  None of them had to do with prefix aggregation or scalability, at least at the time.  BGP was definitely a poor choice, though more for marketing/perception reasons than technical, albeit there were some major technical issues with it too.  It was never tied to BGP for IP routing - it operated on a separate plane really, and even had a different protocol model for internal route distribution, but yes it inherited too much of BGP in terms of deployment model and some unnecessary baggage.  The big killer though, imho, was there was no real problem at the time that it solved.  It's moot though - I'm definitely not suggesting a TRIP down memory lane.
:)

-hadriel

> From: Richard Shockey [mailto:[email-masked]]
> Sent: Monday, February 25, 2008 8:26 PM
> To: Hadriel Kaplan; [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: RE: [Speermint] I-D Action:draft-lendl-speermint-background-
> 01.txt
>

---

From: "Daryl Malas" <[email-masked]>
Date: Tue, 26 Feb 2008 10:58:38 -0700

Otmar,

I also enjoyed reading the draft.  I think you bring up some very
interesting and valid discussion points.  I also think you re-enforce
there is much to do within SPEERMINT.

A comment to the use case authors...please read this draft, because I
think it has some important topics to touch on in your draft.

I encourage everyone to take the time to read this draft prior to
Philadelphia.

Thank you, Otmar, for taking the time to update this draft. 

--Daryl

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Hadriel Kaplan
Sent: Monday, February 25, 2008 4:24 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]
Subject: Re: [Speermint] I-D
Action:draft-lendl-speermint-background-01.txt

I agree with your statement of "The obvious solution is to add an
on-demand mapping step ahead of the routing protocol."  The trick will
be how that works/scales, and how it interacts with a routing protocol.
The easy case is the non-transit bilateral peering - the very hard case
is transit.

One very minor nit: I don't think TRIP failed due to being prefix-based
and thus needing aggregation.  I think it failed because the market
wasn't ready for it (the problem didn't need to be fixed for most people
yet), the idea of implementing/using BGP scared off voip vendors, and it
didn't cover some of the routing selection models people need.

-hadriel

> tries to provide guidance on what kind of work is needed to facilitate

> widespread SIP-based peering of telephony networks.  It is intended to

> spur discussion on the work about peering and should also serve as 
> input to the ongoing discussions on reducing Spam for Internet 
> Telephony (SPIT).
>

> http://www.ietf.org/shadow.html or 
> ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>
>         "FILE
/internet-drafts/draft-lendl-speermint-background-01.txt".

---

From: "Lee, Yiu" <[email-masked]>
Date: Tue, 26 Feb 2008 13:20:09 -0500

I read the first 00 draft and enjoyed it. I will definitely read this
one. Thanks Otmar for taking the time to write it.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Daryl Malas
Sent: Tuesday, February 26, 2008 12:59 PM
To: [email-masked]
Cc: [email-masked]
Subject: Re: [Speermint] I-D
Action:draft-lendl-speermint-background-01.txt

Otmar,

--Daryl

-----Original Message-----

-hadriel