Subject: Re: [Speermint] I-D Action:draft-ietf-speermint-voip-consolidated-usecases-15.txt

From: Robert Sparks <[email-masked]>
Date: Fri, 15 Jan 2010 16:06:01 -0600

Hi Yiu -

I only have one sticking point remaining. In interest in closing on it  
more quickly,
I'll propose text.

--------
OLD:

9.   T-SBE receives the NAPTR record and query DNS for the A record
         of domain "t-proxy.example.net.".  The DNS returns an A record:

           ;; DNS ANSWER
           t-proxy.example.net.   IN A   192.0.2.2

         Note that in this example the T-SBE receives an A record when
         querying "t-proxy.example.net".  But T-SBE should also prepare
         to receive a SRV record and follow the procedures defined in
         [RFC3263] to locate the next-hop.

NEW:

9.   T-SBE receives the NAPTR record and following the requirements
        in [RFC3263] queries DNS for the SRV records indicated by the
        NAPTR result. Not finding any, the T-SBE then queries DNS for
        the A record of domain "t-proxy.example.net.".
        The DNS returns an A record:

           ;; DNS ANSWER
           t-proxy.example.net.   IN A   192.0.2.2

-----------

If this works for the group, I can clear. We can probably handle this  
with
an RFC-Editor note instead of revising the document if you don't have
anything else to change.

RjS

On Dec 3, 2009, at 12:48 PM, Lee, Yiu wrote:

> This revision tries to address the comments from the AD reviews.  
> Please take
> time to review it.
>
> Thanks.
>
>
> On 12/3/09 1:45 PM, "[email-masked]" <[email-masked] 
> >
> wrote:
>
>> A New Internet-Draft is available from the on-line Internet-Drafts
>> directories.
>> This draft is a work item of the Session PEERing for Multimedia  
>> INTerconnect
>> Working Group of the IETF.
>>
>>
>> Title           : VoIP SIP Peering Use Cases
>> Author(s)       : A. Uzelac, Y. Lee
>> Filename        : draft-ietf-speermint-voip-consolidated- 
>> usecases-15.txt
>> Pages           : 25
>> Date            : 2009-12-03
>>
>> This document depicts many common Voice over IP (VoIP) use cases for
>> Session Initiation Protocol (SIP) Peering.  These use cases are
>> categorized into static and on-demand, and then further sub-
>> categorized into direct and indirect.  These use cases are not an
>> exhaustive set, but rather the most common use cases deployed today.
>>
>> Status of this Memo
>>
>> This Internet-Draft is submitted to IETF in full conformance with the
>> provisions of BCP 78 and BCP 79.
>>
>> Internet-Drafts are working documents of the Internet Engineering
>> Task Force (IETF), its areas, and its working groups.  Note that
>> other groups may also distribute working documents as Internet-
>> Drafts.
>>
>> Internet-Drafts are draft documents valid for a maximum of six months
>> and may be updated, replaced, or obsoleted by other documents at any
>> time.  It is inappropriate to use Internet-Drafts as reference
>> material or to cite them other than as "work in progress."
>>
>> The list of current Internet-Drafts can be accessed at
>> http://www.ietf.org/ietf/1id-abstracts.txt.
>>
>> The list of Internet-Draft Shadow Directories can be accessed at
>> http://www.ietf.org/shadow.html.
>>
>> This Internet-Draft will expire on June 6, 2010.
>>
>> Copyright Notice
>>
>> Copyright (c) 2009 IETF Trust and the persons identified as the
>> document authors.  All rights reserved.
>>
>> This document is subject to BCP 78 and the IETF Trust's Legal
>> Provisions Relating to IETF Documents
>> (http://trustee.ietf.org/license-info) in effect on the date of
>> publication of this document.  Please review these documents
>> carefully, as they describe your rights and restrictions with respect
>> to this document.  Code Components extracted from this document must
>> include Simplified BSD License text as described in Section 4.e of
>> the Trust Legal Provisions and are provided without warranty as
>> described in the BSD License.
>>
>> A URL for this Internet-Draft is:
>> http://www.ietf.org/internet-drafts/draft-ietf-speermint-voip-consolidated-use
>> cases-15.txt
>>
>> Internet-Drafts are also available by anonymous FTP at:
>> ftp://ftp.ietf.org/internet-drafts/
>>
>> Below is the data which will enable a MIME compliant mail reader
>> implementation to automatically retrieve the ASCII version of the
>> Internet-Draft.
>> _______________________________________________
>> Speermint mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/speermint
> _______________________________________________
> Speermint mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/speermint

---

From: "Lee, Yiu" <[email-masked]>
Date: Fri, 15 Jan 2010 22:43:28 -0500

Hi Robert,

I have no problem for it and I will modify the draft with your text if I
hear no objection from the mailing list.

Thanks,
Yiu