Subject: Re: [Speermint] shutting down and the arch doc

From: Otmar Lendl <[email-masked]>
Date: Tue, 01 Jun 2010 15:32:46 +0200

Jon,

On 27.05.2010 20:50, Peterson, Jon wrote:
> 
> While all IETF working groups look forward to the day they can close
> their doors, I'm not sure I'd be happy to see SPEERMINT make its final
> bow without completing the architecture document.

As it stands, the architecture draft is mostly worthless as it offers
unspecific bromides and gives little guidance concerning any contentious
issues.

> I believe that in the LUF/LRF distinction, the SPEERMINT group has
> captured an idea that is valuable, and moreover one which, as the
> original charter of this group intended, identifies a reality of
> deployments that the standards community had previously ignored. It
> explodes the conceit that a one-step resolution process, just
> transforming a telephone number into a "global" URI, will address the
> needs of the sort of peering communities this group examines. While the
> distinction between LUF and LRF is not a precise one, and has never been
> immensely well understood, I contend that it is valuable nonetheless,
> and that if confusion about the idea prompts us to discard the work in
> SPEERMINT, I have no reason to expect anything different to happen in
> DRINKS or any other group that must operate on these same architectures.
> I don't think the sketches in the terminology draft suffice as a
> foundation for that work.

This is certainly true, but once again, the current architecture draft
doesn't really put any meat on the LUF/LRF distinction.

> Finishing the architecture document is not solving world hunger. While
> everything in the IETF takes much longer than you'd imagine, I don't
> think this has to be one or two years out - I think it would be
> reasonable to make a final push to clear up the snags in the document,
> and just set a deadline by which this group will emit it as an
> Informational. It doesn't have to be perfect, it just has to be able to
> serve as the framework for the subsequent discussions in DRINKS and
> other future arenas. I think this is an an achievable, and relatively
> honorable, way to round up the work that the SPEERMINT charter
> originally laid out.

If you want a post-mortem of the SPEERMINT WG as a reference for future
IETF work, might I suggest you take a look at
http://tools.ietf.org/html/draft-lendl-speermint-background-02
which summarizes my thoughts on the SPEERMINT problem-space.

It also includes a clear description of the LUF/LRF issue.
Section 5 proposes an architecture.

I think this draft is a better starting-point than the current architecture
draft if you want to leave something behind for other WGs to pick up.

> 
> If there is enough energy here for one last jaunt, I'd be happy to
> assist that effort in any capacity.

Same here. I even might make it to Maastricht.

otmar

PS, and then there are
 http://tools.ietf.org/html/draft-lendl-domain-policy-ddds-02
 http://tools.ietf.org/html/draft-lendl-speermint-federations-03
 http://tools.ietf.org/html/draft-lendl-speermint-technical-policy-00
which actually proposed a protocol to solve a good part of the speermint
problem space.
-- 
// Otmar Lendl <[email-masked]>, T: +43 1 5056416 - 33, F: - 933 //

---

From: Daryl Malas <[email-masked]>
Date: Thu, 3 Jun 2010 10:54:09 -0600

Jon et. al,

I agree we should finish the architecture document.  If members of this mailing list and the working group think it requires greater definition around certain functions, then please contribute.  I would like to suggest we focus on two drafts to wrap up in Maastricht:

Architecture
Security

After completing these two drafts, we shut down the working group by Beijing.

Thoughts?

Regards,

Daryl

On 5/27/10 12:50 PM, "Peterson, Jon" <[email-masked]> wrote:

While all IETF working groups look forward to the day they can close their doors, I’m not sure I’d be happy to see SPEERMINT make its final bow without completing the architecture document.

I believe that in the LUF/LRF distinction, the SPEERMINT group has captured an idea that is valuable, and moreover one which, as the original charter of this group intended, identifies a reality of deployments that the standards community had previously ignored. It explodes the conceit that a one-step resolution process, just transforming a telephone number into a “global” URI, will address the needs of the sort of peering communities this group examines. While the distinction between LUF and LRF is not a precise one, and has never been immensely well understood, I contend that it is valuable nonetheless, and that if confusion about the idea prompts us to discard the work in SPEERMINT, I have no reason to expect anything different to happen in DRINKS or any other group that must operate on these same architectures. I don’t think the sketches in the terminology draft suffice as a foundation for that work.

Finishing the architecture document is not solving world hunger. While everything in the IETF takes much longer than you’d imagine, I don’t think this has to be one or two years out – I think it would be reasonable to make a final push to clear up the snags in the document, and just set a deadline by which this group will emit it as an Informational. It doesn’t have to be perfect, it just has to be able to serve as the framework for the subsequent discussions in DRINKS and other future arenas. I think this is an an achievable, and relatively honorable, way to round up the work that the SPEERMINT charter originally laid out.

If there is enough energy here for one last jaunt, I’d be happy to assist that effort in any capacity.

Jon Peterson
NeuStar, Inc.

---

From: "Mike Hammer (hmmr)" <[email-masked]>
Date: Thu, 3 Jun 2010 12:32:02 -0500

Agree with that approach.

Mike

From: [email-masked] [mailto:[email-masked]] On
Behalf Of Daryl Malas
Sent: Thursday, June 03, 2010 12:54 PM
To: Peterson, Jon; [email-masked]
Subject: Re: [Speermint] shutting down and the arch doc

Jon et. al,

I agree we should finish the architecture document.  If members of this
mailing list and the working group think it requires greater definition
around certain functions, then please contribute.  I would like to
suggest we focus on two drafts to wrap up in Maastricht:

Architecture
Security

After completing these two drafts, we shut down the working group by
Beijing.

Thoughts?

Regards,

Daryl

Jon Peterson
NeuStar, Inc.

---

From: "Terry Martin" <[email-masked]>
Date: Thu, 3 Jun 2010 13:36:24 -0400

I have been following this from the beginning and I work with a lot of
telephone companies and VoIP provides and feel what your working is key
to how islands of carriers are going to be communicating.

I will review the last set of documents and will send my comments.. They
may not be as technical but they come from an operation perspective.

Thanks for your work

Terry

From: [email-masked] [mailto:[email-masked]] On
Behalf Of Mike Hammer (hmmr)
Sent: Thursday, June 03, 2010 10:32 AM
To: Daryl Malas; Peterson, Jon; [email-masked]
Subject: Re: [Speermint] shutting down and the arch doc

Mike

Jon et. al,

Architecture
Security

Thoughts?

Regards,

Daryl

Jon Peterson
NeuStar, Inc.

---

From: "Lee, Yiu" <[email-masked]>
Date: Thu, 3 Jun 2010 13:42:20 -0400

+1. Let¹s me know if I can help in any way.

On 6/3/10 1:32 PM, "Mike Hammer (hmmr)" <[email-masked]> wrote:

> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Daryl Malas
> mailing list and the working group think it requires greater definition around
> certain functions, then please contribute.  I would like to suggest we focus
> on two drafts to wrap up in Maastricht:
> 
> Architecture
> Security
> 
> While all IETF working groups look forward to the day they can close their
> doors, I¹m not sure I¹d be happy to see SPEERMINT make its final bow without
> completing the architecture document.
> 
> I believe that in the LUF/LRF distinction, the SPEERMINT group has captured an
> idea that is valuable, and moreover one which, as the original charter of this
> group intended, identifies a reality of deployments that the standards
> community had previously ignored. It explodes the conceit that a one-step
> resolution process, just transforming a telephone number into a ³global² URI,
> will address the needs of the sort of peering communities this group examines.
> While the distinction between LUF and LRF is not a precise one, and has never
> been immensely well understood, I contend that it is valuable nonetheless, and
> that if confusion about the idea prompts us to discard the work in SPEERMINT,
> I have no reason to expect anything different to happen in DRINKS or any other
> group that must operate on these same architectures. I don¹t think the
> sketches in the terminology draft suffice as a foundation for that work.
> 
> everything in the IETF takes much longer than you¹d imagine, I don¹t think
> this has to be one or two years out  I think it would be reasonable to make a
> final push to clear up the snags in the document, and just set a deadline by
> which this group will emit it as an Informational. It doesn¹t have to be
> perfect, it just has to be able to serve as the framework for the subsequent
> discussions in DRINKS and other future arenas. I think this is an an
> achievable, and relatively honorable, way to round up the work that the
> SPEERMINT charter originally laid out.
> 
> If there is enough energy here for one last jaunt, I¹d be happy to assist that
> effort in any capacity.
> 
> Jon Peterson
> NeuStar, Inc.
> 
> 
> _______________________________________________
> Speermint mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/speermint

---

From: Daryl Malas <[email-masked]>
Date: Thu, 3 Jun 2010 11:49:02 -0600

All,

Tickets were opened against the architecture draft via the IETF website.  I sent links previously, and I think Adam did also.  Please go review and provide comments.  These were the only remaining comments on the draft at the time.

This being said, I have heard comments the architecture draft is still to high level.  Please provide direction to the editors which areas are to high level, and “all of them” is not an acceptable answer.  Instead list them and provide comments on what needs to be further defined.

For the past two years, we have heard generic comments along the lines of:

 *   Too high level
 *   Not enough detail
 *   Don’t like the structure

I’ll be straight...these are not helpful.  Provide feedback such as...I don’t like this, and this is specifically how you fix it.

This will help us move forward quickly.

Thanks,

Daryl

On 6/3/10 11:42 AM, "Lee, Yiu" <[email-masked]> wrote:

+1. Let’s me know if I can help in any way.

Mike

From: [email-masked] [mailto:[email-masked]] On Behalf Of Daryl Malas
Sent: Thursday, June 03, 2010 12:54 PM
To: Peterson, Jon; [email-masked]
Subject: Re: [Speermint] shutting down and the arch doc

Jon et. al,

Architecture
Security

Thoughts?

Regards,

Daryl

Jon Peterson
NeuStar, Inc.

________________________________
_______________________________________________
Speermint mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/speermint

---

From: "Jan Seedorf" <[email-masked]>
Date: Tue, 8 Jun 2010 10:03:47 +0200

Dear Terry,

> I will review the last set of documents and will send my comments.. They may
> not be as technical but they come from an operation perspective.
Excellent, we are looking forward to your comments and would appreciate any feedback you have for our draft:

- SPEERMINT Security Threats and Suggested Countermeasures
(http://tools.ietf.org/html/draft-ietf-speermint-voipthreats-02)

 - Jan

> -----Original Message-----
> Of Terry Martin
> Sent: Donnerstag, 3. Juni 2010 19:36
> To: Mike Hammer (hmmr); Daryl Malas; Peterson, Jon; [email-masked]
> telephone companies and VoIP provides and feel what your working is key to how
> islands of carriers are going to be communicating.
> 
> 
> 
> I will review the last set of documents and will send my comments.. They may
> not be as technical but they come from an operation perspective.
> 
> 
> 
> Thanks for your work
> 
> 
> 
> Terry
> 
> 
> 
> Of Mike Hammer (hmmr)
> doors, I'm not sure I'd be happy to see SPEERMINT make its final bow without
> resolution process, just transforming a telephone number into a "global" URI,
> group that must operate on these same architectures. I don't think the
> everything in the IETF takes much longer than you'd imagine, I don't think
> this has to be one or two years out - I think it would be reasonable to make a
> which this group will emit it as an Informational. It doesn't have to be
> If there is enough energy here for one last jaunt, I'd be happy to assist that
> effort in any capacity.
> 
> Jon Peterson
> NeuStar, Inc.

---

From: "Jan Seedorf" <[email-masked]>
Date: Tue, 8 Jun 2010 10:06:09 +0200

Dear Yiu,

> +1. Let's me know if I can help in any way.

Feedback and comments for

are very much appreciated.

Thanks,

 - Jan

> Of Lee, Yiu
> Sent: Donnerstag, 3. Juni 2010 19:42
> +1. Let's me know if I can help in any way.
> 
> 
> their doors, I'm not sure I'd be happy to see SPEERMINT make its final bow
> without completing the architecture document.
> 
> captured an idea that is valuable, and moreover one which, as the original
> charter of this group intended, identifies a reality of deployments that the
> standards community had previously ignored. It explodes the conceit that a
> one-step resolution process, just transforming a telephone number into a
> "global" URI, will address the needs of the sort of peering communities this
> group examines. While the distinction between LUF and LRF is not a precise
> one, and has never been immensely well understood, I contend that it is
> valuable nonetheless, and that if confusion about the idea prompts us to
> discard the work in SPEERMINT, I have no reason to expect anything different
> to happen in DRINKS or any other group that must operate on these same
> architectures. I don't think the sketches in the terminology draft suffice as
> a foundation for that work.
>

---

From: "Lee, Yiu" <[email-masked]>
Date: Tue, 8 Jun 2010 10:07:38 -0400

Hi Jan,

I will review it!

Yiu

On 6/8/10 4:06 AM, "Jan Seedorf" <[email-masked]> wrote:

>> Behalf
>> around