Subject: [spfbis] [Technical Errata Reported] RFC7208 (5843)

From: RFC Errata System <[email-masked]>
Date: Wed, 21 Aug 2019 18:00:29 -0700 (PDT)

The following errata report has been submitted for RFC7208,
"Sender Policy Framework (SPF) for Authorizing Use of Domains in Email, Version 1".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid5843

--------------------------------------
Type: Technical
Reported by: Jesus Donaldo Osornio <[email-masked]>

Section: 9.1

Original Text
-------------
Received-SPF: pass (mybox.example.org: domain of
    [email-masked] designates 192.0.2.1 as permitted sender)
       receiver=mybox.example.org; client-ip=192.0.2.1;
       mechanism=ip4:192.0.2.1; envelope-from="[email-masked]";
       helo=foo.example.com;

Corrected Text
--------------
Received-SPF: pass (mybox.example.org: domain of
    [email-masked] designates 192.0.2.1 as permitted sender)
       receiver=mybox.example.org; client-ip=192.0.2.1;
       mechanism="ip4:192.0.2.1"; envelope-from="[email-masked]";
       helo=foo.example.com;

Notes
-----
There's an error in the last example of this section:
By the definition of key-value-pair, a "value" can only be a dot-atom or a quoted-string. 
The string ip4:192.0.2.1 in the mechanism key is not a legal dot-atom, so it should be surrounded by double quotes, to be a quoted-string instead

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC7208 (draft-ietf-spfbis-4408bis-21)
--------------------------------------
Title               : Sender Policy Framework (SPF) for Authorizing Use of Domains in Email, Version 1
Publication Date    : April 2014
Author(s)           : S. Kitterman
Category            : PROPOSED STANDARD
Source              : SPF Update
Area                : Applications
Stream              : IETF
Verifying Party     : IESG

---

From: Scott Kitterman <[email-masked]>
Date: Wed, 21 Aug 2019 21:36:31 -0400

The  errata is correct in that the string ip4:192.0.2.1 is not a legal dot-
atom.

Based on the WG history, I don't have any indication that the WG thought this 
should be quoted.  I think it's more likely we should be changing the ABNF to 
allow the example as it.

My recommendation is hold for document update so we can review next time RFC 
7208 is updated.

Scott K

On Wednesday, August 21, 2019 9:00:29 PM EDT RFC Errata System wrote:
> By the definition of key-value-pair, a "value" can only be a dot-atom or a
> quoted-string. The string ip4:192.0.2.1 in the mechanism key is not a legal
> dot-atom, so it should be surrounded by double quotes, to be a
> quoted-string instead
> 
> Instructions:
> -------------
> Title               : Sender Policy Framework (SPF) for Authorizing Use of
> Domains in Email, Version 1 Publication Date    : April 2014
> Author(s)           : S. Kitterman