Subject: Re: Washington Agenda

From: Alec Brusilovsky <[email-masked]>
Date: Thu, 28 Oct 1999 13:18:00 -0400

David,

One of the ways we can describe distributed system interoperability is a
"metaprotocol" level, or a level under which all the other protocols fall and are
controlled.
Metaprotocol that I have in mind will provide a framework and requirements for an
actual protocol without specifying one.

SPIRITS charter says: "...Develop a Standards Track RFC that specifies a protocol
by which PSTN Intelligent Network Service Nodes (or any other node that implements
the Service Control Function) can request services of IP hosts, and which can
return status indications to the PSTN/IN."

This can be achieved by focusing on the protocol itself or starting from the
metaprotocol framework. After defining metaprotocol we can:
a) reuse any suitable existing protocol,
b) extend a suitable existing protocol,
c) come up with a new protocol.

Regards,
Alec

David Shrader wrote:

> Alec,
>
> Can you clarify what you mean by a "meta-protocol" vs. an "actual protocol"?
>
> David
>
> ----------------------------
> David Shrader
> Master Consultant, Inc.
> [email-masked]
>
> ----------
> >From: Alec Brusilovsky <[email-masked]>
> >To: SPIRITS list <[email-masked]>
> >Cc: David Shrader <[email-masked]>, Steve Bellovin
> <[email-masked]>
> >Subject: Re: Washington Agenda
> >Date: Thu, Oct 28, 1999, 10:13 AM
> >
>
> > Good morning,
> >
> > I would like to thank David for raising this very important and timely issue.
> > In fact, Steve Bellovin and I were discussing our proposed agenda for the
> > upcoming November 9 (9 through 11:30 a.m.) meeting.
> > Please see it below:
> >
> > 1. What is our output? Is it meta-protocol or an actual protocol? - 20 min.
> >
> > 2. Plan of work for the WG - 20 min.
> >
> > 3. Relations with ITU SG11 and SG13 - 20 min.
> >
> > 4. Interworking with PINT - 20 min.
> >
> > 5. Discussion on the published SPIRITS I-D - 20 min.
> >
> > Regards,
> > Alec Brusilovsky
> >
> > David Shrader wrote:
> >
> >> Spirits Team Members:
> >>
> >> Do we have any kind of agenda for the December meeting? I took a look at the
> >> initial ID from Igor (and crew, thanks) and I think it is a good start for
> >> describing the architecture and introducing the event reporting aspect of
> >> the service. I think it is important for some discussion of the possible
> >> responses from the Internet. That is, once the internet server has been
> >> notified of an event, what can it instruct the PSTN/IN to do with the call?
> >> Typical responses could include: connect, holdcall, disconnect,
> >> collectinformation, ... Can the server request the PSTN/IN to interact with
> >> the caller and wait for subsequent information from the PSTN/IN?
> >>
> >> I think it would be useful to discuss the scope of the response processing
> >> at the meeting in Washington. I'd be willing to put something together.
> >>
> >> I think another area of discussion is the relationship to PINT. I think
> >> there is some great potential for some neat services that actually combine
> >> elements of both areas to provide the overall service.
> >>
> >> David
> >>
> >> ----------------------------------------------------
> >> David Shrader
> >> Master Consultant, Inc.
> >> [email-masked]
> >

---

From: "David Shrader" <[email-masked]>
Date: Thu, 28 Oct 1999 12:59:31 -0400

Alec,

David

----------
<[email-masked]>